source: projects/specs/branches/6/t/texlive-collection-documentation-slovenian/texlive-collection-documentation-slovenian-vl.spec @ 2505

Revision 2505, 6.8 KB checked in by munepi, 13 years ago (diff)

updated all texlive-collection-* packages: improved %%post

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
3## tlpdb2rpmspec collection-documentation-slovenian
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Slovenian documentation
28Summary(ja): TeX Live: Slovenian documentation
29Name: texlive-collection-documentation-slovenian
30Version: 2009
31Release: 3%{?_dist_release}
32License: GPL+
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Slovenian documentation:
61
62
63This package contains the following CTAN packages:
64lshort-slovenian: Slovenian translation of lshort.
65
66%description -l ja
67TeX Live ソフトウェアディストリビューションは、
68さまざまな Unix, Macintosh, Windows、および
69他のプラットホームに対して完全な TeX システムを提供します。
70多くの異なった言語を含む TeX ドキュメントの
71編集、組版、閲覧、印刷するためのプログラム、
72そして、TeX マクロやフォントライブラリの大きなコレクションを
73同梱しています。
74
75このディストリビューションは
76同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
77TeX に関するたくさんの一般的なドキュメントを含んでいます。
78
79このパッケージは以下のようなパッケージ集です。
80Slovenian documentation:
81
82
83このパッケージは以下の CTAN パッケージを含んでいます:
84lshort-slovenian: Slovenian translation of lshort.
85
86%prep
87
88%build
89
90%install
91[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
92
93PREF=%{buildroot}%{tex_destdir}
94
95manifest=(
96texmf-dist/doc/latex/lshort-slovenian/README
97texmf-dist/doc/latex/lshort-slovenian/lshort-slovenian.pdf
98texmf-dist/doc/latex/lshort-slovenian/src/biblio.tex
99texmf-dist/doc/latex/lshort-slovenian/src/contrib.tex
100texmf-dist/doc/latex/lshort-slovenian/src/custom.tex
101texmf-dist/doc/latex/lshort-slovenian/src/fancyhea.sty
102texmf-dist/doc/latex/lshort-slovenian/src/graphic.tex
103texmf-dist/doc/latex/lshort-slovenian/src/lshort-a5.tex
104texmf-dist/doc/latex/lshort-slovenian/src/lshort-base.tex
105texmf-dist/doc/latex/lshort-slovenian/src/lshort-slovenian.sty
106texmf-dist/doc/latex/lshort-slovenian/src/lshort-slovenian.tex
107texmf-dist/doc/latex/lshort-slovenian/src/lssym.tex
108texmf-dist/doc/latex/lshort-slovenian/src/math.tex
109texmf-dist/doc/latex/lshort-slovenian/src/mylayout.sty
110texmf-dist/doc/latex/lshort-slovenian/src/overview.tex
111texmf-dist/doc/latex/lshort-slovenian/src/spec.tex
112texmf-dist/doc/latex/lshort-slovenian/src/things.tex
113texmf-dist/doc/latex/lshort-slovenian/src/title.tex
114texmf-dist/doc/latex/lshort-slovenian/src/typeset.tex
115)
116
117%__mkdir_p ${PREF}/texmf-dist
118for i in "${manifest[@]}"; do
119    %__install -D %{texlive_src}/$i ${PREF}/$i
120done
121
122## info
123%__rm -f %{buildroot}%{_infodir}/dir
124%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
125
126## man
127## man t1* files are provided by t1utils
128for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
129    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
130done
131
132## man some files are provided by psutils
133for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
134    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
135done
136
137## fix perl path
138for i in source/metapost/expressg/expressg.dtx \
139         doc/metapost/expressg/n2mpsprl.prl \
140         doc/latex/songbook/contrib/crd2sb/crd2sb; do
141    [ -f %{build_texmf}-dist/${i} ] && \
142        %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
143done
144
145## remove asymptote directries, which provides asymptote package
146find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
147# find %{buildroot} -name "Makefile" | xargs %__rm -f
148
149# ## remove xindy
150# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
151
152# ## remove tex4ht
153# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
154
155## remove arch dependent binaries
156%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
157
158## remove unpackaging files
159find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
160find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
161
162## Files list
163find %{buildroot} -type f -or -type l | \
164    %__sed -e "s|%{buildroot}||g" > filelist.full
165
166find %{buildroot}%{texmf}-dist -type d | \
167    %__sed -e "s|^%{buildroot}|%dir |" \
168           -e "s|$|/|"             >> filelist.full
169
170%clean
171%__rm -rf %{buildroot}
172
173%post
174%{exec_texhash}
175
176exit 0
177
178
179%postun
180if [ "$1" = 0 ]; then
181    %{exec_texhash}
182
183fi
184
185exit 0
186
187%files -f filelist.full
188%defattr(-,root,root)
189
190%changelog
191* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
192- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-slovenian
193- improved %%post
194
195* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
196- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-slovenian
197- removed arch dependent binaries (texlive-collection-latexextra)
198- fixed perl path
199- improved updmap process in %%post and %%postun
200
201* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
202- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-slovenian
Note: See TracBrowser for help on using the repository browser.