source: projects/specs/branches/6/t/texlive-collection-documentation-italian/texlive-collection-documentation-italian-vl.spec @ 2505

Revision 2505, 7.2 KB checked in by munepi, 13 years ago (diff)

updated all texlive-collection-* packages: improved %%post

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
3## tlpdb2rpmspec collection-documentation-italian
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Italian documentation
28Summary(ja): TeX Live: Italian documentation
29Name: texlive-collection-documentation-italian
30Version: 2009
31Release: 3%{?_dist_release}
32License: GPL+
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Italian documentation:
61
62
63This package contains the following CTAN packages:
64amsldoc-it:
65amsmath-it:
66amsthdoc-it:
67fancyhdr-it:
68l2tabu-it: Italian Translation of Obsolete packages and commands
69lshort-italian: Introduction to LaTeX in Italian.
70psfrag-italian: PSfrag documentation in Italian.
71texlive-it: TeX Live manual (Italian)
72
73%description -l ja
74TeX Live ソフトウェアディストリビューションは、
75さまざまな Unix, Macintosh, Windows、および
76他のプラットホームに対して完全な TeX システムを提供します。
77多くの異なった言語を含む TeX ドキュメントの
78編集、組版、閲覧、印刷するためのプログラム、
79そして、TeX マクロやフォントライブラリの大きなコレクションを
80同梱しています。
81
82このディストリビューションは
83同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
84TeX に関するたくさんの一般的なドキュメントを含んでいます。
85
86このパッケージは以下のようなパッケージ集です。
87Italian documentation:
88
89
90このパッケージは以下の CTAN パッケージを含んでいます:
91amsldoc-it:
92amsmath-it:
93amsthdoc-it:
94fancyhdr-it:
95l2tabu-it: Italian Translation of Obsolete packages and commands
96lshort-italian: Introduction to LaTeX in Italian.
97psfrag-italian: PSfrag documentation in Italian.
98texlive-it: TeX Live manual (Italian)
99
100%prep
101
102%build
103
104%install
105[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
106
107PREF=%{buildroot}%{tex_destdir}
108
109manifest=(
110texmf-dist/doc/latex/amsldoc-it/itamsldoc.pdf
111texmf-dist/doc/latex/amsldoc-it/itamsldoc.tex
112texmf-dist/doc/latex/amsmath-it/amsmath.faq
113texmf-dist/doc/latex/amsmath-it/diffs-m_it.txt
114texmf-dist/doc/latex/amsthdoc-it/README
115texmf-dist/doc/latex/amsthdoc-it/amsthdoc_it.pdf
116texmf-dist/doc/latex/amsthdoc-it/amsthdoc_it.tex
117texmf-dist/doc/latex/fancyhdr-it/Makefile
118texmf-dist/doc/latex/fancyhdr-it/itfancyhdr.pdf
119texmf-dist/doc/latex/fancyhdr-it/itfancyhdr.tex
120texmf-dist/doc/latex/l2tabu-it/l2tabuit.pdf
121texmf-dist/doc/latex/l2tabu-it/l2tabuit.tex
122texmf-dist/doc/latex/lshort-italian/CHANGES
123texmf-dist/doc/latex/lshort-italian/MANIFEST
124texmf-dist/doc/latex/lshort-italian/Makefile
125texmf-dist/doc/latex/lshort-italian/README
126texmf-dist/doc/latex/lshort-italian/TRANSLATIONS
127texmf-dist/doc/latex/lshort-italian/fixdate.pl
128texmf-dist/doc/latex/lshort-italian/itlshort.pdf
129texmf-dist/doc/latex/lshort-italian/src.zip
130texmf-dist/doc/latex/psfrag-italian/itpfgguide.pdf
131texmf-dist/doc/latex/psfrag-italian/itpfgguide.tex
132)
133
134%__mkdir_p ${PREF}/texmf-dist
135for i in "${manifest[@]}"; do
136    %__install -D %{texlive_src}/$i ${PREF}/$i
137done
138
139## info
140%__rm -f %{buildroot}%{_infodir}/dir
141%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
142
143## man
144## man t1* files are provided by t1utils
145for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
146    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
147done
148
149## man some files are provided by psutils
150for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
151    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
152done
153
154## fix perl path
155for i in source/metapost/expressg/expressg.dtx \
156         doc/metapost/expressg/n2mpsprl.prl \
157         doc/latex/songbook/contrib/crd2sb/crd2sb; do
158    [ -f %{build_texmf}-dist/${i} ] && \
159        %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
160done
161
162## remove asymptote directries, which provides asymptote package
163find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
164# find %{buildroot} -name "Makefile" | xargs %__rm -f
165
166# ## remove xindy
167# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
168
169# ## remove tex4ht
170# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
171
172## remove arch dependent binaries
173%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
174
175## remove unpackaging files
176find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
177find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
178
179## Files list
180find %{buildroot} -type f -or -type l | \
181    %__sed -e "s|%{buildroot}||g" > filelist.full
182
183find %{buildroot}%{texmf}-dist -type d | \
184    %__sed -e "s|^%{buildroot}|%dir |" \
185           -e "s|$|/|"             >> filelist.full
186
187%clean
188%__rm -rf %{buildroot}
189
190%post
191%{exec_texhash}
192
193exit 0
194
195
196%postun
197if [ "$1" = 0 ]; then
198    %{exec_texhash}
199
200fi
201
202exit 0
203
204%files -f filelist.full
205%defattr(-,root,root)
206
207%changelog
208* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
209- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-italian
210- improved %%post
211
212* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
213- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-italian
214- removed arch dependent binaries (texlive-collection-latexextra)
215- fixed perl path
216- improved updmap process in %%post and %%postun
217
218* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
219- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-italian
Note: See TracBrowser for help on using the repository browser.