source: projects/specs/branches/6/t/texlive-collection-documentation-finnish/texlive-collection-documentation-finnish-vl.spec @ 2505

Revision 2505, 6.7 KB checked in by munepi, 13 years ago (diff)

updated all texlive-collection-* packages: improved %%post

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
3## tlpdb2rpmspec collection-documentation-finnish
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Finnish documentation
28Summary(ja): TeX Live: Finnish documentation
29Name: texlive-collection-documentation-finnish
30Version: 2009
31Release: 3%{?_dist_release}
32License: Public Domain
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Finnish documentation:
61
62
63This package contains the following CTAN packages:
64lshort-finnish: Finnish introduction to LaTeX.
65
66%description -l ja
67TeX Live ソフトウェアディストリビューションは、
68さまざまな Unix, Macintosh, Windows、および
69他のプラットホームに対して完全な TeX システムを提供します。
70多くの異なった言語を含む TeX ドキュメントの
71編集、組版、閲覧、印刷するためのプログラム、
72そして、TeX マクロやフォントライブラリの大きなコレクションを
73同梱しています。
74
75このディストリビューションは
76同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
77TeX に関するたくさんの一般的なドキュメントを含んでいます。
78
79このパッケージは以下のようなパッケージ集です。
80Finnish documentation:
81
82
83このパッケージは以下の CTAN パッケージを含んでいます:
84lshort-finnish: Finnish introduction to LaTeX.
85
86%prep
87
88%build
89
90%install
91[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
92
93PREF=%{buildroot}%{tex_destdir}
94
95manifest=(
96texmf-dist/doc/latex/lshort-finnish/README
97texmf-dist/doc/latex/lshort-finnish/lyhyt2e.pdf
98texmf-dist/doc/latex/lshort-finnish/src/asiat.tex
99texmf-dist/doc/latex/lshort-finnish/src/erikois.tex
100texmf-dist/doc/latex/lshort-finnish/src/esipuhe.tex
101texmf-dist/doc/latex/lshort-finnish/src/grafiikka.tex
102texmf-dist/doc/latex/lshort-finnish/src/kiitokset.tex
103texmf-dist/doc/latex/lshort-finnish/src/kirjallisuus.tex
104texmf-dist/doc/latex/lshort-finnish/src/ladonta.tex
105texmf-dist/doc/latex/lshort-finnish/src/llyhyt2e.sty
106texmf-dist/doc/latex/lshort-finnish/src/lyhyt2e.ind
107texmf-dist/doc/latex/lshort-finnish/src/lyhyt2e.tex
108texmf-dist/doc/latex/lshort-finnish/src/matikka.tex
109texmf-dist/doc/latex/lshort-finnish/src/mylayout.sty
110texmf-dist/doc/latex/lshort-finnish/src/otsikko.tex
111texmf-dist/doc/latex/lshort-finnish/src/symbolit.tex
112texmf-dist/doc/latex/lshort-finnish/src/typeset.tex
113texmf-dist/doc/latex/lshort-finnish/src/viritys.tex
114)
115
116%__mkdir_p ${PREF}/texmf-dist
117for i in "${manifest[@]}"; do
118    %__install -D %{texlive_src}/$i ${PREF}/$i
119done
120
121## info
122%__rm -f %{buildroot}%{_infodir}/dir
123%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
124
125## man
126## man t1* files are provided by t1utils
127for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
128    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
129done
130
131## man some files are provided by psutils
132for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
133    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
134done
135
136## fix perl path
137for i in source/metapost/expressg/expressg.dtx \
138         doc/metapost/expressg/n2mpsprl.prl \
139         doc/latex/songbook/contrib/crd2sb/crd2sb; do
140    [ -f %{build_texmf}-dist/${i} ] && \
141        %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
142done
143
144## remove asymptote directries, which provides asymptote package
145find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
146# find %{buildroot} -name "Makefile" | xargs %__rm -f
147
148# ## remove xindy
149# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
150
151# ## remove tex4ht
152# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
153
154## remove arch dependent binaries
155%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
156
157## remove unpackaging files
158find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
159find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
160
161## Files list
162find %{buildroot} -type f -or -type l | \
163    %__sed -e "s|%{buildroot}||g" > filelist.full
164
165find %{buildroot}%{texmf}-dist -type d | \
166    %__sed -e "s|^%{buildroot}|%dir |" \
167           -e "s|$|/|"             >> filelist.full
168
169%clean
170%__rm -rf %{buildroot}
171
172%post
173%{exec_texhash}
174
175exit 0
176
177
178%postun
179if [ "$1" = 0 ]; then
180    %{exec_texhash}
181
182fi
183
184exit 0
185
186%files -f filelist.full
187%defattr(-,root,root)
188
189%changelog
190* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
191- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-finnish
192- improved %%post
193
194* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
195- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-finnish
196- removed arch dependent binaries (texlive-collection-latexextra)
197- fixed perl path
198- improved updmap process in %%post and %%postun
199
200* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
201- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-finnish
Note: See TracBrowser for help on using the repository browser.