source: projects/specs/branches/6/t/texlive-collection-binextra/texlive-collection-binextra-vl.spec @ 3944

Revision 3944, 23.6 KB checked in by munepi, 13 years ago (diff)

updated texlive and its related packages: ready for Vine Linux 6 release

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-4:
3## tlpdb2rpmspec collection-binextra
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: TeX auxiliary programs
28Summary(ja): TeX Live: TeX auxiliary programs
29Name: texlive-collection-binextra
30Version: 2009
31Release: 4%{?_dist_release}
32License: GPL+, LGPLv2+, Knuth, Freely redistributable without restriction, Public Domain, No Info, LPPL, Artistic
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of TeX auxiliary programs:
61Various useful, but non-essential, support programs. Includes
62programs and macros for DVI file manipulation, literate
63programming, patgen, and the TeX Works Editor.
64
65This package contains the following CTAN packages:
66a2ping: Advanced PS, PDF, EPS converter.
67asymptote: 2D and 3D TeX-Aware Vector Graphics Language.
68bibtex8: A fully 8-bit adaptation of BibTeX 0.99.
69ctie:
70cweb: A Web system in C.
71detex: Strip TeX from a source file.
72dtl: Tools to dis-assemble and re-assemble DVI files.
73dvi2tty: Produce ASCII from DVI.
74dviasm: A utility for editing DVI files.
75dvicopy: Copy DVI files, flattening VFs.
76dvidvi: Convert one DVI file into another.
77dviljk: DVI to Laserjet output.
78dvipng: A fast DVI to PNG/GIF converter.
79dvipos:
80findhyph: Find hyphenated words in a document.
81fragmaster: Using psfrag with PDFLaTeX.
82getnonfreefonts:
83hyphenex: Generate a hyphenation exceptions file.
84lacheck: LaTeX checker.
85latex2man: Translate LaTeX-based manual pages into Unix man format.
86latexmk: Fully automated LaTeX document generation routine.
87listings-ext: Automated input of source.
88mkind-english:
89mkjobtexmf: Generate a texmf tree for a particular job.
90patgen:
91pdfcrop: Crop PDF graphics.
92pdftools: PDF-related utilities, including PostScript-to-PDF conversion
93pkfix: Replace pk fonts in PostScript with Type 1 fonts.
94pkfix-helper: Make PostScript files accessible to pkfix.
95purifyeps: Make EPS work with both LaTeX/dvips and pdfLaTeX.
96seetexk: Utiities for manipulating DVI files.
97synctex:
98texcount: Count words in a LaTeX document.
99texdiff: Compare documents and produce tagged merge.
100texdirflatten: Collect files related to a LaTeX job in a single directory.
101texdoc: Documentation access for TeX distributions.
102texloganalyser: Analyse TeX logs.
103texware: Utility programs for use with TeX.
104tie: Allow multiple web change files.
105tpic2pdftex: Use tpic commands in PDFTeX.
106web: original web programs tangle and weave
107xindy: A general-purpose index processor.
108
109%description -l ja
110TeX Live ソフトウェアディストリビューションは、
111さまざまな Unix, Macintosh, Windows、および
112他のプラットホームに対して完全な TeX システムを提供します。
113多くの異なった言語を含む TeX ドキュメントの
114編集、組版、閲覧、印刷するためのプログラム、
115そして、TeX マクロやフォントライブラリの大きなコレクションを
116同梱しています。
117
118このディストリビューションは
119同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
120TeX に関するたくさんの一般的なドキュメントを含んでいます。
121
122このパッケージは以下のようなパッケージ集です。
123TeX auxiliary programs:
124Various useful, but non-essential, support programs. Includes
125programs and macros for DVI file manipulation, literate
126programming, patgen, and the TeX Works Editor.
127
128このパッケージは以下の CTAN パッケージを含んでいます:
129a2ping: Advanced PS, PDF, EPS converter.
130asymptote: 2D and 3D TeX-Aware Vector Graphics Language.
131bibtex8: A fully 8-bit adaptation of BibTeX 0.99.
132ctie:
133cweb: A Web system in C.
134detex: Strip TeX from a source file.
135dtl: Tools to dis-assemble and re-assemble DVI files.
136dvi2tty: Produce ASCII from DVI.
137dviasm: A utility for editing DVI files.
138dvicopy: Copy DVI files, flattening VFs.
139dvidvi: Convert one DVI file into another.
140dviljk: DVI to Laserjet output.
141dvipng: A fast DVI to PNG/GIF converter.
142dvipos:
143findhyph: Find hyphenated words in a document.
144fragmaster: Using psfrag with PDFLaTeX.
145getnonfreefonts:
146hyphenex: Generate a hyphenation exceptions file.
147lacheck: LaTeX checker.
148latex2man: Translate LaTeX-based manual pages into Unix man format.
149latexmk: Fully automated LaTeX document generation routine.
150listings-ext: Automated input of source.
151mkind-english:
152mkjobtexmf: Generate a texmf tree for a particular job.
153patgen:
154pdfcrop: Crop PDF graphics.
155pdftools: PDF-related utilities, including PostScript-to-PDF conversion
156pkfix: Replace pk fonts in PostScript with Type 1 fonts.
157pkfix-helper: Make PostScript files accessible to pkfix.
158purifyeps: Make EPS work with both LaTeX/dvips and pdfLaTeX.
159seetexk: Utiities for manipulating DVI files.
160synctex:
161texcount: Count words in a LaTeX document.
162texdiff: Compare documents and produce tagged merge.
163texdirflatten: Collect files related to a LaTeX job in a single directory.
164texdoc: Documentation access for TeX distributions.
165texloganalyser: Analyse TeX logs.
166texware: Utility programs for use with TeX.
167tie: Allow multiple web change files.
168tpic2pdftex: Use tpic commands in PDFTeX.
169web: original web programs tangle and weave
170xindy: A general-purpose index processor.
171
172%package doc
173Summary: TeX Live: Documentation files of %{name}
174Group: Applications/Publishing
175Requires: %{name} = %{version}-%{release}
176
177%description doc
178This package contains documentation files of %{name}.
179
180%prep
181
182%build
183
184%install
185[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
186
187PREF=%{buildroot}%{tex_destdir}
188
189manifest=(
190texmf-dist/bibtex/csf/base/88591lat.csf
191texmf-dist/bibtex/csf/base/88591sca.csf
192texmf-dist/bibtex/csf/base/README.TEXLIVE
193texmf-dist/bibtex/csf/base/ascii.csf
194texmf-dist/bibtex/csf/base/cp437lat.csf
195texmf-dist/bibtex/csf/base/cp850lat.csf
196texmf-dist/bibtex/csf/base/cp850sca.csf
197texmf-dist/bibtex/csf/base/cp866rus.csf
198texmf-dist/bibtex/csf/base/csfile.txt
199texmf-dist/bibtex/csf/polish-csf/88592pl.csf
200texmf-dist/bibtex/csf/polish-csf/cp1250pl.csf
201texmf-dist/bibtex/csf/polish-csf/cp852pl.csf
202texmf-dist/bibtex/csf/polish-csf/iso8859-7.csf
203texmf-dist/doc/plain/cweb/cwebman.dvi
204texmf-dist/tex/plain/cweb/cwebmac.tex
205texmf-dist/tex/plain/cweb/pdfXcwebmac.tex
206texmf-dist/tex/plain/cweb/pdfcwebmac.tex
207texmf-dist/tex/plain/cweb/pdfdcwebmac.tex
208texmf-dist/tex/plain/cweb/pdffcwebmac.tex
209texmf-dist/tex/plain/cweb/pdficwebmac.tex
210texmf-dist/tex/plain/cweb/pdfwebmac.tex
211texmf-dist/scripts/dviasm/dviasm.py
212texmf-dist/doc/support/findhyph/Makefile
213texmf-dist/doc/support/findhyph/README
214texmf-dist/doc/support/findhyph/findhyph.bat
215texmf-dist/doc/support/findhyph/findhyph.txt
216texmf-dist/scripts/findhyph/findhyph
217texmf-dist/doc/support/fragmaster/AUTHORS
218texmf-dist/doc/support/fragmaster/COPYING
219texmf-dist/doc/support/fragmaster/CREDITS
220texmf-dist/doc/support/fragmaster/README
221texmf-dist/doc/support/fragmaster/README.de
222texmf-dist/doc/support/fragmaster/example/document.pdf
223texmf-dist/doc/support/fragmaster/example/document.ps
224texmf-dist/doc/support/fragmaster/example/document.tex
225texmf-dist/doc/support/fragmaster/example/parabel.eps
226texmf-dist/doc/support/fragmaster/example/parabel.pdf
227texmf-dist/doc/support/fragmaster/example/parabel_fm
228texmf-dist/doc/support/fragmaster/example/parabel_fm.eps
229texmf-dist/doc/support/fragmaster/example/parabel_fm.gp
230texmf-dist/doc/support/fragmaster/example/parabel_fm.pdf
231texmf-dist/scripts/fragmaster/fragmaster.pl
232texmf-dist/source/generic/hyphenex/GNUmakefile
233texmf-dist/source/generic/hyphenex/README
234texmf-dist/source/generic/hyphenex/hyphenex.pl
235texmf-dist/source/generic/hyphenex/hyphenex.sh
236texmf-dist/source/generic/hyphenex/tb0hyf.tex
237texmf-dist/source/generic/hyphenex/test.tex
238texmf-dist/tex/generic/hyphenex/ushyphex.tex
239texmf-dist/doc/support/latex2man/CHANGES
240texmf-dist/doc/support/latex2man/INSTALL
241texmf-dist/doc/support/latex2man/Makefile
242texmf-dist/doc/support/latex2man/README
243texmf-dist/doc/support/latex2man/THIS-IS-VERSION-1.23
244texmf-dist/doc/support/latex2man/latex2man.1
245texmf-dist/doc/support/latex2man/latex2man.html
246texmf-dist/doc/support/latex2man/latex2man.pdf
247texmf-dist/doc/support/latex2man/latex2man.tex
248texmf-dist/doc/support/latex2man/latex2man.texi
249texmf-dist/doc/support/latex2man/latex2man.trans
250texmf-dist/doc/support/latex2man/latex2man.txt
251texmf-dist/scripts/latex2man/latex2man
252texmf-dist/tex/latex/latex2man/latex2man.cfg
253texmf-dist/tex/latex/latex2man/latex2man.sty
254texmf-dist/doc/support/latexmk/CHANGES
255texmf-dist/doc/support/latexmk/COPYING
256texmf-dist/doc/support/latexmk/INSTALL
257texmf-dist/doc/support/latexmk/README
258texmf-dist/doc/support/latexmk/example_rcfiles/README
259texmf-dist/doc/support/latexmk/example_rcfiles/pdflatexmkrc
260texmf-dist/doc/support/latexmk/extra-scripts/README1
261texmf-dist/doc/support/latexmk/extra-scripts/dvipdfm_call
262texmf-dist/doc/support/latexmk/extra-scripts/dvipdfm_call.bat
263texmf-dist/doc/support/latexmk/extra-scripts/dvipdfmx_call
264texmf-dist/doc/support/latexmk/extra-scripts/dvipdfmx_call.bat
265texmf-dist/doc/support/latexmk/extra-scripts/kickxdvi
266texmf-dist/doc/support/latexmk/extra-scripts/l1
267texmf-dist/doc/support/latexmk/extra-scripts/l2
268texmf-dist/doc/support/latexmk/extra-scripts/pst2pdf_for_latexmk
269texmf-dist/doc/support/latexmk/extra-scripts/pst2pdf_for_latexmk_README.txt
270texmf-dist/doc/support/latexmk/extra-scripts/startacroread
271texmf-dist/doc/support/latexmk/latexmk.1
272texmf-dist/doc/support/latexmk/latexmk.bat
273texmf-dist/doc/support/latexmk/latexmk.pdf
274texmf-dist/doc/support/latexmk/latexmk.txt
275texmf-dist/scripts/latexmk/latexmk.pl
276texmf-dist/doc/latex/listings-ext/README
277texmf-dist/doc/latex/listings-ext/THIS_IS_VERSION_v48
278texmf-dist/doc/latex/listings-ext/getversion.tex
279texmf-dist/doc/latex/listings-ext/hyperref.cfg
280texmf-dist/doc/latex/listings-ext/listings-ext.bib
281texmf-dist/doc/latex/listings-ext/listings-ext.el
282texmf-dist/doc/latex/listings-ext/listings-ext.makemake
283texmf-dist/doc/latex/listings-ext/listings-ext.mk
284texmf-dist/doc/latex/listings-ext/listings-ext.pdf
285texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_a.java
286texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_b.java
287texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_c.java
288texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_d.java
289texmf-dist/doc/latex/listings-ext/listings-ext_test_a.tex
290texmf-dist/doc/latex/listings-ext/listings-ext_test_d.tex
291texmf-dist/doc/latex/listings-ext/listings.cfg
292texmf-dist/source/latex/listings-ext/listings-ext.dtx
293texmf-dist/source/latex/listings-ext/listings-ext.ins
294texmf-dist/scripts/listings-ext/listings-ext.sh
295texmf-dist/tex/latex/listings-ext/listings-ext.sty
296texmf-dist/makeindex/mkind-english/digit.ist
297texmf-dist/makeindex/mkind-english/letter.ist
298texmf-dist/makeindex/mkind-english/special.ist
299texmf-dist/doc/generic/mkjobtexmf/README
300texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.html
301texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.ltx
302texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.man
303texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.pdf
304texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.txt
305texmf-dist/source/generic/mkjobtexmf/Makefile.in
306texmf-dist/source/generic/mkjobtexmf/configure
307texmf-dist/source/generic/mkjobtexmf/configure.ac
308texmf-dist/source/generic/mkjobtexmf/install-sh
309texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
310texmf-dist/doc/support/patgen/patgen2.tutorial
311texmf-dist/doc/support/pdfcrop/README
312texmf-dist/scripts/pdfcrop/pdfcrop.pl
313texmf-dist/doc/support/pkfix/README
314texmf-dist/scripts/pkfix/pkfix.pl
315texmf-dist/doc/support/pkfix-helper/README
316texmf-dist/doc/support/pkfix-helper/encoding-samples.pdf
317texmf-dist/doc/support/pkfix-helper/encoding-samples.tex
318texmf-dist/scripts/pkfix-helper/pkfix-helper
319texmf-dist/doc/support/purifyeps/README
320texmf-dist/scripts/purifyeps/purifyeps
321texmf-dist/doc/support/texcount/QuickReference.pdf
322texmf-dist/doc/support/texcount/QuickReference.tex
323texmf-dist/doc/support/texcount/README
324texmf-dist/doc/support/texcount/TeXcount.pdf
325texmf-dist/doc/support/texcount/TeXcount.tex
326texmf-dist/doc/support/texcount/macros.tex
327texmf-dist/scripts/texcount/texcount.pl
328texmf-dist/doc/support/texdiff/README
329texmf-dist/scripts/texdiff/texdiff
330texmf-dist/scripts/texdirflatten/texdirflatten
331texmf-dist/doc/support/texloganalyser/README
332texmf-dist/scripts/texloganalyser/texloganalyser
333)
334
335%__mkdir_p ${PREF}/texmf-dist
336for i in "${manifest[@]}"; do
337    %__install -D %{texlive_src}/$i ${PREF}/$i
338done
339## make symlinks of core script utils
340mk_symlinks=(
341texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
342texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
343texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
344texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
345texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
346texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
347texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
348texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
349texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
350texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
351texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
352texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
353texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
354texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
355texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
356texlive-collection-context,/usr/bin/context,/usr/share/texmf-dist/scripts/context/stubs/unix/context
357texlive-collection-context,/usr/bin/ctxtools,/usr/share/texmf-dist/scripts/context/stubs/unix/ctxtools
358texlive-collection-context,/usr/bin/luatools,/usr/share/texmf-dist/scripts/context/lua/luatools.lua
359texlive-collection-context,/usr/bin/makempy,/usr/share/texmf-dist/scripts/context/stubs/unix/makempy
360texlive-collection-context,/usr/bin/mpstools,/usr/share/texmf-dist/scripts/context/stubs/unix/mpstools
361texlive-collection-context,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/stubs/unix/mptopdf
362texlive-collection-context,/usr/bin/mtxrun,/usr/share/texmf-dist/scripts/context/lua/mtxrun.lua
363texlive-collection-context,/usr/bin/mtxtools,/usr/share/texmf-dist/scripts/context/stubs/unix/mtxtools
364texlive-collection-context,/usr/bin/pdftools,/usr/share/texmf-dist/scripts/context/stubs/unix/pdftools
365texlive-collection-context,/usr/bin/pstopdf,/usr/share/texmf-dist/scripts/context/stubs/unix/pstopdf
366texlive-collection-context,/usr/bin/rlxtools,/usr/share/texmf-dist/scripts/context/stubs/unix/rlxtools
367texlive-collection-context,/usr/bin/runtools,/usr/share/texmf-dist/scripts/context/stubs/unix/runtools
368texlive-collection-context,/usr/bin/texexec,/usr/share/texmf-dist/scripts/context/stubs/unix/texexec
369texlive-collection-context,/usr/bin/texfont,/usr/share/texmf-dist/scripts/context/stubs/unix/texfont
370texlive-collection-context,/usr/bin/texmfstart,/usr/share/texmf-dist/scripts/context/ruby/texmfstart.rb
371texlive-collection-context,/usr/bin/textools,/usr/share/texmf-dist/scripts/context/stubs/unix/textools
372texlive-collection-context,/usr/bin/texutil,/usr/share/texmf-dist/scripts/context/stubs/unix/texutil
373texlive-collection-context,/usr/bin/tmftools,/usr/share/texmf-dist/scripts/context/stubs/unix/tmftools
374texlive-collection-context,/usr/bin/xmltools,/usr/share/texmf-dist/scripts/context/stubs/unix/xmltools
375texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
376texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
377texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
378texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
379texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
380texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
381texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
382texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
383texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
384texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
385texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
386texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
387texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/bengali/ebong.py
388texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
389texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
390texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
391texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
392texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex
393texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
394texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
395texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
396texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
397texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
398texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
399texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
400texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf
401texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk
402texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
403texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf.pl
404texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
405)
406%__mkdir_p %{buildroot}%{_bindir}
407pushd %{buildroot}%{_bindir}
408    for i in "${mk_symlinks[@]}"; do
409        tlc=$(echo $i | cut -f 1 -d",")
410        lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
411        rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
412
413        [ "%{name}" = "$tlc" ] || continue
414        [ -f $rlnk ] || exit 1
415        %__ln_s $rlnk $lnk || exit 1
416    done
417popd
418## info
419%__rm -f %{buildroot}%{_infodir}/dir
420%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
421
422## man
423## man t1* files are provided by t1utils
424for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
425    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
426done
427
428## man some files are provided by psutils
429for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
430    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
431done
432
433## fix perl path
434for i in source/metapost/expressg/expressg.dtx \
435         doc/metapost/expressg/n2mpsprl.prl \
436         doc/latex/songbook/contrib/crd2sb/crd2sb; do
437    [ -f %{build_texmf}-dist/${i} ] && \
438        %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
439done
440
441## remove asymptote directries, which provides asymptote package
442find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
443# find %{buildroot} -name "Makefile" | xargs %__rm -f
444
445# ## remove xindy
446# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
447
448# ## remove tex4ht
449# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
450
451## remove arch dependent binaries
452%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
453
454## remove unpackaging files
455find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
456find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
457
458## Files list
459find %{buildroot} -type f -or -type l | \
460    %__sed -e "s|%{buildroot}||g" > filelist.full
461
462find %{buildroot}%{texmf}-dist -type d | \
463    %__sed -e "s|^%{buildroot}|%dir |" \
464           -e "s|$|/|"             >> filelist.full
465
466## subpackages
467grep "/texmf-dist/doc/" filelist.full > filelist.doc
468cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
469%__mv -f filelist.tmp filelist.full
470
471%clean
472%__rm -rf %{buildroot}
473
474%post
475%{exec_texhash}
476
477exit 0
478
479
480%postun
481if [ "$1" = 0 ]; then
482    %{exec_texhash}
483
484fi
485
486exit 0
487
488%files -f filelist.full
489%defattr(-,root,root)
490
491%files -f filelist.doc doc
492%defattr(-,root,root)
493
494%changelog
495* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
496- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-binextra
497- make symlinks of core script utils (texlive-collection-binextra,
498  texlive-collection-context, texlive-collection-fontutils,
499  texlive-collection-langgreek, texlive-collection-langindic,
500  texlive-collection-latex, texlive-collection-latexextra,
501  texlive-collection-latexrecommended, texlive-collection-pictures,
502  texlive-collection-pstricks, texlive-collection-science)
503
504* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
505- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-binextra
506- improved %%post
507
508* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
509- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-binextra
510- removed arch dependent binaries (texlive-collection-latexextra)
511- fixed perl path
512- improved updmap process in %%post and %%postun
513
514* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
515- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-binextra
Note: See TracBrowser for help on using the repository browser.