source: projects/specs/branches/6/t/texinfo/texinfo-vl.spec @ 3711

Revision 3711, 13.1 KB checked in by daisuke, 13 years ago (diff)

add BR: help2man

Line 
1%define      extraver   a
2
3%define      _infodir   /usr/share/info
4
5Summary:     Tools needed to create Texinfo format documentation files.
6Summary(ja): Texinfo ドキュメントを作成する為に使うツール群
7
8Name:        texinfo
9Version:     4.13a
10Release:     1%{?_dist_release}
11License:     GPLv3+
12Group:       Applications/Publishing
13URL:         http://www.gnu.org/software/texinfo/
14
15#Source0:     ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}%{?extraver:%extraver}.tar.bz2
16Source0:     ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}.tar.lzma
17Source1:     info-dir
18Patch0: texinfo-4.12-zlib.patch
19Patch1: texinfo-4.13a-data_types.patch
20# Patch2: is already upstream
21Patch2: texinfo-4.13a-mosdo-crash.patch
22Patch3: texinfo-4.13a-powerpc.patch
23# Patch4: accepted by upstream, bz579263
24Patch4: texinfo-4.13a-help-index-segfault.patch
25# Patch5: already upstream, bz641534
26Patch5: texinfo-4.13a-texi2dvi-regexp.patch
27# Patch6: already upstream, bz651314
28Patch6: texinfo-4.13a-makeinfo-sectioning.patch
29
30Requires(post): install-info
31Requires(preun): install-info
32Prefix:      %{_prefix}
33Buildroot:   %{_tmppath}/%{name}-%{version}-root
34BuildRequires: autoconf libtool ncurses-devel zlib-devel help2man
35
36
37# Redifine this to "dir" in the info directory isn't compressed
38
39%define __spec_install_post /usr/lib/rpm/brp-strip \; /usr/lib/rpm/brp-strip-comment-note \; rm -f
40
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: daisuke
45
46
47%description
48Texinfo is a documentation system that can produce both online
49information and printed output from a single source file. The GNU
50Project uses the Texinfo file format for most of its documentation.
51
52Install texinfo if you want a documentation system for producing both
53online and print documentation from the same source file and/or if you
54are going to write documentation for the GNU Project.
55
56%description -l ja
57Texinfo は,単一ソースファイルから,オンラインドキュメントと
58印刷用ファイルを出力することの出来るドキュメントシステムです.
59GNU Project では,殆どのドキュメントでこの Texinfo フォーマットを
60採用しています.
61
62単一ソースファイルからオンラインドキュメントと印刷用ファイルを出力
63したい場合,あるいは GNU Project 用にドキュメントを書こうと思っている
64場合は,この texinfo をインストールして下さい.
65
66
67%package -n info
68Summary:     A stand-alone TTY-based reader for GNU texinfo documentation.
69Summary(ja): TTY ベースのスタンドアロン GNU texinfo ドキュメントリーダ
70Group:       System Environment/Base
71# By making info prereq bash, other packages which have triggers based on
72# info don't run those triggers until bash is in place as well. This is an
73# ugly method of doing it (triggers which fire on set intersection would
74# be better), but it's the best we can do for now. Talk to Erik before
75# removing this.
76Requires(pre): bash install-info
77Requires: install-info
78
79%description -n info
80The GNU project uses the texinfo file format for much of its
81documentation. The info package provides a standalone TTY-based
82browser program for viewing texinfo files.
83
84%description -n info -l ja
85GNU Project では殆どのドキュメントに texinfo 形式を採用しています.
86この info パッケージには texinfo ファイルを読む TTY ベースの
87ブラウザプログラムが収められています.
88
89
90%package -n install-info
91Summary:     info file installer
92Summary(ja): info ファイルのインストーラー
93Group:       System Environment/Base
94Conflicts: info < 4.0b-3vl2
95Requires: gzip, bzip2
96
97%description -n install-info
98info file installer.
99
100%description -n install-info -l ja
101info ファイルのインストーラーです.
102
103%prep
104%setup -q -n %{name}-4.13
105%patch0 -p1 -b .zlib
106%patch1 -p1 -b .data_types
107%patch2 -p1 -b .mosdo-crash
108%patch3 -p1 -b .powerpc
109%patch4 -p1 -b .help-index-segfault
110%patch5 -p1 -b .texi2dvi-regexp
111%patch6 -p1 -b .makeinfo-sectioning
112
113
114%build
115
116%configure --mandir=%{_mandir} --infodir=%{_infodir}
117make %{?_smp_mflags}
118
119make -C util LIBS=%{_libdir}/libz.a
120
121
122%install
123rm -rf ${RPM_BUILD_ROOT}
124mkdir -p ${RPM_BUILD_ROOT}/{etc,sbin}
125
126%makeinstall
127
128( cd ${RPM_BUILD_ROOT}
129  gzip -n -9f .%{_infodir}/*info*
130  gzip -n -9f .%{_mandir}/*/*
131  install -m644 ${RPM_SOURCE_DIR}/info-dir ./etc/info-dir
132  ln -sf /etc/info-dir ${RPM_BUILD_ROOT}%{_infodir}/dir
133  for i in makeinfo texindex info install-info ; do
134    strip .%{_bindir}/$i
135  done
136  mv -f .%{_bindir}/install-info ./sbin
137)
138
139%find_lang %name
140
141
142%clean
143rm -rf ${RPM_BUILD_ROOT}
144
145
146%post
147/sbin/install-info %{_infodir}/texinfo.gz %{_infodir}/dir
148
149
150%preun
151if [ $1 = 0 ]; then
152    /sbin/install-info --delete %{_infodir}/texinfo.gz %{_infodir}/dir
153fi
154
155
156%post -n info
157/sbin/install-info %{_infodir}/info-stnd.info.gz %{_infodir}/dir
158
159
160%preun -n info
161if [ $1 = 0 ]; then
162    /sbin/install-info --delete %{_infodir}/info-stnd.info.gz %{_infodir}/dir
163fi
164
165
166%files -f %{name}.lang
167%defattr(-,root,root)
168%doc AUTHORS ChangeLog INSTALL INTRODUCTION NEWS README TODO
169%{_bindir}/makeinfo
170%{_bindir}/pdftexi2dvi
171%{_bindir}/texindex
172%{_bindir}/texi2dvi
173%{_bindir}/texi2pdf
174%{_datadir}/texinfo
175%{_infodir}/texinfo*
176%{_mandir}/man1/makeinfo.1*
177%{_mandir}/man1/pdftexi2dvi.1*
178%{_mandir}/man1/texindex.1*
179%{_mandir}/man1/texi2dvi.1*
180%{_mandir}/man1/texi2pdf.1*
181%{_mandir}/man5/texinfo.5*
182
183
184%files -n info
185%defattr(-,root,root)
186#%config(missingok) /etc/X11/applnk/Utilities/info.desktop
187#%config(noreplace) %verify(not md5 size mtime) /etc/info-dir
188#%config(noreplace) %{_infodir}/dir
189%doc info/README
190%{_bindir}/info
191%{_bindir}/infokey
192%{_infodir}/info.info*
193%{_infodir}/info-stnd.info*
194%{_mandir}/man1/info.1*
195%{_mandir}/man1/infokey.1*
196%{_mandir}/man5/info.5*
197
198
199%files -n install-info
200%defattr(-,root,root)
201%config(noreplace) %verify(not md5 size mtime) /etc/info-dir
202%config(noreplace) %{_infodir}/dir
203%{_syssbindir}/install-info
204%{_mandir}/man1/install-info.1*
205
206
207%changelog
208* Sun Apr 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.13a-1
209- update to 4.13a
210- add patch2-6 from upstream
211- add BR: help2man
212
213* Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.13-2
214- add R: gzip, bzip2 into install-info to fix making vbootstrap env.
215- change tag Prereq -> Req(pre)
216
217* Wed Apr 21 2010 Shu KONNO <owa@bg.wakwak.com> 4.13-1
218- new upstream release, and rebuilt with new environment
219- dropt Patch3: texinfo-4.3-zlib.patch
220
221* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.8-1vl5
222- applied new versioning policy, spec in utf-8
223
224* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.8-0vl1
225- new upstream release (4.8a)
226- move /etc/info-dir, %%{_infodir}/dir to install-info package
227- add URL
228- not apply patch1
229
230* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 4.7-0vl2
231- rebuilt for x86_64 architecture support
232
233* Thu Jul 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7-0vl1
234- new upstream release
235
236* Sat Dec 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2-5vl1
237- updated to 4.2 based on 4.2-5
238
239  * Mon Sep  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-5
240  - Fix crash w/ MALLOC_CHECK_ == 2 (#72831)
241  * Tue Jul  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
242  - Add infokey (#67728)
243  * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
244  - automated rebuild
245  * Thu May 23 2002 Tim Powers <timp@redhat.com>
246  - automated rebuild
247  * Tue Apr 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
248  - 4.2
249
250* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.1-1vl4
251- rebuild
252
253* Fri Nov 29 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1-1vl3
254- /usr/info -> /usr/share/info (defined on the first line of this spec)
255  (rpm-4.0.4-18vl11 and later will define so, though)
256
257* Sun Mar 17 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1-1vl2
258- rewrote changelog at 4.0b-3vl4 (fixed typo)
259- rebuild
260
261* Sat Mar 16 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1-1vl1
262- updated texinfo-4.1
263- fixed broken changelog ;P
264
265* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 4.0b-3vl4
266- updated on zlib (security Fix.)
267
268* Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0b-3vl3
269  - just rebuild with new release number.
270    * Mon Feb 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0b-3vl2
271    - Oops the spec was in Shift-JIS. Fixed.
272
273* Mon Feb 11 2002 akira yamada <akira@vinelinux.org> 4.0b-3vl2
274- %{_syssbindir}/install-info is separated from info package.
275- added autoconf, libtool, ncurses-devel, zlib-devel to BuildRequires.
276
277* Mon Jan 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0b-3vl1
278- based on 4.0b-3 from Rawhide and built for Vine Linux
279- added Japanese summary and description
280- fixed rpm macros
281
282* Tue Aug  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.0b-3
283- Don't create the desktop file - we don't install it anyway.
284
285* Sat Jul 21 2001 Tim Powers <timp@redhat.com>
286- remove the info viewer from the menus, it's cluttering things
287
288* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
289- 4.0b
290
291* Tue Apr 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.0a-1
292- Update to 4.0a, the patch looks sane
293
294* Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
295- langify
296- don't create desktop file in spec file
297
298* Tue Jan 23 2001 Preston Brown <pbrown@redhat.com>
299- danish translation added
300
301* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
302- Rebuild to get rid of 0777 dirs
303
304* Wed Nov  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
305- Fix recognition of .?o extensions in texi2dvi, Bug #20498
306
307* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
308- FHS packaging (64bit systems need to use %%_libdir not /usr/lib).
309
310* Sat Aug 19 2000 Trond Eivind Glomsr <teg@redhat.com>
311- really do it - #16120
312
313* Mon Aug 14 2000 Helge Deller <hdeller@redhat.com>
314- gzip man-pages, #16120
315
316* Mon Aug  7 2000 Tim Waugh <twaugh@redhat.com>
317- List man-pages in %%files.
318
319* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
320- Add Swedish and German translations to desktop file, Bug #15366
321
322* Thu Aug  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
323- mark /etc/info-dir %%verify(not md5 size mime), Bug #14826
324
325* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
326- automatic rebuild
327
328* Wed Jun 28 2000 Bill Nottingham <notting@redhat.com>
329- fix build wackiness with info page compressing
330
331* Fri Jun 16 2000 Bill Nottingham <notting@redhat.com>
332- fix info-dir symlink
333
334* Thu May 18 2000 Preston Brown <pbrown@redhat.com>
335- use FHS paths for info.
336
337* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
338- rebuild with current ncurses
339
340* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
341- wmconfig -> desktop
342
343* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
344- fix descriptions
345
346* Wed Jan 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
347- move info-stnd.info* to the info package, /sbin/install-info it
348  in %post (Bug #6632)
349
350* Thu Jan 13 2000 Jeff Johnson <jbj@redhat.com>
351- recompile to eliminate ncurses foul-up.
352
353* Tue Nov  9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
354- 4.0
355- handle RPM_OPT_FLAGS
356
357* Tue Sep 07 1999 Cristian Gafton <gafton@redhat.com>
358- import version 3.12h into 6.1 tree from HJLu
359
360* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
361- auto rebuild in the new build environment (release 4)
362
363* Wed Mar 17 1999 Erik Troan <ewt@redhat.com>
364- hacked to use zlib to get rid of the requirement on gzip
365
366* Wed Mar 17 1999 Matt Wilson <msw@redhat.com>
367- install-info prerequires gzip
368
369* Thu Mar 11 1999 Cristian Gafton <gafton@redhat.com>
370- version 3.12f
371- make /usr/info/dir to be a %config(noreplace)
372* Wed Nov 25 1998 Jeff Johnson <jbj@redhat.com>
373- rebuild to fix docdir perms.
374
375* Thu Sep 24 1998 Cristian Gafton <gafton@redhat.com>
376- fix allocation problems in install-info
377
378* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
379- /sbin/install-info should not depend on /usr/lib/libz.so.1 -- statically
380  link with /usr/lib/libz.a.
381
382* Fri Aug 07 1998 Erik Troan <ewt@redhat.com>
383- added a prereq of bash to the info package -- see the comment for a
384  description of why that was done
385
386* Tue Jun 09 1998 Prospector System <bugs@redhat.com>
387- translations modified for de
388
389* Tue Jun  9 1998 Jeff Johnson <jbj@redhat.com>
390- add %attr to permit non-root build.
391
392* Thu May 07 1998 Prospector System <bugs@redhat.com>
393- translations modified for de, fr, tr
394
395* Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
396- added %clean
397- manhattan build
398
399* Wed Mar 04 1998 Cristian Gafton <gafton@redhat.com>
400- upgraded to version 3.12
401- added buildroot
402
403* Sun Nov 09 1997 Donnie Barnes <djb@redhat.com>
404- moved /usr/info/dir to /etc/info-dir and made /usr/info/dir a
405  symlink to /etc/info-dir.
406
407* Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
408- added wmconfig entry for info
409
410* Wed Oct 01 1997 Donnie Barnes <djb@redhat.com>
411- stripped /sbin/install-info
412
413* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
414- added info-dir to filelist
415
416* Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
417- added patch from sopwith to let install-info understand gzip'ed info files
418- use skeletal dir file from texinfo tarball (w/ bash entry to reduce
419  dependency chain) instead (and install-info command everywhere else)
420- patches install-info to handle .gz names correctly
421
422* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
423- built against glibc
424
425* Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
426- patched install-info.c for glibc.
427- added /usr/bin/install-info to the filelist
428
429* Tue Feb 18 1997 Michael Fulbright <msf@redhat.com>
430- upgraded to version 3.9.
Note: See TracBrowser for help on using the repository browser.