source: projects/specs/branches/6/t/telepathy-farsight/telepathy-farsight-vl.spec @ 2041

Revision 2041, 4.5 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define dbus_ver        1.4.0
4%define dbus_glib_ver   0.88
5%define tp_glib_ver     0.13.0
6%define farsight2_ver   0.0.17
7
8Name:           telepathy-farsight
9Version:        0.0.15
10Release:        1%{?_dist_release}
11Summary:        Telepathy client to handle media streaming channels
12
13Group:          System Environment/Libraries
14License:        LGPLv2+
15URL:            http://telepathy.freedesktop.org/wiki/
16Source0:        http://telepathy.freedesktop.org/releases/%{name}/%{name}-%{version}.tar.gz
17# Workaround broken private require. https://bugzilla.redhat.com/show_bug.cgi?id=426106
18# Patch0:         %{name}-broken-pkgconfig.patch
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires:  glib2-devel
22BuildRequires:  dbus-devel >= %{dbus_ver}
23BuildRequires:  dbus-glib-devel >= %{dbus_glib_ver}
24BuildRequires:  telepathy-glib-devel >= %{tp_glib_ver}
25BuildRequires:  farsight2-devel >= %{farsight2_ver}
26BuildRequires:  gstreamer-python >= 0.10.10
27# Needed to remove rpath
28BuildRequires:  chrpath
29BuildRequires:  python-devel
30BuildRequires:  pygobject-devel
31
32%description
33%{name} is a Telepathy client that uses Farsight and GStreamer to
34handle media streaming channels. It's used as a background process
35by other Telepathy clients, rather than presenting any user interface
36of its own.
37
38%package        python
39Summary:        Python binding for %{name}
40Group:          Development/Libraries
41Requires:       %{name} = %{version}-%{release}
42
43%description    python
44Python bindings for %{name}.
45
46%package devel
47Summary:        Development files for %{name}
48Group:          Development/Libraries
49Requires:       %{name} = %{version}-%{release}
50Requires:       %{name}-python = %{version}-%{release}
51Requires:       glib2-devel
52Requires:       dbus-glib-devel >= %{dbus_glib_ver}
53Requires:       farsight2-devel >= %{farsight2_ver}
54Requires:       telepathy-filesystem
55Requires:       pkgconfig
56
57%description    devel
58The %{name}-devel package contains libraries and header files for
59developing applications that use %{name}.
60
61
62%prep
63%setup -q
64# %patch0 -p1 -b .pkgconfig
65
66%build
67%configure --disable-static
68make %{?_smp_mflags}
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
73find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
74# Remove rpath
75chrpath --delete $RPM_BUILD_ROOT%{python_sitearch}/*.so
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80
81%post -p /sbin/ldconfig
82
83%postun -p /sbin/ldconfig
84
85
86%files
87%defattr(-,root,root,-)
88%doc COPYING NEWS
89%{_libdir}/*.so.*
90
91%files python
92%defattr(-,root,root,-)
93%{python_sitearch}/*.so
94
95%files devel
96%defattr(-,root,root,-)
97%{_libdir}/*.so
98%{_libdir}/pkgconfig/*.pc
99%{_includedir}/telepathy-1.0/%{name}/
100%{_datadir}/gtk-doc/html/%{name}
101
102%changelog
103* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.0.15-1
104- new upstream release
105
106* Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.0.13-3
107- rebuilt with rpm-4.8.1 for pkg-config
108
109* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.13-2
110- add BuildRequires: python-devel, pygobject-devel
111
112* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.13-1
113- new upstream release
114
115* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.0.12-3
116- rebuild with python-2.6
117
118* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.12-2
119- initial build for Vine Linux
120
121* Mon Oct 19 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.12-1
122- Update to 0.0.12.
123
124* Thu Sep 10 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.11-1
125- Update to 0.0.11.
126
127* Tue Sep  8 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.10-1
128- Update to 0.0.10.
129
130* Tue Aug 25 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.9-1
131- Update to 0.0.9.
132
133* Thu Aug  6 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.8-1
134- Update to 0.0.8.
135
136* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-2
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
138
139* Thu May  7 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.7-1
140- Update to 0.0.7.
141
142* Tue Mar 17 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.6-1
143- Update to 0.0.6.
144- Bump min version of tp-glib needed.
145
146* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.4-3
147- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
148
149* Tue Feb 10 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.4-2
150- Add devel requires on telepathy-filesystem.
151
152* Sat Jan 17 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.4-1
153- Initial spec.
154
Note: See TracBrowser for help on using the repository browser.