source: projects/specs/branches/6/t/tcsh/tcsh-vl.spec @ 4142

Revision 4142, 11.9 KB checked in by iwaim, 13 years ago (diff)

tcsh-6.17-1

Line 
1%define _bindir /bin
2
3Summary: An enhanced version of csh, the C shell
4Summary(ja): csh, Cシェルの進化バージョン
5Name: tcsh
6Version: 6.17
7Release: 1%{?_dist_release}
8License: BSD
9URL: http://www.tcsh.org/
10Group: System Environment/Shells
11
12Source: ftp://ftp.astron.com/pub/tcsh/%{name}-%{version}.00.tar.gz
13Patch1: tcsh-6.15.00-closem.patch
14Patch2: tcsh-6.14.00-tinfo.patch
15Patch3: tcsh-6.14.00-unprintable.patch
16Patch4: tcsh-6.15.00-hist-sub.patch
17Patch6: tcsh-6.15.00-ca-color.patch
18Patch7: tcsh-6.14.00-set.patch
19Patch8: tcsh-6.14.00-syntax.patch
20Patch9: tcsh-6.13.00-memoryuse.patch
21Patch11: tcsh-6.14.00-order.patch
22Patch12: tcsh-6.15.00-rs-color.patch
23Patch13: tcsh-6.17.00-mh-color.patch
24# The idea is good, but the patch must be rewritten to be accepted by upstream
25# (see tcsh mailing list for more information):
26Patch14: tcsh-6.17.00-glob-automount.patch
27# Accepted by upstream:
28Patch15: tcsh-6.17.00-history.patch
29# Accepted by upstream:
30Patch16: tcsh-6.17.00-printexitvalue.patch
31Patch17: tcsh-6.17.00-testsuite.patch
32# Accepted by upstream:
33Patch18: tcsh-6.17.00-extrafork.patch
34# Accepted by upstream (tcsh-6.17.03b http://bugs.gw.com/view.php?id=109):
35Patch19: tcsh-6.17.00-wait-intr.patch
36# Accepted by upstream (tcsh-6.17.03b http://bugs.gw.com/view.php?id=112):
37Patch21: tcsh-6.17.00-dont-set-empty-remotehost.patch
38# Patch by upstream (tcsh-6.17.01b http://mx.gw.com/pipermail/tcsh-bugs/2010-May/000673.html):
39Patch22: tcsh-6.17.00-dont-print-history-on-verbose.patch
40# Accepted by upstream (tcsh-6.17.03b http://bugs.gw.com/view.php?id=113):
41Patch23: tcsh-6.17.00-variable-names.patch
42# Accepted by upstream (tcsh-6.17.05b http://mx.gw.com/pipermail/tcsh-bugs/2011-March/000727.html):
43Patch24: tcsh-6.17.00-avoid-infinite-loop-pendjob-xprintf.patch
44
45Provides: csh = %{version}
46Requires(post): grep
47Requires(postun): coreutils, grep
48
49Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
50BuildRequires: autoconf, automake, ncurses-devel, gettext-devel
51
52%description
53Tcsh is an enhanced but completely compatible version of csh, the C
54shell.  Tcsh is a command language interpreter which can be used both
55as an interactive login shell and as a shell script command processor.
56Tcsh includes a command line editor, programmable word completion,
57spelling correction, a history mechanism, job control and a C language
58like syntax.
59
60%description -l ja
61tcsh は、バークレイ版 UNIX の C シェル csh と完全に互換性があり、
62さらに機能強化したシェルです。対話的なログインシェル、またシェルス
63クリプトのコマンドプロセッサの両方の用途で使われるコマンドインタプ
64リタです。
65tcsh には、コマンド行編集機能や、プログラム可能な単語の補完機能、
66スペル訂正、履歴、ジョブ制御、C 言語風の文法等が含まれます。
67
68%prep
69%setup -q -n %{name}-%{version}.00
70%patch1 -p1 -b .closem
71%patch2 -p1 -b .tinfo
72%patch3 -p1 -b .unprintable
73%patch4 -p1 -b .hist-sub
74%patch6 -p1 -b .ca-color
75%patch7 -p1 -b .set
76%patch8 -p1 -b .syntax
77%patch9 -p1 -b .memoryuse
78%patch11 -p1 -b .order
79%patch12 -p1 -b .rs-color
80%patch13 -p1 -b .mh-color
81%patch14 -p1 -b .glob-automount
82%patch15 -p1 -b .history
83%patch16 -p1 -b .printexitvalue
84%patch17 -p1 -b .testsuite
85%patch18 -p1 -b .extrafork
86%patch19 -p1 -b .wait-intr
87%patch21 -p1 -b .dont-set-empty-remotehost
88%patch22 -p1 -b .dont-print-history-on-verbose
89%patch23 -p1 -b .variable-names
90%patch24 -p1 -b .avoid-infinite-loop-pendjob-xprintf
91
92for i in Fixes WishList; do
93 iconv -f iso-8859-1 -t utf-8 "$i" > "${i}_" && \
94 touch -r "$i" "${i}_" && \
95 mv "${i}_" "$i"
96done
97
98%build
99# For tcsh-6.14.00-tinfo.patch
100autoreconf
101%configure --without-hesiod
102make %{?_smp_mflags} all
103make %{?_smp_mflags} -C nls catalogs
104
105%install
106rm -rf $RPM_BUILD_ROOT
107mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1 ${RPM_BUILD_ROOT}%{_bindir}
108install -p -m 755 tcsh ${RPM_BUILD_ROOT}%{_bindir}/tcsh
109install -p -m 644 tcsh.man ${RPM_BUILD_ROOT}%{_mandir}/man1/tcsh.1
110ln -sf tcsh ${RPM_BUILD_ROOT}%{_bindir}/csh
111ln -sf tcsh.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/csh.1
112
113while read lang language ; do
114        dest=${RPM_BUILD_ROOT}%{_datadir}/locale/$lang/LC_MESSAGES
115        if test -f tcsh.$language.cat ; then
116                mkdir -p $dest
117                install -p -m 644 tcsh.$language.cat $dest/tcsh
118                echo "%lang($lang) %{_datadir}/locale/$lang/LC_MESSAGES/tcsh"
119        fi
120done > tcsh.lang << _EOF
121de german
122el greek
123en C
124es spanish
125et et
126fi finnish
127fr french
128it italian
129ja ja
130pl pl
131ru russian
132uk ukrainian
133_EOF
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%post
139if [ ! -f /etc/shells ]; then
140 echo "%{_bindir}/tcsh" >> /etc/shells
141 echo "%{_bindir}/csh"  >> /etc/shells
142else
143 grep -q '^%{_bindir}/tcsh$' /etc/shells || \
144 echo "%{_bindir}/tcsh" >> /etc/shells
145 grep -q '^%{_bindir}/csh$'  /etc/shells || \
146 echo "%{_bindir}/csh"  >> /etc/shells
147fi
148
149%postun
150if [ ! -x %{_bindir}/tcsh ]; then
151 grep -v '^%{_bindir}/tcsh$'  /etc/shells | \
152 grep -v '^%{_bindir}/csh$' > /etc/shells.rpm && \
153 mv /etc/shells.rpm /etc/shells
154fi
155
156%files -f tcsh.lang
157%defattr(-,root,root,-)
158%doc BUGS FAQ Fixes NewThings WishList complete.tcsh
159%{_bindir}/tcsh
160%{_bindir}/csh
161%{_mandir}/man1/*.1*
162
163%changelog
164* Sun Jun 12 2011 IWAI, Masaharu <iwai@alib.jp> 6.17-1
165- new upstream release
166- drop wide str patch (Patch12): upstream fixed
167- update ca-color patch (Patch6) from Fedora tcsh-6.17-15
168- update syntax patch (Patch8) from Fedora tcsh-6.17-15
169- update rs-color patch from Fedora tcsh-6.17-15
170- resync with Fedora tcsh-6.17-15
171 - change patch number Patch13 -> Patch12
172 - add Patch13..24
173  * Thu Mar 24 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-15
174  - Avoid infinite loop pendjob()-xprintf() when stdout is closed
175    Resolves: #690356
176 
177  * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.17-14
178  - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
179 
180  * Fri Jan 28 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-13
181  - Modify verbose patch to match with upstream (don't print on history -S)
182    Resolves: #672810
183 
184  * Wed Jan 26 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-12
185  - Fix error message on exit
186    Resolves: #672810
187 
188  * Mon Jan 24 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-11
189  - Don't set $REMOTEHOST on the local machine
190    Resolves: #669176
191  - Don't print history in verbose mode
192    Resolves: #583075, #658171
193  - Don't allow illegal variable names to be set
194    Resolves: #436901
195  - Revert "Fix incorrect $status value of pipelined commands"
196 
197  * Tue Dec 21 2010 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-10
198  - Make wait builtin command interruptible
199    Resolves: #440465
200  - Fix incorrect $status value of pipelined commands
201    Resolves: #638955 (Patch by Tomas Smetana <tsmetana@redhat.com>)
202 
203  * Wed Oct  6 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-9
204  - Remove fork when tcsh processes backquotes
205 
206  * Wed Apr 14 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-8
207  - Fix testsuite
208 
209  * Mon Mar  1 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-7
210  - Ship README file
211 
212  * Tue Dec 15 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-6
213  - Fix tcsh obeys printexitvalue for back-ticks
214 
215  * Wed Nov  4 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-5
216  - Fix few globbing problems
217 
218  * Mon Oct 19 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-4
219  - Fix tcsh globbing causing bad automount
220  - Fix truncated history file after network crash
221 
222  * Wed Aug 26 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-3
223  - Add new colorls variable
224    Resolves: #518808
225 
226  * Sun Jul 26 2009 Fedora Release Engineering <releng@lists.fedoraproject.org> - 6.17-2
227  - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
228 
229  * Mon Jul 20 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-1
230  - Update to tcsh-6.17.00
231
232* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.16-2
233- rebuilt with current VineSeed
234
235* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 6.16-1
236- new upstream release
237- resync with 6.16-1(fc12)
238- drop vine patch
239
240* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 6.12-1vl5
241- applied new versioning policy, spec in utf-8
242
243* Wed Oct 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 6.12-0vl6
244- added patch11 from fedora
245  * Thu Mar 23 2006 Miloslav Trmac <mitr@redhat.com> - 6.14-8
246  - Backport a patch to ignore LS_COLOR codes introduced in newer coreutils
247    (#186037)
248- added japanese description
249
250* Thu Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl5
251- added patch from fedora
252  * Tue Feb 10 2004 Nalin Dahyabhai <nalin@redhat.com> 6.12-7
253  - remove declaration of setpgrp() which conflicts with libc's (#115185)
254
255  * Fri Nov 21 2003 Nalin Dahyabhai <nalin@redhat.com> 6.12-6
256  - add missing buildprereqs on groff, libtermcap-devel (#110599)
257
258* Mon Oct 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.12-0vl4
259- rebuild with new toolchains
260- s/Copyright/License/
261- fix spec file to build correctly (based on Rawhide spec file)
262
263* Tue Aug 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl3
264- "Re"-changed the way of fixing check locale from Patch8 to Patch9
265  on ppc strlen() can not deal with 'short' variables
266
267* Sat Aug 03 2002 Satoshi MACHINO <machino@vinelinux.org> 6.12-0vl2
268- fixed changelog
269
270* Thu Jul 25 2002 K. Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.12-0vl1
271- update
272
273* Sun Apr 28 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.11-0vl4
274- change limit.patch
275
276* Fri Apr 26 2002 Kosaku Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.11-0vl3
277- fixed limit by Patch10
278
279* Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl2
280- changed the way of fixing check locale from Patch8 to Patch9
281  on ppc strlen() can not deal with 'short' variables
282
283* Mon Jan 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl1
284- update
285
286* Thu Dec 28 2001 Satoshi MACHINO <machino@vinelinux.org> 6.10.02-0vl2
287- fixed check locale
288        - merged some patches from RHL-7.2
289
290* Thu Aug 09 2001 <sagami@vinelinux.org>
291- 6.10.02-0vl1
292
293* Sun Jan  7 2001 Jun Nishii <jun@vinelinux.org>
294- 6.10-1vl2
295- build with gcc
296
297* Mon Dec 11 2000 Yasuhide OOMORI <dasen@icntv.ne.jp>
298- syncronized release tcsh based on a securty fix for RH6.2.
299
300* Thu Nov 30 2000 Nalin Dahyabhai <nalin@redhat.com>
301- update to 6.10.00 to fix here-script vulnerability
302
303* Wed Sep 18 2000 Adrian Havill <havill@redhat.com>
304- fix catalog locale dirname for Japanese
305
306* Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
307- FHS packaging.
308- add locale support (#10345).
309
310* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
311- rebuild for sparc baud rates > 38400.
312
313* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
314- rebuild to fix dependencies
315
316* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
317- append entries to spanking new /etc/shells.
318
319* Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com>
320- update to 6.09.
321- fix strcoll oddness (#6000, #6244, #6398).
322
323* Sat Sep 25 1999 Michael K. Johnson <johnsonm@redhat.com>
324- fix $shell by using --bindir
325
326* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
327- auto rebuild in the new build environment (release 5)
328
329* Wed Feb 24 1999 Cristian Gafton <gafton@redhat.com>
330- patch for using PATH_MAX instead of some silly internal #defines for
331  variables that handle filenames.
332
333* Fri Nov  6 1998 Jeff Johnson <jbj@redhat.com>
334- update to 6.08.00.
335
336* Fri Oct 02 1998 Cristian Gafton <gafton@redhat.com>
337- upgraded to 6.07.09 from the freebsd
338- security fix
339
340* Wed Aug  5 1998 Jeff Johnson <jbj@redhat.com>
341- use -ltermcap so that /bin/tcsh can be used in single user mode w/o /usr.
342- update url's
343
344* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
345- translations modified for de, fr, tr
346
347* Thu Oct 21 1997 Cristian Gafton <gafton@redhat.com>
348- updated to 6.07; added BuildRoot
349- cleaned up the spec file; fixed source url
350
351* Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
352- added termios hacks for new glibc
353- added /bin/csh to file list
354
355* Fri Jun 13 1997 Erik Troan <ewt@redhat.com>
356- built against glibc
357
358* Fri Feb 07 1997 Erik Troan <ewt@redhat.com>
359 - Provides csh, adds and removes /bin/csh from /etc/shells if csh package
360isn't installed.
Note: See TracBrowser for help on using the repository browser.