source: projects/specs/branches/6/t/tcp_wrappers/tcp_wrappers-vl.spec @ 3528

Revision 3528, 9.6 KB checked in by owa, 13 years ago (diff)

rebuilt

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define LIB_MAJOR 0
3%define LIB_MINOR 7
4%define LIB_REL 6
5
6Summary:     A security tool which acts as a wrapper for TCP daemons.
7Summary(ja): TCP デーモンのラッパとして働くセキュリティツール
8Name: tcp_wrappers
9Version: 7.6
10Release: 38%{?_dist_release}
11License: BSD
12Group: System Environment/Daemons
13Source: ftp://ftp.porcupine.org/pub/security/tcp_wrappers_7.6.tar.gz
14Patch0: tcpw7.2-config.patch
15Patch1: tcpw7.2-setenv.patch
16Patch2: tcpw7.6-netgroup.patch
17Patch3: tcp_wrappers-7.6-bug11881.patch
18Patch4: tcp_wrappers-7.6-bug17795.patch
19Patch5: tcp_wrappers-7.6-bug17847.patch
20Patch6: tcp_wrappers-7.6-fixgethostbyname.patch
21Patch7: tcp_wrappers-7.6-docu.patch
22Patch8: tcp_wrappers-7.6-casesens.patch
23Patch9: tcp_wrappers.usagi-ipv6.patch
24Patch10: tcp_wrappers.ume-ipv6.patch
25Patch11: tcp_wrappers-7.6-shared.patch
26Patch12: tcp_wrappers-7.6-sig.patch
27Patch13: tcp_wrappers-7.6-strerror.patch
28Patch14: tcp_wrappers-7.6-ldflags.patch
29Patch15: tcp_wrappers-7.6-fix_sig-bug141110.patch
30Patch16: tcp_wrappers-7.6-162412.patch
31Patch17: tcp_wrappers-7.6-220015.patch
32Patch18: tcp_wrappers-7.6-restore_sigalarm.patch
33Patch19: tcp_wrappers-7.6-siglongjmp.patch
34Patch20: tcp_wrappers-7.6-sigchld.patch
35Patch21: tcp_wrappers-7.6-196326.patch
36Patch22: tcp_wrappers_7.6-249430.patch
37
38# required by sin_scope_id in ipv6 patch
39BuildRequires: glibc-devel >= 2.2               
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41
42
43%description
44The tcp_wrappers package provides small daemon programs which can
45monitor and filter incoming requests for systat, finger, FTP, telnet,
46rlogin, rsh, exec, tftp, talk and other network services.
47
48Install the tcp_wrappers program if you need a security tool for
49filtering incoming network services requests.
50
51%description -l ja
52tcp_wrapper パッケージには小さなデーモンプログラムが収められており,
53systat, finger, FTP, telnet, rlogin, rsh, exec, tftp, talk, その他
54様々なネットワークサービスに対する外部からの要求を監視し,フィルタリング
55することが出来ます.
56
57ネットワークサービスに対する外部からのリクエストをフィルタリング
58出来るセキュリティツールが必要ならば tcp_wrappers パッケージを
59インストールして下さい.
60
61
62## to build compat32 for x86_64 architecture support
63%package -n compat32-%{name}
64Summary:     A security tool which acts as a wrapper for TCP daemons.
65Summary(ja): TCP デーモンのラッパとして働くセキュリティツール
66Group: System Environment/Daemons
67
68%description -n compat32-%{name}
69The tcp_wrappers package provides small daemon programs which can
70monitor and filter incoming requests for systat, finger, FTP, telnet,
71rlogin, rsh, exec, tftp, talk and other network services.
72
73Install the tcp_wrappers program if you need a security tool for
74filtering incoming network services requests.
75
76
77%prep
78%setup -q -n tcp_wrappers_7.6
79%patch0 -p1 -b .config
80%patch1 -p1 -b .setenv
81%patch2 -p1 -b .netgroup
82%patch3 -p1 -b .bug11881
83%patch4 -p1 -b .bug17795
84%patch5 -p1 -b .bug17847
85%patch6 -p1 -b .fixgethostbyname
86%patch7 -p1 -b .docu
87%patch8 -p1 -b .man
88%patch9 -p1 -b .usagi-ipv6
89%patch10 -p1 -b .ume-ipv6
90%patch11 -p1 -b .shared
91%patch12 -p1 -b .sig
92%patch13 -p1 -b .strerror
93%patch14 -p1 -b .cflags
94%patch15 -p1 -b .fix_sig
95%patch16 -p1 -b .162412
96%patch17 -p1 -b .220015
97%patch18 -p1 -b .restore_sigalarm
98%patch19 -p1 -b .siglongjmp
99%patch20 -p1 -b .sigchld
100%patch21 -p1 -b .196326
101%patch22 -p1 -b .249430
102
103# Disable static library creation by default.
104%define with_static 0
105
106%build
107make RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC -DPIC -D_REENTRANT -DHAVE_STRERROR" \
108     LDFLAGS="-pie" MAJOR=%{LIB_MAJOR} MINOR=%{LIB_MINOR} REL=%{LIB_REL} linux
109
110%install
111[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
112mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
113mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
114mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man{3,5,8}
115mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
116
117cp hosts_access.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
118cp hosts_access.5 hosts_options.5 ${RPM_BUILD_ROOT}%{_mandir}/man5
119cp tcpd.8 tcpdchk.8 tcpdmatch.8 ${RPM_BUILD_ROOT}%{_mandir}/man8
120ln -sf hosts_access.5 ${RPM_BUILD_ROOT}%{_mandir}/man5/hosts.allow.5
121ln -sf hosts_access.5 ${RPM_BUILD_ROOT}%{_mandir}/man5/hosts.deny.5
122%if %{with_static}
123cp -a libwrap.a ${RPM_BUILD_ROOT}%{_libdir}
124%endif
125cp -a libwrap.so* ${RPM_BUILD_ROOT}%{_libdir}
126install -p -m644 tcpd.h ${RPM_BUILD_ROOT}%{_includedir}
127install -m755 safe_finger ${RPM_BUILD_ROOT}%{_sbindir}
128install -m711 tcpd ${RPM_BUILD_ROOT}%{_sbindir}
129install -m755 try-from ${RPM_BUILD_ROOT}%{_sbindir}
130
131## XXX remove utilities that expect /etc/inetd.conf (#16059).
132##install -m755 tcpdchk ${RPM_BUILD_ROOT}%{_sbindir}
133##install -m755 tcpdmatch ${RPM_BUILD_ROOT}%{_sbindir}
134#rm -f ${RPM_BUILD_ROOT}%{_mandir}/man8/tcpdmatch.*
135#rm -f ${RPM_BUILD_ROOT}%{_mandir}/man8/tcpdchk.*
136
137## keep tcpdchk and tcpdmatch included here
138## until xinetd is introduced for Vine Linux....
139##
140install -m755 tcpdchk $RPM_BUILD_ROOT%{_sbindir}
141install -m755 tcpdmatch $RPM_BUILD_ROOT%{_sbindir}
142
143%post -p /sbin/ldconfig
144%postun -p /sbin/ldconfig
145
146%post -n compat32-%{name} -p /sbin/ldconfig
147%postun -n compat32-%{name} -p /sbin/ldconfig
148
149%clean
150[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
151
152%files
153%defattr(-,root,root)
154%doc BLURB CHANGES README* DISCLAIMER Banners.Makefile
155%{_mandir}/man[358]/*
156%{_includedir}/*
157%if %{with_static}
158%{_libdir}/*.a
159%endif
160%{_libdir}/*.so
161%{_libdir}/*.so.*
162%{_sbindir}/*
163
164%if %{build_compat32}
165%files -n compat32-%{name}
166%defattr(-,root,root)
167%if %{with_static}
168%{_libdir}/*.a
169%endif
170%{_libdir}/*.so
171%{_libdir}/*.so.*
172%endif
173
174%changelog
175* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 7.6-38
176- rebuilt with rpm-4.8.1-3
177
178* Fri Feb 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-37
179- s/BuildPrereq/BuildRequires/
180- added Patch14-22 from FC
181  * Wed Jul 25 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-49
182  - fix for a.b.c.d/255.255.255.255 - fixes #249430
183  * Thu Jun 28 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-48
184  - compare localhost and localhost.localdomain as the same
185  * Wed Jun 06 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-47
186  - fix the hostname resolving patch for x86_64
187  * Fri May 25 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-45
188  - unblock and catch SIGCHLD from spawned shell commands, fixes #112975
189  * Mon Apr 16 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-44
190  - added restore_sigalarm and siglongjmp patches from Debian, fixes #205129
191  * Fri Mar 09 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-43
192  - resolve hostnames in hosts.{allow,deny}, should fix a bunch of issues with
193    IPv4/6
194  * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 7.6-40
195  - fixed uninitialized fp in function inet_cfg (#162412)
196  * Fri May  6 2005 Thomas Woerner <twoerner@redhat.com> 7.6-39
197  - fixed sig patch (#141110). Thanks to Nikita Shulga for the patch
198
199* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 7.6-36
200- removed unnecessary %%if %{build_compat32} statements
201- removed the static library libwrap.a by default
202
203* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.6-35
204- new versioning policy
205- spec in UTF-8
206
207* Fri Feb 17 2006 Shu KONNO <owa@bg.wakwak.com> 7.6-34vl3
208- added compat32-* packages for x86_64 architecture support
209- fixed tcp_wrappers-7.6-shared.patch (which changed gcc to $CC)
210
211* Wed Nov 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 7.6-34vl2
212- new upstream release
213- add libwrap.so* to %%files
214
215* Fri Jul  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-34vl1
216- based on 7.6-34 from Rawhide, applied some patches
217- rebuild with new toolchains
218- s/Copyright/License/
219
220* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
221- 7.6-17vl0
222- based on 7.6-17 from Rawhide
223- added Japanese summary and description
224- keep tcpdmatch and tcpchk still until xinetd is introduced for Vine
225  (if so in the future, these two program should be removed again...)
226
227* Sat Dec 30 2000 Jeff Johnson <jbj@redhat.com>
228- permit hosts.{allow,deny} to be assembled from included components (#17795).
229- permit '*' and '?' wildcard matches on hostnames (#17847).
230
231* Sun Nov 19 2000 Bill Nottingham <notting@redhat.com>
232- ia64 needs -fPIC too
233
234* Mon Aug 14 2000 Jeff Johnson <jbj@redhat.com>
235- remove utilities that expect /etc/inetd.conf (#16059).
236
237* Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
238- security hardening (#11881).
239
240* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
241- automatic rebuild
242
243* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
244- FHS packaging.
245
246* Tue May 16 2000 Chris Evans <chris@ferret.lmh.ox.ac.uk>
247- Make tcpd mode -rwx--x--x as a security hardening measure
248
249* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
250- compress man pages.
251
252* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
253- add netgroup support (#3940).
254
255* Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
256- compile on sparc with -fPIC.
257
258* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
259- auto rebuild in the new build environment (release 7)
260
261* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
262- build for glibc 2.1
263
264* Sat Aug 22 1998 Jeff Johnson <jbj@redhat.com>
265- close setenv bug (problem #690)
266- spec file cleanup
267
268* Thu Jun 25 1998 Alan Cox <alan@redhat.com>
269- Erp where did the Dec 05 patch escape to
270
271* Thu May 07 1998 Prospector System <bugs@redhat.com>
272- translations modified for de, fr, tr
273
274* Fri Dec 05 1997 Erik Troan <ewt@redhat.com>
275- don't build setenv.o module -- it just breaks things
276
277* Wed Oct 29 1997 Marc Ewing <marc@redhat.com>
278- upgrade to 7.6
279
280* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
281- built against glibc
282
283* Mon Mar 03 1997 Erik Troan <ewt@redhat.com>
284- Upgraded to version 7.5
285- Uses a build root
Note: See TracBrowser for help on using the repository browser.