source: projects/specs/branches/6/t/tclx/tclx-vl.spec @ 3510

Revision 3510, 7.2 KB checked in by owa, 13 years ago (diff)

rebuilt tclx

Line 
1%define tcl_major       8.4
2%define tk_major        8.4
3%define thread_major    2.6
4%define tclx_major      8.4
5%define tclxvers        %{tclx_major}
6Summary: A Tcl/Tk development environment: tclX
7Summary(ja): Tcl/Tk 開発環境: tclX
8Name: tclx
9Version: %{tclxvers}
10Release: 3%{?_dist_release}
11Group: Development/Languages
12License: BSD
13Source0:   ftp://ftp.tcl.tk/pub/tcl/nightly-cvs/tclx-20070227.tar.gz
14BuildRequires: tcl >= %{tcl_major}
15BuildRequires: tk >= %{tk_major}
16BuildRequires: thread >= %{thread_major}
17Requires: tcl >= %{tcl_major}
18Requires: tk >= %{tk_major}
19Requires: thread >= %{thread_major}
20Buildroot: %{_tmppath}/%{name}-root
21
22Distribution: Vine Linux
23Vendor: Project Vine
24
25%description -n tclx
26TclX is a set of extensions which make it easier to use the Tcl
27scripting language for common UNIX/Linux programming tasks.  TclX
28enhances Tcl support for files, network access, debugging, math, lists,
29and message catalogs.  TclX can be used with both Tcl and Tcl/Tk
30applications.
31
32Install TclX if you are developing applications with Tcl/Tk.  You'll
33also need to install the tcl and tk packages.
34
35%description -n tclx -l ja
36TclX は一般的な UNIX/Linux プログラミング作業のおいて、Tcl スクリプト言語
37をより簡単に使用するための拡張キットです。TclX は、ファイルや、ネットワーク
38アクセス、デバッグ、数値計算、リスト、メッセージカタログの Tcl サポートを拡
39張します。TclX は Tcl と Tcl/Tk アプリケーションの両方で使うことができます。
40
41Tcl/Tk のアプリケーションを開発するときには、TclXもインストールしてください。
42tcl と tk のパッケージも必要です。
43
44
45%prep
46%setup -q -n %{name}
47
48
49%build
50# make the libraries reentrant
51RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
52
53# tclX
54%configure \
55--with-tcl=%{_libdir} --with-tk=%{_libdir} \
56--enable-shared --enable-tk --enable-threads --enable-64bit
57make
58
59
60%install
61rm -rf ${RPM_BUILD_ROOT}
62mkdir -p ${RPM_BUILD_ROOT}
63rm -f *.files
64
65# TclX
66%makeinstall
67
68#if [ "%_mandir" = "%{_prefix}/share/man" ]; then
69#   ( cd ${RPM_BUILD_ROOT}%{_prefix}/man; tar cf - ./man[13n] ) |
70#   ( cd ${RPM_BUILD_ROOT}%{_mandir}; tar xf - )
71#   ( cd ${RPM_BUILD_ROOT}%{_prefix}/man; rm -rf ./man[13n] )
72#fi
73
74echo "%%defattr(-,root,root)" > tclx.files
75(find ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_includedir} \
76        ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
77 find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
78        | sort | uniq -u >> tclx.files
79
80set +x +H
81for n in `cat tclx.files`; do
82        test -f $n || continue
83        head -1 $n | grep -q ^#! || continue
84        chmod u+w $n
85        perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
86done
87set -x -H
88
89# post process the *.files list, removing build sys references and mark
90# which are directories
91set +x
92for n in *.files; do
93        mv $n $n.in
94        sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
95            if [ -d ${RPM_BUILD_ROOT}/$file ]; then
96                echo -n '%dir '
97            fi
98            echo $file
99        done > $n
100        rm -f $n.in
101done
102set -x
103
104# Man pages can be compressed
105perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
106
107%post -p /sbin/ldconfig -n tclx
108%postun -p /sbin/ldconfig -n tclx
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%files -f tclx.files -n tclx
113
114%changelog
115* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.2-3
116- rebuilt with rpm-4.8.1-3
117
118* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
119- rebuilt with tcl/tk-8.4.19-2
120
121* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
122- applied new versioning policy
123
124* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
125- updated tclx to tclx-20070227.tar.gz
126- rebuild with tcl/tk-8.4.18
127
128* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
129- rebuild with tcl/tk-8.4.16
130
131* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
132- update based on BitWalk's tcltk-8.4.2-83bw
133
134* Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
135- split source package.
136
137* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
138- expand some macros.. (FIXME)
139
140* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
141- use %configure macros
142- add Patch 47,50
143
144* Thu May 31 2001 <sagami@vinelinux.org>
145- 8.0.5_jp-10
146- unexpand old %%{configure}, new one causes build failure
147- fixed missing libtkx.so libtclx.so symlink in /usr/lib
148- install manpages into %%{_mandir} and mode 644
149
150* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
151- 8.0.5_jp-9
152- modified %install section to handle compressed man pages
153- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
154
155* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
156- changed default fonts
157
158* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
159- added defattr
160
161* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
162- added some symlinks, such as libtcl8.0.so.
163- obsoletes version number using _jp, now 8.0.5-31vl1
164
165* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
166- Apply Tcl/Tk 8.0 Japanese Patch 1.7
167
168* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
169- fix tclX symlinks.
170- compile on systems where SIGPWR == SIGLOST.
171
172* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
173- update tcl/tk to 8.0.5.
174- avoid "containing" in Tix (#2332).
175
176* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
177- use /usr/bin/write in kibitz (#1320).
178- use cirrus.sprl.umich.edu in weather (#1926).
179
180* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
181- auto rebuild in the new build environment (release 28)
182
183* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
184- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
185
186* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
187- expect does unaligned access on alpha (#989)
188- upgrade tcl/tk/tclX to 8.0.4
189- upgrade expect to 5.28.
190- add itcl 3.0.1
191
192* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
193- call libtoolize to allow building on the arm
194- build for glibc 2.1
195- strip binaries
196
197* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
198- update tcl/tk/tclX to 8.0.3, expect is updated also.
199
200* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
201- expect: mkpasswd needs delay before sending password (problem #576)
202
203* Thu May 07 1998 Prospector System <bugs@redhat.com>
204- translations modified for de, fr, tr
205
206* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
207- fixed expect binaries exec permissions
208
209* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
210- updated to Tix 4.1.0.006
211- updated version numbers of tcl/tk to relflect includsion of p2
212
213* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
214- updated tcl/tk to patch level 2
215- updated tclX to 8.0.2
216
217* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
218- fixed filelist for tix... replacing path to the expect binary in scripts
219  was leaving junk files around.
220
221* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
222- added patch to remove libieee test in configure.in for tcl and tk.
223  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
224  solution for all systems
225- fixed src urls
226
227* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
228- removed version numbers from descriptions
229
230* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
231- updated to tcl/tk 8.0 and related versions of packages
232
233* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
234- built against glibc
235- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.