source: projects/specs/branches/6/t/tar/tar-vl.spec @ 3902

Revision 3902, 11.2 KB checked in by kudoh, 13 years ago (diff)
Line 
1Summary: A GNU file archiving program.
2Summary(ja): GNU ファイルアーカイブプログラム
3Name: tar
4Version: 1.26
5Release: 1%{?_dist_release}
6License: GPLv3+
7Group: Applications/Archiving
8Source: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.bz2
9Patch0: tar-1.13.18-manpage.patch
10Patch8: tar-1.20-loneZeroWarning.patch
11Patch10: tar-1.15.1-gcc4.patch
12
13#Fix extracting sparse files to a filesystem like vfat,
14#when ftruncate may fail to grow the size of a file.(#179507)
15Patch11: tar-1.15.1-vfatTruncate.patch
16#change inclusion defaults of tar to "--wildcards --anchored
17#--wildcards-match-slash" for compatibility reasons (#206841)
18Patch12: tar-1.17-wildcards.patch
19#oldarchive option was not working(#594044)
20Patch13: tar-1.23-oldarchive.patch
21
22# adhoc but useful patch for z option accepts bzip2ed tarball.
23Patch100: tar-1.13.6-barterly.patch
24Patch110: tar-1.22-rtapelib-overflow.patch
25
26BuildRequires: autoconf texinfo gettext
27
28Requires(post,postun): install-info
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30
31
32%description
33The GNU tar program saves many files together in one archive and can
34restore individual files (or all of the files) from that archive. Tar
35can also be used to add supplemental files to an archive and to update
36or list files in the archive. Tar includes multivolume support,
37automatic archive compression/decompression, the ability to perform
38remote archives, and the ability to perform incremental and full
39backups.
40
41If you want to use tar for remote backups, you also need to install
42the rmt package.
43
44
45%description -l ja
46GNU tar プログラムは多くのファイルを一つのファイルにまとめたりアーカイブ
47から個々のファイルを(または全てのファイルを)リストアしたりする。tar はまた
48追加ファイルを加えたりアーカイブファイル中のリストを更新したりするために
49使われる。
50
51tar はマルチボリュームサポート、自動アーカイブ圧縮/伸長、リモート
52アーカイブの取り扱う機能、そして差分バックアップとフルバックアップをする
53機能を含んでいる。
54
55もしリモートバックアップのために tar をインストールするなら、rmt パッケージ
56もまたインストールする必要がある。
57
58
59%prep
60%setup -q
61%patch0 -p1 -b .manpage
62%patch8 -p1 -b .loneZeroWarning
63%patch11 -p1 -b .vfatTruncate
64%patch12 -p1 -b .wildcards
65%patch13 -p1 -b .oldarchive
66
67%patch100 -p1 -b .accept-bz2
68%patch110 -p1 -b .CVE-2010-0624
69
70%build
71autoreconf
72%configure --bindir=/bin --libexecdir=/sbin
73make LIBS=-lbsd %{?_smp_mflags}
74
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
79make prefix=${RPM_BUILD_ROOT}%{_prefix} \
80    localedir=${RPM_BUILD_ROOT}%{_prefix}/share/locale \
81    bindir=${RPM_BUILD_ROOT}/bin \
82    libexecdir=${RPM_BUILD_ROOT}/sbin \
83    mandir=${RPM_BUILD_ROOT}%{_mandir} \
84    infodir=${RPM_BUILD_ROOT}%{_infodir} \
85        install
86ln -s tar ${RPM_BUILD_ROOT}/bin/gtar
87
88( cd $RPM_BUILD_ROOT
89  for dir in ./bin ./sbin .%{_prefix}/bin .%{_prefix}/libexec
90  do
91    [ -d $dir ] || continue
92    strip $dir/* || :
93  done
94  gzip -9nf .%{_infodir}/tar.info*
95  rm -f .%{_infodir}/dir
96)
97
98mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
99install -c -m644 tar.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
100
101rm -f ${RPM_BUILD_ROOT}/sbin/rmt
102
103%find_lang %name
104
105
106%post
107/sbin/install-info %{_infodir}/tar.info.gz %{_infodir}/dir
108
109
110%preun
111if [ $1 = 0 ]; then
112   /sbin/install-info --delete %{_infodir}/tar.info.gz %{_infodir}/dir
113fi
114
115
116%clean
117rm -rf ${RPM_BUILD_ROOT}
118
119
120%files -f %{name}.lang
121%defattr(-,root,root)
122%doc AUTHORS COPYING ChangeLog* NEWS README THANKS TODO
123/bin/tar
124/bin/gtar
125%{_mandir}/man1/tar.1*
126%{_infodir}/tar.info*
127
128
129%changelog
130* Wed May 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.26-1
131- new upstream release
132- added BuildRequires: gettext
133
134* Mon Nov 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.25-1
135- new upstream release
136- changed source archive type (gzip to bzip2)
137- modified Patch8 a little
138- added Patch11,12,13 from Fedora development
139- added BuildRequires: autoconf texinfo
140- run autoreconf on %%build
141
142* Tue Mar 16 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.22-4
143- add patch110 for fix CVE-2010-0624 (rmt) from fc11
144
145* Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.22-3
146- add missing documents
147
148* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-2
149- spec in utf-8
150
151* Mon Mar 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
152- new upstream release
153- improved tar-1.20-loneZeroWarning.patch (refer to Fedora package)
154
155* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-1
156- new upstream release
157- remove unneeded patches
158
159* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15.1-0vl3
160- rebuilt for VineSeed
161
162* Thu Nov 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2.1
163- add patch120 for fix CVE-2006-6097
164
165* Sun Sep 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2
166- add patch110 for fix CVE-2006-0300
167
168* Mon May 02 2005 Satoshi MACHINO <machino@vinelinux.org> 1.15.1-0vl1
169- new upstream release
170- fixed patch6 and patch7 for new upstream release
171- some patches are imported from fedora package. and fixed
172        -- stop issuing lone zero block warnings(patch8)
173        -- fixed testsuite(patch9)
174        -- don't applyed(patch10)
175        -- fixed offset had incorrect type(patch11)
176
177* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
178- new upstream release
179- some patches are imported from fedora package.
180
181* Fri May  2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.25-8vl4
182- rebuild with new toolchain
183  - update BuildRequire (autoconf253 -> autoconf)
184
185* Thu Oct 31 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.25-8vl3
186- add adhoc but useful patch100 for "z" option to accepts bz2 tarball.
187
188* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl2
189- Oops the spec was in Shift-JIS. Fixed.
190
191* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl1
192- based on 1.3.25-8 from Rawhide and built for Vine Linux
193- the previous Vine package was 1.3.18-0vl2. Vine's changelog was as follows:
194
195  - Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.18-0vl2
196  - rebuild to remove rpmlib dependancy
197
198  - Sat May 26 2001 <sagami@vinelinux.org>
199  - 1.13.18-0vl1: based on 1.13.18-1 and added Japanese summary and description
200  - added barterly patch
201
202* Fri Aug 23 2002 Phil Knirsch <pknirsch@redhat.com> 1.13.25-8
203- Included security patch from errata release.
204
205* Mon Jul  1 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-7
206- Fix argv NULL termination (#64869)
207
208* Thu May 23 2002 Tim Powers <timp@redhat.com>
209- automated rebuild
210
211* Tue Apr  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-4
212- Fix build with autoconf253 (LIBOBJ change; autoconf252 worked)
213
214* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
215- automated rebuild
216
217* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-2
218- Don't include hardlinks to sockets in a tar file (#54827)
219
220* Thu Sep 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-1
221- 1.13.25
222
223* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.22-1
224- Update to 1.13.22, adapt patches
225
226* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-6
227- Fix #52084
228
229* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-5
230- Fix build with current autoconf (stricter checking on AC_DEFINE)
231- Fix segfault when tarring directories without having read permissions
232  (#40802)
233
234* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
235- Don't depend on librt.
236
237* Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
238- langify
239
240* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
241- Fix up the man page (#28915)
242
243* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
244- 1.3.19, nukes -I and fixes up -N
245- Add -I back in as an alias to -j with a nice loud warning
246
247* Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
248- 1.3.18
249- Update man page to reflect changes
250
251* Thu Oct  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
252- Fix the "ignore failed read" option (Bug #8330)
253
254* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
255- fix hang on tar tvzf - <something.tar.gz, introduced by
256  exit code fix (Bug #15448), Patch from Tim Waugh <twaugh@redhat.com>
257
258* Fri Aug 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
259- really fix exit code (Bug #15448)
260
261* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
262- fix exit code (Bug #15448), patch from Tim Waugh <twaugh@redhat.com>
263
264* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
265- automatic rebuild
266
267* Mon Jun 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
268- FHSify
269
270* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
271- fix for ia64
272
273* Wed Feb  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
274- Fix the exclude bug (#9201)
275
276* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
277- man pages are compressed
278- fix description
279- fix fnmatch build problems
280
281* Sun Jan  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
282- 1.13.17
283- remove dotbug patch (fixed in base)
284- update download URL
285
286* Fri Jan  7 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
287- Fix a severe bug (tar xf any_package_containing_. would delete the
288  current directory)
289
290* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
291- 1.3.16
292- unset LINGUAS before running configure
293
294* Tue Nov  9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
295- 1.13.14
296- Update man page to know about -I / --bzip
297- Remove dependancy on rmt - tar can be used for anything local
298  without it.
299
300* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
301- upgrade to 1.13.11.
302
303* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
304- update to 1.13.9.
305
306* Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
307- update to 1.13.6.
308- support -y --bzip2 options for bzip2 compression (#2415).
309
310* Fri Jul 23 1999 Jeff Johnson <jbj@redhat.com>
311- update to 1.13.5.
312
313* Tue Jul 13 1999 Bill Nottingham <notting@redhat.com>
314- update to 1.13
315
316* Sat Jun 26 1999 Jeff Johnson <jbj@redhat.com>
317- update to 1.12.64014.
318- pipe patch corrected for remote tars now merged in.
319
320* Sun Jun 20 1999 Jeff Johnson <jbj@redhat.com>
321- update to tar-1.12.64013.
322- subtract (and reopen #2415) bzip2 support using -y.
323- move gtar to /bin.
324
325* Tue Jun 15 1999 Jeff Johnson <jbj@redhat.com>
326- upgrade to tar-1.12.64011 to
327-   add bzip2 support (#2415)
328-   fix filename bug (#3479)
329
330* Mon Mar 29 1999 Jeff Johnson <jbj@redhat.com>
331- fix suspended tar with compression over pipe produces error (#390).
332
333* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
334- auto rebuild in the new build environment (release 8)
335
336* Mon Mar 08 1999 Michael Maher <mike@redhat.com>
337- added patch for bad name cache.
338- FIXES BUG 320
339
340* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
341- Injected new description and group.
342
343* Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
344- bumped spec number for initial rh 6.0 build
345
346* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
347- add /usr/bin/gtar symlink (change #421)
348
349* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
350- Fiddle bindir/libexecdir to get RH install correct.
351- Don't include /sbin/rmt -- use the rmt from dump.
352- Turn on nls.
353
354* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
355- translations modified for de, fr, tr
356
357* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
358- updated from 1.11.8 to 1.12
359- various spec file cleanups
360- /sbin/install-info support
361
362* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
363- built against glibc
364
365* Thu May 29 1997 Michael Fulbright <msf@redhat.com>
366- Fixed to include rmt
Note: See TracBrowser for help on using the repository browser.