source: projects/specs/branches/6/s/systemtap/systemtap-vl.spec @ 10389

Revision 10389, 25.3 KB checked in by Takemikaduchi, 8 years ago (diff)

add java-1.7.0

Line 
1%{!?with_sqlite: %global with_sqlite 1}
2%{!?with_docs: %global with_docs 0}
3# crash is not available
4%ifarch ppc ppc64 %{sparc}
5%{!?with_crash: %global with_crash 0}
6%else
7%{!?with_crash: %global with_crash 1}
8%endif
9%{!?with_rpm: %global with_rpm 1}
10%{!?with_bundled_elfutils: %global with_bundled_elfutils 0}
11%{!?elfutils_version: %global elfutils_version 0.142}
12%{!?pie_supported: %global pie_supported 1}
13%{!?with_boost: %global with_boost 0}
14%{!?with_publican: %global with_publican 0}
15%{!?publican_brand: %global publican_brand fedora}
16
17Name: systemtap
18Version: 2.0
19Release: 1%{?_dist_release}
20# for version, see also configure.ac
21
22
23# Packaging abstract:
24#
25# systemtap              empty req:-client req:-devel
26# systemtap-server       /usr/bin/stap-server*, req:-devel
27# systemtap-devel        /usr/bin/stap, runtime, tapset, req:kernel-devel
28# systemtap-runtime      /usr/bin/staprun, /usr/bin/stapsh
29# systemtap-client       /usr/bin/stap, samples, docs, tapset(bonus), req:-runtime
30# systemtap-initscript   /etc/init.d/systemtap, req:systemtap
31# systemtap-sdt-devel    /usr/include/sys/sdt.h /usr/bin/dtrace
32# systemtap-testsuite    /usr/share/systemtap/testsuite*, req:systemtap, req:sdt-devel
33#
34# Typical scenarios:
35#
36# stap-client:           systemtap-client
37# stap-server:           systemtap-server
38# local user:            systemtap
39#
40# Unusual scenarios:
41#
42# intermediary stap-client for --remote:       systemtap-client (-runtime unused)
43# intermediary stap-server for --use-server:   systemtap-server (-devel unused)
44
45Summary: Programmable system-wide instrumentation system
46Group: Development/System
47License: GPLv2+
48URL: http://sourceware.org/systemtap/
49Source: ftp://sourceware.org/pub/%{name}/releases/%{name}-%{version}.tar.gz
50
51# Build*
52BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
53BuildRequires: gcc-c++
54BuildRequires: gettext-devel
55BuildRequires: nss-devel avahi-devel pkgconfig
56%if %{with_sqlite}
57BuildRequires: sqlite-devel
58%endif
59# Needed for libstd++ < 4.0, without <tr1/memory>
60%if %{with_boost}
61BuildRequires: boost-devel
62%endif
63%if %{with_crash}
64BuildRequires: crash-devel zlib-devel
65%endif
66%if %{with_rpm}
67BuildRequires: rpm-devel glibc-headers
68%endif
69%if %{with_bundled_elfutils}
70Source1: elfutils-%{elfutils_version}.tar.gz
71Patch1: elfutils-portability.patch
72BuildRequires: m4
73%global setup_elfutils -a1
74%else
75BuildRequires: elfutils-devel >= %{elfutils_version}
76%endif
77%if %{with_docs}
78BuildRequires: texlive-common
79BuildRequires: latex2html
80%if %{with_publican}
81BuildRequires: publican
82BuildRequires: /usr/share/publican/Common_Content/%{publican_brand}/defaults.cfg
83%endif
84%endif
85
86# Install requirements
87Requires: systemtap-client = %{version}-%{release}
88Requires: systemtap-devel = %{version}-%{release}
89
90%description
91SystemTap is an instrumentation system for systems running Linux.
92Developers can write instrumentation scripts to collect data on
93the operation of the system.  The base systemtap package contains/requires
94the components needed to locally develop and execute systemtap scripts.
95
96# ------------------------------------------------------------------------
97
98%package server
99Summary: Instrumentation System Server
100Group: Development/System
101License: GPLv2+
102URL: http://sourceware.org/systemtap/
103Requires: systemtap-devel = %{version}-%{release}
104# On RHEL[45], /bin/mktemp comes from the 'mktemp' package.  On newer
105# distributions, /bin/mktemp comes from the 'coreutils' package.  To
106# avoid a specific RHEL[45] Requires, we'll do a file-based require.
107Requires: nss /bin/mktemp
108Requires: zip unzip
109Requires(pre): shadow-utils
110Requires(post): chkconfig
111Requires(preun): chkconfig
112Requires(preun): initscripts
113Requires(postun): initscripts
114Requires(post): %{name}-runtime
115BuildRequires: nss-devel avahi-devel
116
117%description server
118This is the remote script compilation server component of systemtap.
119It announces itself to nearby clients with avahi (if available), and
120compiles systemtap scripts to kernel objects on their demand.
121
122
123%package devel
124Summary: Programmable system-wide instrumentation system - development headers, tools
125Group: Development/System
126License: GPLv2+
127URL: http://sourceware.org/systemtap/
128Requires: kernel >= 2.6.9-11
129# Alternate kernel packages kernel-PAE-devel et al. have a virtual
130# provide for kernel-devel, so this requirement does the right thing,
131# at least past RHEL4.
132Requires: kernel-devel
133Requires: gcc make
134# Suggest: kernel-debuginfo
135
136%description devel
137This package contains the components needed to compile a systemtap
138script from source form into executable (.ko) forms.  It may be
139installed on a self-contained developer workstation (along with the
140systemtap-client and systemtap-runtime packages), or on a dedicated
141remote server (alongside the systemtap-server package).  It includes
142a copy of the standard tapset library and the runtime library C files.
143
144
145%package runtime
146Summary: Programmable system-wide instrumentation system - runtime
147Group: Development/System
148License: GPLv2+
149URL: http://sourceware.org/systemtap/
150Requires: kernel >= 2.6.9-11
151Requires(pre): shadow-utils
152
153%description runtime
154SystemTap runtime contains the components needed to execute
155a systemtap script that was already compiled into a module
156using a local or remote systemtap-devel installation.
157
158
159%package client
160Summary: Programmable system-wide instrumentation system - client
161Group: Development/System
162License: GPLv2+
163URL: http://sourceware.org/systemtap/
164Requires: zip unzip
165Requires: systemtap-runtime = %{version}-%{release}
166Requires: coreutils grep sed unzip zip
167Requires: openssh-clients
168
169%description client
170This package contains/requires the components needed to develop
171systemtap scripts, and compile them using a local systemtap-devel
172or a remote systemtap-server installation, then run them using a
173local or remote systemtap-runtime.  It includes script samples and
174documentation, and a copy of the tapset library for reference.
175
176
177%package initscript
178Summary: Systemtap Initscripts
179Group: Development/System
180License: GPLv2+
181URL: http://sourceware.org/systemtap/
182Requires: systemtap = %{version}-%{release}
183Requires(post): chkconfig
184Requires(preun): chkconfig
185Requires(preun): initscripts
186Requires(postun): initscripts
187
188%description initscript
189Sysvinit scripts to launch selected systemtap scripts at system startup.
190
191
192%package sdt-devel
193Summary: Static probe support tools
194Group: Development/System
195License: GPLv2+ and Public Domain
196URL: http://sourceware.org/systemtap/
197
198%description sdt-devel
199This package includes the <sys/sdt.h> header file used for static
200instrumentation compiled into userspace programs and libraries, along
201with the optional dtrace-compatibility preprocessor to process related
202.d files into tracing-macro-laden .h headers.
203
204
205%package testsuite
206Summary: Instrumentation System Testsuite
207Group: Development/System
208License: GPLv2+
209URL: http://sourceware.org/systemtap/
210Requires: systemtap = %{version}-%{release}
211Requires: systemtap-sdt-devel = %{version}-%{release}
212Requires: systemtap-server = %{version}-%{release}
213Requires: dejagnu which prelink elfutils grep
214Requires: gcc gcc-c++ make glibc-devel
215# testsuite/systemtap.server/client.exp needs avahi
216Requires: avahi
217%if %{with_crash}
218# testsuite/systemtap.base/crash.exp needs crash
219Requires: crash
220%endif
221%ifarch x86_64
222Requires: compat32-glibc-devel
223%endif
224
225%description testsuite
226This package includes the dejagnu-based systemtap stress self-testing
227suite.  This may be used by system administrators to thoroughly check
228systemtap on the current system.
229
230
231# ------------------------------------------------------------------------
232
233%prep
234%setup -q %{?setup_elfutils}
235
236%if %{with_bundled_elfutils}
237cd elfutils-%{elfutils_version}
238%patch1 -p1
239sleep 1
240find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
241sleep 1
242find . \( -name configure -o -name config.h.in \) -print | xargs touch
243cd ..
244%endif
245
246sed -i "s|_BSD_SOURCE|_DEFAULT_SOURCE|" staprun/staprun.c
247
248%build
249
250%if %{with_bundled_elfutils}
251# Build our own copy of elfutils.
252%global elfutils_config --with-elfutils=elfutils-%{elfutils_version}
253
254# We have to prevent the standard dependency generation from identifying
255# our private elfutils libraries in our provides and requires.
256%global _use_internal_dependency_generator      0
257%global filter_eulibs() /bin/sh -c "%{1} | sed '/libelf/d;/libdw/d;/libebl/d'"
258%global __find_provides %{filter_eulibs /usr/lib/rpm/find-provides}
259%global __find_requires %{filter_eulibs /usr/lib/rpm/find-requires}
260
261# This will be needed for running stap when not installed, for the test suite.
262%global elfutils_mflags LD_LIBRARY_PATH=`pwd`/lib-elfutils
263%endif
264
265# Enable/disable the sqlite coverage testing support
266%if %{with_sqlite}
267%global sqlite_config --enable-sqlite
268%else
269%global sqlite_config --disable-sqlite
270%endif
271
272# Enable/disable the crash extension
273%if %{with_crash}
274%global crash_config --enable-crash
275%else
276%global crash_config --disable-crash
277%endif
278
279# Enable/disable the code to find and suggest needed rpms
280%if %{with_rpm}
281%global rpm_config --with-rpm
282%else
283%global rpm_config --without-rpm
284%endif
285
286%if %{with_docs}
287%global docs_config --enable-docs
288%else
289%global docs_config --disable-docs
290%endif
291
292# Enable pie as configure defaults to disabling it
293%if %{pie_supported}
294%global pie_config --enable-pie
295%else
296%global pie_config --disable-pie
297%endif
298
299%if %{with_publican}
300%global publican_config --enable-publican --with-publican-brand=%{publican_brand}
301%else
302%global publican_config --disable-publican
303%endif
304
305
306%configure %{?elfutils_config} %{sqlite_config} %{crash_config} %{docs_config} %{pie_config} %{publican_config} %{rpm_config} --disable-silent-rules
307make %{?_smp_mflags}
308
309%install
310rm -rf ${RPM_BUILD_ROOT}
311make DESTDIR=$RPM_BUILD_ROOT install
312%find_lang %{name}
313
314# We want the examples in the special doc dir, not the build install dir.
315# We build it in place and then move it away so it doesn't get installed
316# twice. rpm can specify itself where the (versioned) docs go with the
317# %doc directive.
318mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/examples examples
319
320# Fix paths in the example & testsuite scripts
321find examples testsuite -type f -name '*.stp' -print0 | xargs -0 sed -i -r -e '1s@^#!.+stap@#!%{_bindir}/stap@'
322
323# To make rpmlint happy, remove any .gitignore files in the testsuite.
324find testsuite -type f -name '.gitignore' -print0 | xargs -0 rm -f
325
326# Because "make install" may install staprun with whatever mode, the
327# post-processing programs rpmbuild runs won't be able to read it.
328# So, we change permissions so that they can read it.  We'll set the
329# permissions back to 04110 in the %files section below.
330chmod 755 $RPM_BUILD_ROOT%{_bindir}/staprun
331
332#install the useful stap-prep script
333install -c -m 755 stap-prep $RPM_BUILD_ROOT%{_bindir}/stap-prep
334
335# Copy over the testsuite
336cp -rp testsuite $RPM_BUILD_ROOT%{_datadir}/systemtap
337
338%if %{with_docs}
339# We want the manuals in the special doc dir, not the generic doc install dir.
340# We build it in place and then move it away so it doesn't get installed
341# twice. rpm can specify itself where the (versioned) docs go with the
342# %doc directive.
343mkdir docs.installed
344mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/*.pdf docs.installed/
345mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/tapsets docs.installed/
346%if %{with_publican}
347mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/SystemTap_Beginners_Guide docs.installed/
348%endif
349%endif
350
351mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
352install -m 755 initscript/systemtap $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
353mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap
354mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/conf.d
355mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/script.d
356install -m 644 initscript/config.systemtap $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/config
357mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/systemtap
358mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/run/systemtap
359
360install -m 755 initscript/stap-server $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
361mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server
362mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server/conf.d
363mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
364install -m 644 initscript/config.stap-server $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/stap-server
365mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/stap-server
366touch $RPM_BUILD_ROOT%{_localstatedir}/log/stap-server/log
367mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
368install -m 644 initscript/logrotate.stap-server $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/stap-server
369
370%clean
371rm -rf ${RPM_BUILD_ROOT}
372
373%pre runtime
374getent group stapusr >/dev/null || groupadd -g 156 -r stapusr || groupadd -r stapusr
375getent group stapsys >/dev/null || groupadd -g 157 -r stapsys || groupadd -r stapsys
376getent group stapdev >/dev/null || groupadd -g 158 -r stapdev || groupadd -r stapdev
377exit 0
378
379%pre server
380getent group stap-server >/dev/null || groupadd -g 155 -r stap-server || groupadd -r stap-server
381getent passwd stap-server >/dev/null || \
382  useradd -c "Systemtap Compile Server" -u 155 -g stap-server -d %{_localstatedir}/lib/stap-server -m -r -s /sbin/nologin stap-server || \
383  useradd -c "Systemtap Compile Server" -g stap-server -d %{_localstatedir}/lib/stap-server -m -r -s /sbin/nologin stap-server
384test -e ~stap-server && chmod 755 ~stap-server
385
386if [ ! -f ~stap-server/.systemtap/rc ]; then
387  mkdir -p ~stap-server/.systemtap
388  chown stap-server:stap-server ~stap-server/.systemtap
389  echo "--rlimit-as=614400000 --rlimit-cpu=60 --rlimit-nproc=20 --rlimit-stack=1024000 --rlimit-fsize=51200000" > ~stap-server/.systemtap/rc
390  chown stap-server:stap-server ~stap-server/.systemtap/rc
391fi
392exit 0
393
394%post server
395test -e %{_localstatedir}/log/stap-server/log || {
396     touch %{_localstatedir}/log/stap-server/log
397     chmod 664 %{_localstatedir}/log/stap-server/log
398     chown stap-server:stap-server %{_localstatedir}/log/stap-server/log
399}
400
401# If it does not already exist, as stap-server, generate the certificate
402# used for signing and for ssl.
403if test ! -e ~stap-server/.systemtap/ssl/server/stap.cert; then
404   runuser -s /bin/sh - stap-server -c %{_libexecdir}/%{name}/stap-gen-cert >/dev/null
405   # Authorize the certificate as a trusted ssl peer and as a trusted signer
406   # on the local host.
407   %{_libexecdir}/%{name}/stap-authorize-cert ~stap-server/.systemtap/ssl/server/stap.cert %{_sysconfdir}/systemtap/ssl/client >/dev/null
408   %{_libexecdir}/%{name}/stap-authorize-cert ~stap-server/.systemtap/ssl/server/stap.cert %{_sysconfdir}/systemtap/staprun >/dev/null
409fi
410
411# Activate the service
412/sbin/chkconfig --add stap-server
413exit 0
414
415%preun server
416# Check that this is the actual deinstallation of the package, as opposed to
417# just removing the old package on upgrade.
418if [ $1 = 0 ] ; then
419    /sbin/service stap-server stop >/dev/null 2>&1
420    /sbin/chkconfig --del stap-server
421fi
422exit 0
423
424%postun server
425# Check whether this is an upgrade of the package.
426# If so, restart the service if it's running
427if [ "$1" -ge "1" ] ; then
428    /sbin/service stap-server condrestart >/dev/null 2>&1 || :
429fi
430exit 0
431
432%post initscript
433/sbin/chkconfig --add systemtap
434exit 0
435
436%preun initscript
437# Check that this is the actual deinstallation of the package, as opposed to
438# just removing the old package on upgrade.
439if [ $1 = 0 ] ; then
440    /sbin/service systemtap stop >/dev/null 2>&1
441    /sbin/chkconfig --del systemtap
442fi
443exit 0
444
445%postun initscript
446# Check whether this is an upgrade of the package.
447# If so, restart the service if it's running
448if [ "$1" -ge "1" ] ; then
449    /sbin/service systemtap condrestart >/dev/null 2>&1 || :
450fi
451exit 0
452
453%post
454# Remove any previously-built uprobes.ko materials
455(make -C %{_datadir}/%{name}/runtime/uprobes clean) >/dev/null 2>&1 || true
456(/sbin/rmmod uprobes) >/dev/null 2>&1 || true
457
458%preun
459# Ditto
460(make -C %{_datadir}/%{name}/runtime/uprobes clean) >/dev/null 2>&1 || true
461(/sbin/rmmod uprobes) >/dev/null 2>&1 || true
462
463# ------------------------------------------------------------------------
464
465%files -f %{name}.lang
466# The master "systemtap" rpm doesn't include any files.
467
468%files server -f %{name}.lang
469%defattr(-,root,root)
470%{_bindir}/stap-server
471%dir %{_libexecdir}/%{name}
472%{_libexecdir}/%{name}/stap-serverd
473%{_libexecdir}/%{name}/stap-start-server
474%{_libexecdir}/%{name}/stap-stop-server
475%{_libexecdir}/%{name}/stap-gen-cert
476%{_libexecdir}/%{name}/stap-sign-module
477%{_mandir}/man7/stappaths.7*
478%{_mandir}/man8/stap-server.8*
479%{_sysconfdir}/rc.d/init.d/stap-server
480%config(noreplace) %{_sysconfdir}/logrotate.d/stap-server
481%dir %{_sysconfdir}/stap-server
482%dir %{_sysconfdir}/stap-server/conf.d
483%config(noreplace) %{_sysconfdir}/sysconfig/stap-server
484%dir %attr(0755,stap-server,stap-server) %{_localstatedir}/log/stap-server
485%ghost %config(noreplace) %attr(0644,stap-server,stap-server) %{_localstatedir}/log/stap-server/log
486%ghost %attr(0755,stap-server,stap-server) %{_localstatedir}/run/stap-server
487%doc initscript/README.stap-server
488%doc README README.unprivileged AUTHORS NEWS COPYING
489
490
491%files devel -f %{name}.lang
492%{_bindir}/stap
493%{_bindir}/stap-prep
494%{_bindir}/stap-report
495%dir %{_datadir}/%{name}/runtime
496%{_datadir}/%{name}/runtime
497%dir %{_datadir}/%{name}/tapset
498%{_datadir}/%{name}/tapset
499%{_mandir}/man1/stap.1*
500%{_mandir}/man7/stappaths.7*
501%doc README README.unprivileged AUTHORS NEWS COPYING
502%if %{with_bundled_elfutils}
503%dir %{_libdir}/%{name}
504%{_libdir}/%{name}/lib*.so*
505%endif
506
507%files runtime -f %{name}.lang
508%defattr(-,root,root)
509%attr(4110,root,stapusr) %{_bindir}/staprun
510%{_bindir}/stapsh
511%{_bindir}/stap-merge
512%{_bindir}/stap-report
513%dir %{_libexecdir}/%{name}
514%{_libexecdir}/%{name}/stapio
515%{_libexecdir}/%{name}/stap-env
516%{_libexecdir}/%{name}/stap-authorize-cert
517%if %{with_crash}
518%dir %{_libdir}/%{name}
519%{_libdir}/%{name}/staplog.so*
520%endif
521%{_mandir}/man7/stappaths.7*
522%{_mandir}/man8/staprun.8*
523%doc README README.security AUTHORS NEWS COPYING
524
525
526%files client -f %{name}.lang
527%defattr(-,root,root)
528%doc README README.unprivileged AUTHORS NEWS COPYING examples
529%if %{with_docs}
530%doc docs.installed/*.pdf
531%doc docs.installed/tapsets/*.html
532%if %{with_publican}
533%doc docs.installed/SystemTap_Beginners_Guide
534%endif
535%endif
536%{_bindir}/stap
537%{_bindir}/stap-prep
538%{_bindir}/stap-report
539%{_mandir}/man1/stap.1*
540%{_mandir}/man1/stap-merge.1*
541%{_mandir}/man3/*
542%{_mandir}/man7/stappaths.7*
543%dir %{_datadir}/%{name}
544%{_datadir}/%{name}/tapset
545
546
547
548%files initscript
549%defattr(-,root,root)
550%{_sysconfdir}/rc.d/init.d/systemtap
551%dir %{_sysconfdir}/systemtap
552%dir %{_sysconfdir}/systemtap/conf.d
553%dir %{_sysconfdir}/systemtap/script.d
554%config(noreplace) %{_sysconfdir}/systemtap/config
555%dir %{_localstatedir}/cache/systemtap
556%ghost %{_localstatedir}/run/systemtap
557%doc initscript/README.systemtap
558
559
560%files sdt-devel -f %{name}.lang
561%defattr(-,root,root)
562%{_bindir}/dtrace
563%{_includedir}/sys/sdt.h
564%{_includedir}/sys/sdt-config.h
565%{_mandir}/man1/dtrace.1*
566%doc README AUTHORS NEWS COPYING
567
568
569%files testsuite
570%defattr(-,root,root)
571%dir %{_datadir}/%{name}
572%{_datadir}/%{name}/testsuite
573
574
575# ------------------------------------------------------------------------
576
577%changelog
578* Sun Jun 19 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0-1
579- initial build for Vine Linux
580
581
582
583* Wed Jul 18 2012 Josh Stone <jistone@redhat.com> - 1.8-5
584- bz840902 ppc build fix (related to bz837641)
585
586* Fri Jul 13 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.8-4
587- Fix ifarch statement
588- use file based requires for glibc-devel on x86_64 so that we work in koji
589
590* Wed Jul 11 2012 Frank Ch. Eigler <fche@redhat.com> - 1.8-3
591- PR14348 task_work_add race condition fix
592
593* Mon Jul 09 2012 Josh Stone <jistone@redhat.com>
594- bz837641 build fix
595
596* Sun Jun 17 2012 Frank Ch. Eigler <fche@redhat.com> - 1.8-1
597- Upstream release.
598
599* Mon Apr 30 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.7-7
600- Enable crash support on ARM, cleanup spec
601
602* Thu Apr 19 2012 Karsten Hopp <karsten@redhat.com> - 1.7-6.1
603- rebuild on PPC(64) without crash, publican
604
605* Thu Mar 29 2012 Richard W.M. Jones <rjones@redhat.com> - 1.7-6
606- Rebuild for rpm soname bump.
607
608* Fri Mar 16 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-5
609- dbhole advises ARM publican/fop/java is a go for launch.
610
611* Thu Mar 01 2012 Mark Wielaard <mjw@redhat.com> - 1.7-4
612- ARM currently doesn't have publican/fop/java and no prelink.
613
614* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-3
615- Rebuilt for c++ ABI breakage
616
617* Wed Feb 22 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-2
618- CVE-2012-0875 (kernel panic when processing malformed DWARF unwind data)
619
620* Wed Feb 01 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-1
621- Upstream release.
622
623* Fri Jan 13 2012 David Smith <dsmith@redhat.com> - 1.6-2
624- Fixed /bin/mktemp require.
625
626* Mon Jul 25 2011 Stan Cox <scox@redhat.com> - 1.6-1
627- Upstream release.
628
629* Tue May 23 2011 Stan Cox <scox@redhat.com> - 1.5-1
630- Upstream release.
631
632* Mon Jan 17 2011 Frank Ch. Eigler <fche@redhat.com> - 1.4-1
633- Upstream release.
634
635* Wed Jul 21 2010 Josh Stone <jistone@redhat.com> - 1.3-1
636- Upstream release.
637
638* Mon Mar 22 2010 Frank Ch. Eigler <fche@redhat.com> - 1.2-1
639- Upstream release.
640
641* Mon Dec 21 2009 David Smith <dsmith@redhat.com> - 1.1-1
642- Upstream release.
643
644* Tue Sep 22 2009 Josh Stone <jistone@redhat.com> - 1.0-1
645- Upstream release.
646
647* Tue Aug  4 2009 Josh Stone <jistone@redhat.com> - 0.9.9-1
648- Upstream release.
649
650* Thu Jun 11 2009 Josh Stone <jistone@redhat.com> - 0.9.8-1
651- Upstream release.
652
653* Thu Apr 23 2009 Josh Stone <jistone@redhat.com> - 0.9.7-1
654- Upstream release.
655
656* Fri Mar 27 2009 Josh Stone <jistone@redhat.com> - 0.9.5-1
657- Upstream release.
658
659* Wed Mar 18 2009 Will Cohen <wcohen@redhat.com> - 0.9-2
660- Add location of man pages.
661
662* Tue Feb 17 2009 Frank Ch. Eigler <fche@redhat.com> - 0.9-1
663- Upstream release.
664
665* Thu Nov 13 2008 Frank Ch. Eigler <fche@redhat.com> - 0.8-1
666- Upstream release.
667
668* Tue Jul 15 2008 Frank Ch. Eigler <fche@redhat.com> - 0.7-1
669- Upstream release.
670
671* Fri Feb  1 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-3
672- Add zlib-devel to buildreq; missing from crash-devel
673- Process testsuite .stp files for #!stap->#!/usr/bin/stap
674
675* Fri Jan 18 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-1
676- Add crash-devel buildreq to build staplog.so crash(8) module.
677- Many robustness & functionality improvements:
678
679* Wed Dec  5 2007 Will Cohen <wcohen@redhat.com> - 0.6-2
680- Correct Source to point to location contain code.
681
682* Thu Aug  9 2007 David Smith <dsmith@redhat.com> - 0.6-1
683- Bumped version, added libcap-devel BuildRequires.
684
685* Wed Jul 11 2007 Will Cohen <wcohen@redhat.com> - 0.5.14-2
686- Fix Requires and BuildRequires for sqlite.
687
688* Tue Jul  2 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.14-1
689- Many robustness improvements: 1117, 1134, 1305, 1307, 1570, 1806,
690  2033, 2116, 2224, 2339, 2341, 2406, 2426, 2438, 2583, 3037,
691  3261, 3282, 3331, 3428 3519, 3545, 3625, 3648, 3880, 3888, 3911,
692  3952, 3965, 4066, 4071, 4075, 4078, 4081, 4096, 4119, 4122, 4127,
693  4146, 4171, 4179, 4183, 4221, 4224, 4254, 4281, 4319, 4323, 4326,
694  4329, 4332, 4337, 4415, 4432, 4444, 4445, 4458, 4467, 4470, 4471,
695  4518, 4567, 4570, 4579, 4589, 4609, 4664
696
697* Mon Mar 26 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.13-1
698- An emergency / preliminary refresh, mainly for compatibility
699  with 2.6.21-pre kernels.
700
701* Mon Jan  1 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.12-1
702- Many changes, see NEWS file.
703
704* Tue Sep 26 2006 David Smith <dsmith@redhat.com> - 0.5.10-1
705- Added 'systemtap-runtime' subpackage.
706
707* Wed Jul 19 2006 Roland McGrath <roland@redhat.com> - 0.5.9-1
708- PRs 2669, 2913
709
710* Fri Jun 16 2006 Roland McGrath <roland@redhat.com> - 0.5.8-1
711- PRs 2627, 2520, 2228, 2645
712
713* Fri May  5 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.7-1
714- PRs 2511 2453 2307 1813 1944 2497 2538 2476 2568 1341 2058 2220 2437
715  1326 2014 2599 2427 2438 2465 1930 2149 2610 2293 2634 2506 2433
716
717* Tue Apr  4 2006 Roland McGrath <roland@redhat.com> - 0.5.5-1
718- Many changes, affected PRs include: 2068, 2293, 1989, 2334,
719  1304, 2390, 2425, 953.
720
721* Wed Feb  1 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.4-1
722- PRs 1916, 2205, 2142, 2060, 1379
723
724* Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 0.5.3-1
725- Many changes, affected PRs include: 2056, 1144, 1379, 2057,
726  2060, 1972, 2140, 2148
727
728* Mon Dec 19 2005 Roland McGrath <roland@redhat.com> - 0.5.2-1
729- Fixed build with gcc 4.1, various tapset changes.
730
731* Wed Dec  7 2005 Roland McGrath <roland@redhat.com> - 0.5.1-1
732- elfutils update, build changes
733
734* Fri Dec 02 2005  Frank Ch. Eigler  <fche@redhat.com> - 0.5-1
735- Many fixes and improvements: 1425, 1536, 1505, 1380, 1329, 1828, 1271,
736  1339, 1340, 1345, 1837, 1917, 1903, 1336, 1868, 1594, 1564, 1276, 1295
737
738* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.4.2-1
739- Many fixes and improvements: PRs 1344, 1260, 1330, 1295, 1311, 1368,
740  1182, 1131, 1332, 1366, 1456, 1271, 1338, 1482, 1477, 1194.
741
742* Wed Sep 14 2005 Roland McGrath <roland@redhat.com> - 0.4.1-1
743- Many fixes and improvements since 0.2.2; relevant PRs include:
744  1122, 1134, 1155, 1172, 1174, 1175, 1180, 1186, 1187, 1191, 1193, 1195,
745  1197, 1205, 1206, 1209, 1213, 1244, 1257, 1258, 1260, 1265, 1268, 1270,
746  1289, 1292, 1306, 1335, 1257
747
748* Wed Sep  7 2005 Frank Ch. Eigler <fche@redhat.com>
749- Bump version.
750
751* Wed Aug 16 2005 Frank Ch. Eigler <fche@redhat.com>
752- Bump version.
753
754* Wed Aug  3 2005 Martin Hunt <hunt@redhat.com> - 0.2.2-1
755- Add directory /var/cache/systemtap
756- Add stp_check to /usr/libexec/systemtap
757
758* Wed Aug  3 2005 Roland McGrath <roland@redhat.com> - 0.2.1-1
759- New version 0.2.1, various fixes.
760
761* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.2-1
762- New version 0.2, requires elfutils 0.111
763
764* Mon Jul 25 2005 Roland McGrath <roland@redhat.com>
765- Clean up spec file, build bundled elfutils.
766
767* Thu Jul 21 2005 Martin Hunt <hunt@redhat.com>
768- Set Version to use version from autoconf.
769- Fix up some of the path names.
770- Add Requires and BuildRequires.
771
772* Wed Jul 19 2005 Will Cohen <wcohen@redhat.com>
773- Initial creation of RPM.
Note: See TracBrowser for help on using the repository browser.