source: projects/specs/branches/6/s/system-config-network/system-config-network-vl.spec @ 3654

Revision 3654, 32.2 KB checked in by daisuke, 13 years ago (diff)

system-config-network: add V/D/P

Line 
1# -*- RPM-SPEC -*-
2Summary: The GUI of the Network Adminstration Tool
3Summary(ja): ネットワーク管理ツール(GUI)
4Name: system-config-network
5Version: 1.6.2
6Release: 1%{?_dist_release}
7URL: http://fedoraproject.org/wiki/SystemConfig/network
8License: GPLv2+
9Group: Applications/System
10
11Source0: %{name}-%{version}.tar.bz2
12Source1: %{name}-ja-help-image.tar.bz2
13Patch0: %{name}-1.5.97-fix-crash-on-saving.patch
14#Patch1: %{name}-1.5.99-modprobeconf.patch
15Patch2: %{name}-1.6.2-ja-help.patch
16
17BuildArch: noarch
18BuildRequires: python >= 0:2.2, openjade, docbook-style-dsssl, perl, gettext, desktop-file-utils, perl-XML-Parser
19BuildRequires: intltool, autoconf, automake
20Requires: %{name}-tui = %{version}-%{release}
21Requires: pygtk2-libglade, pygtk2, gnome-python, usermode-gtk, xdg-utils
22BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: daisuke
27
28%description
29This is the GUI of the network configuration tool,
30supporting Ethernet, Wireless, TokenRing, ADSL, ISDN and PPP.
31
32%package tui
33Summary: The Network Adminstration Tool
34Summary(ja): ネットワーク管理ツール
35Group: Applications/System
36Requires: initscripts >= 8.80.0, usermode , python, rpm-python, newt
37Requires: pciutils, dbus-python
38Requires: python-ethtool, python-iwlib
39
40%description tui
41This is the network configuration tool,
42supporting Ethernet, Wireless, TokenRing, ADSL, ISDN and PPP.
43
44%prep
45%setup -q -a 1
46%patch0 -p1
47#%patch1 -p1
48%patch2 -p1
49
50%build
51autoreconf
52%configure
53
54%install
55rm -rf $RPM_BUILD_ROOT
56make DESTDIR=$RPM_BUILD_ROOT install
57
58mkdir $RPM_BUILD_ROOT%{_datadir}/applications
59
60for i in system-config-network.desktop system-control-network.desktop; do \
61  desktop-file-install --vendor "" --delete-original       \
62    --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
63    --add-category System                                     \
64    --add-category Settings                                   \
65    $RPM_BUILD_ROOT%{_datadir}/system-config-network/$i; \
66done;
67
68mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/networking/devices
69mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/networking/profiles/default
70
71%find_lang %name
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76
77%files
78%defattr(-,root,root,-)
79%doc COPYING
80%{_datadir}/system-config-network/pixmaps
81%{_datadir}/system-config-network/netconfpkg/gui
82%{_datadir}/system-config-network/netconf.py*
83%{_datadir}/system-config-network/netconf_control.py*
84%{_sbindir}/system-config-network-gui
85%{_bindir}/system-control-network
86%{_datadir}/applications/*
87%{_datadir}/pixmaps/*
88
89%files -f %{name}.lang tui
90%defattr(-,root,root,-)
91%doc COPYING
92%dir %{_datadir}/system-config-network
93%doc %dir %{_datadir}/system-config-network/help
94%doc %{_datadir}/system-config-network/help/*
95%{_datadir}/system-config-network/netconf_cmd.py*
96%{_datadir}/system-config-network/netconf_tui.py*
97%{_datadir}/system-config-network/version.py*
98%dir %{_datadir}/system-config-network/netconfpkg
99%{_datadir}/system-config-network/netconfpkg/conf
100%{_datadir}/system-config-network/netconfpkg/tui
101%{_datadir}/system-config-network/netconfpkg/plugins
102%{_datadir}/system-config-network/netconfpkg/*.py*
103%{_datadir}/system-config-network/module-info
104%{_datadir}/system-config-network/providerdb
105%config(noreplace) %{_sysconfdir}/pam.d/*
106%config(noreplace) %{_sysconfdir}/security/console.apps/*
107%dir %{_sysconfdir}/sysconfig/networking
108%dir %{_sysconfdir}/sysconfig/networking/profiles
109%dir %{_sysconfdir}/sysconfig/networking/profiles/default
110%dir %{_sysconfdir}/sysconfig/networking/devices
111%{_sbindir}/system-config-network
112%{_sbindir}/system-config-network-tui
113%{_sbindir}/system-config-network-cmd
114%{_bindir}/system-config-network
115%{_bindir}/system-config-network-cmd
116
117%changelog
118* Sat Apr 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-1
119- update to 1.6.2
120- remove R: rhpl, kudzu
121- add R: python-ethtool, python-iwlib to tui
122- add R: usermode-gtk instead of usermode
123- add BR: intltool, autoconf, automake
124
125* Sat Apr 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.97-5
126- rebuild for Vine 6
127
128* Thu Oct 22 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.5.97-4
129- add source1(images of Japanese help).
130
131* Wed Oct 21 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.5.97-3
132- add patch2 to add Japanese help.
133
134* Wed Sep 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.97-2
135- add patch1 to use /etc/modprobe.d/modprobe.conf
136
137* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.97-1
138- new upstream release
139- add Patch0 to fix crash on saving data.
140
141* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.95-1
142- new upstream release
143
144* Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
145- initial build for Vine Linux
146
147* Tue May 27 2008 Harald Hoyer <harald@redhat.com> - 1.5.10
148- fixed Makefile.am
149
150* Tue May 27 2008 Harald Hoyer <harald@redhat.com> - 1.5.9
151- fixed console perms for Fedora <= 8
152
153* Fri May 16 2008 Harald Hoyer <harald@redhat.com> - 1.5.8
154- copy info from DNS page into each ifcfg file (dcbw)
155
156* Fri Apr 25 2008 Harald Hoyer <harald@redhat.com> - 1.5.7
157- NCisdnhardware.card -> NCisdnhardware._card (harald)
158- Fixed pap-secret parsing. (#rhbz#443347) (jmoskovc)
159
160* Tue Apr 08 2008 Harald Hoyer <harald@redhat.com> - 1.5.6
161- translation update
162- check origLine for None (harald)
163
164* Mon Mar 31 2008 Harald Hoyer <harald@redhat.com> - 1.5.5
165- fixed more rhbz#439718
166
167* Mon Mar 31 2008 Harald Hoyer <harald@redhat.com> - 1.5.4
168- fixed typos in DialupDruid (harald)
169- return None is nothing is selected (harald)
170- fixed #438901: Network Device Control doesn't work unless s-c-n has been run once (harald)
171- fixed #435041 and added UnitTest (harald)
172- be case-independent in mode parsing rhbz#433748 (harald)
173- fixed rhbz#429725 (harald)
174- do not traceback on non-int Volume (harald)
175- fixed rhbz#439718 (harald)
176
177* Sat Mar 29 2008 Harald Hoyer <harald@redhat.com> - 1.5.3
178- readded DialupDruid (harald)
179
180* Sat Mar 29 2008 Harald Hoyer <harald@redhat.com> - 1.5.2
181- devices which are controlled by NM cannot be activated/deactivated (rhbz#438902)
182- use ". config-util" in console-apps config file (rhbz#428408) (harald)
183- use xdg-open instead of htemlview (rhbz#415031) (harald)
184- added sr@latin (rhbz#425845)
185- update buttons on device edit change (harald)
186- fixed some Alias handling (harald)
187- removed Init2 string (clashes with UTMS) (harald)
188- no activate/deactivate/delete NMControlled devices (harald)
189- NCPluginDevTokenRing return None if no dialog (harald)
190- BackendHal fix to use Factory classes, no kudzu hw import (harald)
191- check if hostname is not None, before checking it (harald)
192- added tui/NCPluginTokenRingInterface (harald)
193- MTU moved to base device (rhbz#439202) (harald)
194- fixed import for ParseError (harald)
195
196* Thu Feb 28 2008 Harald Hoyer <harald@redhat.com> - 1.5.1
197- removed CIPE (harald)
198- s/Devernet/Network/ (harald)
199- Auto -> auto (harald)
200- only append localhost to AliasList, if not already in (harald)
201- show error dialog, if device loading failes (harald)
202- moved MRU to Dialup only (harald)
203- recognize qeth devices in kudzu lists (rhbz#184734) (harald)
204- added MRU field (rhbz#221294) (harald)
205- added TUI for QETH (harald)
206- do not traceback, if we try to remove a device not in our active list (harald)
207- added qeth support (harald)
208- removed ctc and iucv devices (rhbz#219180) (harald)
209- do not handle ifcfg-${parent_device}-range* rhbz#221292 (harald)
210- Minor fix in hosts parser to make tui works. (jmoskovc)
211- Stupid mode doesn't go away anymore.(rhbz#177931) (jmoskovc)
212- Fixed crash when Baud=None (jmoskovc)
213- Removing PPP option should work. NETWORKMANAGER -> NM_CONTROLLED (jmoskovc)
214- Fixed problem with import rhbz#429725 (jmoskovc)
215- Changed Clist in host editor to GtkTreeView, added checkbox to show loopbacks in hosts (jmoskovc)
216- Minor fix in hosts parser - now it accepts trailing dot. (jmoskovc)
217- Improved {pap|chap}-secrets parser, added checkbox to reveal password in dialup config (jmoskovc)
218- Fixed crash when hostname is changed. (jmoskovc)
219
220* Mon Dec 03 2007 Harald Hoyer <harald@redhat.com> - 1.5.0
221- v1.5.0
222
223* Mon Dec 03 2007 Harald Hoyer <harald@redhat.com>, Jiri Moskovcak <jmoskovc@redhat.com> - 1.4.7
224- added HAL support
225- fixed /etc/hosts parser
226- added "Controlled by NetworkManager"
227- do not fall into modified state for activate/deactivate (rhbz#377261)
228
229* Mon Nov 12 2007 Harald Hoyer <harald@redhat.com> - 1.4.6
230- moved network.xpm to (pkgdatadir)/pixmaps (rhbz#377861)
231
232* Mon Nov 12 2007 Harald Hoyer <harald@redhat.com> - 1.4.5
233- changed yelp to htmlview
234
235* Wed Nov  7 2007 Stepan Kasal <skasal@redhat.com> - 1.4.4
236- s/NEtwork/Network/ in the summary of -tui, to be consistent
237  with the summary line of the main rpm (the neat acronym is no
238  longer advertised anyway)
239- Resolves: #239216
240
241* Fri Oct 26 2007 Harald Hoyer <harald@redhat.com> - 1.4.4
242- removed not yet used NCBackendHal.py (rhbz#353771)
243- fixed yelp dependency (rhbz#344981)
244- moved %%configure to %%build (rhbz#353761)
245- fixed type with getRoot (rhbz#368871)
246
247* Mon Oct 15 2007 Harald Hoyer <harald@redhat.com> - 1.4.3
248- fixed /etc/hosts problem (rhbz#331451)
249
250* Fri Oct 12 2007 Harald Hoyer <harald@redhat.com> - 1.4.3
251- added version.py.in to POTFILES.in (rhbz#244053)
252- corrected URL (rhbz#237717)
253
254* Mon Oct 08 2007 Harald Hoyer <harald@redhat.com> - 1.4.2
255- speedup genClass
256- restorecon selinux context
257
258* Mon Sep 24 2007 Harald Hoyer <harald@redhat.com> - 1.4.1-2
259- require newt-python instead of newt only
260
261* Mon Sep 24 2007 Harald Hoyer <harald@redhat.com> - 1.4.1
262- version 1.4.1
263
264* Thu Aug 16 2007 Harald Hoyer <harald@redhat.com> - 1.4.0
265- version 1.4.0
266
267* Mon Jan  8 2007 Harald Hoyer <harald@redhat.com> - 1.3.99
268- fixed #221289
269- Resolves: rhbz#221289
270
271* Fri Dec 15 2006 Harald Hoyer <harald@redhat.com> - 1.3.98
272- translation update (bug #216559)
273- Resolves: rhbz#216559
274
275* Tue Nov 28 2006 Harald Hoyer <harald@redhat.com> - 1.3.97
276- translation update
277
278* Thu Nov  2 2006 Harald Hoyer <harald@redhat.com> - 1.3.96
279- Resolves: rhbz #211980, rhbz #213181
280
281* Wed Oct  4 2006 Harald Hoyer <harald@redhat.com> - 1.3.95
282- translation update (bug #208886)
283- use rhpl.iwlib for wireless functions (bug #197954)
284- added perl-XML-Parser build requirement
285
286* Tue Aug 15 2006 Harald Hoyer <harald@redhat.com> - 1.3.94
287- translation update (bug #182650)
288
289* Tue Aug 15 2006 Harald Hoyer <harald@redhat.com> - 1.3.93
290- added tui subdir (bug #202560)
291
292* Fri Aug 11 2006 Harald Hoyer <harald@redhat.com> - 1.3.92
293- fixed #201659
294- translation update
295
296* Tue Jul 25 2006 Harald Hoyer <harald@redhat.com> - 1.3.91
297- fixed "New Device" in text-mode
298
299* Tue Jul 18 2006 Harald Hoyer <harald@redhat.com> - 1.3.90
300- fixed:
301- [135014] MTU and MRU should be confiurable for ADSL
302- [141055] system-config-network needs to be able to set MTU
303- [149780] no GATEWAY, IPADDR and NETMASK, if BOOTPROTO=dhcp
304- [150362] [Errno 2] No such file or directory: '/etc/hosts'
305- [157172] Wrong DNS for provider "ZEDAT_Berlin"
306- [160417] Bad: cannot make any changes to network settings
307- [169819] Trailing space in host name causes crash
308- [175078] String (country name) change request
309- [176145] Please enable Serbian translation in system-config-network
310- [177198] deprecation warning in system-config-network
311- [187563] localized option passed to ifcfg-wlan0 files
312- [188321] Creating an alias for a network interface breaks device
313           setup after reboots
314- [190242] Firefox instance running as root when used to read docs
315           for system-config-*
316- [197401] Don't write HWADDR for alias interfaces
317
318* Fri Jul 14 2006 Nils Philippsen <nphilipp@redhat.com>
319- enable ml, or, sr, sr@Latn translations (#176145)
320
321* Wed Nov 02 2005 Harald Hoyer <harald@redhat.com> - 1.3.30
322- removed interdruid
323- reversed Cancel/Ok button ordering
324
325* Tue Oct 25 2005 Harald Hoyer <harald@redhat.com> - 1.3.29
326- fixed profileFrame labeling
327
328* Wed Oct 10 2005 Harald Hoyer <harald@redhat.com> - 1.3.28
329- fixed picture paths in glade files
330- fixed cancel case of passphrase dialog
331
332* Wed Oct 10 2005 Harald Hoyer <harald@redhat.com> - 1.3.27
333- use new pam stack replacement
334- added OnParent for Alias Devices
335- added SPI and better key generation for ipsec
336- corrected column handling in main window
337- GUI liftup
338- added AVM Fritz!PCI v2.0 ISDN card to ISDN Hardwarelist (bug 134605)
339- remove /etc/sysconfig/isdncard, if no ISDN is configured
340
341* Wed Apr 20 2005 Harald Hoyer <harald@redhat.com> - 1.3.26
342- CBCP_MSN added (bug #125710)
343
344* Tue Mar 31 2005 Harald Hoyer <harald@redhat.com> - 1.3.25
345- more i18n languages
346
347* Wed Mar 30 2005 Harald Hoyer <harald@redhat.com> - 1.3.24
348- gtk.FALSE and gtk.TRUE cleanups
349
350* Mon Mar 21 2005 Harald Hoyer <harald@redhat.com> - 1.3.23-2
351- moved gui parts out of the tui package
352
353* Fri Mar 04 2005 Harald Hoyer <harald@redhat.com> - 1.3.23
354- update to new gnome/gtk/glade
355
356* Wed Oct 20 2004 Harald Hoyer <harald@redhat.com> - 1.3.22
357- translation updates, added nb.po (bug 136462)
358
359* Tue Oct 05 2004 Harald Hoyer <harald@redhat.com> - 1.3.21
360- fixed /etc/hosts handling
361- handle .ko module names in updateFromKudzu
362
363* Fri Sep 03 2004 Harald Hoyer <harald@redhat.com> - 1.3.20
364- dhcp cannot be selected for aliased devices (bug 129096)
365
366* Thu Aug 26 2004 Harald Hoyer <harald@redhat.com> - 1.3.19
367- hopefully fixed bug 125393
368- fixed removal of device files
369
370* Fri Jul 30 2004 Harald Hoyer <harald@redhat.com> - 1.3.18
371- changed mainloop and mainquit
372- translation updates
373 
374* Tue Jul 06 2004 Harald Hoyer <harald@redhat.com> - 1.3.17
375- bugfix release for FC2
376
377* Tue Jun 29 2004 Harald Hoyer <harald@redhat.com> - 1.3.17
378- better "make clean"
379- removed references to Red Hat Linux
380- added testsuite for data layer
381- added some module-info entries
382- added command line parsing to network-control
383- added IPsec to network-cmd
384- switched logging to syslog
385- do not touch bonding slaves
386- better alias handling
387- better handling of chroot
388- read *.ko modules also
389- handle modules parameter without "="
390- create correct SPI_ identifier for manual IPsec keying
391- better hostname handling
392- better profile handling
393- fix kernel version parsing
394- unknown-flag.xpm for unknown country flags
395- fixed TokenRing glade file (bad hash at beginning of file)
396- fix the length of IPSec shared keys
397- prevent modified status after profile switching
398- save dialog, for ipsec deactivation
399- PEERDNS defaults to yes
400- routing for wireless config dialog
401- only display CIPE for kernel < 2.6
402
403* Thu Apr  1 2004 Harald Hoyer <harald@redhat.com> - 1.3.17
404- translation updates (119610)
405
406* Thu Mar  4 2004 Harald Hoyer <harald@redhat.com> - 1.3.16
407- be more relaxed, when parsing the kernel version (115917)
408- fixed removing of Hostname (115795)
409- fixed "DevEthernet instance has no attribute 'IPv6Init'" (116375)
410- removed save dialog, when switching profiles (107399)
411- added generic Initstrings (115768)
412- added secure.png logo
413- added "-c" parameter for activate/deactivate
414- changed hotkeys to avoid double entries
415- use new pixmap loading code (only take local paths, if debugging is active)
416- moved updateNetworkScripts() to NC_functions.py
417- fallback on /etc/sysconfig/network-scripts
418- removed /usr/lib/rhs/python from sys.path
419- added -? as a command line option
420- corrected --root= option for gui
421- activate/deactivate buttons always sensitive
422- check for ipsec-tools and dynamically display ipsec tab
423- no second dialog while activating in system-control-network
424- change hosts file on hostname change
425- PEERDNS is true, if not configured
426
427* Thu Jan 29 2004 Harald Hoyer <harald@redhat.com> - 1.3.15
428- added IPv6 support per device (111377)
429
430* Wed Jan 28 2004 Harald Hoyer <harald@redhat.com> - 1.3.14
431- modules.conf -> modprobe.conf
432
433* Thu Dec 18 2003 Harald Hoyer <harald@redhat.de> 1.3.13-2
434- added mkinstalldirs to EXTRA_DIST
435- added version to provides
436
437* Wed Dec 17 2003 Harald Hoyer <harald@redhat.de> 1.3.13
438- fixed T-Online dialog #110911
439- default flow control to CTSRTS #110347
440- only clear login/pw on provider select, if provider has its own number
441- fixed cancel of dialup process #103421
442- default to "/" for chrooted configuration
443- default to "default" profile if none active
444- fixed "activate button not active" #110193
445- scn-tui requires newt #104213
446- fixed #107816, by recognizing /var/run/ppp-ppp<NICKNAME>.pid
447- fixed a bug in ISDN activate #100677
448
449* Tue Dec 16 2003 Harald Hoyer <harald@redhat.de> 1.3.12
450- renamed redhat-config-network -> system-config-network
451- added pciutils requirement
452- added utf-8 encoding comments
453- corrected some translation strings
454- added redhat-config-network provides
455
456* Tue Oct 28 2003 Harald Hoyer <harald@redhat.de> 1.3.10
457- removed restriction on t-online password entry #105970
458- failsafe changing the error image #108094
459- corrected indention #108151
460
461* Mon Oct 27 2003 Harald Hoyer <harald@redhat.de> 1.3.9
462- fixed 107501, 107387, 106751, 104213
463- fallback to no logfile, if opening the logfile fails
464- test, if /etc/{hosts,resolv.conf} exists
465- removed ipsec tab
466
467* Thu Oct 23 2003 Than Ngo <than@redhat.com> 1.3.8
468- fix a bug in ISDN activate
469
470* Wed Oct 22 2003 Than Ngo <than@redhat.com> 1.3.7-2
471- fix a bug in saving of ISDN config file
472- add support nickname for ISDN
473 
474* Wed Oct  8 2003 Harald Hoyer <harald@redhat.de> 1.3.7
475- merged in changes from Taroon
476
477* Thu Aug 14 2003 Harald Hoyer <harald@redhat.de> 1.3.6
478- fixed #100471
479
480* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 1.3.5
481- fixed #98251
482
483* Fri Aug  1 2003 Harald Hoyer <harald@redhat.de> 1.3.4
484- fixed #101386
485- save wireless keys in keys file
486
487* Thu Jul 31 2003 Harald Hoyer <harald@redhat.de> 1.3.3
488- fixed #85365
489- fixed glade file loading
490- more ipsec stuff
491- neat can use a "chrooted" environment now (-r)
492- .rpmsave will not be loaded
493- no interrupt/io settings for PNP cards
494- HIGIfied labels
495- double click for hardware and ipsec
496
497* Wed Jul  2 2003 Than Ngo <than@redhat.com> 1.3.2-2
498- upgrade provide database
499
500* Wed Jun 18 2003 Harald Hoyer <harald@redhat.de> 1.2.12-2
501- fixed #97562
502
503* Thu Jun 17 2003 Harald Hoyer <harald@redhat.de> 1.2.12-1
504- wlan0 handling
505- splash screen bug fixed
506- improvements in HW list handling
507- isdncard handling #91607
508
509* Thu Jun 12 2003 Harald Hoyer <harald@redhat.de> 1.2.11
510- fixed #97027
511- fixed subs of -
512
513* Wed Jun 11 2003 Harald Hoyer <harald@redhat.de> 1.2.10
514- fixed #97027 #96994
515- fixed fedora bugzilla issues #326
516- update of some translations
517
518* Wed Jun  4 2003 Harald Hoyer <harald@redhat.de> 1.2.8
519- lazy file unlinking
520- fixed #91620 #91583
521- ConfEHosts -> ConfFHosts
522
523* Mon May 19 2003 Harald Hoyer <harald@redhat.de> 1.2.7
524- make PAP/CHAP work again
525- route files chmod(0644)
526- added local variables to traceback
527
528* Thu May 01 2003 Harald Hoyer <harald@redhat.de> 1.2.6
529- use unsernetctl instead of ifdown/ifup
530
531* Thu May 01 2003 Harald Hoyer <harald@redhat.de> 1.2.5
532- fixed early import of plugins
533
534* Wed Apr 30 2003 Harald Hoyer <harald@redhat.de> 1.2.4-3
535- fixed #89915 and #89916
536
537* Tue Apr 29 2003 Harald Hoyer <harald@redhat.de> 1.2.4-1
538- 1.2.4 bugfix release
539
540* Wed Apr  2 2003 Harald Hoyer <harald@redhat.de> 1.2.3-3
541- Bugfix release for 9
542- fixed #85011, #85703, #85653, #84956, #83640, #68169, #86476, #78043, #77763
543
544* Fri Feb 21 2003 Harald Hoyer <harald@redhat.de> 1.2.0-2
545- bump to 1.2.0
546- fixed #84725
547- warning for #84752
548
549* Fri Feb 12 2003 Harald Hoyer <harald@redhat.de> 1.1.97-1
550- fixed #83692
551- updated documentation
552
553* Mon Feb  3 2003 Harald Hoyer <harald@redhat.de> 1.1.94-1
554- base -> tui, gui -> base
555
556* Thu Jan 30 2003 Harald Hoyer <harald@redhat.de> 1.1.93-1
557- 1.1.93
558
559* Wed Jan 29 2003 Harald Hoyer <harald@redhat.de> 1.1.92-1
560- 1.1.92
561
562* Tue Jan 14 2003 Harald Hoyer <harald@redhat.de> 1.1.90-1
563- 1.1.90
564
565* Thu Dec 19 2002 Than Ngo <than@redhat.com>
566- import ConfDevice
567
568* Mon Dec 16 2002 Harald Hoyer <harald@redhat.de>
569- 1.1.86
570
571* Fri Dec 13 2002 Harald Hoyer <harald@redhat.de>
572- 1.1.85
573
574* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.1.80-1
575- Remove unpackaged files
576
577* Mon Sep  2 2002 Than Ngo <than@redhat.com> 1.1.20-1
578- don't crash by selecting provider
579- Set correct HangupTimeout for ISDN connection
580
581* Sat Aug 31 2002 Preston Brown <pbrown@localhost.localdomain>
582- fix typo in error dialog function
583
584* Thu Aug 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.17-1
585- Make it use the gnome help system, add yelp as a dependency (#71857)
586- Traceback fix: # 72581
587- translation updates
588
589* Wed Aug 14 2002 Harald Hoyer <harald@redhat.de>
590- #71448
591- #71265
592- #70988
593
594* Tue Aug 13 2002 Harald Hoyer <harald@redhat.de> 1.1.15-1
595- many bugfixes, including  #71062 #69333 #68793 #69133
596
597* Thu Aug  1 2002 Than Ngo <than@redhat.com> 1.1.14-1
598- set correct device type for rawip ISDN connections (bug #69568)
599- add some ISPs for Austria
600
601* Tue Jul 30 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.13-1
602- Fixes to the traceback dialog (fix "save to floppy" (we don't do that),
603  add i18n.)
604- Fix traceback with malformed /etc/hosts (#69320)
605- Fix dependencies (#69990)
606- Some minor userhelper fixes
607
608* Thu Jul 25 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.12-1
609- doc loc fixes (images)
610- add pam_timestamp support (#69869)
611
612* Wed Jul 24 2002 Harald Hoyer <harald@redhat.de>
613- renamed "default" profile in GUI
614- fixed device renaming in profiles
615
616* Wed Jul 24 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.10-1
617- More bugfixes, including #69635 #69636
618- Updated docs
619
620* Tue Jul 23 2002 Harald Hoyer <harald@redhat.de> 1.1.9-1
621- lots of bugfixes again :)
622
623* Wed Jul 17 2002 Harald Hoyer <harald@redhat.de>
624- lots of bugfixes
625- reactivated profile gui
626
627* Mon Jul  8 2002 Harald Hoyer <harald@redhat.de>
628- lots of bugfixes, new .desktop stuff
629- added desktop-file-utils BuildRequires
630
631* Tue Jul  2 2002 Harald Hoyer <harald@redhat.de> 1.1.7-1
632- cleanup, usability
633
634* Mon Jul 01 2002 Than Ngo <than@redhat.com> 1.1.6-1
635- get rid of isdnup userisdnctl, both are now part of isdn4k-utils
636
637* Thu Jun 27 2002 Harald Hoyer <harald@redhat.de> 1.1.5-1
638- many bug fixes due to gtk2 conversion
639- fixed #67273 #66200 #65185 #65073 #63963
640
641* Wed Jun 26 2002 Preston Brown <pbrown@redhat.com>
642- ethtool, pcmcia, wireless improvements
643
644* Sat Jun 22 2002 Than Ngo <than@redhat.com> 1.1.4-1
645- fixed traceback bug in activate
646- some fixes in glade file
647
648* Sun Jun 16 2002 Than Ngo <than@redhat.com> 1.1.3-1
649- get_pixbuf: if no icon was not found, looks the icons
650  in standard icon directory
651- bug fixes in wireless
652
653* Wed Jun 12 2002 Harald Hoyer <harald@redhat.de> 1.1.2-1
654- lots of i18n and migration changes
655- wireless reactivated
656
657* Fri Jun 07 2002 Than Ngo <than@redhat.com> 1.1.1-1
658- set PPPOE_TIMEOUT=80 as default, it should be about 4 times
659  the LCP_INTERVAL (bug #64903)
660
661* Wed May 29 2002 Harald Hoyer <harald@redhat.de>
662- ported to python2, gtk2, gnome2
663
664* Wed Apr 17 2002 Trond Eivind Glomsrød <teg@redhat.com>
665- Turn off wireless. It doesn't work with all modes, all cards
666 and you can't edit IP settings after the initial attempt
667
668* Wed Apr 17 2002 Harald Hoyer <harald@redhat.com> 1.0.0-1
669- moved ethmodule.so to /usr/lib
670- call it 1.0.0
671
672* Tue Apr 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.30-1
673- Updated translations
674- Updated docs
675
676* Tue Apr 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.28-1
677- more fixes
678
679* Mon Apr 15 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.27-1
680- Update translations, more fixes
681
682* Mon Apr 15 2002 Harald Hoyer <harald@redhat.com> 0.9.26-1
683- The Most Fixes (tm)
684
685* Sat Apr 13 2002 Than Ngo <than@redhat.com> 0.9.25-1
686- More fixes
687
688* Thu Apr 11 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.24-1
689- More fixes (#63177,#57064,#63207)
690
691* Tue Apr 09 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.23-1
692- more fixes
693- updated translations
694
695* Thu Apr 04 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.22-1
696- more fixes, including #62697,
697
698* Sat Mar 30 2002 Than Ngo <than@redhat.com> 0.9.21-1
699- add Token Ring/Wireless/Cipe Druids
700- more fixes
701
702* Wed Mar 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.20-1
703- Rebuild... it should have more fixes
704
705* Wed Mar 26 2002 Than Ngo <than@redhat.com> 0.9.19-1
706- add functions for status/activate/deactivate in neat
707- more fixes
708
709* Sat Mar 16 2002 Than Ngo <than@redhat.com> 0.9.18-1
710- add userisdnctl for ISDN
711- more fixes
712
713* Thu Mar 14 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.17-1
714- Even more fixes
715
716* Thu Mar 14 2002 Than Ngo <than@redhat.com> 0.9.16-1
717- various fixes
718
719* Thu Mar 14 2002 Than Ngo <than@redhat.com> 0.9.15-1
720- add desktop file for neat-control
721- various fixes, additions
722
723* Wed Mar 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.14-1
724- Require gnome-core, buildrequire gnome-core-devel
725
726* Mon Mar 11 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.13-1
727- New build
728- No longer noarch
729
730* Thu Feb 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.12-1
731- Various fixes, additions
732
733* Tue Jan 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.11-1
734- build in new environment
735
736* Mon Jan 07 2002 Than Ngo <than@redhat.com> 0.9.10.1-1
737- fixed bug #57853
738
739* Tue Dec 03 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.10-1
740- minor fixes, more translations
741
742* Mon Nov 26 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.9-0.1
743- Trying again, with more fixes :)
744
745* Fri Nov 25 2001 Than Ngo <than@redhat.com> 0.9.8-0.6
746- fixed bug #56145, #56146, #56147
747
748* Tue Nov 20 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.8-0.5
749- prepare for errata
750
751* Fri Nov 02 2001 Than Ngo <than@redhat.com> 0.9.7-1
752- fixed 'AVM PnP'/'Sedlbauer Speed Fax+ PnP'/'ASUS Com ISDNLink ISA PnP'
753- update provider DB
754
755* Tue Oct 30 2001 Than Ngo <than@redhat.com> 0.9.7-1
756- allow setting AVM PCI (Fritz!PCI v2) if kernel supports it
757- fixed some typo bugs
758
759* Wed Oct 24 2001 Harald Hoyer <harald@redhat.com> 0.9.6-1
760- seperated gui from data layer
761- make .pyc ghost files
762- fixed profile/alias problem
763- modem probing only once
764
765* Mon Oct 22 2001 Harald Hoyer <harald@redhat.com> 0.9.5-1
766- fixed consolehelper
767- added chars [_-] ro nickname pattern
768- added traceback catching dialog
769
770* Wed Oct 17 2001 Harald Hoyer <harald@redhat.com> 0.9.4-1
771- fixed /etc/hosts
772- fixed pap/chap
773- fixed 'save changes?'
774
775* Tue Oct 16 2001 Than Ngo <than@redhat.com> 0.9.3-1
776- fix internet-druid fails (bug #54192)
777- fix dial on demand problem from some ISDN Provider in German
778- don't trace back if length of Login name is 2 (bug #54322)
779
780* Thu Sep 27 2001 Than Ngo <than@redhat.com> 0.9.2-1
781- enable TCPIP for CIPE
782- show device Tab as default if devices exist
783
784* Wed Sep 12 2001 Than Ngo <than@redhat.com> 0.9.1-1
785- add CTC and IUCV support for s390/s390x
786- disable Dialup on s390/s390x
787
788* Thu Sep  5 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9-1
789- Add Russian
790
791* Wed Sep  4 2001 Phil Knirsch <phil@redhat.de> 0.8.4-1
792- Fixed problem with unwanted removal of entries in /etc/modules.conf (#53042)
793
794* Mon Sep  3 2001 Than Ngo <than@redhat.com> 0.8.3-1
795- fix a bug in setting Authentication
796- fix some critical typo bugs
797
798* Fri Aug 31 2001 Than Ngo <than@redhat.com> 0.8.2-1
799- fix backtrace bug in CIPE
800- fix traceback bug if self.device.Dialup is None
801- if hardware is deleted, remove all devices used this hardware
802- de.po: fix bad translation
803
804* Fri Aug 31 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.8.1-1
805- Add support for Czech
806
807* Fri Aug 31 2001 Than Ngo <than@redhat.com>
808- fix #52920, #52922, #52914, #52916, #52917
809
810* Fri Aug 31 2001 Phil Knirsch <phil@redhat.de> 0.8.0-2
811- Fixed wrong option handling in /etc/modules.conf (#52853, #52923)
812- Fixed empty search entry in /etc/resolv.conf (#52926)
813- Fixed empty domain entry in /etc/resolv.conf (#52924)
814- Fixed ethernet hardware probing traceback (#52921)
815
816* Tue Aug 28 2001 Than Ngo <than@redhat.com> 0.8.0-1
817- fix some typo bugs
818
819* Tue Aug 28 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.10-1
820- minor fixes, including bootprotocol for CIPE (don't say it will use DHCP...)
821
822* Tue Aug 28 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.9-1
823- Not everything was marked for translation (#52650)
824
825* Tue Aug 28 2001 Than Ngo <than@redhat.com> 0.7.8-1
826- fix some typo bugs
827- fix wrong Modem entry (Bug #52601)
828
829* Mon Aug 27 2001 Than Ngo <than@redhat.com> 0.7.7-1
830- fix wrong type CBHUP
831
832* Mon Aug 27 2001 Phil Knirsch <phil@redhat.de> 0.7.6-2
833- Fixed use of /etc/sysconfig/network (#52359)
834
835* Fri Aug 24 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.6-1
836- Reordered tabs, added descriptions on each of the tabs
837
838* Fri Aug 24 2001 Bill Nottingham <notting@redhat.com> 0.7.5-1
839- tokenring support
840
841* Thu Aug 23 2001 Phil Knirsch <phil@redhat.de> 0.7.4-2
842- Fixed recalculation of BROADCAST and NETWORK values if IP and netmask are
843  present (#51462)
844
845* Mon Aug 20 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.4-1
846- More bugfixes, among them #51929, #51991, #51721, #51722,
847  partial #52044, #51720.
848- Updated translations, include more languages
849
850* Thu Aug 16 2001 Phil Knirsch <phil@redhat.de> 0.7.3-2
851- Fixed major bug in device renaming (#50885)
852
853* Tue Aug 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.3-1
854- more bugfixes, more docs, GUI fixes
855
856* Fri Aug 10 2001 Than Ngo <than@redhat.com> 0.7.2-1
857- more bugfixes
858
859* Fri Aug 10 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.1-1
860- more bugfixes, more docs
861
862* Wed Aug  8 2001 Alexander Larsson <alexl@redhat.com> 0.7-2
863- Install desktop files in sysconfig instead of serverconf.
864
865* Wed Aug  8 2001 Phil Knirsch <phil@redhat.de> 0.7-1
866- Added a lot of documentation
867- Final changes to the Modem druid dialog and code to look just like the
868  hardware add dialog for modems.
869
870* Wed Aug  8 2001 Phil Knirsch <phil@redhat.de> 0.6.8-3
871- Added the modem detection for the ModemDruid.
872- Added kudzu as requirement as it is needed for modem detection.
873- For compatibility still check for symlinks, too. Otherwise older setups will
874  break.
875
876* Tue Aug  7 2001 Phil Knirsch <phil@redhat.de> 0.6.7-2
877- Fixed various important bugzilla bugs
878- Added and implemented the add Hardware dialog.
879- Added a working Apply button.
880- Switched to using hardlinks instead of symlinks for config files.
881
882* Tue Aug  7 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.7-1
883- Add online help capability (#50739)
884
885* Mon Aug  6 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.6-1
886- Disable profiles in GUI and as necesarry in code
887
888* Mon Aug  6 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.5-1
889- more bugfixes
890- add Conf.py from pythonlib, which has gone to the great bitbucket
891  in the sky
892
893* Sun Aug  5 2001 Than Ngo <than@redhat.com>
894- fix bug 50740
895- wvdial.conf readonly for root
896
897* Fri Aug  3 2001 Than Ngo <than@redhat.com>
898- fix pap/chap Login name for T-online
899- fix InitStrings
900- use gettext function in NC_functions
901- fix loading DEFROUTE/PERSIST/DEMAND/IDLETIMEOUT for Modem dialup
902- don't backtrace if 'SetVolume' and 'Dial Command' are not defined
903
904* Thu Aug 02 2001 Phil Knirsch <phil@redhat.de> 0.6.1-2
905- Fixed buggous removal of ifcfg-lo (#50478)
906- Fixed problems with modem volume in hardware dialog
907- Fixed missing /dev/modem for modem setup (#50673)
908
909* Wed Aug  2 2001 Yukihiro Nakai <ynakai@redhat.com>
910- POTFILES.in list up fix
911- Add Japanese translation
912
913* Wed Aug 02 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.2-1
914- More bugfixes
915
916* Tue Jul 24 2001 Than Ngo <than@redhat.com> 0.6.1-1
917- Some more bugfixes...
918
919* Tue Jul 24 2001 Phil Knirsch <phil@redhat.de> 0.6-2
920- Some more bugfixes...
921
922* Tue Jul 24 2001 Phil Knirsch <phil@redhat.de> 0.6-1
923- Bumped version to 0.6
924
925* Tue Jul 24 2001 Than Ngo <than@redhat.com>
926- add Druid for dialup connection (ISDN/ADSL/Modem)
927
928* Thu Jul 19 2001 Trond Eivind Glomsrød <teg@redhat.com>
929- Obsolete netcfg - rp3 is next, when gnome-lokkit doesn't require
930  it anymore
931- More fixes...
932
933* Tue Jul 17 2001 Trond Eivind Glomsrød <teg@redhat.com>
934- CIPE and wireless added
935
936* Mon Jul 16 2001 Trond Eivind Glomsrød <teg@redhat.com>
937- Add i18n
938- Many minor fixes...
939
940* Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
941- Don't run autogen.sh
942- Mark files in /etc as configuration files
943- Multiple fixes to automake files
944- Add Norwegian translation to desktop files
945- install into the configuration tool desktop directory
946
947* Wed Jul 11 2001 Than Ngo <than@redhat.com> 0.3.1-1
948- obsolete isdn-config internet-config
949- requires consolehelper, alchemist
950- add icon and desktop file
951- use bzip2
952
953* Wed Jul 11 2001 Phil Knirsch <phil@redhat.de> 0.3.0-2
954- Fixed critical problem during profile saving.
955
956* Wed Jul 10 2001 Phil Knirsch <phil@redhat.de> 0.3.0-1
957- 0.3.0-1
958- Final touches for beta2. Most stuff should work now.
959
960* Thu Jul 10 2001 Phil Knirsch <phil@redhat.de> 0.2.2-2
961- Added some missing files.
962
963* Tue Jul 10 2001 Trond Eivind Glomsrød <teg@redhat.com>
964- 0.2.2
965
966* Tue Jul 10 2001 Trond Eivind Glomsrød <teg@redhat.com>
967- 0.2.1
968
969* Mon Jul  9 2001 Trond Eivind Glomsrød <teg@redhat.com>
970- 0.2
971- New name - system-config-network.
972  Shortcut: neat (NEtwork Administration Tool)
973
974* Fri Jul 06 2001 Trond Eivind Glomsrød <teg@redhat.com>
975- Require a recent version of initscripts
976- Initial build. Don't obsolete older tools just yet...
Note: See TracBrowser for help on using the repository browser.