source: projects/specs/branches/6/s/system-config-lvm/system-config-lvm-vl.spec @ 3381

Revision 3381, 10.0 KB checked in by daisuke, 13 years ago (diff)

system-config-lvm: update to 1.1.15

Line 
1# -*- RPM-SPEC -*-
2Summary: A utility for graphically configuring Logical Volumes
3Summary(ja): LVM をグラフィカルに設定するためのユーティリティ
4Name: system-config-lvm
5Version: 1.1.15
6Release: 1%{?_dist_release}
7URL: http://www.redhat.com/
8License: GPLv2
9Group: Applications/System
10
11Vendor: Project Vine
12Distribution: Vine Linux
13Packager: daisuke
14
15Source0: %{name}-%{version}.tar.gz
16
17BuildArch: noarch
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19Requires: usermode-gtk, /sbin/chkconfig
20Requires: gnome-python, pygtk2, pygtk2-libglade
21Requires: urw-fonts
22Requires: lvm2
23Requires: python
24BuildRequires: perl(XML::Parser)
25BuildRequires: gettext
26BuildRequires: intltool
27BuildRequires: desktop-file-utils
28
29%description
30system-config-lvm is a utility for graphically configuring Logical Volumes
31
32%prep
33%setup -q
34
35for i in src/* ;do
36  perl -pi -e 's|python2|python|g' $i
37done
38
39%build
40%configure
41make %{?_smp_mflags}
42
43%install
44rm -rf %{buildroot}
45make DESTDIR=%{buildroot} install
46
47desktop-file-install --vendor system --delete-original          \
48  --dir %{buildroot}%{_datadir}/applications                    \
49  --remove-category Application                                 \
50 --remove-category SystemSetup                                  \
51  --remove-category X-Red-Hat-Base                              \
52  --add-category Settings                                       \
53  --add-category System                                         \
54  %{buildroot}%{_datadir}/applications/system-config-lvm.desktop
55
56%find_lang %name
57
58%clean
59rm -rf %{buildroot}
60
61#Replace the files line with the one commented out when translations are done
62%files -f %{name}.lang
63#%files
64
65%defattr(-,root,root)
66%doc COPYING
67%{_sbindir}/*
68%{_bindir}/*
69%{_datadir}/applications/system-config-lvm.desktop
70%{_datadir}/system-config-lvm
71%config(noreplace) %{_sysconfdir}/pam.d/system-config-lvm
72%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-lvm
73
74%changelog
75* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.15-1
76- new upstream release
77- remove R: rhpl
78
79* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-1
80- initial build for Vine Linux
81
82* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-5.1
83- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
84
85* Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.1.4-4.1
86- Rebuild for Python 2.6
87
88* Mon Oct 27 2008 Matthias Clasen  <mclasen@redhat.com> 1.1.4-3.1
89- Require usermode-gtk
90
91* Fri Oct 10 2008 Matthias Clasen  <mclasen@redhat.com> 1.1.4-3.0
92- Fix up BuildRequires
93
94* Thu Oct  9 2008 Matthias Clasen  <mclasen@redhat.com> 1.1.4-2.0
95- Properly install the desktop file (#442910)
96
97* Tue Apr 25 2008 Jim Parsons <jparsons@redhat.com> 1.1.4-1.0
98- Build for fedora
99
100* Tue Mar 25 2008 Ryan McCabe <rmccabe@redhat.com> 1.1.3-2.0
101- Fix for bz247325
102- Restore missing translations.
103
104* Wed Feb 06 2008 Ryan McCabe <rmccabe@redhat.com> 1.1.3-1.0
105- Fix for bz332651
106
107* Fri Sep 28 2007 Ryan McCabe <rmccabe@redhat.com> 1.1.2-1.0
108- Update the spec, configure.in, and Makefile.am files
109- Some other minor build tweaks
110- Bump the version number
111
112* Tue May 01 2007 Stanko Kupcevic <kupcevic@redhat.com> 1.1.1-1.0
113- Update pam file
114- Update translation files
115
116* Mon Jan 22 2007 Stanko Kupcevic <kupcevic@redhat.com> 1.0.22-1.0
117- Fixed 223518 (s-c-lvm fails to probe CS5 properly)
118- fixes bz223518
119
120* Mon Dec 18 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.21-1.0
121- Fixed 216569 (some messages not localized)
122- Fixed 218126 (Can't resize ext3 fs online)
123- fixes bz216569, bz218126
124
125* Mon Oct 16 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.20-1.0
126- Updated translation files
127
128* Mon Jul 10 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.19-1.0
129- Version bump
130
131* Thu Jun 01 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.18-1.0
132- Version bump
133
134* Fri May 12 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.17-1.0
135- Fixes for 175077, 171117, 175131, 176967, enable mirroring, 159455, 159456
136
137* Thu Feb 16 2006 Jim Parsons <jparsons@redhat.com> 1.0.16-1.0
138- Disabled mirroring support in UI.
139
140* Mon Feb 14 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.14-1.0
141- Fixes for bz180281, 159457, 180269. Mirroring support available with
142  constants in lvmui_constants file by setting MIRRORING_UI_SUPPORT to True
143
144* Fri Feb 10 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.13-1.0
145- Fix failure to display all unused space
146
147* Mon Feb 06 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.12-1.0
148- Under certain conditions, labels might show partially
149
150* Fri Feb 03 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.11-1.0
151- Fixes for bz175077,169860,178128,161917,171117,175131,178195
152
153* Thu Jan 05 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.10-1.0
154- Fix for bz176967
155
156* Fri Dec 2 2005 Jim Parsons <jparsons@redhat.com> 1.0.9-1.0
157- Removed cLVM test.
158
159* Mon Nov 14 2005 Jim Parsons <jparsons@redhat.com> 1.0.8-1.0
160- Fixes for bz171744,171746,171747,171751,171753,171754,171755,171758,159457
161
162* Mon Sep 26 2005 Jim Parsons <jparsons@redhat.com> 1.0.7-1.0
163- Version bump.
164
165* Mon Sep 26 2005 Jim Parsons <jparsons@redhat.com> 1.0.6-1.0
166- Version bump for FC.
167
168* Wed Sep 13 2005 Stanko Kupcevic <kupcevic@redhat.com> 1.0.5-1.0
169- Fix for bz167671.
170
171* Wed Sep 08 2005 Stanko Kupcevic <kupcevic@redhat.com> 1.0.4-1.0
172- Fix for bz167662, 167643.
173
174* Mon Aug 15 2005 Stanko Kupcevic <kupcevic@redhat.com> 1.0.3-1.0
175- Fix for bz159457: Temporary removal of mirroring support.
176
177* Tue Aug 02 2005 Jim Parsons <jparsons@redhat.com> 1.0.2-1.0
178- Major new release that supports snapshotting, mirroring, and resizing.
179
180* Mon Jul 26 2005 Stanko Kupcevic <kupcevic@redhat.com> 0.9.52-1.0
181- Alpha release: Strings, minor bugs, GFS, GFS2, mirrors on diff HDs
182
183* Fri Jul 15 2005 Stanko Kupcevic <kupcevic@redhat.com> 0.9.51-1.0
184- Alpha release: mirroring, multipath, GPT, zoom, ...
185
186* Tue Jun 21 2005 Stanko Kupcevic <kupcevic@redhat.com> 0.9.50-1.0
187- Alpha release: snapshotting, resizing, lv properties
188
189* Thu May 26 2005 Jim Parsons <jparsons@redhat.com> 0.9.33-1.0
190- Version bump for rhel
191
192* Thu May 26 2005 Jim Parsons <jparsons@redhat.com> 0.9.32-1.0
193- Fix for 158872; x86_64 pam file path
194
195* Mon May 23 2005 Jim Parsons <jparsons@redhat.com> 0.9.31-1.0
196- Version bump for RHEL4
197
198* Mon May 23 2005 Jim Parsons <jparsons@redhat.com> 0.9.30-1.0
199- Fixed bz157744
200
201* Tue May 17 2005 Jim Parsons <jparsons@redhat.com> 0.9.29-1.0
202- Version Bump
203
204* Tue May 17 2005 Jim Parsons <jparsons@redhat.com> 0.9.28-1.0
205- Version Bump
206
207* Tue May 17 2005 Jim Parsons <jparsons@redhat.com> 0.9.27-1.0
208- Fix for bz154458,153042,155438,157743
209
210* Thu May 05 2005 Jim Parsons <jparsons@redhat.com> 0.9.26-1.0
211- Fix for bz156957
212
213* Thu Apr 14 2005 Jim Parsons <jparsons@redhat.com> 0.9.25-1.0
214- Version bump.
215
216* Thu Apr 14 2005 Jim Parsons <jparsons@redhat.com> 0.9.24-1.0
217- Changed permissions on Icon file.
218
219* Thu Apr 14 2005 Jim Parsons <jparsons@redhat.com> 0.9.23-1.0
220- Subtle change to .desktop file moves app launcher to system settings
221
222* Wed Apr 06 2005 Jim Parsons <jparsons@redhat.com> 0.9.22-1.0
223- Version Bump.
224
225* Wed Apr 06 2005 Jim Parsons <jparsons@redhat.com> 0.9.21-1.0
226- Changed path to lvm command for Fedora.
227
228* Mon Feb 21 2005 Jim Parsons <jparsons@redhat.com> 0.9.20-1.0
229- Added desktop icon file.
230
231* Mon Feb 21 2005 Jim Parsons <jparsons@redhat.com> 0.9.19-1.0
232- Added desktop file.
233
234* Wed Nov 24 2004 Jim Parsons <jparsons@redhat.com> 0.9.18-1.0
235- Adjustments to configure.in so this builds in fedora as well as RHEL.
236
237* Tue Nov 23 2004 Jim Parsons <jparsons@redhat.com> 0.9.17-1.0
238- Fixes for bz140413 and bz 140562
239
240* Tue Nov 23 2004 Jim Parsons <jparsons@redhat.com> 0.9.16-1.0
241- Strips whitespace off of all incoming command handler args.
242
243* Tue Nov 23 2004 Jim Parsons <jparsons@redhat.com> 0.9.15-1.0
244- Fixes for two small nits.
245
246* Mon Nov 22 2004 Jim Parsons <jparsons@redhat.com> 0.9.14-1.0
247- Fixes for bz140413, 140386, 140355, 140359, 140419, 138103, 140529.
248
249* Thu Nov 18 2004 Jim Parsons <jparsons@redhat.com> 0.9.12-1.0
250- Fix for bz137041, 139711 plus require for new RHPL pkg.
251
252* Tue Nov 16 2004 Jim Parsons <jparsons@redhat.com> 0.9.11-1.0
253- Fix for bz138019 -- extent segs correct for stripe corner case
254
255* Mon Nov 15 2004 Jim Parsons <jparsons@redhat.com> 0.9.10-1.0
256- Fixes for bz137291, 138008, and 137122
257
258* Thu Nov 11 2004 Jim Parsons <jparsons@redhat.com> 0.9.9-1.0
259- Fixes for bz137111, 138887, 138006,138097. Also removed fstab checkbox
260  and added it as a feature at 138831 for next release.
261
262* Wed Nov 10 2004 Jim Parsons <jparsons@redhat.com> 0.9.8-1.0
263- Fixes for bz137930, 137872, 137292, 137052, 137054
264
265* Tue Nov 9 2004 Jim Parsons <jparsons@redhat.com> 0.9.7-1.0
266- Improved handling of garbage in the size string -- try catch in place
267  now that traps for ValueError
268- Improved handling of sizes/units for new LV creation
269- Now 'Unused' sections in Logical View of VGs, are unselectable. Also,
270  if there are no LVs associated with a VG, the Logical view buttonpanel
271  button for "Remove selected extents" is set to not be sensitive, as
272  there is nothing to remove from this case.
273- Revamped PV removal code, so that proper checking is done before moving
274  extents.
275- Added new method that checks if dm-mirror mod is loaded in kernel. If not,
276  an appropriate error message is generated.
277- Fixed tree selection mechanism by preventing multiple VG selection.
278- Handle delete-event on VG creation dialog, so it is hidden.
279- Fixed bz137099, 137071, 137869, 137434, 138085
280
281* Mon Nov 1 2004 Jim Parsons <jparsons@redhat.com> 0.9.6-1.0
282- Changed gtk.mainloop to gtk.main to address bz137288.
283
284* Mon Nov 1 2004 Jim Parsons <jparsons@redhat.com> 0.9.5-1.0
285- Added Menubar to address bz137293.
286
287* Fri Oct 29 2004 Jim Parsons <jparsons@redhat.com> 0.9.4-1.0
288- Fixes for bz137190 empty vg name field validation,
289- bz137048 removes resizable checkbox for vgcreate,
290- bz137208 unique vg name checking fixed,
291- bz137107 remove autobackup checkbox,
292- bz137231 warn on extend vg when init'ing a new entity.
293
294* Tue Oct 26 2004 Jim Parsons <jparsons@redhat.com> 0.9.3-1.0
295- Version bump.
296
297* Tue Oct 26 2004 Jim Parsons <jparsons@redhat.com> 0.9.2-1.0
298- Fixed bz137118 warningMessage error. This is a critical mustfix.
299
300* Wed Oct 20 2004 Jim Parsons <jparsons@redhat.com> 0.9.1-2.5
301- Fixed size selection issue, bz136217.
302
303* Wed Sep 01 2004 Jim Parsons <jparsons@redhat.com> 0.9.1-1
304- Initial copy
Note: See TracBrowser for help on using the repository browser.