source: projects/specs/branches/6/s/synaptic/synaptic-vl.spec @ 4277

Revision 4277, 15.8 KB checked in by daisuke, 13 years ago (diff)

synaptic: use config-util

Line 
1Name: synaptic
2Version: 0.57.2
3Release: 16%{?_dist_release}
4Summary: GTK based graphical front-end for APT
5Summary(ja): GTK ベースの APT グラフィカルフロントエンド
6Group: Applications/Administration
7License: GPL
8
9Source0: %{name}-%{version}.tar.gz
10Source10: synaptic-0.57.2-ja.po
11Source20: synaptic-dummy-grouplist.txt
12Source30: package-supported.png
13
14Patch1: synaptic-0.57.2-gcc41.patch
15Patch2: synaptic-0.57.2-repomd-1.patch
16Patch3: synaptic-0.57.2-showprog.patch
17Patch4: synaptic-0.57.2-progressapi-hack.patch
18Patch5: synaptic-0.57.2-gcc43.patch
19Patch6: synaptic-0.57.2-gcc44.patch
20
21Patch10: synaptic-0.56-desktopfile.patch
22Patch11: synaptic-0.57.2-no-utf8-help.patch
23Patch13: synaptic-0.57.2-apt-cdrom.patch
24Patch14: synaptic-0.57.2-prefer-normal-upgrade.patch
25Patch15: synaptic-0.57.2-default-size.patch
26Patch16: synaptic-0.57.2-firefox.patch
27Patch20: synaptic-dummy-grouplist.patch
28
29Patch21: synaptic-0.57.2-convert-eucjp-to-utf8.patch
30Patch22: synaptic-0.57.2-fix-memory-corruption.patch
31Patch23: synaptic-0.57.2-fix-assertion-failure.patch
32Patch24: synaptic-0.57.2-no-skip-taskbar.patch
33Patch25: synaptic-0.57.2-add-default-filters.patch
34Patch26: synaptic-0.57.2-fix-repository-updown.patch
35Patch27: synaptic-0.57.2-fix-crash-on-font-change.patch
36Patch28: synaptic-0.57.2-fix-reinstall.patch
37
38Requires: apt >= 0.5.15lorg3.93-0vl1
39Requires: usermode >= 1.69
40BuildRequires: bzip2-devel, zlib-devel
41BuildRequires: rpm-devel >= 4.8
42BuildRequires: apt-devel >= 0.5.15lorg3.95
43BuildRequires: gtk2-devel >= 2.4.0
44BuildRequires: libglade2-devel >= 2.0.1
45BuildRequires: vte-devel >= 0.11.10
46BuildRequires: xmlto
47BuildRequires: scrollkeeper
48BuildRequires: perl-XML-Parser
49BuildRequires: desktop-file-utils
50BuildRoot: %{_tmppath}/%{name}-%{version}-root
51
52Vendor: Project Vine
53Distribution: Vine Linux
54Packager: daisuke
55
56
57%description
58Synaptic is a graphical front-end for APT (Advanced Package Tool). This
59version is written with the Gtk toolkit.
60
61Instead of using trees to display packages, Synaptic is heavily based on a
62powerful package filtering system. That greatly simplifies the interface
63while giving a lot more flexibility to browse through very long package
64lists.
65
66%description -l ja
67Synaptic は APT(Advanced Package Tool) の Gtk+ ベースのグラフィカル
68フロントエンドです。Synaptic はパッケージを単純にツリー表示するのでは
69なく、強力なパッケージフィルタリングシステムを用いてパッケージを表示
70しています。
71
72
73%prep
74%setup -q
75%patch1 -p1
76%patch2 -p1
77%patch3 -p1
78%patch4 -p1
79%patch5 -p1
80%patch6 -p1
81%patch10 -p1
82%patch11 -p1
83#%patch12 -p1
84%patch13 -p1
85%patch14 -p1
86%patch15 -p1
87%patch16 -p1
88%patch20 -p1
89%patch21 -p1
90%patch22 -p1
91%patch23 -p1
92%patch24 -p1
93%patch25 -p1
94%patch26 -p1
95%patch27 -p1
96%patch28 -p1
97
98cp -f po/ja.po po/ja.po.orig
99cp -f %{SOURCE10} po/ja.po
100
101cp -f %{SOURCE20} .
102
103cp -f %{SOURCE30} pixmaps/
104
105%build
106%configure --with-pkg-hold --with-vte --enable-scripts --disable-dependency-tracking
107make -C po update-po
108make %{?_smp_mflags}
109
110%install
111rm -fr %{buildroot}
112%makeinstall
113
114# usermode setting
115mkdir -p %{buildroot}%{_bindir}
116mkdir -p %{buildroot}%{_sysconfdir}/security/console.apps
117mkdir -p %{buildroot}%{_sysconfdir}/pam.d
118ln -s %{_bindir}/consolehelper %{buildroot}%{_bindir}/synaptic
119cat << EOF > %{buildroot}%{_sysconfdir}/security/console.apps/synaptic
120. config-util
121PROGRAM=%{_sbindir}/synaptic
122SESSION=true
123EOF
124cat << EOF > %{buildroot}%{_sysconfdir}/pam.d/synaptic
125#%PAM-1.0
126auth        include     config-util
127account     include     config-util
128session     include     config-util
129EOF
130
131desktop-file-install --vendor=synaptic          \
132  --delete-original                             \
133  --dir %{buildroot}%{_datadir}/applications    \
134  --remove-key MultipleArgs                     \
135  --add-category Application                    \
136  --add-category System                         \
137  --add-category Settings                       \
138  %{buildroot}%{_datadir}/applications/%{name}.desktop
139
140# install japanese manpage
141mkdir -p %{buildroot}%{_mandir}/ja/man8/
142install man/synaptic.ja.8 %{buildroot}%{_mandir}/ja/man8/synaptic.8
143
144# fixed uri of manual.
145sed -i 's@file://usr@file:///usr@' %{buildroot}%{_datadir}/omf/synaptic/*.omf
146
147# remove uninstalled files
148rm -rf %{buildroot}/%{_localstatedir}/scrollkeeper
149rm -rf %{buildroot}/%{_sysconfdir}/X11
150rm -rf %{buildroot}/%{_datadir}/applications/%{name}-kde.desktop
151
152%clean
153rm -rf %{buildroot}
154
155
156%files
157%defattr(-,root,root)
158%doc COPYING* README* TODO
159%attr(755,root,root) %{_sbindir}/synaptic
160%attr(755,root,root) %{_bindir}/synaptic
161%{_sysconfdir}/security/console.apps/synaptic
162%{_sysconfdir}/pam.d/synaptic
163%{_datadir}/locale/*/LC_MESSAGES/%{name}.mo
164%{_datadir}/%{name}
165%{_datadir}/applications/%{name}.desktop
166%{_datadir}/pixmaps/%{name}.png
167%{_datadir}/omf/synaptic/*.omf
168%{_datadir}/gnome/help/synaptic
169%{_mandir}/man8/*
170%{_mandir}/ja/man8/*
171
172%changelog
173* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-16
174- use config-util for pam/usermode settings
175
176* Mon May 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-15
177- rebuild with apt-0.5.15lorg3.95-10.git522
178
179* Mon Apr 18 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.57.2-14
180- update Source10 and Source20.
181
182* Wed Apr 13 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.57.2-13
183- fixed uri of manual.
184
185* Thu Jan 27 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.57.2-12
186- add Patch28: fix reinstall error (<BTS:VineLinux:356>)
187- add BuildRequires: desktop-file-utils
188
189* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.57.2-11
190- rebuilt with rpm-4.8.0-3 (on ppc)
191
192* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-10
193- rebuild with rpm-4.8.0
194
195* Fri Aug 21 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.57.2-9
196- add %Patch26: fix segfault when changing repository order
197  <BTS:VineLinux:0645>
198- add %Patch27: fix crash when changing fonts <BTS:VineLinux:0751>
199
200* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.57.2-8
201- add %Patch25: add custom filter for multiple verision package
202- update Source10: add translation in ja.po
203- update Patch24: not to skip multiple version warning dialog
204
205* Sat Jul 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.57.2-7
206- add Patch24: don't skip taskbar when main window is hidden
207
208* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-6
209- add Patch23: fix assertion failure on gtk_widget_hide
210
211* Sun Jun 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-5
212- add Patch21: fix memory corruption bug.
213- add Patch22: convert EUC text to UTF-8
214
215* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-4
216- update ja.po
217- don't apply patch12
218
219* Tue Jul 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-3
220- update pam.d/synaptic for pam-1.0
221
222* Fri May 16 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.57.2-2
223- add BuildRequires perl-XML-Parser
224
225* Sat May 10 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.57.2-1
226- apply new versioning policy
227- rebuild with apt-0.5.15lorg3.94a
228
229* Wed Nov 21 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl18
230- add "Applications/Accessories" and "Restricted Software" to grouplist
231- update ja.po
232
233* Fri Oct 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl17
234- add Patch2,3,4 to support apt-0.5.15lorg3.93
235- renumber Patch16 to Patch1
236- add Patch16 to use firefox instead of mozilla
237
238* Sun Oct 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl16
239- rebuild with apt-0.5.15lorg3.93
240
241* Sun Oct 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl15
242- rebuild with rpm-4.4.2.2
243
244* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl14
245- rebuild with new environment
246- add patch16 to build with gcc4
247- add SOURCE30 to use vine icon for package-supported.png
248
249* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl13
250- rebuild with vte-0.16
251
252* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl12
253- add Patch15 to modify default windows size and treeview font size
254
255* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl11
256- add Patch14 to change default upgrade method to normal upgrade
257  instead of dist-upgrade.
258
259* Thu Nov 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.57.2-0vl10
260- update required-version of apt (>= 0.5.15lorg3.2-0vl7)
261  - comes from libapt-pkg(MountCdrom) API change
262
263* Fri Oct 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl9
264- add Patch13 for libapt-pkg(MountCdrom) API change.
265
266* Tue Sep 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl8
267- add Patch12 to fix broken summary and descriptions on UTF-8 locale.
268  - convert rpm summaries and descriptions to UTF-8 from EUC-JP.
269
270* Wed Aug 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.57.2-0vl7
271- add BuildRequires: scrollkeeper
272
273* Sun May 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.57.2-0vl6
274- rebuilt with apt-0.5.15org3.1
275
276* Sun May 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl5
277- add Patch11 to use locale to show help messages instead of utf-8.
278
279* Tue Apr 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl4
280- rebuild with new apt
281- change Group to Applications/Administration
282
283* Sat Feb 11 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.57.2-0vl3
284- update ja.po from [VineSeed:10523] etc...
285
286* Sat Feb 11 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.57.2-0vl2
287- update ja.po
288
289* Fri Dec 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl1
290- new upstream release
291- update ja.po
292- build with rpm-4.4
293
294* Sun May 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56-0vl1
295- new upstream release
296
297* Thu Apr 07 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56-0vl0
298- new upstream version (0.56beta)
299
300* Thu Nov 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.55.1-0vl1
301- new upstream release
302
303* Tue Nov 02 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.55-0vl1
304- new upstream release
305- update ja.po
306
307* Mon Nov 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53.4-0vl1
308- new upstream release
309- update ja.po
310
311* Sun Aug 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53-0vl1
312- new upstream release
313- update ja.po
314
315* Tue Jul 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52-0vl1
316- new upstream release
317
318* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51-0vl3
319- do not run automake/autoconf in %%build
320
321* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51-0vl2
322- add japanese man page.
323
324* Wed Jun 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51-0vl1
325- new upstream release
326
327* Tue Jun 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl2
328- more update ja.po
329
330* Tue Jun 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
331- new upstream release
332- update ja.po (merged cvs head)
333- add patch10 to fix 'filter' on non-UTF8 locale (merged in cvs head)
334
335* Sat Apr 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.48.2-0vl1
336- new upstream release
337- remove obsolete ja.po that is included in upstream
338
339* Sat Mar 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.48.1-0vl1
340- new upstream release
341- update ja.po
342- add BuildRequires: xmlto to build manuals.
343
344* Sat Feb 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.48-0vl0.2
345- new upstream test release
346  - fix desktopfile to use usermode instead of gksu.
347
348* Thu Dec 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0vl1
349- new upstream release
350  - Fixed many i18n issues (thanks to Ales Kapica and Jean-Michel Poure)
351  - New Czech, Arabic translation
352  - Updated Polish,Spanish,French,Japanese,Chinese,German translation
353  - Minor documentation updates
354  - Reworked the context menu for packages
355  - Some ui improvements in the common tab
356  - Use units according to the SI spec now
357  - New summary window
358  - A lot of minor bug and typo fixes
359
360* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0vl0
361- new upstream pre release
362
363* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-0vl1
364- new upstream release
365  - font selection added for default interface font and terminal
366  - better support for translated descriptions (thanks johnnybgate)
367  - dist-upgrade is gone from the menu, the user is asked what kind of
368    upgrade he wants now
369  - toolbar has a new style (text beside buttons) now
370  - real docbook help added (yeah! thanks SEBASTIAN)
371  - "hold" button gone from the gui, moved to menü
372  - sections can translated and a more descriptive description is used
373  - rpm-src-dir support added (thanks to Panu Matilainen)
374
375* Sun Oct 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45-0vl1
376- fixed kanji code in spec file..
377- new upstream release
378  - proxy can be configured with the gui now
379  - new preferences dialog layout (thanks Sebastian Heinlein)
380  - new filter dialog layout  (thanks Sebastian Heinlein)
381  - when adding filter, they are called "New Filter 1", "New Filter 2" etc
382  - added "search lack", so that the interactive search does not start
383    immediately
384  - new quit dialog
385  - speedup for the pattern filters
386  - small ui-enhancements in the filter dialog
387  - basic support for distribution selection (if you have more than one
388    distro in your sources.list, you can choose which to use by default)
389  - new about dialog (thanks Sebastian)
390  - support to choose between different versions of a given package
391  - updated japanese, chinese, polish, spanish, russian, frensh, german
392    and italian translations
393               
394* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.44-0vl1
395- new upstream release
396  - two alternative main layouts can be choosen now
397  - "clean cache now" implemented" in preferences window
398  - the search entry in the main window is interactive again
399  - much improved preferences dialog (thanks to Sebastian Heinlein)
400  - new italian, spanish, russian, chinese translation
401  - new belarussian translation
402  - improved main window design (thanks Sebastian Heinlein)
403  - added "rpm-dir" repository support (thanks Panu)
404  - prepeared a lot of strings for better i18n (thanks Jean-Michel POURE)
405
406* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.44-0vl0.pre3
407- new upstream snapshot release
408
409* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.43.1-0vl1
410- new upstream release
411  - the descriptionParser for rpm has changed
412    (the actuall parser is configurable now)
413  - new find and changes dialog layout, more HIG compliant
414  - more bugfixes in the PkgTreeView and the new sorting code
415
416* Tue Aug 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.42-0vl1
417- new upstream release
418  - download percentage is now always calculated correctly
419  - save selection on "pin", "update" and "proceed" now
420  - some bugs fixed in the new sortable tree/list
421  - the order of the columns in the treeview is configurable now
422  - updated german/spanish/japanese/russian translation
423  - [debian only] debian package tags support
424  - sortable installed size column added
425  - "Information" tab now scrollable
426
427* Wed Jul 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.40-0vl1
428- new upstream release
429
430* Tue Jul  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.39-0vl2
431- remove BuildRequires: libzvt
432
433* Sat Jul  5 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.39-0vl1
434- new upstream release
435- update ja.po
436
437* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.38-0vl2
438- update ja.po
439
440* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.38-0vl1
441- new upstream release
442
443* Thu Jun 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.37-0vl1
444- new upstream release
445
446* Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.36.1-0vl1
447- new upstream release
448
449* Thu Apr 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.36-0vl1
450- new upstream release 0.36
451- fixed usermode configuration file.
452
453* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.35.1-0vl2
454- rebuild with apt-0.5.5.cnc.5-0vl1
455
456* Wed Apr  2 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.35.1-0vl1
457- new upstream release 0.35.1
458- drop obsolete patch0 which included in upstream.
459- add modified synaptic.desktop entry.
460
461* Mon Mar 31 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.35-0vl2
462- add patch0 to fix compilation failure on apt-rpm.
463- add ja.po and patch10.
464
465* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.35-0vl1
466- new upstream release
467
468* Fri Mar 28 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32-0vl1
469- initial release.
470
Note: See TracBrowser for help on using the repository browser.