source: projects/specs/branches/6/s/sudo/sudo-vl.spec @ 6313

Revision 6313, 9.0 KB checked in by iwamoto, 12 years ago (diff)

sudo-vl: 20120610-1 update

Line 
1Summary: Allows command execution as root for specified users
2Summary(ja): スーパーユーザ権限でのコマンドの実行
3Name: sudo
4Version: 1.7.2p7
5Release: 5%{?_dist_release}
6License: ISC-style
7Group: Applications/System
8URL: http://www.sudo.ws/
9
10Source0: http://www.sudo.ws/sudo/dist/sudo-%{version}.tar.gz
11Source1: sudo-sudoers-vine
12
13Patch1: sudo-1.6.7p5-strip.patch
14Patch2: sudo-1.7.2-login.patch
15Patch3: sudo-1.7.2p4-getgrouplist.patch
16Patch4: sudo-1.7.1-envdebug.patch
17Patch5: sudo-1.7.1-libtool.patch
18# reset HOME when using the -i' option (#635250)
19Patch6: sudo-1.7.4p4-sudoi.patch
20# security
21Patch100: sudo-1.7.2p7_CVE-2010-2956.patch
22Patch110: sudo-1.7.2p7_CVE-2011-0010.patch
23Patch111: sudo-1.7.2p7_user_in_group.patch
24Patch120: sudo-1.7.2p7_CVE-2012-2337.patch
25
26Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
27BuildRequires: pam-devel
28BuildRequires: groff
29BuildRequires: flex
30BuildRequires: bison
31BuildRequires: openldap-devel
32BuildRequires: automake autoconf libtool
33BuildRequires: libcap-devel
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39Sudo (superuser do) allows a system administrator to give certain users
40(or groups of users) the ability to run some (or all) commands as root while
41logging all commands and arguments. Sudo operates on a per-command basis,
42it is not a replacement for the shell.
43
44%description -l ja
45sudo は、特定のユーザや特定のグループに所属するユーザが、スーパーユーザ権限で
46いくつかのコマンド操作を行うことを許可するためのプログラムです。
47
48%prep
49%setup -q
50%patch1 -p1 -b .strip
51%patch2 -p1 -b .login
52%patch3 -p1 -b .getgrouplist
53%patch4 -p1 -b .envdebug
54%patch5 -p1 -b .libtool
55
56%patch100 -p1 -b .CVE-2010-2956
57%patch110 -p1 -b .CVE-2011-0010
58%patch111 -p1 -b .user_in_group
59%patch120 -p1 -b .CVE-2012-2337
60
61libtoolize --force && rm acsite.m4 && mv aclocal.m4 acinclude.m4 && autoreconf
62
63%build
64%configure \
65  --prefix=%{_prefix} \
66  --sbindir=%{_sbindir} \
67  --libdir=%{_libdir} \
68  --sysconfdir=%{_sysconfdir} \
69  --with-pam \
70  --with-pam-login \
71  --with-logging=syslog \
72  --with-logfac=authpriv \
73  --with-tty-tickets \
74  --with-ignore-dot \
75  --with-editor=/bin/vi \
76  --with-env-editor \
77  --with-ldap \
78  --with-passprompt="[sudo] password for %p: " \
79  --with-secure-path="/sbin:/bin:/usr/sbin:/usr/bin" \
80  --without-interfaces
81make %{?_smp_mflags}
82
83%install
84rm -rf $RPM_BUILD_ROOT
85mkdir $RPM_BUILD_ROOT
86make install DESTDIR="$RPM_BUILD_ROOT" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
87chmod 755 $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_sbindir}/*
88install -p -d -m 700 $RPM_BUILD_ROOT/var/run/sudo
89install -p -c -m 0440 %{SOURCE1} $RPM_BUILD_ROOT/etc/sudoers
90
91mkdir -p $RPM_BUILD_ROOT/etc/pam.d
92cat > $RPM_BUILD_ROOT/etc/pam.d/sudo << EOF
93#%PAM-1.0
94auth       include      system-auth
95account    include      system-auth
96password   include      system-auth
97session    optional     pam_keyinit.so revoke
98session    required     pam_limits.so
99EOF
100
101cat > $RPM_BUILD_ROOT/etc/pam.d/sudo-i << EOF
102#%PAM-1.0
103auth       include      sudo
104account    include      sudo
105password   include      sudo
106session    optional     pam_keyinit.so force revoke
107session    required     pam_limits.so
108EOF
109
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%files
115%defattr(-,root,root)
116%doc HISTORY LICENSE README* TROUBLESHOOTING UPGRADE
117%doc ChangeLog
118%doc *.pod schema.* sudoers2ldif sample.*
119%attr(0440,root,root) %config(noreplace) /etc/sudoers
120%config(noreplace) /etc/pam.d/sudo
121%config(noreplace) /etc/pam.d/sudo-i
122%dir /var/run/sudo
123%attr(4111,root,root) %{_bindir}/sudo
124%attr(4111,root,root) %{_bindir}/sudoedit
125%attr(0755,root,root) %{_sbindir}/visudo
126%{_libexecdir}/sudo_noexec.*
127%{_mandir}/man5/sudoers*.5*
128%{_mandir}/man8/sudo.8*
129%{_mandir}/man8/sudoedit.8*
130%{_mandir}/man8/visudo.8*
131
132%post
133/bin/chmod 0440 /etc/sudoers || :
134
135%changelog
136* Sat May 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-5
137- add patch120 for fix CVE-2012-2337 (netmask match)
138
139* Fri Jun 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2p7-4
140- update sudoers
141  - enable "%wheel ALL=(ALL) ALL" by default.
142
143* Thu Feb 10 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-3
144- add patch110,111 for fix CVE-2011-0010 ("-g" option)
145
146* Wed Sep  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-2
147- add Patch100 for fix CVE-2010-2956 (sudo Runas)
148- add _smp_mflags flag into make section
149- fix doc filelist (no longer exist BUGS, CHANGSE)
150
151* Sun Jun 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-1
152- new upstream release with security fix (CVE-2010-1646)
153- change specfile name (-vl)
154
155* Sun Apr 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p6-1
156- new upstream release with security fix (CVE-2010-1163)
157- add sudoers.ldap.5 into files section
158
159* Wed Feb 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p4-1
160- new upstream release with security fix (CVE-2010-0426)
161- update Patch3
162
163* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-1
164- new upstream release
165
166* Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.1-1
167- new upstream release
168- update patches
169- disable "Defaults requiretty"
170
171* Fri Feb 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.9p20-2
172- rebuilt with openldap-2.4.11
173
174* Thu Feb 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.9p20-1
175- new upstream release with security fix (CVE 2009-0034)
176
177* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.9p17-1
178- new upstream release
179- merge some changes from fedoraproject
180  - include [sudo] in password prompt
181  - compiled with secure path
182  - also use getgrouplist() to determine group membership
183  - add sudoers file
184    - add command aliases, default environment config
185- build with openldap
186
187* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.8p12-1vl5
188- applied new versioning policy, spec in utf-8
189
190* Fri May 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p12-0vl2
191- change PAM configuration to use system-auth
192- add --with-ignore-dot, --with-editor and --with-env-editor to
193  configure option.
194
195* Mon Jan 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.8p12-0vl1
196- new upstream release (included security fix)
197- add patch1 for fix CVE-2006-0151
198
199* Mon May 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p8-0vl1
200- new upstream release
201- use macros
202- build with pam
203
204* Wed Jan 19 2005 IWAI, Masaharu <iwai@alib.jp> 1.6.8p6-0vl1
205- new upstream release
206
207* Sun Oct 10 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8p1-0vl1
208- SECURITY FIX: new upstream release
209- update rpmnonroot.patch ( Patch0 )
210- add new man page: sudoedit(8)
211
212* Wed Sep  1 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8-0vl1
213- new upstream release
214- update rpmnonroot.patch ( Patch0 )
215- change Copyrigh tag to License tag
216- update License
217- update URL and Source0: official web site moved.
218- new files: %%{_bindir}/sudoedit and %%{_libexecdir}/sudo_noexec.*
219
220* Mon Apr 14 2003 IWAI Masaharu <iwai@alib.jp> 1.6.7p3-0vl1
221- upstream release
222
223* Wed May 08 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl3
224- fixed changelog
225        -- don't expand macros in changelog ;P
226               
227* Wed May 01 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl2
228- changed to use configure in build section
229        (can't build on sparc)
230
231* Fri Apr 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.6-0vl1
232- upstream release
233- fix security hole : buffer over flow
234
235* Thu Jan 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p2-0vl1
236- upstream release
237- updated sudo.rpmnonroot.diff
238
239* Fri Jan 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p1-0vl1
240- upstream release
241- added configure script option '--disable-root-mailer'
242
243* Tue Jan 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4p1-0vl1
244- upstream release
245- eliminated FAQ from %doc
246
247* Mon Jan 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4-0vl1
248- upstream release
249- added noreplace flag (%{_sysconfdir}/sudoers file is not replaced)
250- updated sudo.rpmnonroot.diff
251
252* Wed May 09 2001 <sagami@vinelinux.org>
253- 1.6.3p7-0vl2: follow up 1.6.2p6-0.6vl1
254
255* Fri Mar 02 2001 sagami@vinelinux.org
256- 1.6.3p7-0vl1
257- use better macros
258
259* Tue Mar 1 2001 Kunio Murasawa <murasawa@marineroad.com>
260- 1.6.3p6-0vl1
261- changed sudo.rpmnonroot.diff for 1.6.3p6
262
263* Tue Sep 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
264- 1.6.1-2vl5
265- patch -p1 -> patch -p0
266
267* Mon Sep 18 2000 MATSUMOTO Shoji <shom@vinelinux.org>
268- 1.6.1-2vl4
269- fix uid/gid to root.root
270- add sudo.rpmnonroot.diff to built by non-root users
271
272* Tue Sep 12 2000 Jun Nishii <jun@vinelinux.org>
273- 1.6.1-2vl3
274- fix attr
275
276* Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
277- 1.6.1-2vl2
278- enable to build by non-root useres
279
280* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
281- 1.6.1-2vl1
282- modified %files section to handle compressed man page(s)
283
284* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
285- change group
286
287* Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
288- version 1.6.1
289- build for Vine Linux 2.0
290
291* Fri May 14  1999 Takeda Eiji <keda@flatout.org>
292- sudo reads $BuildRoot%{_sysconfdir}/sudoers. Make change to read /etc/sudoers.
293
294* Wed Apr 21 1999 Hiroto Watanabe <watanabe@cij.co.jp>
295- Initial Release
296
Note: See TracBrowser for help on using the repository browser.