source: projects/specs/branches/6/s/sudo/sudo-vl.spec @ 10725

Revision 10725, 10.5 KB checked in by tomop, 8 years ago (diff)

sudo-1.8.17p1-1

RevLine 
[521]1Summary: Allows command execution as root for specified users
2Summary(ja): スーパーユーザ権限でのコマンドの実行
3Name: sudo
[10725]4Version: 1.8.17p1
[8378]5Release: 1%{?_dist_release}
[521]6License: ISC-style
7Group: Applications/System
[10725]8URL: http://www.sudo.ws/sudo/
[521]9
10Source0: http://www.sudo.ws/sudo/dist/sudo-%{version}.tar.gz
11Source1: sudo-sudoers-vine
12
[10725]13# don't strip
[521]14Patch1: sudo-1.6.7p5-strip.patch
[10725]15# Patch to read ldap.conf more closely to nss_ldap
16Patch2: sudo-1.8.14p1-ldapconfpatch.patch
[7523]17
[521]18Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pam-devel
20BuildRequires: groff
21BuildRequires: flex
22BuildRequires: bison
23BuildRequires: openldap-devel
24BuildRequires: automake autoconf libtool
25BuildRequires: libcap-devel
[8378]26BuildRequires: zlib-devel
[521]27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32Sudo (superuser do) allows a system administrator to give certain users
33(or groups of users) the ability to run some (or all) commands as root while
34logging all commands and arguments. Sudo operates on a per-command basis,
35it is not a replacement for the shell.
36
37%description -l ja
38sudo は、特定のユーザや特定のグループに所属するユーザが、スーパーユーザ権限で
39いくつかのコマンド操作を行うことを許可するためのプログラムです。
40
41%prep
42%setup -q
43%patch1 -p1 -b .strip
[10725]44%patch2 -p1 -b .ldapconfpatch
[521]45
[10725]46rm -rf zlib/
[2401]47
[10725]48%build
[7523]49autoreconf -I m4 -fv --install
50
[10725]51F_PIE=-fpie
52export CFLAGS="$RPM_OPT_FLAGS $F_PIE" LDFLAGS="-pie -Wl,-z,relro -Wl,-z,now"
53
[521]54%configure \
55  --prefix=%{_prefix} \
56  --sbindir=%{_sbindir} \
57  --libdir=%{_libdir} \
58  --sysconfdir=%{_sysconfdir} \
[10725]59  --docdir=%{_datadir}/doc/%{name}-%{version} \
[7523]60  --with-iologdir=/var/log/sudo-io \
[521]61  --with-pam \
62  --with-pam-login \
63  --with-logging=syslog \
64  --with-logfac=authpriv \
65  --with-tty-tickets \
66  --with-ignore-dot \
67  --with-editor=/bin/vi \
68  --with-env-editor \
69  --with-ldap \
70  --with-passprompt="[sudo] password for %p: " \
71  --with-secure-path="/sbin:/bin:/usr/sbin:/usr/bin" \
[10725]72  --without-interfaces \
73  --without-selinux
[2401]74make %{?_smp_mflags}
[521]75
76%install
77rm -rf $RPM_BUILD_ROOT
78mkdir $RPM_BUILD_ROOT
79make install DESTDIR="$RPM_BUILD_ROOT" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
[10725]80
[521]81chmod 755 $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_sbindir}/*
82install -p -d -m 700 $RPM_BUILD_ROOT/var/run/sudo
[10725]83install -p -d -m 700 $RPM_BUILD_ROOT/var/db/sudo/lectured
[7523]84install -p -d -m 700 $RPM_BUILD_ROOT/var/log/sudo-io
[10725]85install -p -d -m 750 $RPM_BUILD_ROOT/etc/sudoers.d
[521]86install -p -c -m 0440 %{SOURCE1} $RPM_BUILD_ROOT/etc/sudoers
87
[10725]88chmod +x $RPM_BUILD_ROOT%{_libexecdir}/sudo/*.so # for stripping, reset in %%files
89
90# Remove execute permission on this script so we don't pull in perl deps
91chmod -x $RPM_BUILD_ROOT%{_docdir}/sudo-*/sudoers2ldif
92
93mv -f %{buildroot}%{_docdir}/sudo-%{version} docdir
94
95#Remove all .la files
96find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
97
98%find_lang sudo
99%find_lang sudoers
100
101cat sudo.lang sudoers.lang > sudo_all.lang
102rm sudo.lang sudoers.lang
103
[521]104mkdir -p $RPM_BUILD_ROOT/etc/pam.d
105cat > $RPM_BUILD_ROOT/etc/pam.d/sudo << EOF
106#%PAM-1.0
107auth       include      system-auth
108account    include      system-auth
109password   include      system-auth
110session    optional     pam_keyinit.so revoke
111session    required     pam_limits.so
[10725]112session    include      system-auth
[521]113EOF
114
115cat > $RPM_BUILD_ROOT/etc/pam.d/sudo-i << EOF
116#%PAM-1.0
117auth       include      sudo
118account    include      sudo
119password   include      sudo
120session    optional     pam_keyinit.so force revoke
[10725]121session    include      sudo
[521]122EOF
123
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
[10725]128%files -f sudo_all.lang
[521]129%defattr(-,root,root)
[10725]130%doc plugins/sample/sample_plugin.c
131%doc docdir/*
[521]132%attr(0440,root,root) %config(noreplace) /etc/sudoers
[10725]133%attr(0750,root,root) %dir /etc/sudoers.d/
[521]134%config(noreplace) /etc/pam.d/sudo
135%config(noreplace) /etc/pam.d/sudo-i
136%dir /var/run/sudo
[10725]137%dir /var/db/sudo
138%dir /var/db/sudo/lectured
[7523]139%attr(0750,root,root) %dir /var/log/sudo-io
[521]140%attr(4111,root,root) %{_bindir}/sudo
[10725]141%{_bindir}/sudoedit
[7523]142%attr(0111,root,root) %{_bindir}/sudoreplay
[521]143%attr(0755,root,root) %{_sbindir}/visudo
[10725]144%dir %{_libexecdir}/sudo
145%attr(0644,root,root) %{_libexecdir}/sudo/sudo_noexec.so
146%attr(0644,root,root) %{_libexecdir}/sudo/sudoers.so
147%attr(0644,root,root) %{_libexecdir}/sudo/group_file.so
148%attr(0644,root,root) %{_libexecdir}/sudo/system_group.so
149%attr(0644,root,root) %{_libexecdir}/sudo/libsudo_util.so.?.?.?
150%{_libexecdir}/sudo/libsudo_util.so.?
151%{_libexecdir}/sudo/libsudo_util.so
[1393]152%{_mandir}/man5/sudoers*.5*
[10725]153%{_mandir}/man5/sudo.conf.5*
[521]154%{_mandir}/man8/sudo.8*
155%{_mandir}/man8/sudoedit.8*
[10725]156%{_mandir}/man8/sudoreplay.8*
[521]157%{_mandir}/man8/visudo.8*
[10725]158# should be splitted to -devel?
159%{_includedir}/sudo_plugin.h
160%{_mandir}/man8/sudo_plugin.8*
[521]161
[10725]162
[521]163%post
164/bin/chmod 0440 /etc/sudoers || :
165
166%changelog
[10725]167* Sat Jul 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.17p1-1
168- updated to 1.8.17p1.
169- added Patch2.
170- dropped Patch4.
[8378]171
[10725]172* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.6p8-1
173- update to 1.8.6p8
174
175* Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-3
176- fix permission of sudoreplay
177
178* Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-2
[7523]179- add /var/log/sudo-io
[10725]180- add some comments to default sudoers
[7523]181
[10725]182* Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-1
183- update to 1.8.6p7
184- drop unneeded patches.
[7523]185
[6313]186* Sat May 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-5
187- add patch120 for fix CVE-2012-2337 (netmask match)
188
[4035]189* Fri Jun 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2p7-4
190- update sudoers
191  - enable "%wheel ALL=(ALL) ALL" by default.
192
[3394]193* Thu Feb 10 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-3
194- add patch110,111 for fix CVE-2011-0010 ("-g" option)
195
[2401]196* Wed Sep  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-2
197- add Patch100 for fix CVE-2010-2956 (sudo Runas)
198- add _smp_mflags flag into make section
199- fix doc filelist (no longer exist BUGS, CHANGSE)
200
[1393]201* Sun Jun 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-1
202- new upstream release with security fix (CVE-2010-1646)
203- change specfile name (-vl)
204
205* Sun Apr 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p6-1
206- new upstream release with security fix (CVE-2010-1163)
207- add sudoers.ldap.5 into files section
208
[819]209* Wed Feb 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p4-1
210- new upstream release with security fix (CVE-2010-0426)
211- update Patch3
[521]212
213* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-1
214- new upstream release
215
216* Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.1-1
217- new upstream release
218- update patches
219- disable "Defaults requiretty"
220
221* Fri Feb 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.9p20-2
222- rebuilt with openldap-2.4.11
223
224* Thu Feb 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.9p20-1
225- new upstream release with security fix (CVE 2009-0034)
226
227* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.9p17-1
228- new upstream release
229- merge some changes from fedoraproject
230  - include [sudo] in password prompt
231  - compiled with secure path
232  - also use getgrouplist() to determine group membership
233  - add sudoers file
234    - add command aliases, default environment config
235- build with openldap
236
237* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.8p12-1vl5
238- applied new versioning policy, spec in utf-8
239
240* Fri May 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p12-0vl2
241- change PAM configuration to use system-auth
242- add --with-ignore-dot, --with-editor and --with-env-editor to
243  configure option.
244
245* Mon Jan 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.8p12-0vl1
246- new upstream release (included security fix)
247- add patch1 for fix CVE-2006-0151
248
249* Mon May 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p8-0vl1
250- new upstream release
251- use macros
252- build with pam
253
254* Wed Jan 19 2005 IWAI, Masaharu <iwai@alib.jp> 1.6.8p6-0vl1
255- new upstream release
256
257* Sun Oct 10 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8p1-0vl1
258- SECURITY FIX: new upstream release
259- update rpmnonroot.patch ( Patch0 )
260- add new man page: sudoedit(8)
261
262* Wed Sep  1 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8-0vl1
263- new upstream release
264- update rpmnonroot.patch ( Patch0 )
265- change Copyrigh tag to License tag
266- update License
267- update URL and Source0: official web site moved.
268- new files: %%{_bindir}/sudoedit and %%{_libexecdir}/sudo_noexec.*
269
270* Mon Apr 14 2003 IWAI Masaharu <iwai@alib.jp> 1.6.7p3-0vl1
271- upstream release
272
273* Wed May 08 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl3
274- fixed changelog
275        -- don't expand macros in changelog ;P
276               
277* Wed May 01 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl2
278- changed to use configure in build section
279        (can't build on sparc)
280
281* Fri Apr 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.6-0vl1
282- upstream release
283- fix security hole : buffer over flow
284
285* Thu Jan 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p2-0vl1
286- upstream release
287- updated sudo.rpmnonroot.diff
288
289* Fri Jan 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p1-0vl1
290- upstream release
291- added configure script option '--disable-root-mailer'
292
293* Tue Jan 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4p1-0vl1
294- upstream release
295- eliminated FAQ from %doc
296
297* Mon Jan 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4-0vl1
298- upstream release
299- added noreplace flag (%{_sysconfdir}/sudoers file is not replaced)
300- updated sudo.rpmnonroot.diff
301
302* Wed May 09 2001 <sagami@vinelinux.org>
303- 1.6.3p7-0vl2: follow up 1.6.2p6-0.6vl1
304
305* Fri Mar 02 2001 sagami@vinelinux.org
306- 1.6.3p7-0vl1
307- use better macros
308
[10725]309* Thu Mar 1 2001 Kunio Murasawa <murasawa@marineroad.com>
[521]310- 1.6.3p6-0vl1
311- changed sudo.rpmnonroot.diff for 1.6.3p6
312
313* Tue Sep 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
314- 1.6.1-2vl5
315- patch -p1 -> patch -p0
316
317* Mon Sep 18 2000 MATSUMOTO Shoji <shom@vinelinux.org>
318- 1.6.1-2vl4
319- fix uid/gid to root.root
320- add sudo.rpmnonroot.diff to built by non-root users
321
322* Tue Sep 12 2000 Jun Nishii <jun@vinelinux.org>
323- 1.6.1-2vl3
324- fix attr
325
326* Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
327- 1.6.1-2vl2
328- enable to build by non-root useres
329
330* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
331- 1.6.1-2vl1
332- modified %files section to handle compressed man page(s)
333
334* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
335- change group
336
337* Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
338- version 1.6.1
339- build for Vine Linux 2.0
340
341* Fri May 14  1999 Takeda Eiji <keda@flatout.org>
342- sudo reads $BuildRoot%{_sysconfdir}/sudoers. Make change to read /etc/sudoers.
343
344* Wed Apr 21 1999 Hiroto Watanabe <watanabe@cij.co.jp>
345- Initial Release
346
Note: See TracBrowser for help on using the repository browser.