source: projects/specs/branches/6/s/subversion/subversion-vl.spec @ 4024

Revision 4024, 15.9 KB checked in by iwamoto, 13 years ago (diff)

subversion: new upstream release with security fixes

Line 
1%define neon_version 0.25.5
2%define swig_version 1.3.29
3%define apache_dir /usr
4
5%define db_version 4.3.29
6
7%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
8
9# set to zero to avoid running test suite
10%define make_check 0
11
12Summary: Modern Version Control System
13Summary(ja): モダンなバージョン管理システム
14Name: subversion
15Version: 1.6.17
16Release: 1%{?_dist_release}
17License: ASL 1.1
18Group: Development/Tools
19URL: http://subversion.apache.org/
20
21Packager: iwaim
22Vendor: Project Vine
23Distribution: Vine Linux
24
25SOURCE0: subversion-%{version}.tar.bz2
26SOURCE1: subversion.conf
27SOURCE2: httpd.davcheck.conf
28SOURCE3: filter-requires.sh
29Patch1: subversion-1.6.0-deplibs.patch
30Patch3: subversion-1.6.1-rpath.patch
31Patch6: subversion-1.5.0-pie.patch
32Patch10: subversion-1.5.7-update-neon-m4.patch
33
34Requires: db4 >= %{db_version}
35Requires: expat
36Requires: neon >= %{neon_version}
37BuildRequires: apache2-devel
38BuildRequires: apr-devel, apr-util-devel
39BuildRequires: autoconf >= 2.53
40BuildRequires: db4-devel >= %{db_version}
41BuildRequires: expat-devel
42BuildRequires: gdbm-devel
43BuildRequires: libtool >= 1.4.2
44BuildRequires: neon-devel >= %{neon_version}
45BuildRequires: openssl-devel
46BuildRequires: python
47BuildRequires: python-devel
48BuildRequires: swig >= %{swig_version}
49BuildRequires: texinfo
50BuildRequires: zlib-devel
51BuildRequires: openldap-devel
52BuildRequires: ruby >= 1.8.2
53BuildRequires: ruby-devel >= 1.8.2
54BuildRequires: perl >= 5.8.0
55BuildRequires: sqlite3-devel
56BuildRequires: krb5-devel
57BuildRequires: keyutils-libs-devel
58BuildRequires: dbus-devel
59BuildRequires: libgnome-keyring-devel
60BuildRoot: %{_tmppath}/%{name}-%{version}-root
61
62%define __perl_requires %{SOURCE3}
63
64%description
65Subversion is a concurrent version control system which enables one
66or more users to collaborate in developing and maintaining a
67hierarchy of files and directories while keeping a history of all
68changes.  Subversion only stores the differences between versions,
69instead of every complete file.  Subversion is intended to be a
70compelling replacement for CVS.
71
72%package devel
73Group: Development/Libraries
74Summary: Development package for Subversion developers.
75Requires: subversion = %{version}-%{release}
76Requires: apr-devel, apr-util-devel
77%description devel
78The subversion-devel package includes the static libraries and include files
79for developers interacting with the subversion package.
80
81%package mod_dav_svn
82Group: System Environment/Daemons
83Summary: Apache server module for Subversion server.
84Requires: httpd >= %{apache_version}
85Requires: subversion = %{version}-%{release}
86%description mod_dav_svn
87The subversion-mod_dav_svn package adds the Subversion server Apache module to
88the Apache directories and configuration.
89
90%package tools
91Group: Development/Tools
92Summary: Tools for Subversion
93BuildRequires: perl >= 5.8.0
94Requires: perl >= 5.8.0
95Requires: subversion = %{version}-%{release}
96
97%description tools
98Tools for Subversion.
99
100%package perl
101Group: Development/Libraries
102Summary: Perl bindings to the Subversion libraries
103Requires: subversion = %{version}-%{release}
104Requires: perl >= 5.8.0
105Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
106
107%description perl
108This package includes the Perl bindings to the Subversion libraries.
109
110%package ruby
111Group: Development/Libraries
112Summary: Ruby bindings to the Subversion libraries
113Requires: subversion = %{version}-%{release}
114Requires: ruby >= 1.8.2
115
116%description ruby
117This package includes the Ruby bindings to the Subversion libraries.
118
119%package python
120Group: Development/Libraries
121Summary: Python bindings to the Subversion libraries
122Requires: subversion = %{version}-%{release}, python
123
124%description python
125This package includes the Python bindings to the Subversion libraries.
126
127%prep
128%setup -q
129%patch1 -p1 -b .deplibs
130%patch3 -p1 -b .rpath
131## comment out: 1.6.9-1
132#%patch6 -p1 -b .pie
133## comment out: 1.6.9-1
134#%patch10 -p1 -b .nola
135
136rm -rf neon apr apr-util db4
137
138%build
139./autogen.sh
140
141# fix shebang lines, #111498
142perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
143
144# override weird -shrext from ruby
145export svn_cv_ruby_link="%{__cc} -shared"
146export svn_cv_ruby_sitedir_libsuffix=""
147export svn_cv_ruby_sitedir_archsuffix=""
148
149export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
150export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
151%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
152        --with-swig --with-neon=%{_prefix} \
153        --with-ruby-sitedir=%{rarchdir} \
154        --with-apxs=%{_bindir}/apxs \
155        --with-gnome-keyring \
156        --disable-mod-activation \
157        --disable-static \
158        --disable-neon-version-check
159# 1.3.0 tarball ships with generated swig sources
160make extraclean-swig-headers
161make %{?_smp_mflags} all
162make swig-py swig-py-lib %{swigdirs}
163make swig-pl swig-pl-lib swig-rb swig-rb-lib
164
165
166%install
167echo %{rarchdir}
168rm -rf $RPM_BUILD_ROOT
169make install \
170        install-swig-py \
171        install-swig-pl-lib \
172        install-swig-rb \
173        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
174
175make pure_vendor_install -C subversion/bindings/swig/perl/native \
176        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
177install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
178
179# Add subversion.conf configuration file into httpd/conf.d directory.
180install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
181install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
182
183# Set up tools package files.
184mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
185cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
186
187# Remove unpackaged files
188rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
189       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
190       $RPM_BUILD_ROOT%{_libdir}/*.la
191       
192# remove stuff produced with Perl modules
193find $RPM_BUILD_ROOT -type f \
194     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
195     -print0 | xargs -0 rm -f
196
197# make Perl modules writable so they get stripped
198find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
199     xargs -0 chmod 755
200
201# unnecessary libraries for swig bindings
202rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
203
204# Remove unnecessary ruby libraries
205rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
206
207# Trim what goes in docdir
208rm -rf tools/*/*.in tools/test-scripts
209                       
210# Rename authz_svn INSTALL doc for docdir
211ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
212
213%clean
214rm -rf $RPM_BUILD_ROOT
215
216%post -p /sbin/ldconfig
217
218%postun -p /sbin/ldconfig
219
220%post tools -p /sbin/ldconfig
221
222%postun tools -p /sbin/ldconfig
223
224
225%files
226%defattr(-,root,root)
227%doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
228%doc subversion/LICENSE
229%{_bindir}/*
230%{_libdir}/libsvn_*.so.*
231%{_localedir}/*/*/subversion.mo
232%{_mandir}/man*/*
233%dir %{_sysconfdir}/subversion
234%exclude %{_mandir}/man*/*::*
235%exclude %{_libdir}/libsvn_swig_perl*.so.*
236%exclude %{_libdir}/libsvn_swig_py*.so.*
237%exclude %{_libdir}/libsvn_swig_ruby*.so.*
238
239%files devel
240%defattr(-,root,root)
241%{_includedir}/subversion-1
242%{_libdir}/libsvn*.so
243%exclude %{_libdir}/libsvn_swig_perl*.so.*
244%exclude %{_libdir}/libsvn_swig_py*.so.*
245%exclude %{_libdir}/libsvn_swig_ruby*.so.*
246
247%files mod_dav_svn
248%defattr(-,root,root)
249%config(noreplace) /etc/apache2/conf.d/subversion.conf
250%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
251
252%files tools
253%defattr(-,root,root)
254%{_prefix}/lib/subversion/tools
255
256%files perl
257%defattr(-,root,root,-)
258%{perl_vendorarch}/auto/SVN
259%{perl_vendorarch}/SVN
260%{_libdir}/libsvn_swig_perl*
261%{_mandir}/man*/*::*
262
263%files ruby
264%defattr(-,root,root,-)
265%{_libdir}/libsvn_swig_ruby*
266%{rarchdir}/svn
267
268%files python
269%defattr(-,root,root,-)
270%{_libdir}/libsvn_swig_py*
271%{python_sitearch}/libsvn
272%{python_sitearch}/svn
273
274
275%changelog
276* Fri Jun  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
277- new upstream release with security fix (CVE-2011-1752, 1783, 1921)
278- add configure option with-gnome-keyring
279- add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
280- fix Packager name
281
282* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
283- build with perl 5.12.3
284- add Requires: perl(:MODULE_COMPAT_...)
285
286* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
287- new upstream release with security fix
288- add Vendor/Distri tags
289
290* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
291- new upstream release
292
293* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
294- fix <BTS:VineLinux:941>
295  - using rpm macro: rarchdir
296  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
297- using rpm macros: perl_vendorarch and python_sitearch
298- add BuildRequires: sqlite3-devel krb5-devel
299
300* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
301- new upstream release
302- update URL
303- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
304- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
305- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
306- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
307
308* Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
309- new upstream release
310
311* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
312- new upstream release
313
314* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
315- rebuilt with python-2.5.2
316
317* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
318- new upstream release
319- rebuild with neon-0.28.2
320- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
321- added Patch6, 8, 9, 10 from Fedora Core
322  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
323  - Correct install location of java stuff (#433295)
324  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
325  - fix build with new glibc open()-as-macro
326  - build all swig code in %%build, not %%install
327  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
328  - build /usr/bin/* as PIEs
329
330* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
331- rebuild with expat-2.0.1
332
333* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
334- new upstream release
335- add Patch10 to build with neon.
336  1.3.2-0vl5 does not support neon..
337
338* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
339- rebuild with new neon
340
341* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
342- rebuilt with new toolchain and db4-4.3.x
343
344* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
345- modified %%files section for lib64 architecture
346
347* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
348- new upstream release
349- rebuild with new openldap-2.3.24
350
351* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
352- new upstream release
353- change Group to Develoment/Tools
354- build with apr-1.2.7/apr-util-1.2.7
355  - require apr/apr-util instead of apache2-apr
356- build with swig-1.3.29
357- split {perl,python,ruby} related files to subpackage.
358
359* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
360- new upstream release
361- add noreplace option for config file
362
363* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
364- fix Requires and BuildPreReq.
365
366* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
367- new upstream release.
368- add swig-runtime to 'BuildPreReq:'.
369- fix %%files.
370
371* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
372- require neon version 0.24.7 for ra_dav
373- add BuildPreReq: openldap-devel
374- replace BuildPreReq: httpd to BuildPreReq: apache2
375- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
376
377* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
378- new upstream release
379
380* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
381- new upstream release
382
383* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
384- new upstream release
385- clean up specfile.
386
387* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
388- new upstream release
389- build with apache2-2.0.47
390
391* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
392- build Vine Linux
393
394* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
395- Enabled RA_DAV checking.
396  Now requires httpd package to build because of RA_DAV tests.
397
398* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
399- Created tools package to hold the tools.
400
401* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
402- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
403  version of APR/APR-UTILS as of 2003.01.15.
404- Added svnversion command.
405
406* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
407- Create a svnadmin.static which is copied to svnadmin-version-release
408  when the package is erased, so users can still dump/load their repositories
409  even after they have upgraded the RPM package.
410
411* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
412- SWIG now builds so we can use cvs2svn.
413
414* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
415- Made cvs2svn conditional (at least until we can get it to build consistently
416  and work).
417
418* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
419- Added SWIG dependencies to add cvs2svn capabilities.
420
421* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
422- Now requires neon-0.22.0.
423
424* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
425- Took out loading mod_dav_svn from subversion.spec file and put it in
426  subversion.conf file which goes into the apache conf directory.
427- Simplify what gets put into httpd.conf to only the include for the
428  subversion.conf file.
429  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
430  me to do this).
431
432* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
433- Updated to APR/APR-UTIL 2002-08-08.
434
435* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
436- Updated to APACHE/APR/APR-UTIL 2002-06-25.
437- Previous version had a few problems because of missing apache error/ files.
438
439* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
440- Updated to apache-2.0.40-0.3.
441- Updated to subversion-0.13.1-2318.
442
443* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
444- Updated for RedHat 7.3 (autoconf253).
445- Added a bunch of pre-requisites I didn't know were needed because I built a
446  new machine that didn't have them already installed.
447- Fixed installation of man and info documentation pages.
448
449* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
450- Back to apache-libapr* stuff, hopefully to stay.
451
452* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
453- Fixed expat.patch to not have to make so many changes by writing a small
454  shell script that changes libexpat to -lexpat.
455
456* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
457- Updated to neon-0.19.2.
458
459* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
460- Back to using apr and apr-util separately from apache.
461
462* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
463- Updated to APR and APR-UTIL 2002.02.11.
464- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
465- Took out a (now non-existant) documentation file.
466- Moved SPEC file changelog to after all package definitions.
467 
468* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
469- Updated to neon-0.18.5.
470- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
471  apache-apr-utils, and apache-apr-utils-devel.
472- Updated apache to APR and APR-UTILS to 2002.02.03 version.
473
474* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
475- Now builds without the separate APR package as it is built into and
476  "exported" from apache-2.0.31-0.3.
477
478* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
479- Took out patches to install procedure now not required because of fixes
480  in rev 1130.
481
482* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
483- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
484  program was added.
485
486* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
487- Release M5-r340: Added the subversion-server package.
488
489* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
490- Release M5-r327: No longer need expat-lite. We can use the normal expat.
491
492* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
493- Release M3-r117: Initial Version.
494
Note: See TracBrowser for help on using the repository browser.