source: projects/specs/branches/6/s/strigi/strigi-vl.spec @ 1884

Revision 1884, 5.8 KB checked in by inagaki, 14 years ago (diff)

update: libgadu, libmsn, libotr, libqalculate, qzion, strigi

Line 
1Name:           strigi
2Summary:        A desktop search program for KDE
3Summary(ja):    KDE 用のデスクトップ検索プログラム
4Version:        0.7.2
5Release:        4%{?_dist_release}
6
7Group:          Applications/Productivity
8License:        LGPL
9URL:            http://strigi.sourceforge.net/
10
11Source0:        strigi-%{version}.tar.bz2
12Source1:        strigiclient.desktop
13Source2:        strigi-daemon.desktop
14Patch0:         strigi-0.6.2-multilib.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  cmake >= 2.4.5
18BuildRequires:  exiv2-devel >= 0.12
19BuildRequires:  clucene-core-devel
20BuildRequires:  qt4-devel
21BuildRequires:  dbus-devel
22BuildRequires:  expat-devel
23BuildRequires:  libxml2-devel
24BuildRequires:  bzip2-devel
25BuildRequires:  zlib-devel
26BuildRequires:  gamin-devel
27BuildRequires:  desktop-file-utils
28
29%description
30Strigi is a fast and light desktop search engine. It can handle a large range
31of file formats such as emails, office documents, media files, and file
32archives. It can index files that are embedded in other files. This means email
33attachments and files in zip files are searchable as if they were normal files
34on your harddisk.
35
36Strigi is normally run as a background daemon that can be accessed by many
37other programs at once. In addition to the daemon, Strigi comes with powerful
38replacements for the popular unix commands 'find' and 'grep'. These are called
39'deepfind' and 'deepgrep' and can search inside files just like the strigi
40daemon can.
41
42%package        libs
43Summary:        Strigi libraries
44Summary(ja):    Strigi 検索エンジンライブラリ
45Group:          System Environment/Libraries
46
47%description    libs
48Strigi search engine libraries
49
50%package        devel
51Summary:        Development files for the strigi desktop search engine
52Summary(ja):    Strigi デスクトップ検索エンジンの開発用ファイル
53Group:          Development/Libraries
54Requires:       %{name}-libs = %{version}-%{release}
55
56%description    devel
57Development files for the strigi desktop search engine
58
59
60%prep
61%setup -q
62%patch0 -p1 -b .multilibs
63
64%build
65mkdir build
66cd build
67export CFLAGS="%{optflags}"
68export CXXFLAGS="%{optflags}"
69export FFLAGS="%{optflags}"
70%ifarch x86_64 ppc64
71%define lib_suffix 64
72%else
73%define lib_suffix %{nil}
74%endif
75cmake \
76    -DCMAKE_INSTALL_PREFIX=%{_prefix} \
77    -DLIB_DESTINATION=%{_libdir} \
78    -DLIB_SUFFIX=%{lib_suffix} \
79    -DENABLE_EXPAT:BOOL=ON \
80    -DENABLE_INOTIFY:BOOL=ON \
81    -DENABLE_DBUS:BOOL=ON \
82    -DENABLE_FAM:BOOL=ON \
83    ..
84make VERBOSE=1 %{?_smp_mflags}
85
86%install
87rm -rf %{buildroot}
88cd build
89make DESTDIR=%{buildroot} install
90
91desktop-file-install \
92        --vendor="" \
93        --dir=%{buildroot}%{_datadir}/applications \
94        %{SOURCE1}
95
96# Add an autostart desktop file for the strigi daemon
97mkdir -p %{buildroot}%{_sysconfdir}/xdg/autostart
98cp -pr %{SOURCE2} %{buildroot}%{_sysconfdir}/xdg/autostart/
99
100find %{buildroot}%{_libdir} -type f -name "*.so*" -exec chmod 755 {} ';'
101
102%clean
103rm -rf %{buildroot}
104
105%post libs -p /sbin/ldconfig
106
107%postun libs -p /sbin/ldconfig
108
109%files
110%defattr(-,root,root,-)
111%doc AUTHORS COPYING ChangeLog README TODO
112%{_bindir}/*
113%{_datadir}/applications/strigiclient.desktop
114%{_sysconfdir}/xdg/autostart/strigi-daemon.desktop
115%{_datadir}/strigi
116%{_datadir}/dbus-1/services/*
117
118%files libs
119%defattr(-,root,root,-)
120%{_libdir}/*.so.*
121%{_libdir}/strigi
122%exclude %{_libdir}/strigi/*.cmake
123
124%files devel
125%defattr(-,root,root,-)
126%{_libdir}/*.so
127%{_libdir}/pkgconfig/libstream*.pc
128%{_libdir}/strigi/*.cmake
129%{_includedir}/strigi
130
131%changelog
132* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-4
133- rebuilt with rpm-4.8.1
134- added Japanese summaries
135
136* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-3
137- rebuilt with exiv2-0.19
138
139* Sun Apr 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 0.7.2-2
140- rebuilt to support strigiclient (x86_64)
141
142* Fri Feb 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-1
143- new upstream release
144- built with new toolchain
145
146* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.0-1
147- new upstream release
148
149* Mon Apr 13 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.4-2
150- rebuild with exiv2-0.18.1-1
151
152* Tue Feb 17 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.4-1
153- new upstream release
154- update Patch0 and delete Patch1
155
156* Wed Jan 21 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.11-2
157- add Patch0 and Patch1
158
159* Sun Dec  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.11-1
160- new upstream release
161
162* Tue Aug  5 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.10-1
163- new upstream release
164
165* Sun May  4 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.9-1
166- new upstream release
167
168* Wed Nov 21 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.7-0vl1
169- new upstream release
170
171* Thu Sep  6 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.5-0vl1
172- new upstream release
173
174* Thu Aug 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.4-0vl1
175- new upstream release
176
177* Thu Jun 28 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.1-5vl2
178- rebuild with qt4-4.3.0-0vl1
179
180* Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.1-5vl1
181- initial release for VineSeed
182
183* Wed May 16 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-5
184- Split out a strigi-libs subpackage as suggested in BZ#223586
185_ Include a strigidaemon autostart desktop file
186
187* Sat May 05 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-4
188- Add dbus-devel BR.
189
190* Sat May 05 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-3
191- Misc. fixes from package review
192
193* Fri May 04 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-2
194- Updates from reviews:
195-       Have the -devel subpackage require pkgconfig
196-       Add a versioned dependency on cmake and remove dbus-qt buildrequire
197
198* Fri May 04 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
199- New release
200
201* Wed May 02 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-3
202- Allow building on FC6
203
204* Thu Feb 22 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-2
205- Assorted fixed arising from reviews
206
207* Wed Jan 17 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-1
208- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.