source: projects/specs/branches/6/s/stone/stone-vl.spec @ 8079

Revision 8079, 4.3 KB checked in by iwamoto, 10 years ago (diff)

libtiff: seed libtiff security patch
stone: add R:gcc-cpp

Line 
1# ----------------------------------------------------------
2# (1) Data definition
3# ----------------------------------------------------------
4
5%define _mandir %{_datadir}/man
6%define _source_dir stone-2.3d-2.3.2.7
7
8Summary: The stone is TCP and UDP packet repeater.
9Summary(ja): TCP & UDP パケットリピータ stone
10Name: stone
11Version: 2.3e
12Release: 3%{_dist_release}
13URL: http://www.gcd.org/sengoku/stone/
14Source0: http://www.gcd.org/sengoku/stone/%{name}-%{version}.tar.gz
15# 'rfc1321.txt', 'global.h', 'md5.h', and 'md5c.c'
16Source1: stone-Source1.tar.gz
17Source2: stone.init
18Source3: stone.conf
19Source4: stone.1.gz
20Source5: stone.1.ja.gz
21# adapted for Vine Linux
22Patch0: stone-%{version}-Makefile.patch
23License: GPL
24Group: Applications/Internet
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26Prefix: %{_prefix}
27
28Requires: openssl, gcc-cpp
29BuildRequires: openssl-devel
30
31Packager: iwamoto
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36Stone is a TCP/IP packet repeater in the application layer.  It
37repeats TCP and UDP packets from inside to outside of a firewall, or
38from outside to inside.
39
40%description -l ja
41stone は、アプリケーションレベルの TCP & UDP パケットリピーターです。
42ファイアウォールの内から外へ、あるいは外から内へ、TCP パケットあるいは
43UDP パケットを中継します。
44
45
46
47# ----------------------------------------------------------
48# (2) Scripts
49# ----------------------------------------------------------
50
51# --- prep
52%prep
53rm -rf ${RPM_BUILD_ROOT}
54# %setup -a 1 -n ${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION}
55%setup -a 1 -n %{_source_dir}
56%patch0 -p0 -b .vine
57
58# --- build
59%build
60make linux-ssl SSL_FLAGS='-DUSE_SSL' SSL_LIBS='-lssl -lcrypto'
61
62
63# --- install
64%install
65install -d --mode=0755 ${RPM_BUILD_ROOT}%{_bindir}
66install -d --mode=0755 ${RPM_BUILD_ROOT}%{_mandir}/man1
67install -d --mode=0755 ${RPM_BUILD_ROOT}%{_mandir}/ja/man1
68install --mode=0755 stone ${RPM_BUILD_ROOT}%{_bindir}/stone
69install --mode=0644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_mandir}/man1/stone.1.gz
70install --mode=0644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_mandir}/ja/man1/stone.1.gz
71mkdir -p %{buildroot}/etc/rc.d/init.d
72install --mode=0755 %{SOURCE2} ${RPM_BUILD_ROOT}/etc/rc.d/init.d/stone
73install --mode=0644 %{SOURCE3} ${RPM_BUILD_ROOT}/etc/stone.conf
74
75# --- clean
76%clean
77rm -rf ${RPM_BUILD_ROOT}
78
79
80
81# ----------------------------------------------------------
82# (3) File Lists
83# ----------------------------------------------------------
84
85%files
86%defattr(-,root,root)
87%doc README.txt README.en.txt GPL.txt rfc1321.txt
88%{_bindir}/stone
89%{_mandir}/man1/stone.1*
90%{_mandir}/ja/man1/stone.1*
91%config /etc/rc.d/init.d/stone
92%config(noreplace) /etc/stone.conf
93
94
95
96# ----------------------------------------------------------
97# (4) Change Log
98# ----------------------------------------------------------
99
100%changelog
101* Mon Dec 30 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3e-3
102- add R:gcc-cpp (cpp is required to parse conf file)
103- add Distri/Vendor/Packager tags
104
105* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3e-2
106- rebuild with openssl-1.0.0c
107
108* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3e-1
109- new upstream release
110- new versioning policy and spec in UTF-8
111- update patch0 (_GNU_SOURCE macro is required glibc >= 2.8)
112
113* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3c-0vl4
114- rebuild with new environment
115
116* Wed Oct 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3c-0vl3
117- rebuilt for Vine Linux 4.0
118
119* Fri Oct  6 2006 Takeru INOUE <takeru.inoue@ieee.org>
120- 2.3c-0vl1
121- Updated
122
123* Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3b-0vl2
124- rebuilt for VineSeed (4.0)
125
126* Sun Jul 16 2006 Takeru INOUE <takeru.inoue@ieee.org>
127- 2.3b-0vl1
128- Build for Vine 3.2
129
130* Sat Jul  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl2
131- rebuilt for VineSeed
132- changed Group to Applications/Internet
133
134* Mon Mar 27 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
135- 2.3-0vl1
136- new upstream release
137- update Patch0
138- Build for Vine 3.2
139
140* Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
141- 2.1x-0vl0
142- updated
143- add /etc/rc.d/init.d/stone and /etc/stone.conf
144
145* Fri Dec  6 2002 Takashi `Muneharu' Sugimoto <muneharu@raug.net>
146- 2.1w-0vl1
147- change the file list
148* Thu Oct 31 2002 Takashi Sugimoto
149- 2.1w-0vl0
150- updated
151* Mon Aug 19 2002 Takashi Sugimoto
152- 2.1v-0vl0
153- updated
154* Wed Apr 10 2002 Takashi Sugimoto
155- 2.1r-0.1vl3
156
Note: See TracBrowser for help on using the repository browser.