source: projects/specs/branches/6/s/sqlite3-ruby/sqlite3-ruby-vl.spec @ 521

Revision 521, 1.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pkg_version 1.2.4
2%define pkg_release 1%{?_dist_release}
3
4Summary:       SQLite3/Ruby Interface
5Name:          sqlite3-ruby
6Version:       %{pkg_version}
7Release:       %{pkg_release}
8Source0:       %{name}-%{version}.tar.bz2
9License:       MIT
10Group:         Development/Languages
11URL:           http://rubyforge.org/projects/sqlite-ruby
12
13Requires:      ruby, sqlite3
14BuildRequires: ruby, sqlite3-devel
15BuildRoot:     %{_tmppath}/%{name}-%{version}-root
16
17Vendor:        Project Vine
18Distribution:  Vine Linux
19
20
21%description
22This module allows Ruby programs to interface with the SQLite3
23database engine (http://www.sqlite.org).  You must have the
24SQLite engine installed in order to build this module.
25
26Note that this module is NOT compatible with SQLite 2.x.
27
28%prep
29%setup -q
30
31%build
32ruby setup.rb config --site-ruby=%{rarchdir} --so-dir=%{rarchdir}
33ruby setup.rb setup
34
35%install
36%{__rm} -rf ${RPM_BUILD_ROOT}
37ruby setup.rb install --prefix=${RPM_BUILD_ROOT}
38
39%clean
40%{__rm} -rf ${RPM_BUILD_ROOT}
41
42
43%files
44%defattr(-,root,root)
45%doc CHANGELOG.rdoc README.rdoc LICENSE doc api
46%{rarchdir}/sqlite3_api.so
47%{rarchdir}/sqlite3.rb
48%{rarchdir}/sqlite3
49
50%changelog
51* Sat Mar  7 2009 IWAI, Masaharu <iwai@alib.jp> 0.8.4-1
52- initial release
Note: See TracBrowser for help on using the repository browser.