source: projects/specs/branches/6/s/sox/sox-vl.spec @ 9238

Revision 9238, 7.1 KB checked in by iwamoto, 9 years ago (diff)

sox: update to 14.4.1 with security fix patch

Line 
1##
2## disable gsm for Vine Linux
3%define nogsm 1
4## disable libmad
5%define nomad 1
6
7Summary:     A general purpose sound file conversion tool.
8Summary(ja): 汎用サウンドファイル変換ツール
9Name: sox
10Version: 14.4.1
11Release: 2%{?_dist_release}
12License: LGPL
13Group: Applications/Multimedia
14Source:  http://prdownloads.sourceforge.net/sox/sox-%{version}.tar.bz2
15Patch100: sox-14.4.1_CVE-2014-8145.patch
16
17URL: http://sox.sourceforge.net/
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires: alsa-lib-devel
21BuildRequires: pulseaudio-lib-devel
22BuildRequires: flac-devel
23BuildRequires: libvorbis-devel
24Build%{?nomad:Conflicts}%{!?nomad:Requires}: libmad-devel
25Build%{?nogsm:Conflicts}%{!?nogsm:Requires}: gsm-devel
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31SoX (Sound eXchange) is a sound file format converter for Linux, UNIX
32and DOS PCs. The 'Swiss Army knife of sound tools,' SoX can convert
33between many different digitized sound formats and perform simple
34sound manipulation functions, including sound effects.
35
36%description -l ja
37SoX (Sound eXchange) は Linux, UNIX, DOS PC 用サウンドファイルフォーマット
38変換ツールです.SoX は「サウンドツール界のスイスアーミーナイフ」で,
39様々なデジタルサウンドフォーマットを相互に変換したり,
40簡単なサウンドエフェクト等の処理も行うことが出来ます.
41
42
43%package -n  sox-devel
44Summary: The SoX sound file format converter libraries.
45Summary(ja): SoX サウンドファイル変換ライブラリ
46Group: Development/Libraries
47
48%description -n sox-devel
49This package contains the library needed for compiling applications
50which will use the SoX sound file format converter.
51
52Install sox-devel if you want to develop applications which will use
53SoX.
54
55%description -n sox-devel -l ja
56このパッケージには SoX サウンドファイルフォーマット変換ツールを
57利用するアプリケーションをコンパイルするのに必要なライブラリが
58収められています.
59
60SoX を利用するプログラムを開発する場合は sox-devel パッケージを
61インストールして下さい.
62
63
64%prep
65%setup -q
66%patch100 -p1 -b .CVE-2014-8145
67
68%build
69%configure \
70        --disable-static \
71        --includedir=%{_includedir}/sox \
72%{!?nogsm: --with-gsm}
73make
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78mkdir -p $RPM_BUILD_ROOT%{_bindir}
79mkdir -p $RPM_BUILD_ROOT%{_libdir}
80mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
81mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
82
83make install DESTDIR=$RPM_BUILD_ROOT
84
85echo "#!/bin/sh" > $RPM_BUILD_ROOT%{_bindir}/soxplay
86echo "" >> $RPM_BUILD_ROOT%{_bindir}/soxplay
87echo '%{_bindir}/sox $1 -t .au - > /dev/audio' >> $RPM_BUILD_ROOT%{_bindir}/soxplay
88chmod 755 $RPM_BUILD_ROOT%{_bindir}/soxplay
89
90strip $RPM_BUILD_ROOT%{_bindir}/sox
91
92ln -snf play $RPM_BUILD_ROOT%{_bindir}/rec
93rm -f $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
94ln -snf play.1 $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
95ln -snf sox.1 $RPM_BUILD_ROOT%{_mandir}/man1/soxmix.1
96
97mkdir -p $RPM_BUILD_ROOT%{_includedir}/sox
98install -m 644 src/*.h $RPM_BUILD_ROOT%{_includedir}/sox
99
100find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
101
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -p /sbin/ldconfig
107
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(-,root,root)
112%doc Changelog README TODO INSTALL
113%{_bindir}/*
114%{_libdir}/libsox.so.*
115%{_mandir}/man1/*
116
117%files -n sox-devel
118%defattr(-,root,root)
119%{_includedir}/*
120%{_libdir}/libsox.so
121%{_libdir}/pkgconfig/sox.pc
122%{_mandir}/man3/*
123%{_mandir}/man7/*
124
125
126%changelog
127* Thu Jan  8 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 14.4.1-2
128- add patch100 for fix CVE-2014-8145
129- add BR: flac-devel, libvorbis-devel
130- add Vendor/Distri tags
131
132* Sun Aug 03 2014 Yoji TOYODA <owa@bg.wakwak.com> 14.4.1-1
133- update to 14.4.1
134
135* Sat Nov 05 2011 Yoji TOYODA <owa@bg.wakwak.com> 14.3.2-1
136- new upstream release
137- add BuildRequires: pulseaudio-lib-devel
138
139* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 12.18.1-2
140- rebuilt with rpm-4.8.1-3
141
142* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 12.18.1-1vl5
143- applied new versioning policy, spec in utf-8
144
145* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 12.18.1-0vl3
146- fix installing play.1 man page (<BTS:510>)
147- add BuildRequires: alsa-lib-devel (alsa stuffs are now in main repo)
148
149* Mon Sep 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 12.18.1-0vl2
150- add "%%define nomad 1" to disable libmad dependency
151
152* Fri Aug 25 2006 NAKAMURA Kenta <kenta@vinelinux.org> 12.18.1-0vl1
153- new upstream release
154- dropped sox-vorberr.patch and sox-CAN-2004-0557.patch
155
156* Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl2
157- add patch for buffer overflow in wav code (CAN-2004-0557, #128158)
158- fixed %files section
159
160* Thu Jul  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl1
161- based on 12.17.3-12 from Rawhide
162- rebuild with new toolchains
163- to use License tag instead of Copyright
164- fix License (from distributable to LGPL)
165
166* Fri Jan 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
167- 12.17.1-1vl1
168- based on 12.17.1-1 from Rawhide
169- use better macros (%%{_bindir}, %%{_libdir}, %%{_includedir})
170- added Japanese summary and description
171- disable gsm stuff for Vine Linux
172
173* Tue Jan  2 2001 Bill Nottingham <notting@redhat.com>
174- re-enable gsm stuff
175- update to 12.17.1
176
177* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
178- rebuild because of broken fileutils
179
180* Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
181- update to 12.17
182- yank out gsm stuff
183
184* Mon Aug  7 2000 Bill Nottingham <notting@redhat.com>
185- fix playing of sounds on cards that don't support mono
186
187* Sat Aug  5 2000 Bill Nottingham <notting@redhat.com>
188- fix playing of sounds on cards that don't support 8-bit
189
190* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
191- automatic rebuild
192
193* Thu Feb 03 2000 Bill Nottingham <notting@redhat.com>
194- fix manpage link the Right Way(tm)
195
196* Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
197- Fix rec manpage link - now that man pages are compressed, it should point to
198  play.1.gz, not play.1
199
200* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
201- fix description
202
203* Tue Sep 28 1999 Bill Nottingham <notting@redhat.com>
204- Grrr. Arrrrgh. Fix link.
205
206* Fri Sep 24 1999 Bill Nottingham <notting@redhat.com>
207- add some more files to devel
208
209* Fri Sep 17 1999 Bill Nottingham <notting@redhat.com>
210- fix link
211
212* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
213- update to 12.16
214
215* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
216- auto rebuild in the new build environment (release 4)
217
218* Wed Jan 20 1999 Bill Nottingham <notting@redhat.com>
219- allow spaces in filenames for play/rec
220
221* Wed Dec  9 1998 Bill Nottingham <notting@redhat.com>
222- fix docs
223
224* Mon Nov 23 1998 Bill Nottingham <notting@redhat.com>
225- update to 12.15
226
227* Sat Oct 10 1998 Michael Maher <mike@redhat.com>
228- fixed broken spec file
229
230* Mon Jul 13 1998 Michael Maher <mike@redhat.com>
231- updated source from Chris Bagwell.
232
233* Tue Jun 23 1998 Michael Maher <mike@redhat.com>
234- made patch to fix the '-e' option. BUG 580
235- added buildroot
236
237* Fri May 08 1998 Prospector System <bugs@redhat.com>
238- translations modified for de, fr, tr
239
240* Thu Nov 06 1997 Erik Troan <ewt@redhat.com>
241- built against glibc
Note: See TracBrowser for help on using the repository browser.