source: projects/specs/branches/6/s/slocate/slocate-vl.spec @ 5393

Revision 5393, 8.6 KB checked in by Takemikaduchi, 12 years ago (diff)

fix BTS:1176

Line 
1Summary:     Finds files on a system via a central database.
2Summary(ja): システム上のファイルをデータベースを使って検索します
3Name: slocate
4Version: 3.1
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/System
8Source0: slocate-3.1.tar.gz
9Source1: slocate.cron
10Source2: updatedb.conf
11Source3: updatedb.conf.5
12Patch0: slocate-3.1-CVE-2007-0227.patch
13BuildRequires: gzip
14Requires(pre): shadow-utils
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16
17
18%description
19Slocate is a security-enhanced version of locate. Just like locate,
20slocate searches through a central database (which is updated nightly)
21for files which match a given pattern. Slocate allows you to quickly
22find files anywhere on your system.
23
24%description -l ja
25slocate は locate のセキュリティ対策バージョンです.locate と同様に,
26slocate は (毎晩自動更新される) データベースを元に,指定したパターンに
27マッチするファイルを検索します.slocate を使って,システム上のどこにある
28ファイルでも高速に探し出すことが出来ます.
29
30
31%prep
32%setup -q
33%patch0 -p1
34
35%build
36sed -i "s/local\///g" Makefile
37sed -i "s/local\///g" src/Makefile
38make
39
40%install
41rm -rf $RPM_BUILD_ROOT
42mkdir -p $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man{1,5}}
43mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
44mkdir -p $RPM_BUILD_ROOT/var/lib/slocate
45install src/slocate $RPM_BUILD_ROOT%{_bindir}
46ln -sf slocate $RPM_BUILD_ROOT%{_bindir}/locate
47ln -sf slocate $RPM_BUILD_ROOT%{_bindir}/updatedb
48install doc/slocate.1 $RPM_BUILD_ROOT%{_mandir}/man1/slocate.1
49install doc/updatedb.1 $RPM_BUILD_ROOT%{_mandir}/man1
50ln -sf slocate.1 $RPM_BUILD_ROOT%{_mandir}/man1/locate.1
51install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
52install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
53install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man5
54
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59
60%pre
61/usr/sbin/groupadd -g 21 -r -f slocate
62
63
64%preun
65if [ "$1" = "0" ]; then
66  /usr/sbin/groupdel slocate
67  rm -f /var/lib/slocate/slocate.db
68fi
69
70
71%files
72%defattr(-,root,root)
73%doc README LICENSE
74%attr(2755,root,slocate) %{_bindir}/slocate
75%attr(-,root,slocate) %{_bindir}/locate
76%attr(-,root,slocate) %{_bindir}/updatedb
77%attr(644,root,root) %{_mandir}/man[15]/*
78%attr(755,root,root) %{_sysconfdir}/cron.daily/slocate.cron
79%attr(644,root,root) %config %{_sysconfdir}/updatedb.conf
80%dir %attr(750,root,slocate) /var/lib/slocate
81
82
83%changelog
84* Wed Jan 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1-1
85- update to 3.1
86- remove old patches
87- add Patch0 (slocate-3.1-CVE-2007-0227.patch)
88
89* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 2.7-25vl6
90- build on current VineSeed
91
92* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.7-24vl5
93- applied new versioning policy, spec in utf-8
94
95* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.7-24vl2
96- changed Group to Applications/System
97
98* Tue Aug 02 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.7-24vl1
99- added Patches based on Fedora development
100  * Tue Jun 21 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-24
101  - Add missing OOM handling to lazy-mtab.patch
102  * Sun May  1 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-23
103  - Remove "nodev" filesystems from PRUNEFS
104  * Sat Apr 16 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-22
105  - Point the user at updatedb.conf if the database is too old
106  * Sat Apr 16 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-21
107  - Don't assume paths in /etc/mtab don't contain symlinks (#139950, #110575)
108  - Use %%config(noreplace) for /etc/updatedb.conf (#155014)
109  * Sun Apr  3 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-20
110  - Don't run updatedb by default
111  * Tue Mar 29 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-19
112  - Add updatedb.conf(5) (#135952)
113  * Mon Mar 28 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-18
114  - Drop unnecessary BuildRequires: autoconf
115  - Remove /mnt/floppy from PRUNEPATHS, it's in /media now
116  * Fri Mar 25 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-17
117  - Update to debian slocate_2.7-4 (#151710)
118  - Fix comment parsing in /etc/updatedb.conf (#135952)
119  - Exclude /var/spool/squid and /var/spool/cups (#150388)
120  - Remove 'export' lines from /etc/updatedb.conf to avoid the false impression
121    that the file is a shell script
122  * Fri Mar  4 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-16
123  - Fix crash when no filesystems are pruned
124  - Rebuild with gcc 4
125  * Tue Feb 16 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-15
126  - Fix slocate-2.7-fts.patch
127  - Automatically prune all nodev filesystems, remove those entries from
128    PRUNEFS (#123914)
129  * Tue Feb 15 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-14
130  - Process the filesystem type exclusion list when finding the mount points,
131    not only before starting the filesystem tree walk (#139950)
132  - Clean up the spec file (#135192, original patch by Robert Scheck)
133  * Wed Nov  3 2004 Thomas Woerner <twoerner@redhat.com> 2.7-13
134  - added /media to PRUNEPATHS
135  * Wed Oct 20 2004 Thomas Woerner <twoerner@redhat.com> 2.7-12
136  - added /mnt/floppy to PRUNEPATHS
137  * Fri May 21 2004 Bill Nottingham <notting@redhat.com> 2.7-10
138  - exclude cifs (#122499)
139  * Fri Apr 16 2004 Karsten Hopp <karsten@redhat.de> 2.7-9
140  - exlude usbdevfs (#113816)
141  * Mon Mar 29 2004 Karsten Hopp <karsten@redhat.de> 2.7-8
142  - use included sl_fts.h, fix handling of large files (#105950)
143  - use one single file to configure updatedb (#112964)
144
145* Sun Feb 08 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.7-5vl1
146- updated 2.7 and added patch6 from Fedora 2.7-5
147  * Wed Jan 21 2004 Mark Cox <mjc@redhat.com>
148  - drop privs for non slocate gid databases (CAN-2003-0848)
149
150* Mon Oct 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6-10vl1
151- rebuild with new toolchains
152- s/Copyright/License/
153- based on Redhat Rawhide 2.6-10
154
155* Sat Jan 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.5-1vl3
156- fixed spec typo to install gzipped man page correctly
157
158* Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
159- 2.5-1vl2
160- place /var/lib in absolute without using %%_localstatedir macros
161
162* Sun Jan 14 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 2.5-1vl1
163- based on 2.5-1 from Rawhide
164- rebuilt for Vine Linux
165- use better macros
166- added Japanese summary and description
167
168* Fri Jan  6 2001 Bill Nottingham <notting@redhat.com>
169- update to 2.5
170
171* Mon Dec 18 2000 Bill Nottingham <notting@redhat.com>
172- update to the mysterious 2.4 release
173
174* Mon Nov 27 2000 Bill Nottingham <notting@redhat.com>
175- update to 2.3; fixes database reading problem
176
177* Wed Aug 23 2000 Than Ngo <than@redhat.com>
178- add a default updatedb.conf (Bug #13475)
179
180* Wed Aug 23 2000 Jakub Jelinek <jakub@redhat.com>
181- fix build with glibc defining DT_WHT but not defining S_IFWHT.
182
183* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
184- don't print a message telling how to rebuild the database if we're
185  rebuilding the database
186
187* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
188- automatic rebuild
189
190* Thu Jun 22 2000 Bill Nottingham <notting@redhat.com>
191- update to 2.2
192- fix it to not have debugging (oops)
193
194* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
195- rebuild, FHS manpages, etc.
196
197* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
198- simplify preun
199
200* Fri Mar 17 2000 Bill Nottingham <notting@redhat.com>
201- fix a segfault
202
203* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
204- handle compressed man pages
205
206* Tue Oct 21 1999 Bill Nottingham <notting@redhat.com>
207- update to 2.1
208
209* Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
210- fix a bug that was causing segfaults.
211
212* Mon Sep 20 1999 Bill Nottingham <notting@redhat.com>
213- remove group database on final uninstall
214
215* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
216- add a note about creating the database if opening of it fails.
217
218* Tue Jul  6 1999 Bill Nottingham <notting@redhat.com>
219- update to 2.0
220- use new -f (filesystem type) option to simplify cron script
221- link updatedb back to slocate to allow parsing of updatedb.conf
222  config files
223
224* Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
225- don't exclude VFAT partitions
226- add some docs
227
228* Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
229- update to 1.6.
230- use /etc/cron.daily as /usr/bin/updatedb to more perfectly imitate the
231  findutils updatedb.
232- exclude vfat partitions too (#3164).
233
234* Tue May 11 1999 Bill Nottingham <notting@redhat.com>
235- update to 1.5
236- make database dir 0750
237
238* Mon Apr 19 1999 Bill Nottingham <notting@redhat.com>
239- fix updatedb cron script
240
241* Mon Apr 12 1999 Bill Nottingham <notting@redhat.com>
242- add updatedb as a link to slocate
243- add an updatedb man page
244
245* Fri Mar 26 1999 Michael Maher <mike@redhat.com>
246- added man page
247
248* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
249- auto rebuild in the new build environment (release 3)
250
251* Mon Feb 15 1999 Bill Nottingham <notting@redhat.com>
252- %post groupadd changed to %pre
Note: See TracBrowser for help on using the repository browser.