source: projects/specs/branches/6/s/slang1/slang1-vl.spec @ 521

Revision 521, 6.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: shared library for C like extension language
3Summary(ja): C ¤È¤è¤¯»÷¤¿³ÈÄ¥¸À¸ì¥é¥¤¥Ö¥é¥ê
4Name: slang1
5%define ever 1.4.9
6%define jver jp0
7Version: %{ever}
8Release: 1%{?_dist_release}
9License: GPL
10Group: System Environment/Libraries
11Source: ftp://space.mit.edu/pub/davis/slang/v1.4/slang-%{ever}.tar.bz2
12Patch0: slang-%{ever}%{jver}.patch
13Patch10: slang-1.4.9-nointerlibc.patch
14Patch20: slang-1.4.9-fix.patch
15Patch30: slang-1.4.9-buildfix.patch
16URL: http://space.mit.edu/~davis/slang.html
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19Provides: slang = %{version}-%{release}
20Obsoletes: slang < %{version}-%{release}
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
25
26%description
27S-lang (pronounced ``sssslang'') is a powerful stack based interpreter
28that supports a C-like syntax.  It has been designed from the beginning
29to be easily embedded into a program to make it extensible. Slang also
30provides a way to quickly develop and debug the application embedding it
31in a safe and efficient manner.  Since slang resembles C, it is easy to
32recode slang procedures in C if the need arises.
33
34This is Japanese visible version.
35This package is patched for linux console and kon.
36
37%description -l ja
38S-lang (``sssslang'' ¤Èȯ²»¤·¤Þ¤¹)¤Ï¡¢C¤È¤è¤¯»÷¤¿Ê¸Ë¡¤Î¥¹¥¿¥Ã¥¯¥Ù¡¼¥¹
39¡¦¥¤¥ó¥¿¥×¥ê¥¿¤Ç¤¹¡£³«È¯½é´ü¤«¤é¡¢¥×¥í¥°¥é¥à¤ËÍưפËÁȤ߹þ¤á¤ë¤è¤¦¤Ë
40¥Ç¥¶¥¤¥ó¤µ¤ì¤Æ¤­¤Þ¤·¤¿¡£¤Þ¤¿¡¢S-lang ¤òÍѤ¤¤ë¤È¡¢¥¢¥×¥ê¥±¡¼¥·¥ç¥ó¤ò°Â
41Á´¤Ë¤«¤Ä¸úΨÎɤ¯¥Ç¥Ð¥Ã¥°¡¦³«È¯¤Ç¤­¤Þ¤¹¡£S-lang ¤Ï C ¤È»÷¤Æ¤¤¤Þ¤¹¤«¤é¡¢
42ɬÍפˤʤì¤Ð¡¢S-lang ¤Î¼ê³¤­¤òC¤Ë´Êñ¤ËÊÑ´¹¤¹¤ë¤³¤È¤â¤Ç¤­¤Þ¤¹¡£
43
44
45## to build compat32 for x86_64 architecture support
46%package -n compat32-%{name}
47Summary: shared library for C like extension language
48Group: System Environment/Libraries
49%description -n compat32-%{name}
50S-lang (pronounced ``sssslang'') is a powerful stack based interpreter
51that supports a C-like syntax.  It has been designed from the beginning
52to be easily embedded into a program to make it extensible. Slang also
53provides a way to quickly develop and debug the application embedding it
54in a safe and efficient manner.  Since slang resembles C, it is easy to
55recode slang procedures in C if the need arises.
56
57This is Japanese visible version.
58This package is patched for linux console and kon.
59
60
61
62%prep
63%setup -q -n slang-%{ever}
64%patch0 -p1 -b .jp
65%patch10 -p1 -b .nointerlibc
66%patch20 -p1 -b .fixed-tick
67%patch30 -p1 -b .buildfix
68
69%build
70%if %{build_compat32}
71export CC='gcc -m32'
72%endif
73#CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=-s ./configure --prefix=%{_prefix}
74CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=-s %configure
75make all elf "ELF_CFLAGS=$RPM_OPT_FLAGS -fPIC"
76( cd src
77  make untic "ELF_CFLAGS=$RPM_OPT_FLAGS -fPIC"
78)
79
80%install
81rm -rf $RPM_BUILD_ROOT
82mkdir -p $RPM_BUILD_ROOT%{_bindir}
83
84make DESTDIR=$RPM_BUILD_ROOT \
85     install_include_dir=%{_includedir}/slang \
86     install install-elf
87install -s -m 755 src/objs/untic $RPM_BUILD_ROOT%{_bindir}
88chmod 755 $RPM_BUILD_ROOT%{_libdir}/libslang.so.%{ever}
89ln -sf libslang.so.%{ever} $RPM_BUILD_ROOT%{_libdir}/libslang.so.1
90
91# remove unneeded files
92rm -rf $RPM_BUILD_ROOT%{_includedir}
93rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,so}
94rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
95rm -rf $RPM_BUILD_ROOT%{_bindir}
96
97%post -p /sbin/ldconfig
98
99%postun -p /sbin/ldconfig
100
101%if %{build_compat32}
102%post -n compat32-%{name} -p /sbin/ldconfig
103%postun -n compat32-%{name} -p /sbin/ldconfig
104%endif
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%if !%{build_compat32}
110%files
111%defattr(- , root, root)
112%doc README COPY* UPGRADE.txt NEWS INSTALL* changes.txt
113%doc doc/ slang-j.doc
114%{_libdir}/libslang.so.*
115%endif
116
117%if %{build_compat32}
118%files -n compat32-%{name}
119%defattr(- , root, root)
120%{_libdir}/libslang.so.*
121%endif
122
123%changelog
124* Sun May 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-1
125- rename to slang1
126  - build as compat package
127
128* Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-0vl1
129- update to slang-1.4.9
130- rediffed slang_jp patch
131
132* Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 1.4.4-0vl5
133- change ./configure to %%configure
134- uncommented a script to make symbolic link of %%{_libdir}/libslang.so.1
135- added compat32-* packages for x86_64 architecture support
136
137* Fri Jul 18 2003 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl4
138- rebuild with new toolchains
139- s/Copyright/License/
140
141* Sat Feb  9 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl3
142- bug fixed canna input for jed
143- change patch: bug fixed slsng-console.patch
144
145* Mon Jan 21 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl2
146- rebuild with glibc-2.2.4
147
148* Wed Jun 27 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl1
149- update to 1.4.4
150- use jp0 patch
151- use better macros
152- use Release No for Vine Linux
153
154* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
155[1.2.2_jp-7]
156- Japanese summary and description
157- change group
158
159* Mon Sep 12 1999 Norihito Ohmori <ohmori@flatout.org>
160- rebuild for new environment.
161
162* Fri Jul 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
163[1.2.2_jp-5]
164- Updated to 1.2.2j056
165
166* Sun Feb 21 1999 MATSUMOTO Shoji <vine@flatout.org>
167[1.2.2_jp-4]
168- fix box bug with KANJI
169
170* Tue Feb 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
171[1.2.2_jp-2]
172- Updated to 1.2.2j054
173
174* Mon Dec 21 1998 MATSUMOTO Shoji <shom@flatout.org>
175[1.2.2j052-2]
176- patch for linux console and kon
177- bug fix for no-kanji version
178- separate devel
179
180* Sat Jul  4 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
181[1.2.1j-1]
182- Updated to 1.2.2 (j052)
183
184* Fri Jun  5 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
185[1.2.1j-1]
186- japanize patch added
187
188* Mon Apr 13 1998 Manoj Kasichainula <manojk@io.com>
189[1.2.1-1]
190- Updated to 1.2.1
191
192* Sun Apr 12 1998 Manoj Kasichainula <manojk@io.com>
193[1.2.0-1]
194- Updated to 1.2.0, the first 1.x non-beta version
195
196* Wed Feb 11 1998 Manoj Kasichainula <manojk@io.com>
197[1.0.3-1]
198- Updated to 1.0.3
199- Minor fixes
200
201* Tue Feb 3 1998 Manoj Kasichainula <manojk@io.com>
202
203- Earlier changes were lost, because of misplacement of RPM:
204 - BuildRoot
205 - RPM_OPT_FLAGS
206 - %clean section
207 - other minor spec file changes
208- Should be buildable by non-root now
209- Included untic, a very cool terminfo interpreter (this probably out to be
210  split out eventually)
211- Added bug fix from JED
212
213* Thu Jan 29 1998 Bill Nottingham <wen1@cec.wustl.edu>
214
215- upgraded to 1.0.2
216
217* Wed Jan 28 1998 Bill Nottingham <wen1@cec.wustl.edu>
218
219- Apparently so, Donnie. :)
220- upgraded to 1.0.0beta
221
222* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
223
224- spec file cleanups
225
226* Mon Sep 1 1997 Donnie Barnes <djb@redhat.com>
227
228- upgraded to 0.99.38 (will it EVER go 1.0???)
229- all patches removed (all appear to be in this version)
230
231* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
232
233- built against glibc
Note: See TracBrowser for help on using the repository browser.