source: projects/specs/branches/6/s/slang/slang-vl.spec @ 3069

Revision 3069, 9.1 KB checked in by inagaki, 13 years ago (diff)

update: aalib, cyrus-sasl, cyrus-imapd, pcre, slang

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: The shared library for the S-Lang extension language
4Summary(ja): S-Lang 拡張言語ライブラリ
5Name: slang
6Version: 2.1.4
7Release: 4%{?_dist_release}
8
9License: GPLv2+
10Group: System Environment/Libraries
11URL: http://www.jedsoft.org/slang/
12
13Source: ftp://space.mit.edu/pub/davis/slang/v2.1/%{name}-%{version}.tar.bz2
14Patch1: slang-2.1.4-makefile.patch
15Patch2: slang-nointerlibc2.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: libpng-devel
19BuildRequires: oniguruma-devel
20BuildRequires: pcre-devel
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
25
26%description
27S-lang (pronounced `sssslang'') is a powerful stack based interpreter
28that supports a C-like syntax.  It has been designed from the beginning
29to be easily embedded into a program to make it extensible. Slang also
30provides a way to quickly develop and debug the application embedding it
31in a safe and efficient manner.  Since slang resembles C, it is easy to
32recode slang procedures in C if the need arises.
33
34%description -l ja
35S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
36・インタプリタです。開発初期から、プログラムに容易に組み込めるように
37デザインされてきました。また、S-lang を用いると、アプリケーションを安
38全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
39必要になれば、S-lang の手続きをCに簡単に変換することもできます。
40
41%package slsh
42Summary: Interpreter for S-Lang scripts
43Summary(ja): S-Lang スクリプトインタプリタ
44Group: Development/Languages
45Requires: %{name} = %{version}-%{release}
46
47%description slsh
48slsh (slang-shell) is a program for interpreting S-Lang scripts.
49It supports dynamic loading of S-Lang modules and includes a readline
50interface for interactive use.
51
52This package also includes S-Lang modules that are distributed with
53the S-Lang distribution.
54
55%package devel
56Summary: Development package for %{name}
57Summary(ja): %{name} の開発パッケージ
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60
61%description devel
62This package contains files which you'll need if you want to
63develop S-Lang based applications.  Documentation which may help
64you write S-Lang based applications is also included.
65
66Install the slang-devel package if you want to develop applications
67based on the S-Lang extension language.
68#'
69
70%description devel -l ja
71このパッケージには S-lang を用いたアプリケーションの開発に必要な静的
72ライブラリとヘッダファイルが含まれています。S-lang を記述する助けに
73なるようなドキュメントも含まれています。
74
75もし S-lang を使ったアプリケーションを開発するなら、このパッケージを
76インストールしてください。
77
78## to build compat32 for x86_64 architecture support
79%package -n compat32-%{name}
80Summary: The shared library for the S-Lang extension language
81Summary(ja): S-Lang 拡張言語ライブラリ
82Group: System Environment/Libraries
83Requires: %{name} = %{version}-%{release}
84
85%description -n compat32-%{name}
86S-lang (pronounced `sssslang'') is a powerful stack based interpreter
87that supports a C-like syntax.  It has been designed from the beginning
88to be easily embedded into a program to make it extensible. Slang also
89provides a way to quickly develop and debug the application embedding it
90in a safe and efficient manner.  Since slang resembles C, it is easy to
91recode slang procedures in C if the need arises.
92
93%description -n compat32-%{name} -l ja
94S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
95・インタプリタです。開発初期から、プログラムに容易に組み込めるように
96デザインされてきました。また、S-lang を用いると、アプリケーションを安
97全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
98必要になれば、S-lang の手続きをCに簡単に変換することもできます。
99
100%package -n compat32-%{name}-devel
101Summary: Development package for %{name}
102Summary(ja): %{name} の開発パッケージ
103Group: Development/Libraries
104Requires: compat32-%{name} = %{version}-%{release}
105Requires: %{name}-devel = %{version}-%{release}
106
107%description -n compat32-%{name}-devel
108This package contains files which you'll need if you want to
109develop S-Lang based applications.  Documentation which may help
110you write S-Lang based applications is also included.
111
112Install the slang-devel package if you want to develop applications
113based on the S-Lang extension language.
114#'
115
116%prep
117%setup -q
118%patch1 -p1 -b .makefile
119%patch2 -p1 -b .nointerlibc2
120
121%build
122%configure --includedir=%{_includedir}/slang
123make %{?_smp_mflags} install_doc_dir=%{_docdir}/%{name}-%{version}
124
125%install
126rm -rf ${RPM_BUILD_ROOT}
127
128make install-all INSTALL="install -p" DESTDIR=$RPM_BUILD_ROOT
129rm -rf $RPM_BUILD_ROOT%{_docdir}/{slang,slsh}
130
131%clean
132rm -rf ${RPM_BUILD_ROOT}
133
134%post -p /sbin/ldconfig
135
136%postun -p /sbin/ldconfig
137
138%post -n compat32-%{name} -p /sbin/ldconfig
139
140%postun -n compat32-%{name} -p /sbin/ldconfig
141
142
143%files
144%defattr(-,root,root)
145%doc COPYING doc/README changes.txt doc/*/slang*.txt doc/*.txt
146%{_libdir}/libslang*.so.*
147
148%files slsh
149%defattr(-,root,root)
150%doc slsh/doc/html/slsh*.html
151%config(noreplace) %{_sysconfdir}/slsh.rc
152%{_bindir}/slsh
153%{_libdir}/slang
154%{_mandir}/man1/slsh.1*
155%{_datadir}/slsh
156
157%files devel
158%defattr(-,root,root)
159%doc doc/*/cslang*.txt doc/*/cref.txt
160%{_libdir}/libslang*.so
161%{_libdir}/libslang*.a
162%{_includedir}/slang
163
164%if %{build_compat32}
165%files -n compat32-%{name}
166%defattr(- , root, root)
167%{_libdir}/libslang.so.*
168
169%files -n compat32-%{name}-devel
170%defattr(- , root, root)
171%{_libdir}/libslang.a
172%{_libdir}/libslang.so
173%endif
174
175
176%changelog
177* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.4-4
178- rebuilt with new toolchains
179
180* Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.4-3
181- removed unneccesary %if !%{build_compat32} case condition
182
183* Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.4-2
184- rebuilt with oniguruma-5.9.1
185
186* Wed Mar 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-1
187- new upstream release
188
189* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-1
190- new upstream release
191- drop slang_jp patch
192
193* Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-0vl1
194- update to slang-1.4.9
195- rediffed slang_jp patch
196
197* Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 1.4.4-0vl5
198- change ./configure to %%configure
199- uncommented a script to make symbolic link of %%{_libdir}/libslang.so.1
200- added compat32-* packages for x86_64 architecture support
201
202* Fri Jul 18 2003 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl4
203- rebuild with new toolchains
204- s/Copyright/License/
205
206* Sat Feb  9 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl3
207- bug fixed canna input for jed
208- change patch: bug fixed slsng-console.patch
209
210* Mon Jan 21 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl2
211- rebuild with glibc-2.2.4
212
213* Wed Jun 27 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl1
214- update to 1.4.4
215- use jp0 patch
216- use better macros
217- use Release No for Vine Linux
218
219* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
220[1.2.2_jp-7]
221- Japanese summary and description
222- change group
223
224* Mon Sep 12 1999 Norihito Ohmori <ohmori@flatout.org>
225- rebuild for new environment.
226
227* Fri Jul 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
228[1.2.2_jp-5]
229- Updated to 1.2.2j056
230
231* Sun Feb 21 1999 MATSUMOTO Shoji <vine@flatout.org>
232[1.2.2_jp-4]
233- fix box bug with KANJI
234
235* Tue Feb 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
236[1.2.2_jp-2]
237- Updated to 1.2.2j054
238
239* Mon Dec 21 1998 MATSUMOTO Shoji <shom@flatout.org>
240[1.2.2j052-2]
241- patch for linux console and kon
242- bug fix for no-kanji version
243- separate devel
244
245* Sat Jul  4 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
246[1.2.1j-1]
247- Updated to 1.2.2 (j052)
248
249* Fri Jun  5 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
250[1.2.1j-1]
251- japanize patch added
252
253* Mon Apr 13 1998 Manoj Kasichainula <manojk@io.com>
254[1.2.1-1]
255- Updated to 1.2.1
256
257* Sun Apr 12 1998 Manoj Kasichainula <manojk@io.com>
258[1.2.0-1]
259- Updated to 1.2.0, the first 1.x non-beta version
260
261* Wed Feb 11 1998 Manoj Kasichainula <manojk@io.com>
262[1.0.3-1]
263- Updated to 1.0.3
264- Minor fixes
265
266* Tue Feb 3 1998 Manoj Kasichainula <manojk@io.com>
267
268- Earlier changes were lost, because of misplacement of RPM:
269 - BuildRoot
270 - RPM_OPT_FLAGS
271 - %clean section
272 - other minor spec file changes
273- Should be buildable by non-root now
274- Included untic, a very cool terminfo interpreter (this probably out to be
275  split out eventually)
276- Added bug fix from JED
277
278* Thu Jan 29 1998 Bill Nottingham <wen1@cec.wustl.edu>
279
280- upgraded to 1.0.2
281
282* Wed Jan 28 1998 Bill Nottingham <wen1@cec.wustl.edu>
283
284- Apparently so, Donnie. :)
285- upgraded to 1.0.0beta
286
287* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
288
289- spec file cleanups
290
291* Mon Sep 1 1997 Donnie Barnes <djb@redhat.com>
292
293- upgraded to 0.99.38 (will it EVER go 1.0???)
294- all patches removed (all appear to be in this version)
295
296* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
297
298- built against glibc
Note: See TracBrowser for help on using the repository browser.