source: projects/specs/branches/6/s/sed/sed-vl.spec @ 3494

Revision 3494, 6.4 KB checked in by inagaki, 13 years ago (diff)

update: ed, sed

Line 
1%ifos linux
2%define _bindir /bin
3%endif
4
5Summary: A GNU stream text editor.
6Summary(ja): GNU ストリームテキストエディタ
7Name: sed
8Version: 4.2.1
9Release: 3%{?_dist_release}
10
11License: GPLv2+
12Group: Applications/Text
13URL: http://www.gnu.org/software/sed/
14
15Source0: ftp://ftp.gnu.org/pub/gnu/sed/sed-%{version}.tar.bz2
16Patch0: sed-4.2.1-dummyparam.diff
17Patch1: sed-4.2.1-multibyte.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: glibc-devel
21BuildRequires: libacl-devel
22Requires(post): /sbin/install-info
23Requires(preun): /sbin/install-info
24
25%description
26The sed (Stream EDitor) editor is a stream or batch (non-interactive)
27editor.  Sed takes text as input, performs an operation or set of
28operations on the text and outputs the modified text.  The operations
29that sed performs (substitutions, deletions, insertions, etc.) can be
30specified in a script file or from the command line.
31
32%description -l ja
33sed (Stream Editor) エディタはストリームまたはバッチ(非インタラクティブ)
34エディタです。sed は入力としてテキストを用い、テキストの操作または
35操作のセットをテキストとに対して行い、修正されたテキストを出力します。
36sed が行う操作 (置換、削除、挿入、その他) はスクリプトファイルか、
37コマンドラインから指定されます。
38
39%prep
40%setup -q
41%patch0 -p1
42%patch1 -p1 -b .mb
43
44%build
45export LANG=C
46%configure --without-included-regex
47make %{_smp_mflags}
48
49echo ====================TESTING=========================
50make check
51echo ====================TESTING END=====================
52
53%install
54rm -rf $RPM_BUILD_ROOT
55
56%makeinstall
57rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
58
59%find_lang %{name}
60
61%post
62/sbin/install-info %{_infodir}/sed.info.gz %{_infodir}/dir
63
64%preun
65if [ $1 = 0 ]; then
66   /sbin/install-info --delete %{_infodir}/sed.info.gz %{_infodir}/dir
67fi
68
69%clean
70rm -rf ${RPM_BUILD_ROOT}
71
72%files -f %{name}.lang
73%defattr(-,root,root)
74%doc BUGS NEWS THANKS README AUTHORS
75%{_bindir}/sed
76%{_infodir}/*.info*
77%{_mandir}/man*/*
78
79%changelog
80* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-3
81- rebuilt with current VineSeed
82
83* Mon Dec 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-2
84- added Patch1 from Debian (#551075)
85  Apply patch from WANG Yunfeng to treat incomplete multibyte
86  sequences as a single-byte character.
87
88* Mon Nov 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-1
89- new upstream release, dropped Patch1 and 2
90- added Patch0 from Fedora
91  * Mon Jun 29 2009  Jiri Moskovcak <jmoskovc@redhat.com>
92  - added patch to maintain backwards compatibility for scripts using -c/--copy
93  - Resolves: #502934
94
95* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.5-3
96- rebuilt against current toolchain
97- spec in UTF-8
98
99* Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-2vl5
100- dropped Patch0
101
102* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-1vl5
103- added Patch0-2 from Fedora
104  * Mon Sep  4 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-5
105  - Fix handling of relative symlinks (#205122)
106  * Wed Aug  3 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-4
107  - remove superfluous multibyte processing in str_append for UTF-8
108    encoding (thanks Paolo Bonzini, #177246)
109  * Thu Jun 29 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-2
110  - #185374:
111    - Follow symlinks before rename (avoid symlink overwrite)
112    - Add -c flag for copy instead of rename (avoid ownership change)
113
114* Sat Aug 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-0vl1
115- new upstream release
116- run 'make check' on non-English locale
117
118* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-0vl2
119- s/Copyright/License/
120- rebuilt for x86_64 architecture support
121
122* Wed Oct 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.2-0vl1
123- new upstream release
124
125* Thu Jun 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-0vl1
126- new upstream release
127- remove obsolete patch
128
129* Sat Apr 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.8-4vl2
130- rebuilt for Vine
131  * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 4.0.8-3
132  - if not -n, print current buffer after N command on the last line
133    unless POSIXLY_CORRECT (#112952)
134  - adjust XFAIL_TESTS for the improved glibc regex implementation
135    (#112642)
136
137  * Fri Nov 14 2003 Jakub Jelinek <jakub@redhat.com> 4.0.8-2
138  - enable --without-included-regex again
139  - use fastmap for regex searching
140
141  * Sat Oct 25 2003 Florian La Roche <Florian.LaRoche@redhat.de>
142  - update to 4.0.8
143  - simplify specfile
144  - disable --without-included-regex to pass the testsuite
145
146  * Sat Apr 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
147  - update to 4.0.7
148  - use "--without-included-regex"
149  - do not gzip info pages in spec file, "TODO" is not present anymore
150
151  * Thu Jan 23 2003 Jakub Jelinek <jakub@redhat.com> 4.0.5-1
152  - update to 4.0.5
153
154  * Tue Oct 22 2002 Jakub Jelinek <jakub@redhat.com>
155  - rebuilt to fix x86-64 miscompilation
156  - run make check in %%build
157
158  * Fri Apr  5 2002 Jakub Jelinek <jakub@redhat.com>
159  - Remove stale URLs from documentation (#62519)
160
161  * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
162  - Bump release + rebuild.
163
164  * Mon Dec 18 2000 Yukihiro Nakai <ynakai@redhat.com>
165  - Update to 2000.11.28 patch
166  - Rebuild for 7.1 tree
167
168  * Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
169  - FHS packaging.
170
171  * Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
172  - compress man pages.
173
174  * Tue Jan 18 2000 Jakub Jelinek <jakub@redhat.com>
175  - rebuild with glibc 2.1.3 to fix an mmap64 bug in sys/mman.h
176
177* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.02_mb1.09-0vl1
178- mb patch updated to 1.09
179
180* Tue May 29 2001 <sagami@vinelinux.org>
181- 3.02_mb1.08-1vl2: use better macros
182
183* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
184- 3.02_mb1.08-1vl1
185- modified %files section to handle compressed man page(s)
186
187* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
188- auto rebuild in the new build environment (release 4)
189
190* Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
191- update to 3.02
192
193* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
194- update to 3.01
195
196* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
197- translations modified for de, fr, tr
198
199* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
200- removed references to the -g option from the man page that we add
201
202* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
203- spec file cleanups
204- added BuildRoot
205
206* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
207- built against glibc
Note: See TracBrowser for help on using the repository browser.