source: projects/specs/branches/6/s/seahorse-plugins/seahorse-plugins-vl.spec @ 3505

Revision 3505, 8.7 KB checked in by yasumichi, 13 years ago (diff)

rpm-4.8.1 でリビルド。
ただし、nautilus がリポジトリに反映された後、再ビルドする。

Line 
1# Basic Information
2Name:           seahorse-plugins
3Version:        2.30.1
4Release:        2%{?_dist_release}
5License:        GPL-2
6Group:          Applications/Accessories
7Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.30/%{name}-%{version}.tar.bz2
8BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9
10Vendor:         Project Vine
11Distribution:   Vine Linux
12Packager:       yasumichi
13
14Summary:        plugins and utilities for encryption in GNOME
15Summary(ja):    GNOMEにおける暗号化のためのプラグインとユーティリティ
16
17# Dependency
18Requires:       GConf2
19Requires:       glib2
20Requires:       gtk2 >= 2.18.0
21Requires:       gnupg
22Requires:       gpgme
23Requires:       libgnome-keyring
24Requires:       dbus-glib
25Requires:       libnotify
26Requires:       evolution-data-server
27Requires(post,postun):  shared-mime-info
28
29BuildRequires:  gnome-doc-utils
30BuildRequires:  pkgconfig
31BuildRequires:  GConf2-devel
32BuildRequires:  glib2-devel
33BuildRequires:  gtk2-devel >= 2.18.0
34BuildRequires:  gnupg
35BuildRequires:  gpgme-devel
36BuildRequires:  libgnome-keyring-devel
37BuildRequires:  dbus-glib-devel
38BuildRequires:  seahorse-devel
39BuildRequires:  libnotify-devel
40BuildRequires:  evolution-data-server
41
42%description
43Seahorse is integrated into the GNOME Desktop Environment and allows users to
44perform operations from their regular applications, like nautilus or gedit.
45The effective use of this package, please install the following packages.
46
47* seahorse-plugins-applet
48* seahorse-plugins-gedit
49* seahorse-plugins-nautilus
50
51%description -l ja
52SeahorseがGNOMEデスクトップ環境に統合され、Nautilusやgeditといったユーザが
53よく使うアプリケーションから操作を実行することができます。
54このパッケージの有効利用には、以下のパッケージをインストールしてください。
55
56* seahorse-plugins-applet
57* seahorse-plugins-gedit
58* seahorse-plugins-nautilus
59
60#
61# sub package: applet
62#
63%package applet
64Summary:        Applet for GnomePanel  to encrypt/decrypt/sign text easily
65Summary(ja):    テキストを簡単に暗号化/復号化/署名するためのGNOMEパネルアプレット
66Group:          Applications/Accessories
67Requires:       %{name} = %{version}-%{release}
68Requires:       libbonoboui
69Requires:       gnome-panel-libs
70BuildRequires:  libbonoboui-devel
71BuildRequires:  gnome-panel-devel
72
73%description applet
74Encryption Applet performs the various encryption operations using standard
75OpenPGP methods. You will need to have already created an OpenPGP key with
76Encryption Key Manager and imported the public keys of those you want to
77encrypt to or verify signatures of.
78
79%description applet -l ja
80暗号化アプレットは、標準的なOpenPGP手法を使って様々な暗号化の操作を行えます。
81あなたは暗号鍵マネージャによってOpenPGP鍵を既に作成し、暗号化や署名の検証を
82行いたい相手の公開鍵をインポートしている必要があります。
83
84#
85# sub package: gedit
86#
87%package gedit
88Summary:        Adds functionality to Gedit to encrypt/decrypt/sign text
89Summary:        geditにテキストを暗号化/復号化/署名するための機能を追加します。
90Group:          Applications/Accessories
91Requires:       %{name} = %{version}-%{release}
92Requires:       gedit
93BuildRequires:  gedit-devel
94
95%description gedit
96The Text Encryption plugin adds functionality to Gedit, the GNOME text
97editor, to encrypt/decrypt/sign text
98
99%description gedit -l ja
100テキスト暗号化プラグインは、GNOMEテキストエディタGeditにテキストを
101暗号化/復号化/署名するための機能を追加します。
102
103#
104# sub package: nautilus
105#
106%package nautilus
107Summary:        Contains code for calling seahorse-tool from Nautilus
108Summary(ja):    Nautilusから、seahorse-toolを呼ぶためのコードが含まれています。
109Group:          Applications/Accessories
110Requires:       %{name} = %{version}-%{release}
111Requires:       nautilus
112BuildRequires:  nautilus-devel
113
114%description nautilus
115Encryption and Keyrings integrates with Nautilus.  You can encrypt, decrypt,
116sign and verify files as well as import public keys from the file manager
117window without launching Encryption and Keyrings.
118
119%description nautilus -l ja
120パスワードと暗号化が、Nautilusに統合されます。パスワードと暗号化を起動する
121ことなく、ファイルマネージャからファイルの暗号化、復号化、署名及び公開鍵の
122インポートを行うことができます。
123
124#
125# script section
126#
127%prep
128%setup -q
129
130%build
131%configure --disable-update-mime-database --disable-epiphany
132%{__make} %{?_smp_mflags}
133
134%install
135%{__rm} -rf ${RPM_BUILD_ROOT}
136
137export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
138%{__make} install DESTDIR=${RPM_BUILD_ROOT}
139unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
140
141%find_lang %{name}
142
143# treat not install file
144%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/gedit-2/plugins/libseahorse-pgp.a
145%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/gedit-2/plugins/libseahorse-pgp.la
146%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/nautilus/extensions-2.0/libnautilus-seahorse.a
147%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/nautilus/extensions-2.0/libnautilus-seahorse.la
148
149%clean
150%{__rm} -rf ${RPM_BUILD_ROOT}
151
152%post
153/sbin/ldconfig
154%{_bindir}/scrollkeeper-update -q ||:
155export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
156gconftool-2 --makefile-install-rule \
157    %{_sysconfdir}/gconf/schemas/seahorse-plugins.schemas > /dev/null ||:
158update-mime-database %{_datadir}/mime/
159
160%post gedit
161export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
162gconftool-2 --makefile-install-rule \
163    %{_sysconfdir}/gconf/schemas/seahorse-gedit.schemas > /dev/null ||:
164
165%pre
166if [ "$1" -gt 1 ]; then
167  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
168  gconftool-2 --makefile-uninstall-rule \
169      %{_sysconfdir}/gconf/schemas/seahorse-plugins.schemas > /dev/null ||:
170fi
171
172%pre gedit
173if [ "$1" -gt 1 ]; then
174  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
175  gconftool-2 --makefile-uninstall-rule \
176      %{_sysconfdir}/gconf/schemas/seahorse-gedit.schemas > /dev/null ||:
177fi
178
179%preun
180if [ "$1" -eq 0 ]; then
181  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
182  gconftool-2 --makefile-uninstall-rule \
183      %{_sysconfdir}/gconf/schemas/seahorse-plugins.schemas > /dev/null ||:
184fi
185
186%preun gedit
187if [ "$1" -eq 0 ]; then
188  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
189  gconftool-2 --makefile-uninstall-rule \
190      %{_sysconfdir}/gconf/schemas/seahorse-gedit.schemas > /dev/null ||:
191fi
192
193%postun
194/sbin/ldconfig
195%{_bindir}/scrollkeeper-update -q ||:
196update-mime-database %{_datadir}/mime/
197
198
199%files -f %{name}.lang
200%defattr(-,root,root)
201%doc COPYING ChangeLog NEWS README
202%{_sysconfdir}/gconf/schemas/seahorse-plugins.schemas
203%{_bindir}/seahorse-agent
204%{_bindir}/seahorse-preferences
205%{_bindir}/seahorse-tool
206%{_datadir}/applications/seahorse-pgp-encrypted.desktop
207%{_datadir}/applications/seahorse-pgp-keys.desktop
208%{_datadir}/applications/seahorse-pgp-preferences.desktop
209%{_datadir}/applications/seahorse-pgp-signature.desktop
210%{_datadir}/gnome/help/seahorse-plugins/
211%{_datadir}/man/man1/seahorse-agent.1.gz
212%{_datadir}/man/man1/seahorse-tool.1.gz
213%{_datadir}/mime/packages/seahorse.xml
214%{_datadir}/omf/seahorse-plugins/
215%{_datadir}/pixmaps/seahorse-plugins/
216%{_datadir}/seahorse-plugins/ui/
217
218%exclude %{_datadir}/seahorse-plugins/ui/seahorse-applet-preferences.xml
219%exclude %{_datadir}/pixmaps/seahorse-plugins/22x22/seahorse-applet-*.png
220%exclude %{_datadir}/pixmaps/seahorse-plugins/48x48/seahorse-applet*.png
221%exclude %{_datadir}/pixmaps/seahorse-plugins/scalable/seahorse-applet*.svg
222
223%files applet
224%defattr(-, root, root)
225%{_libdir}/bonobo/servers/GNOME_SeahorseApplet.server
226%{_libdir}/seahorse/seahorse-applet
227%{_datadir}/gnome-2.0/ui/GNOME_SeahorseApplet.xml
228%{_datadir}/gnome/help/seahorse-applet/
229%{_datadir}/icons/hicolor/48x48/apps/seahorse-applet.png
230%{_datadir}/icons/hicolor/scalable/apps/seahorse-applet.svg
231%{_datadir}/omf/seahorse-applet/
232%{_datadir}/pixmaps/seahorse-applet.svg
233%{_datadir}/pixmaps/seahorse-plugins/22x22/seahorse-applet-*.png
234%{_datadir}/pixmaps/seahorse-plugins/48x48/seahorse-applet*.png
235%{_datadir}/pixmaps/seahorse-plugins/scalable/seahorse-applet*.svg
236%{_datadir}/seahorse-plugins/ui/seahorse-applet-preferences.xml
237
238%files gedit
239%defattr(-, root, root)
240%{_sysconfdir}/gconf/schemas/seahorse-gedit.schemas
241#%%{_libdir}/gedit-2/plugins/libseahorse-pgp.a
242#%%{_libdir}/gedit-2/plugins/libseahorse-pgp.la
243%{_libdir}/gedit-2/plugins/libseahorse-pgp.so
244%{_libdir}/gedit-2/plugins/seahorse-pgp.gedit-plugin
245
246%files nautilus
247%defattr(-, root, root)
248#%%{_libdir}/nautilus/extensions-2.0/libnautilus-seahorse.a
249#%%{_libdir}/nautilus/extensions-2.0/libnautilus-seahorse.la
250%{_libdir}/nautilus/extensions-2.0/libnautilus-seahorse.so
251
252%changelog
253* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.30.1-2
254- rebuild with rpm-4.8.1
255- update R,BR
256
257* Fri Jun 18 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.30.1-1
258- initial build for Vine Linux
259
Note: See TracBrowser for help on using the repository browser.