source: projects/specs/branches/6/s/scim-bridge/scim-bridge-vl.spec @ 2981

Revision 2981, 11.8 KB checked in by inagaki, 13 years ago (diff)

updated: qt, qt4, PyQt4, avogadro, phonon, qca-ossl, qca2, qoauth, scim-bridge and uim

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define name scim-bridge
4%define version 0.4.16
5%define release 15%{?_dist_release}
6
7%define qt3_ver 3.3.8
8%define qt4_ver 4.7.2
9
10# build qt3 immodule ("--without qt3" to disable qt3)
11%bcond_without qt3
12# Qt3 version auto-detection -- inagaki
13%define _qt3_version %(rpm -q --queryformat "%%{version}" qt-devel 2>/dev/null || echo %{qt3_ver})
14%define _qt3_prefix  %{_libdir}/qt-%{_qt3_version}
15%define _qt3_plugindir %{_qt3_prefix}/plugins
16
17# build qt4 immodule ("--without qt4" to disable qt4)
18%bcond_without qt4
19# Qt4 version auto-detection -- inagaki
20%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
21%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
22%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
23
24
25Summary: yet another IM client of SCIM
26Summary(ja): もう一つ別の SCIM IM クライアント
27Name: %{name}
28Version: %{version}
29Release: %{release}
30
31Group: System Environment/Libraries
32License: GPL/LGPL
33URL: http://www.scim-im.org/projects/scim_bridge
34
35Source0: http://1jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
36
37# Patch from Fedora 10
38Patch0: scim-bridge-0.4.15-fix-gdm.patch
39Patch1: scim-bridge-0.4.15-bz461373.patch
40
41# Patch from Mandriva 2009
42Patch2: bug-351920-should-return-retval.patch
43Patch3: scim-bridge-0.4.15.2-linkage.patch
44
45# Patch from Fedora development
46Patch4: scim-bridge-0.4.15-EOF.patch
47Patch5: scim-bridge-0.4.15-hotkey-help.patch
48Patch6: scim-bridge-0.4.16-fix-gtk-key-snooper.patch
49Patch7: scim-bridge-0.4.16-fixes-null-imengine.patch
50
51BuildRoot: %{_tmppath}/%{name}-%{version}-root
52BuildRequires: scim-devel >= 1.4
53BuildRequires: pkgconfig >= 0.9.0
54BuildRequires: gtk2-devel >= 2.14.0
55
56Requires: scim >= 1.4
57
58%description
59Scim-bridge is yet another IM client of SCIM.
60The im-module of scim-bridge communicates with scim via socket.
61
62%description -l ja
63scim-bridge は、もう一つ別の SCIM IM クライアントです。
64scim-bridge の im-module はソケット経由で SCIM と通信します。
65
66%package gtk
67Summary:        SCIM Bridge GTK IM Module
68Summary(ja):    SCIM Bridge GTK IM モジュール
69Group:          System Environment/Libraries
70Requires:       %{name} = %{version}-%{release}
71Requires:       gtk2 >= 2.14.0
72Requires(post): gtk2 >= 2.14.0
73Requires(postun): gtk2 >= 2.14.0
74Obsoletes:      %{name} <= 0.1.7
75
76%description gtk
77This package provides the SCIM Bridge GTK IM module.
78
79%description -l ja gtk
80このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
81
82%if !%{without qt3}
83%package qt
84Summary:        SCIM Bridge Qt IM Module
85Summary(ja):    SCIM Bridge Qt IM モジュール
86Group:          System Environment/Libraries
87Requires:       %{name} = %{version}-%{release}
88Requires:       qt = %{_qt3_version}
89BuildRequires:  qt-devel
90BuildRequires:  libXmu-devel
91
92%description qt
93This package provides the SCIM Bridge Qt IM module.
94
95%description -l ja qt
96このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
97%endif
98
99%if !%{without qt4}
100%package qt4
101Summary:        SCIM Bridge Qt4 IM Module
102Summary(ja):    SCIM Bridge Qt4 IM モジュール
103Group:          System Environment/Libraries
104Requires:       %{name} = %{version}-%{release}
105Requires:       qt4 = %{_qt4_version}
106BuildRequires:  qt4-devel
107
108%description qt4
109This package provides the SCIM Bridge Qt4 IM module.
110
111%description -l ja qt4
112このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
113%endif
114
115## to build compat32 for x86_64 architecture support
116%package -n compat32-%{name}-gtk
117Summary:        SCIM Bridge GTK IM Module
118Summary(ja):    SCIM Bridge GTK IM モジュール
119Group:          System Environment/Libraries
120Requires:       %{name} = %{version}-%{release}
121Requires:       gtk2 >= 2.14.0
122Requires(post): gtk2 >= 2.14.0
123Requires(postun): gtk2 >= 2.14.0
124
125%description -n compat32-%{name}-gtk
126This package provides the SCIM Bridge GTK IM module.
127
128%description -l ja -n compat32-%{name}-gtk
129このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
130
131%if !%{without qt3}
132%package -n compat32-%{name}-qt
133Summary:        SCIM Bridge Qt IM Module
134Summary(ja):    SCIM Bridge Qt IM モジュール
135Group:          System Environment/Libraries
136Requires:       %{name} = %{version}-%{release}
137Requires:       qt = %{_qt3_version}
138BuildRequires:  qt-devel
139
140%description -n compat32-%{name}-qt
141This package provides the SCIM Bridge Qt IM module.
142
143%description -l ja -n compat32-%{name}-qt
144このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
145%endif
146
147%if !%{without qt4}
148%package -n compat32-%{name}-qt4
149Summary:        SCIM Bridge Qt4 IM Module
150Summary(ja):    SCIM Bridge Qt4 IM モジュール
151Group:          System Environment/Libraries
152Requires:       %{name} = %{version}-%{release}
153Requires:       qt4 = %{_qt4_version}
154BuildRequires:  qt4-devel
155
156%description -n compat32-%{name}-qt4
157This package provides the SCIM Bridge Qt4 IM module.
158
159%description -l ja -n compat32-%{name}-qt4
160このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
161%endif
162
163
164
165%prep
166%setup -q
167%patch0 -p1 -b .0-fix-gdm
168%patch1 -p1
169%patch2 -p1
170%patch3
171%patch4 -p1
172%patch5 -p1
173pushd client-gtk
174%patch6 -p0
175popd
176%patch7 -p1
177
178%build
179%if !%{without qt3}
180export QT3_PREFIX=%{_qt3_prefix}
181%endif
182%if !%{without qt4}
183export QT4_PREFIX=%{_qt4_prefix}
184%endif
185
186%configure --disable-static \
187%if %{without qt3}
188        --disable-qt3-immodule \
189%else
190        --enable-qt3-immodule \
191%endif
192%if %{without qt4}
193        --disable-qt4-immodule \
194%else
195        --enable-qt4-immodule \
196%endif
197        --enable-gtk2-immodule
198
199%__make %{?_smp_mflags}
200
201%install
202%__rm -rf %{buildroot}
203#%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
204%__make DESTDIR=%{buildroot} install
205
206# remove unneeded files
207%__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
208%__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
209%__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
210
211%clean
212%__rm -rf %{buildroot}
213
214%post gtk
215%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
216
217%postun gtk
218%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
219
220%post -n compat32-%{name}-gtk
221%{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
222
223%postun -n compat32-%{name}-gtk
224%{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
225
226%files
227%defattr(-,root,root)
228%doc AUTHORS COPYING ChangeLog NEWS README doc/LICENSE*
229%{_bindir}/scim-bridge
230
231%files gtk
232%defattr(-,root,root)
233%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
234
235%if !%{without qt3}
236%files qt
237%defattr(-,root,root)
238%{_qt3_plugindir}/inputmethods/*.so
239%endif
240
241%if !%{without qt4}
242%files qt4
243%defattr(-,root,root)
244%{_qt4_plugindir}/inputmethods/*.so
245%endif
246
247## to build compat32 for x86_64 architecture support
248%if %{build_compat32}
249%files -n compat32-%{name}-gtk
250%defattr(-,root,root)
251%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
252
253%if !%{without qt3}
254%files -n compat32-%{name}-qt
255%defattr(-,root,root)
256%{_qt3_plugindir}/inputmethods/*.so
257%endif
258
259%if !%{without qt4}
260%files -n compat32-%{name}-qt4
261%defattr(-,root,root)
262%{_qt4_plugindir}/inputmethods/*.so
263%endif
264%endif
265
266
267%changelog
268* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-15
269- rebuilt with qt4-4.7.2
270
271* Sat Feb  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-14
272- added BR: libXmu-devel to qt package
273
274* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-13
275- rebuilt with qt4-4.7.1
276
277* Sat Oct 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.16-12
278- added compat32-* packages for x86_64 architecture support
279
280* Thu Jul 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-11
281- rebuilt with qt4-4.6.3
282
283* Tue Jun 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-10
284- used %{?_smp_mflags} macro on build
285- deleted in unused log in changelog
286  - Patch8 was none, forgot to delete...
287
288* Fri May 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-9
289- added Patch6,7 from Fedora development
290  - to fix Text input in firefox becomes increasingly sluggish (Patch6)
291  - to fix Process /usr/bin/scim-bridge was killed by signal 11 (Patch7)
292- added configure --disable-static option
293
294* Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-8
295- updated Qt version detection macros to build properly
296
297* Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
298- rebuilt with qt4-4.6.1
299
300* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
301- rebuilt with qt4-4.5.3
302
303* Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
304- cleaned up spec
305- renumbered patch
306- added Patch5 from Fedora
307
308* Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
309- rebuild with qt4-4.5.2
310
311* Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
312- dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
313
314* Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
315- rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
316
317* Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
318- new upstream release
319- dropt Pacth3,4,5 (these patches are merged)
320
321* Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
322- spec in UTF-8
323- fixed description in scim-bridge-qt4
324- added patch6,7 (import Fedora, Mandriva patches)
325
326* Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
327- new upstream release
328- added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
329
330* Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
331- rebuild with qt4-4.4.2
332
333* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
334- add qt4 immodule
335  - build gtk,qt3,qt4 immodule by default
336
337* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
338- rebuild with gtk+-2.14
339
340* Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
341- new upstream release
342- apply new versioning policy
343
344* Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
345- drop unnecessary BuildRequires for qt3-immodule package
346- fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
347
348* Wed Jan  9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
349- new upstream release
350- drop unnecessary Qt fix patch ( Patch0 ): upstream merged
351- update BuildRequires
352  - drop doxygen
353  - add XOrg-gl-devel for building qt3-immodule
354  - move libmng-devel for building qt3-immodule
355
356* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
357- rebuild for Vine Linux 4.2.
358
359* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
360- add patch0 to fix symbol lookup error with qt3.
361
362* Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
363- rebuild for Vine Linux 4.2.
364
365* Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
366- new upstrm release
367- detect qt version at build time.
368- add --disable-qt4-immodule configure option.
369- add BuildRequires libmng-devel.
370
371* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
372- rebuild with libstdc++34
373
374* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
375- new upstream release
376
377* Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
378- change License to GPL/LGPL
379- add doc/LICENSE.* as documents
380
381* Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
382- new upstream release
383- add BuildRequires: doxygen, qt-devel
384- add new sub-packages:
385  - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
386  - qt:  Qt IM module
387
388* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
389- new upstream release
390- add documents
391- running gtk-query-immodules-2.0 in post and postun scripts
392- add PreReq: gtk2 > 2.2
393
394* Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
395- new upstream release
396
397* Thu Apr  6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
398- initial release
399
Note: See TracBrowser for help on using the repository browser.