source: projects/specs/branches/6/s/sane/sane-vl.spec @ 10614

Revision 10614, 13.2 KB checked in by tomop, 8 years ago (diff)

sane-1.0.25-1

Line 
1# To make src.rpm
2# rpm -bs --define 'src:1'
3# To make nosrc.rpm
4# rpm -bs --define 'nosrc:1'
5
6%define build_html 0
7
8Summary:        SANE -- Easy local and networked scanner access
9Summary(ja):    スキャナ操作ツール
10Name:           sane
11Version:        1.0.25
12Release:        1%{?_dist_release}
13URL:            http://www.sane-project.org/
14Source:         ftp://ftp.sane-project.org/pub/sane/%{name}-backends-%{version}.tar.gz
15Source10:       sane-hierarchy.png
16Patch0:         sane-1.0.24-vine.patch
17%{?nosrc:NoSource: 0}
18License:        GPL (programs), relaxed LGPL (libraries), and public domain (docs)
19Group:          Applications/Multimedia
20#Icon:          sane-logo.png
21Provides:       libsane.so.1 sane-backends
22
23BuildRequires:  sed
24BuildRequires:  libjpeg-devel
25BuildRequires:  libusb1-devel
26BuildRequires:  libgphoto2-devel
27#BuildPrereq:    latex2html
28#BuildPrereq: emacs/or/xemacs pLaTeX2e/or/tetex-latex pTeX/or/tetex
29Buildroot:      %{_tmppath}/%{name}-%{version}-root
30
31%{?nosrc:%define src 1}
32%{?src:%define _src 1}
33%{?!src:%define _src 0}
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39SANE (Scanner Access Now Easy) is a sane and simple interface
40to both local and networked scanners and other image acquisition devices
41like digital still and video cameras.  SANE currently includes modules for
42accessing a range of scanners, including models from Agfa SnapScan, Apple,
43Artec, Canon, CoolScan, Epson, HP, Microtek, Mustek, Nikon, Siemens,
44Tamarack, UMAX, Connectix, QuickCams and other SANE devices via network.
45This package also include a client program 'scanimage','sane-find-scanner',
46'xerox' and etc.
47
48For the latest information on SANE, the SANE standard definition, and
49mailing list access, see http://www.mostang.com/sane/
50%if %{_src}
51You need xemacs or emacs to build this package.
52And you need latex2html to build this package if you like html documents.
53%endif
54
55%description -l ja
56SANE (Scanner Access Now Easy) はローカル/ネットワーク・スキャナや
57デジタルカメラ、デジタルビデオカメラなど画像取り込み装置の簡単なイン
58ターフェースです。SANE は Agfa SnapScan, Apple, Artec, Canon, CoolScan,
59Epson, HP, Microtek, Mustek, Nikon, Siemens, Tamarack, UMAX, Connectix,
60QuickCams その他、いろいろなスキャナを使うことができます。
61コマンドラインで動くscanimage, sane-find-scanner, xeroxなどもこのパッケージに
62含まれています。
63%if %{_src}
64このソースパッケージからビルドするにはxemacsまたはemacsが必要です。
65またHTMLドキュメントを含めるにはlatex2htmlが必要です。
66%endif
67
68%package devel
69Summary:  SANE (Scanner Access Now Easy) development toolkit
70Summary(ja):  SANE (Scanner Access Now Easy) 開発ツールキット
71Group:    Development/Libraries
72Requires: %{name} = %{version}
73Requires: pkgconfig
74Requires: libjpeg-devel
75Requires: libgphoto2-devel
76Requires: libexif-devel
77Requires: libusb1-devel
78
79%description devel
80Static libraries and header files for writing SANE modules.
81
82%description devel -l ja
83SANE のモジュールを書くための、ヘッダファイルと静的ライブラリ
84です。
85
86%prep
87%setup -q -n %{name}-backends-%{version}
88%patch0 -p1 -b .vine
89
90%build
91%configure --with-gnu-ld --enable-static --enable-libusb_1_0
92# don't set smp flags!
93make
94
95# dll.conf: comment out all lines
96# epson.conf: add example for usb scanner
97( cd backend
98cat dll.conf | %__sed "s/^\([^#]\)/#\1/" > dll.conf~
99%__mv -f dll.conf~ dll.conf
100echo "#usb /dev/usb/scanner0" >> epson.conf
101)
102
103%if %{build_html}
104( cd doc
105  %__make html
106  %__mv sane html
107  cd html
108  %__cp -f %{SOURCE10} img1.png
109  %__cat node10.html | \
110    %__sed 's/WIDTH="5.." HEIGHT="2"/WIDTH="500" HEIGHT="246"/' \
111    > node10.html~
112  %__mv -f node10.html~ node10.html
113  %__rm -f WARNINGS
114)
115[ -d doc/html ] || %__mkdir doc/html
116%endif
117
118%install
119%__rm -rf $RPM_BUILD_ROOT
120%{__make} install DESTDIR=${RPM_BUILD_ROOT}
121%__mv $RPM_BUILD_ROOT%{_sbindir}/saned $RPM_BUILD_ROOT%{_sbindir}/in.saned
122%__install -m755 tools/xerox $RPM_BUILD_ROOT%{_bindir}
123%__install -m755 tools/umax_pp $RPM_BUILD_ROOT%{_bindir}
124%__cp tools/README README.tools
125%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/%{name}
126%if %{build_html}
127%__cp doc/*.html doc/*.png doc/*.jpg $RPM_BUILD_ROOT%{_datadir}/%{name}
128##%__mv doc/*.html doc/*.png doc/*.jpg doc/html
129%endif
130
131pushd $RPM_BUILD_ROOT%{_bindir}
132%__ln_s sane-find-scanner find-scanner
133popd
134
135# Create ld.so.conf.d entry
136mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
137cat >> %{buildroot}%{_sysconfdir}/ld.so.conf.d/%{name}-%{_arch}.conf << EOF
138%{_libdir}/%{name}
139EOF
140
141# clear uninstall files
142%__rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
143%__rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
144%__rm -rf $RPM_BUILD_ROOT%{_libdir}/sane/lib*.la
145
146
147%post
148/sbin/ldconfig
149
150[ -d /dev/usb ] || %__mkdir /dev/usb
151[ -c /dev/usb/scanner0 ] || mknod /dev/usb/scanner0 c 180 48 -m 777
152
153# network settings
154SERVICES=%{_sysconfdir}/services
155if [ -x "%__grep" -a -f "$SERVICES" ] ; then
156%__grep -q "^sane" $SERVICES || \
157echo "sane          6566/tcp       # network sccaner deamon" >> $SERVICES
158fi
159INETDCONF=%{_sysconfdir}/inetd.conf
160if [ -x "%__grep" -a -f "$INETDCONF" ] ; then
161%__grep -q "^#*sane" $INETDCONF || \
162echo "#sane    stream  tcp     nowait  root    %{_sbindir}/in.saned   %{_sbindir}/in.saned" >>   $INETDCONF
163fi
164#kill -HUP `/sbin/pidof inetd`
165
166%postun -p /sbin/ldconfig
167
168
169%clean
170%__rm -rf $RPM_BUILD_ROOT
171
172%files
173%defattr(-,root,root)
174%doc README* AUTHORS ChangeLog* COPYING LICENSE PROBLEMS PROJECTS NEWS
175%doc doc/figs doc/icons doc/canon doc/mustek doc/mustek_usb doc/umax
176%if %{build_html}
177%doc doc/html
178%endif
179%doc doc/*.{txt,tex,sty}
180%doc tools
181%dir %{_sysconfdir}/sane.d
182%config %{_sysconfdir}/sane.d/*
183%config(noreplace) %{_sysconfdir}/ld.so.conf.d/%{name}-%{_arch}.conf
184%{_sbindir}/*
185%{_bindir}/find-scanner
186%{_bindir}/gamma4scanimage
187%{_bindir}/sane-find-scanner
188%{_bindir}/scanimage
189%{_bindir}/umax_pp
190%{_bindir}/xerox
191%{_libdir}/lib*.so.*
192%{_libdir}/lib*.so
193%{_libdir}/sane/lib*.so.*
194%{_libdir}/sane/lib*.so
195%dir %{_libdir}/sane
196%{_datadir}/sane
197%{_mandir}/man1/*.1*
198%{_mandir}/man5/*.5*
199%{_mandir}/man7/*.7*
200%{_mandir}/man8/*.8*
201%{_datadir}/locale
202
203%files devel
204%defattr(-,root,root)
205%{_bindir}/sane-config
206%{_includedir}/sane
207%{_libdir}/pkgconfig/sane-backends.pc
208%{_libdir}/lib*.a
209%{_libdir}/sane/lib*.a
210
211%changelog
212* Wed May 18 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.25-1
213- new upstream release.
214- replace BR:libusb with BR:libusb1.
215
216* Mon Feb 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.24-2
217- rebuild with libgphoto2-2.5.7
218
219* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.24-1
220- update to 1.0.24
221- update Patch0 (sane-1.0.24-vine.patch)
222- remove Patch1 (sane-backends-1.0.21-i18n.patch)
223- fix %%post and %%postun (fix BTS:2514)
224
225* Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.21-2
226- build with libghoto2 2.5.0-1
227- stop generating HTML manual: missing man2html(1) in current VineSeed
228- add Vendor and Distribution tags
229
230* Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.21-1
231- new upstream release
232- change Patch (from sane-1.0.15-vine.patch to sane-1.0.21-vine.patch)
233- move sane-config to devel package
234- add Requires: libjpeg-devel, libgphoto2-devel, libexif-devel, libusb-devel (devel package)
235- add Patch1(sane-backends-1.0.21-i18n.patch)
236
237* Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.18-3
238- added BuildRequires: libgphoto2-devel instead of ghoto2-devel
239
240* Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.18-2
241- spec in utf-8
242
243* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.18-1
244- applied new versioning policy
245- removed lib*.la files from devel package
246
247* Mon Dec 24 2007 Shu KONNO <owa@bg.wakwak.com> 1.0.18-0vl1
248- new upstream release
249
250* Sun Jan 09 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.15-0vl1
251- new upstream version(sane-1.0.15)
252- fixed spec file
253        -- cleaned up patches
254        -- added Requires:       libjpeg, libusb
255        -- added BuildRequires:  glibc, libjpeg-devel, libusb-devel
256
257* Fri Oct 25 2002 Tomoya TAKA <taka@vinelinux.org> 1.0.8-0vl1
258- new upstream release
259- update sane-1.0.8-vine.patch
260- add --enable-static option to %%configure
261
262* Mon May 13 2002 Masaki Shinomiya <shino@pos.to>
263- 1.0.7-0vl2: sparc.patch, ppc.patch both from Mandrake(4mdk)
264- informed by Iohara [VinePlus:01130]
265
266* Thu Apr 4 2002 Masaki Shinomiya <shino@pos.to>
267- 1.0.7-0vl1 for Vine Linux-2.x
268- 1.0.7-0.1
269- set %_sysconfdir to /etc for RedHat6.x/Vine2.x
270
271* Wed Mar 6 2002 Masaki SHINOMIYA <shino@pos.to>
272- 1.0.7-0
273- new source
274- avoid listing %{_libdir}/sane from sane-devel
275- add LEVEL2 in doc
276
277* Fri Feb 1 2002 Masaki SHINOMIYA <shino@pos.to>
278- 1.0.6-0.3
279- allow to build without latex2html
280- prereq ldconfig, buildprereq sed, provide sane-backends
281
282* Sun Dec 23 2001 Masaki SHINOMIYA <shino@pos.to>
283- 1.0.6-0.2
284- dll.conf, epson.conf, network settings
285
286* Tue Dec 18 2001 Masaki SHINOMIYA <shino@pos.to>
287- 1.0.6-0.1
288- new source
289
290* Mon Dec 17 2001 Masaki SHINOMIYA <shino@pos.to>
291- 1.0.5-1.3
292- allow to use emacs or xemacs in building
293- nosrc
294
295#* Wed Oct 3 2001 Masaki SHINOMIYA <shino@pos.to>
296#- 1.0.5-1.2
297#- surpress swapping R<-->G colors on EPSON GT-8700/Perfection1640
298#- ( information from [vine-users:037559] tyu <tyu@mbd.nifty.com> )
299#- omit doc/*.tex etc.
300
301* Tue Sep 18 2001 Masaki SHINOMIYA <shino@pos.to>
302- 1.0.5-1.1
303- use emacs instead of xemacs in building
304
305* Sat Jul 7 2001 Masaki SHINOMIYA <shino@pos.to>
306- 1.0.5-1
307
308* Thu Jun 7 2001 Masaki SHINOMIYA <shino@pos.to>
309- 1.0.4 + epson backend ver.20010519
310- sane-clients is removed from this package
311- scanimage, find-scanner and xerox are left in this package
312
313* Thu May 17 2001 Masaki SHINOMIYA <shino@pos.to>
314- 1.0.4 + epson backend ver.20010331
315- 'scanimage' is included in the binary'sane-1.0.4-1.i386.rpm'package.
316- refined script for gimp plug-in setup
317- html documents shal be installed in the directory '/usr/share/sane'
318- automatically make device the file /dev/usb/scanner0
319
320* Wed Nov 15 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
321- 1.0.3-0vl8
322- included missing "sane-config" script for sane
323
324* Tue Oct 17 2000 Jun Nishii <jun@vinelinux.org>
325- 1.0.3-0vl7
326- merge xscanimage patch
327
328* Mon Oct 16 2000 Jun Nishii <jun@vinelinux.org>
329- 1.0.3-0vl6
330- build with gimp-1.1.27
331
332* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
333- 1.0.3-0vl5
334- fixed group
335
336* Sat Sep 30 2000 Jun Nishii <jun@vinelinux.org>
337- 1.0.3-0vl4
338- added %defattr in clients
339
340* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org>
341- 1.0.3-0vl3
342- build with gimp-1.1.26
343
344* Mon Sep 25 2000 Jun Nishii <jun@vinelinux.org>
345- 1.0.3-0vl2
346- build with gimp-1.1.25
347
348* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
349- 1.0.3-0vl1
350
351* Thu Jun  8 2000 Jun Nishii <jun@vinelinux.org>
352- 1.0.2-0vl1
353
354* Mon Jan 17 2000 Jun Nishii <jun@vinelinux.org>
355- build for Vine Linux 2.0
356- added find-scanner, xerox
357
358* Fri Apr 23 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
359- Fixed packaging a bit.
360
361* Wed Apr 21 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
362- Updated package to 1.01
363
364* Fri Apr 09 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
365- Split off the clients
366- Fixed a Alpha system anomaly by removing the specific backend.
367
368* Mon Nov 23 1998 Jonathan Miller <jlm@mvhi.com>
369 [1.00-1]
370- upgraded to 1.00 (and made description less space-consuming)
371- included the post 1.00 fixed "configure" script available 22 Nov 1998.
372
373* Sat Aug 08 1998 Arne Coucheron <arneco@online.no>
374  [0.74-3]
375- added /etc/sane.d to %dir in file list
376
377* Sat Aug 01 1998 Arne Coucheron <arneco@online.no>
378  [0.74-2]
379- devel Group: reverted back to Development/Libraries
380- some changes to the %defattr and %attr usage in file list
381
382* Tue Jul 28 1998 Binaire <binaire@binaire.ml.org>
383  [0.74-1]
384
385* Fri May 22 1998 Arne Coucheron <arneco@online.no>
386  [0.73-3]
387- added use of %%{name} and %%{version} macros
388- added a %postun for running ldconfig after uninstall
389- using BuildRoot properly now
390- using %defattr and %attr macros in filelist, allows non-root build
391  this means that RPM 2.5 is required to build this spec file now!
392- devel Group: changed to X11/Libraries
393- added using RPM_OPT_FLAGS during make
394- added striping of programs and libraries
395- added Requires: gtk+ >= 0.99.13 to main package
396- added Requires: %%{name} = %%{version} to devel package
397- added a %clean section for removing the buildroot dir
398- simplified the filelist and added %config for sane-style.rc
399- moved lib*.so to %files devel and dropped the *.la files
400- added -q parameter to %setup
401- removed some older changelog entries
402- removed the "fix ldconfig brokenness..." stuff
403- removed the Packager: line; use /etc/rpmrc if you want your name in
404- if GIMP is installed, make symlink from xscanimage to plug-ins dir
405- install the find-scanner program from the tools dir
406
407* Mon May 18 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
408- Version 0.73 was created: May 13 1998
409- gimp (original was build against 0.99.29)
410- gtk+ (original was build against 1.0.1)
411- dlh (original was build against 0.7d)
412- X11 development tree including xpm libraries.
413
414* Wed Apr 22 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
415- Binaries are now BuildRoot proof.
416
417* Wed Apr 22 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
418- Binaries are not BuildRoot proof. release 3 is done without BuildRoot!
419
420* Tue Apr 21 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
421- Temp. fix for some documentations problems with BuildRoot.
422
423* Sat Apr 11 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
424- Formal 0.72 now made as RPM! (Build against GTK+ 0.99.10 and GIMP 0.99.24)
425- Original package was released: Tue Apr 7 1998
Note: See TracBrowser for help on using the repository browser.