source: projects/specs/branches/6/s/sane-clients/sane-clients-vl.spec @ 5581

Revision 5581, 6.9 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild packages

Line 
1%define sane_ver %(/usr/bin/sane-config --version 2> /dev/null)
2%define gimpdirs %(/bin/ls -d %{_libdir}/gimp/*/plug-ins 2> /dev/null)
3
4Summary:        SANE (Scanner Access Now Easy) clients
5Summary(ja):    SANE (Scanner Access Now Easy) クライアント
6Group:          Applications/Multimedia
7Name:           sane-clients
8Version:        1.0.14
9Release:        3%{?_dist_release}
10URL:            http://www.mostang.com/sane/
11Source:         ftp://ftp.mostang.com/pub/sane/sane-frontends-%{version}.tar.gz
12Patch0:         sane-frontends-1.0.14-array-out-of-bounds.patch
13Patch1:         sane-frontends-1.0.14-sane-backends-1.0.20.patch
14%{?nosrc:NoSource: 0}
15License:        GPL (programs), relaxed LGPL (libraries), and public domain (docs)
16
17BuildRequires: sane-devel = %{sane_ver}
18BuildRequires: gtk2-devel
19BuildRequires: gimp-devel
20Requires: sane = %{sane_ver}
21Buildroot: %{_tmppath}/%{name}-%{version}-root
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26
27%description
28The clients,'xscanimage' and 'xcam', those use the SANE modules.
29
30%description -l ja
31SANE モジュールを使うGUIクライアントxscanimageとxcamを収録しています。
32
33%prep
34%setup -q -n sane-frontends-%{version}
35%patch0 -p1 -b .array
36%patch1 -p1 -b .sane_backends
37
38%build
39%configure --datadir=%{_datadir}/sane
40make %{?_smp_mflags}
41
42%install
43rm -rf $RPM_BUILD_ROOT
44%makeinstall datadir=$RPM_BUILD_ROOT%{_datadir}
45
46if (echo "%{gimpdirs}" | grep -q plug-ins) ;then
47        for D in %{gimpdirs} ; do
48                mkdir -p $RPM_BUILD_ROOT${D}
49                %__ln_s -f %{_bindir}/xscanimage $RPM_BUILD_ROOT${D}/xscanimage
50        done
51fi
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56
57%files
58%defattr(-,root,root)
59%{_bindir}/*
60%config %{_datadir}/sane/sane-style.rc
61%{_mandir}/man1/*
62%doc README* AUTHORS COPYING Changelog INSTALL NEWS PROBLEMS
63%{_libdir}/gimp/*/plug-ins/*
64
65
66%changelog
67* Sun Feb 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.14-3
68- rebuild with Vine6 environment
69
70* Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.14-2
71- rebuild with sane-1.0.21
72- change BuildRequires (from gtk+ to gtk2-devel)
73- change BuildRequires (from gimp to gimp-devel)
74- add Patch0(sane-frontends-1.0.14-array-out-of-bounds.patch)
75- add Patch1(sane-frontends-1.0.14-sane-backends-1.0.20.patch)
76
77* Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.14-1vl5
78- applied new versioning policy, spec in utf-8
79
80* Mon Dec 24 2007 Shu KONNO <owa@bg.wakwak.com> 1.0.14-0vl1
81- updated sane-frontends to 1.0.14
82- defined macro 'sane_ver' by sane-config
83- s/Copyright/License/
84
85* Fri Oct 25 2002 Tomoya TAKA <taka@vinelinux.org> 1.0.8-0vl1
86- new upstream release
87
88* Wed Apr 4 2002 Masaki Shinomiya <shino@pos.to>
89- 1.0.7-0vl1 for Vine Linux-2.x
90- 1.0.7-0.1
91- symlink for gimp listed in %file section
92- set %_sysconfdir to /etc for RedHat6.x/Vine2.x
93
94* Wed Mar 6 2002 Masaki SHINOMIYA <shino@pos.to>
95- 1.0.7-0
96
97* Sun Dec 23 2001 Masaki SHINOMIYA <shino@pos.to>
98- 1.0.6-0.2: %config sane-style.rc
99
100* Fri Dec 21 2001 Masaki SHINOMIYA <shino@pos.to>
101- 1.0.6-0.1
102- use macros as possible
103- %{_datadir}/sane/sane-style.rc
104
105* Wed Jul 4 2001 Masaki SHINOMIYA <shino@pos.to>
106- 1.0.5
107
108* Wed May 17 2001 Masaki SHINOMIYA <shino@pos.to>
109- 1.0.4
110- sane-clients seperated from sane package
111
112* Wed May 17 2001 Masaki SHINOMIYA <shino@pos.to>
113- 1.0.4 + epson backend ver.20010331
114- 'scanimage' is included in the binary'sane-1.0.4-1.i386.rpm'package.
115- refined script for gimp plug-in setup
116- html documents shall be installed in the directory '/usr/share/sane'
117- automatically make device the file /dev/usb/scanner0
118
119* Wed Nov 15 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
120- 1.0.3-0vl8
121- included missing "sane-config" script for sane
122
123* Tue Oct 17 2000 Jun Nishii <jun@vinelinux.org>
124- 1.0.3-0vl7
125- merge xscanimage patch
126
127* Mon Oct 16 2000 Jun Nishii <jun@vinelinux.org>
128- 1.0.3-0vl6
129- build with gimp-1.1.27
130
131* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
132- 1.0.3-0vl5
133- fixed group
134
135* Sat Sep 30 2000 Jun Nishii <jun@vinelinux.org>
136- 1.0.3-0vl4
137- added %defattr in clients
138
139* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org>
140- 1.0.3-0vl3
141- build with gimp-1.1.26
142
143* Mon Sep 25 2000 Jun Nishii <jun@vinelinux.org>
144- 1.0.3-0vl2
145- build with gimp-1.1.25
146
147* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
148- 1.0.3-0vl1
149
150* Thu Jun  8 2000 Jun Nishii <jun@vinelinux.org>
151- 1.0.2-0vl1
152
153* Mon Jan 17 2000 Jun Nishii <jun@vinelinux.org>
154- build for Vine Linux 2.0
155- added find-scanner, xerox
156
157* Fri Apr 23 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
158- Fixed packaging a bit.
159
160* Wed Apr 21 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
161- Updated package to 1.01
162
163* Fri Apr 09 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
164- Split off the clients
165- Fixed a Alpha system anomaly by removing the specific backend.
166
167* Mon Nov 23 1998 Jonathan Miller <jlm@mvhi.com>
168 [1.00-1]
169- upgraded to 1.00 (and made description less space-consuming)
170- included the post 1.00 fixed "configure" script available 22 Nov 1998.
171
172* Sat Aug 08 1998 Arne Coucheron <arneco@online.no>
173  [0.74-3]
174- added /etc/sane.d to %dir in file list
175
176* Sat Aug 01 1998 Arne Coucheron <arneco@online.no>
177  [0.74-2]
178- devel Group: reverted back to Development/Libraries
179- some changes to the %defattr and %attr usage in file list
180
181* Tue Jul 28 1998 Binaire <binaire@binaire.ml.org>
182  [0.74-1]
183
184* Fri May 22 1998 Arne Coucheron <arneco@online.no>
185  [0.73-3]
186- added use of %%{name} and %%{version} macros
187- added a %postun for running ldconfig after uninstall
188- using BuildRoot properly now
189- using %defattr and %attr macros in filelist, allows non-root build
190  this means that RPM 2.5 is required to build this spec file now!
191- devel Group: changed to X11/Libraries
192- added using RPM_OPT_FLAGS during make
193- added striping of programs and libraries
194- added Requires: gtk+ >= 0.99.13 to main package
195- added Requires: %%{name} = %%{version} to devel package
196- added a %clean section for removing the buildroot dir
197- simplified the filelist and added %config for sane-style.rc
198- moved lib*.so to %files devel and dropped the *.la files
199- added -q parameter to %setup
200- removed some older changelog entries
201- removed the "fix ldconfig brokenness..." stuff
202- removed the Packager: line; use /etc/rpmrc if you want your name in
203- if GIMP is installed, make symlink from xscanimage to plug-ins dir
204- install the find-scanner program from the tools dir
205
206* Mon May 18 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
207- Version 0.73 was created: May 13 1998
208- gimp (original was build against 0.99.29)
209- gtk+ (original was build against 1.0.1)
210- dlh (original was build against 0.7d)
211- X11 development tree including xpm libraries.
212
213* Wed Apr 22 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
214- Binaries are now BuildRoot proof.
215
216* Wed Apr 22 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
217- Binaries are not BuildRoot proof. release 3 is done without BuildRoot!
218
219* Tue Apr 21 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
220- Temp. fix for some documentations problems with BuildRoot.
221
222* Sat Apr 11 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
223- Formal 0.72 now made as RPM! (Build against GTK+ 0.99.10 and GIMP 0.99.24)
224- Original package was released: Tue Apr 7 1998
Note: See TracBrowser for help on using the repository browser.