source: projects/specs/branches/6/s/sablotron/sablotron-vl.spec @ 5581

Revision 5581, 5.7 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild packages

Line 
1%define name sablotron
2%define version 1.0.3
3%define release 3%{?_dist_release}
4
5%define altname Sablot
6%define builddir $RPM_BUILD_DIR/%{altname}-%{version}
7%define lib_name_orig libsablotron
8%define lib_major 0
9%define lib_name %{lib_name_orig}%{lib_major}
10
11Summary:                XSLT processor
12Summary(ja):            XSLT プロセッサ
13Name:                   %{name}
14Version:                %{version}
15Release:                %{release}
16License:                MPL/GPL
17Group:                  Applications/Text
18#URL:                   http://www.gingerall.cz
19#Source:                http://www.gingerall.com:/perl/rd?url=sablot/%{altname}-%{version}.tar.gz
20#Source0:               http://download-1.gingerall.cz/download/sablot/%{altname}-%{version}.tar.gz
21URL:                    http://sourceforge.net/projects/sablotron/
22Source0:                %{url}/files/sablotron-%{version}/Sablot-%{version}.tar.gz
23Patch:                  sablot-lib-0.71.patch.bz2
24Requires:               expat >= 1.95.2
25Requires:               %{lib_name}
26BuildRequires:          expat-devel >= 1.95.2
27BuildRequires:          perl-XML-Parser
28
29BuildRoot:              %{_tmppath}/%{name}-%{version}-root
30
31%description
32Sablotron is a fast, compact and portable XML toolkit
33implementing XSLT, DOM and XPath.
34
35The goal of this project is to create a lightweight,
36reliable and fast XML library processor conforming to the W3C
37specification, which is available for public and can be used as a base
38for multi-platform XML applications.
39
40%package -n %{lib_name}
41Summary:        Main library for sablotron
42Summary(ja):    sablotron ライブラリ
43Group:          System Environment/Libraries
44Provides:       %{name} = %{version}-%{release}
45
46%description -n %{lib_name}
47Contains the library for sablotron.
48
49%package -n %{lib_name}-devel
50Summary:        The development libraries and header files for Sablotron
51Summary(ja):    Sablotron の開発ライブラリおよびヘッダファイル
52Requires:       sablotron = %{version}
53Group:          Development/Libraries
54Requires:       %{lib_name} = %{version}
55Provides:       %{lib_name_orig}-devel = %{version}-%{release}
56
57%description -n %{lib_name}-devel
58These are the development libraries and header files for Sablotron
59
60%prep
61%setup -q -n %{altname}-%{version}
62#%patch
63
64%build
65export CXXFLAGS="${RPM_OPT_FLAGS}"
66./configure --prefix=%{_prefix}
67make
68
69%install
70%makeinstall prefix=$RPM_BUILD_ROOT/%{_prefix}
71## remove unuse files
72rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
73
74
75%files
76%defattr(755,root,root)
77%{_bindir}/sabcmd
78%{_docdir}/html/jsdom-ref
79%{_docdir}/html/sablot
80%{_docdir}/html/sxp
81%{_mandir}/man1/sabcmd.*
82
83%files -n %{lib_name}
84%defattr(-,root,root)
85%{_libdir}/libsablot.so.*
86%doc README RELEASE
87
88%files -n %{lib_name}-devel
89%defattr(-,root,root)
90%{_bindir}/sablot-config
91%{_libdir}/lib*.a
92#%{_libdir}/lib*.la
93%{_libdir}/lib*.so
94%{_includedir}/*.h
95
96%clean
97[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
98
99%post -n %{lib_name} -p /sbin/ldconfig
100
101%postun -n %{lib_name} -p /sbin/ldconfig
102
103%changelog
104* Sun Feb 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-3
105- rebuild with Vine6 environment
106
107* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.3-2
108- rebuilt with new toolchain
109
110* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.3-1vl5
111- applied new versioning policy, spec in utf-8
112- removed *.la
113
114* Wed Feb 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl2
115- rebuild with expat-2.0.1
116
117* Sun Jan  6 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.3-0vl1
118- updated Sablot to 1.0.3
119- dropt sablot-lib-0.71.patch.bz2
120
121* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl5
122- rebuilt with new toolchain
123
124* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl4
125- changed Group to Applications/Text
126
127* Sat Mar 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl3
128- added Japanese summary
129- changed Group:
130
131* Sat Jan 25 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.97-0vl2
132- added BuildRequires: perl-XML-Parser
133
134* Thu Jan 21 2003 Satoshi MACHINO <machino@vinelinux.org> 0.97-0vl1
135- new upstream version
136
137* Thu May 16 2002 Satoshi MACHINO <machino@vinelinux.org> 0.90-1vl1
138- build on Vine Linux
139        -- modified spec
140
141* Wed Apr 03 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.90-1mdk
142- release 0.90.
143- patch to add -lexpat and -lstdc++ in libsablot.so (required for php4)
144
145* Mon Feb 04 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.82-1mdk
146- release 0.82.
147
148* Wed Jan 16 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.81-1mdk
149- release 0.81.
150- Removed patch for 0.80.
151
152* Tue Jan 15 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.80-1mdk
153- release 0.80.
154
155* Wed Nov 21 2001 Christian Belisle <cbelisle@mandrakesoft.com> 0.71-1mdk
156- release 0.71.
157- bzip2 the source.
158- remove the patch.
159
160* Tue Nov 06 2001 Philippe Libat <philippe@mandrakesoft.com> 0.70-2mdk
161- %macros
162- move sabcmd in sablotron rpm
163
164* Mon Nov 05 2001 Christian Belisle <cbelisle@mandrakesoft.com> 0.70-1mdk
165- first mdk release.
166
167* Tue Sep 18 2001 Petr Cimprich <petr@gingerall.cz>
168- sablotron 0.70 RPM release 1
169
170* Wed Aug 15 2001 Petr Cimprich <petr@gingerall.cz>
171- sablotron 0.65 RPM release 1
172
173* Thu Jun 14 2001 Petr Cimprich <petr@gingerall.cz>
174- sablotron 0.60 RPM release 1
175- build under RedHat 7.1 with rpm 4.0.2
176
177* Wed Apr 22 2001 Petr Cimprich <petr@gingerall.cz>
178- sablotron 0.52 RPM release 1
179- based on 0.51-5 spec by Henri Gomez
180
181* Thu Feb 22 2001 Henri Gomez <hgomez@slib.fr>
182- sablotron 0.51 RPM release 5
183- apply patch to add -lexpat and -lstdc++ in libsablot.so
184  REQUIRED for use with PHP4
185
186* Thu Feb 22 2001 Henri Gomez <hgomez@slib.fr>
187- sablotron 0.51 RPM release 4
188- follow Redhat way to dispatch between pack and pack-devel
189
190* Tue Feb 20 2001 Henri Gomez <hgomez@slib.fr>
191- sablotron 0.51 RPM release 3
192- added ldconfig is post/preun and cleanup stuff
193- build under Redhat 6.2 + updates with rpm 3.0.5
194
195* Mon Feb 19 2001 Henri Gomez <hgomez@slib.fr>
196- sablotron 0.51 RPM release 2
197- added Requires expat >= 1.95.1
198
199* Mon Feb 19 2001 Henri Gomez <hgomez@slib.fr>
200- sablotron 0.51 RPM release 1
201- updated spec file
202
Note: See TracBrowser for help on using the repository browser.