source: projects/specs/branches/6/r/rwho/rwho-vl.spec @ 3756

Revision 3756, 5.5 KB checked in by inagaki, 13 years ago (diff)

update: rusers, rwho

Line 
1Summary:     Displays who is logged in to local network machines.
2Summary(ja): ローカルネットワーク機に誰がログインしているか表示する
3Name: rwho
4Version: 0.17
5Release: 27%{?_dist_release}
6
7License: BSD
8Group: Applications/Internet
9
10Source: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/netkit-rwho-%{version}.tar.gz
11Source1: rwhod.init
12Patch0: netkit-rwho-0.15-alpha.patch
13Patch1: netkit-rwho-0.17-bug22014.patch
14Patch2: rwho-0.17-fixbcast.patch
15Patch3: rwho-0.17-fixhostname.patch
16Patch4: netkit-rwho-0.17-strip.patch
17Patch5: netkit-rwho-0.17-include.patch
18Patch6: netkit-rwho-0.17-wd_we.patch
19Patch7: netkit-rwho-0.17-time.patch
20Patch8: netkit-rwho-0.17-gcc4.patch
21Patch9: netkit-rwho-0.17-getloadavg.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24#Requires: /sbin/chkconfig /etc/init.d
25Requires: /sbin/chkconfig
26
27
28%description
29The rwho command displays output similar to the output of the who
30command (it shows who is logged in) for all machines on the local
31network running the rwho daemon.
32
33Install the rwho command if you need to keep track of the users who
34are logged in to your local network.
35
36%description -l ja
37rwho コマンドは who コマンド (誰がログインしているかを表示します) の
38出力に似た表示をするプログラムで,rwho デーモンが動作しているローカル
39ネットワーク上の全マシンの情報を出力します.
40
41あなたのローカルネットワーク上のマシンに誰がログインしているかを
42知りたい場合は rwho コマンドをインストールして下さい.
43
44
45%prep
46%setup -q -n netkit-rwho-%{version}
47%patch0 -p1 -b .alpha
48%patch1 -p1 -b .bug22014
49%patch2 -p1 -b .fixbcast
50%patch3 -p1 -b .fixhostname
51%patch4 -p1 -b .strip
52%patch9 -p0 -b .getloadavg
53
54%build
55sh configure
56perl -pi -e '
57    s,^CC=.*$,CC=cc,;
58    s,-O2,\$(RPM_OPT_FLAGS),;
59    s,^BINDIR=.*$,BINDIR=%{_bindir},;
60    s,^MANDIR=.*$,MANDIR=%{_mandir},;
61    s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
62    ' MCONFIG
63
64make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
65
66
67%install
68rm -rf ${RPM_BUILD_ROOT}
69mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
70mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man{1,8}
71mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
72mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
73mkdir -p ${RPM_BUILD_ROOT}/var/spool/rwho
74
75make INSTALLROOT=${RPM_BUILD_ROOT} install
76make INSTALLROOT=${RPM_BUILD_ROOT} install -C ruptime
77
78install -m 755 $RPM_SOURCE_DIR/rwhod.init ${RPM_BUILD_ROOT}%{_initdir}/rwhod
79
80
81%clean
82rm -rf ${RPM_BUILD_ROOT}
83
84
85%post
86/sbin/chkconfig --add rwhod
87
88
89%preun
90if [ $1 = 0 ]; then
91    /sbin/chkconfig --del rwhod
92fi
93
94
95%files
96%defattr(-,root,root)
97%doc README
98%{_bindir}/ruptime
99%{_mandir}/man1/ruptime.1*
100%{_bindir}/rwho
101%{_mandir}/man1/rwho.1*
102
103%{_sbindir}/rwhod
104%{_mandir}/man8/rwhod.8*
105/var/spool/rwho
106%config %{_initdir}/rwhod
107
108
109%changelog
110* Sun May  1 2011 Shu KONNO <owa@bg.wakwak.com> 0.17-27
111- rebuilt with current VineSeed
112
113* Fri Oct 10 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-26vl5
114- added netkit-rwho-0.17-getloadavg.patch
115- applied new versioning policy, spec in utf-8
116
117* Mon Jul 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-19vl1
118- added Patch5, 6, 7 and 8 from Fedora 0.17-25.2.1
119  * Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 0.17-25
120  - gcc4 rebuild fixes
121  * Fri Oct 22 2004 Phil Knirsch <pknirsch@redhat.com> 0.17-23
122  - Fixed long standig bug with only 42 entries per host showing up (#27643)
123  - Fixed some warnings of missing prototypes.
124  * Wed May 12 2004 Phil Knirsch <pknirsch@redhat.com> 0.17-21
125  - Enabled PIE for server and application.
126- changed Group to Applications/Internet
127
128* Mon Jul 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-19vl1
129- based on Redhat Rawhide 0.17-19
130- added Patch2, 3 and 4
131- rebuild with new toolchains
132
133* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
134- 0.17-7vl1
135- based on 0.17-7 from Rawhide
136- use better macros (%%{_initdir})
137- added Japanese summary and description
138
139* Wed Dec 27 2000 Jeff Johnson <jhbj@redhat.com>
140- use glibc's <protocols/rwhod.h>, internal version broken on alpha (#22014).
141
142* Thu Aug 10 2000 Bill Nottingham <notting@redhat.com>
143- fix broken init script
144
145* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
146- condrestart fixes
147
148* Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
149- move initscript back
150
151* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
152- automatic rebuild
153
154* Mon Jul 10 2000 Preston Brown <pbrown@redhat.com>
155- move initscript
156
157* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
158- FHS packaging.
159- update to 0.17.
160
161* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
162- compress man pages.
163
164* Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
165- update to 0.16.
166
167* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
168- postun should have been preun.
169
170* Thu Aug 26 1999 Jeff Johnson <jbj@redhat.com>
171- fix unaligned trap on alpha.
172- update to 0.15.
173
174* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
175- initscript munging
176
177* Fri Apr  9 1999 Jeff Johnson <jbj@redhat.com>
178- add ruptime (#2023)
179
180* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
181- auto rebuild in the new build environment (release 22)
182
183* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
184- compile for 6.0.
185
186* Tue May 05 1998 Prospector System <bugs@redhat.com>
187- translations modified for de, fr, tr
188
189* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
190- enhanced initscripts
191
192* Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
193- added /var/spool/rwho
194
195* Fri Oct 31 1997 Donnie Barnes <djb@redhat.com>
196- fixed init script
197
198* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
199- added an init script
200- uses chkconfig
201- uses %attr tags
202
203* Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
204- initial build
Note: See TracBrowser for help on using the repository browser.