source: projects/specs/branches/6/r/riece/riece-vl.spec @ 5231

Revision 5231, 5.5 KB checked in by munepi, 12 years ago (diff)

updated riece-vl.spec

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define       origver       8.0.0
5%define       origname      riece
6
7Summary:      Riece is emacs based irc client
8Summary(ja):  Riece は Emacsen 上で動作する IRC のクライアント
9Name:         %{origname}
10Version:      %{origver}
11Release:      1%{?_dist_release}
12
13Source0:      http://dl.sv.gnu.org/releases/riece/%{name}-%{version}.tar.gz
14Source1:      %{name}-install.sh
15Source2:      %{name}-remove.sh
16Source3:      %{name}-init.el
17
18License:      GPL
19Group:        Applications/Editors/Emacs
20BuildRoot:    %{_tmppath}/%{name}-%{version}-root
21BuildArch:    noarch
22
23Requires(post): emacsen
24Requires(post): /sbin/install-info
25Requires(preun): emacsen
26Requires(preun): /sbin/install-info
27
28%prereq_ge emacsen-common
29%prereq_ge flim
30
31%description
32Riece is a user interface for IRC (Internet Relay Chat). You should spell it
33with the first letter capitalized and pronounce it as /ri:s/.
34
35The features of Riece are as follows:
36 * Several IRC servers may be used at the same time.
37 * Many features built upon the extension mechanism called add-on.
38   Currently 30 such add-ons are available.
39 * Installation is easy. Riece doesn't depend on other packages.
40 * Setup is easy. Automatically save/restore the configuration.
41 * Step-by-step instructions are included.
42 * Mostly compliant with the latest IRC client protocol (RFC2812).
43
44#'
45
46%description -l ja
47Riece は IRC (Internet Relay Chat) の世界でチャットを楽しむためのユーザインタ
48ーフェースです。Riece は「りーす」と読みます。
49
50Riece の主な特長は以下の通りです。
51 * 複数の IRC サーバに同時に接続可能
52 * アドオンにより機能の追加や取り外しが容易
53 * 他の elisp パッケージに依存しないため、インストールが簡単
54 * 設定が簡単で、前回起動時の設定を記録・復元する仕組みを提供
55 * 段階的な操作説明書が附属
56 * 最新の IRC のクライアントプロトコル (RFC2812) に準拠
57
58%prep
59%setup -q
60
61
62%build
63%configure
64
65%install
66[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
67[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
68
69mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
70mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
71mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
72mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
73
74
75#
76# install el files
77#
78
79cp -a lisp/* ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
80
81#
82#  build & install info
83#
84
85make DESTDIR=${RPM_BUILD_ROOT} install-info
86
87
88#
89# install  script( bytecompile el and install elc , remove )   
90#
91
92%_installemacsenscript %{origname} %{SOURCE1}
93
94%_removeemacsenscript  %{origname} %{SOURCE2}
95
96
97#
98# install info file
99#
100
101mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
102
103
104#
105# install site-start script
106#
107
108install %{SOURCE3} ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
109
110
111## remove unpackaged files
112%__rm ${RPM_BUILD_ROOT}%{_infodir}/dir
113
114
115%pre
116if (grep -q "Riece: (liece)" /usr/share/info/dir) ; then
117  cp /usr/share/info/dir /usr/share/info/dir.rpmsave
118  grep -v "Riece: (liece)" /usr/share/info/dir.rpmsave > /usr/share/info/dir
119  rm -f /usr/share/info/dir.rpmsave
120fi
121
122%post
123#
124# bytecompile and install
125#
126
127if [ "$1" = 2 ]; then
128
129%_emacsenPackageRemove %{origname}
130
131fi
132
133
134%_addemacsenlist %{origname}
135
136%_emacsenPackageInstall %{origname}
137
138
139/sbin/install-info %{_infodir}/riece-ja.info.gz %{_infodir}/dir \
140    --entry="* Riece: (riece-ja).  IRC Client On Emacsen" --section="Emacs" ||:
141
142%preun
143
144if [ "$1" = 0 ]; then
145
146%_emacsenPackageRemove %{origname}
147
148%_removeemacsenlist %{origname}
149
150/sbin/install-info --delete %{_infodir}/riece-ja.info.gz %{_infodir}/dir \
151    --entry="* Riece: (riece-ja).  IRC Client On Emacsen" --section="Emacs" ||:
152
153fi
154
155
156%clean
157[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
158
159
160%files
161%defattr(-,root,root)
162%doc AUTHORS COPYING ChangeLog* INSTALL NEWS* README*
163
164%{_datadir}/emacs/site-lisp/%{origname}
165%{emacsen_pkgdir}/install/%{origname}
166%{emacsen_pkgdir}/remove/%{origname}
167%{_infodir}/%{origname}-*.info*
168 
169
170%changelog
171* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.0-1
172- new upstream release
173
174* Wed Feb 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.3-1
175- new upstream release
176- dropped riece-7.0.0-check-make-local-hook.patch
177
178* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.0-2
179- applied riece-7.0.0-check-make-local-hook.patch
180
181* Wed Nov 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.0-1
182- new upstream release
183
184* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.1.0-1
185- new upstream release
186
187* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 5.0.0-2
188- updated riece-install.sh
189  - *-init.el: changed from hard copy to symbolic link
190    on /etc/emacs-XX.YY/site-start.d
191
192* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 5.0.0-1
193- new upstream release
194
195* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.0-1
196- applied new versioning policy
197- spec in UTF-8
198
199* Thu Sep 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.0-0vl1
200- new upstream release
201
202* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-0vl4
203- fixed %post script <BTS:VineLinux:177>
204
205* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-0vl3
206- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
207- s/Copyright/License/
208
209* Sat Sep 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0-0vl2
210- change BuildArch to noarch
211
212* Fri Sep  9 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0-0vl1
213- initial build
214
Note: See TracBrowser for help on using the repository browser.