source: projects/specs/branches/6/r/rarian/rarian-vl.spec @ 1960

Revision 1960, 5.5 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1Name: rarian
2Version: 0.8.1
3Release: 4%{?_dist_release}
4License: LGPLv2+
5Group: System Environment/Libraries
6Summary: Rarian is a documentation meta-data library
7Summary(ja): Rarian 文書メタデータライブラリ
8URL: http://ftp.gnome.org/pub/gnome/sources/rarian
9Source: http://ftp.gnome.org/pub/gnome/sources/rarian/0.6/rarian-%{version}.tar.bz2
10Source1: scrollkeeper-omf.dtd
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12
13### Dependencies ###
14
15Requires(post): libxml2
16Requires(postun): libxml2
17# for /usr/bin/xmlcatalog
18
19Requires: libxslt
20# for /usr/bin/xsltproc
21Requires: coreutils, util-linux, gawk
22# for basename, getopt, awk, etc
23
24### Build Dependencies ###
25BuildRequires: libxslt-devel
26
27%description
28Rarian is a documentation meta-data library that allows access to documents,
29man pages and info pages.  It was designed as a replacement for scrollkeeper.
30
31%package compat
32License: GPLv2+
33Group: System Environment/Base
34Summary: Extra files for compatibility with scrollkeeper
35Requires: rarian = %{version}-%{release}
36Requires(post): rarian, xml-common
37# The scrollkeeper version is arbitrary.  It just
38# needs to be greater than what we're obsoleting.
39Provides: scrollkeeper = 0.4
40Obsoletes: scrollkeeper <= 0.3.14
41
42%description compat
43This package contains files needed to maintain backward-compatibility with
44scrollkeeper.
45
46%package devel
47Group: Development/Libraries
48Summary: Development files for Rarian
49Summary(ja): Rarian 用開発ファイル
50Requires: rarian = %{version}-%{release}
51Requires: pkgconfig
52
53%description devel
54This package contains files required to develop applications that use the
55Rarian library ("librarian").
56
57%prep
58%setup -q
59
60%build
61
62%configure --disable-skdb-update
63make %{?_smp_mflags}
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68
69mkdir -p $RPM_BUILD_ROOT%{_datadir}/xml/scrollkeeper/dtds
70cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/xml/scrollkeeper/dtds
71
72rm -rf $RPM_BUILD_ROOT%{_libdir}/librarian.a
73rm -rf $RPM_BUILD_ROOT%{_libdir}/librarian.la
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%post -p /sbin/ldconfig
79
80%post compat
81%{_bindir}/rarian-sk-update
82
83# Add OMF DTD to XML catalog.
84CATALOG=/etc/xml/catalog
85/usr/bin/xmlcatalog --noout --add "rewriteSystem" \
86  "http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0/scrollkeeper-omf.dtd" \
87  "%{_datadir}/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd" $CATALOG
88/usr/bin/xmlcatalog --noout --add "rewriteURI" \
89  "http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0/scrollkeeper-omf.dtd" \
90  "%{_datadir}/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd" $CATALOG
91
92%postun -p /sbin/ldconfig
93
94%postun compat
95
96# Delete OMF DTD from XML catalog.
97if [ $1 = 0 ]; then
98  CATALOG=/etc/xml/catalog
99  /usr/bin/xmlcatalog --noout --del \
100    "%{_datadir}/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd" $CATALOG
101fi
102
103%files
104%defattr(-,root,root,-)
105%doc README COPYING COPYING.LIB COPYING.UTILS ChangeLog NEWS AUTHORS
106%{_bindir}/rarian-example
107%{_libdir}/librarian.so.*
108%{_datadir}/librarian
109%{_datadir}/help
110
111%files compat
112%defattr(-,root,root,-)
113%{_bindir}/rarian-sk-*
114%{_bindir}/scrollkeeper-*
115%{_datadir}/xml/scrollkeeper
116
117%files devel
118%defattr(644,root,root,755)
119%{_includedir}/rarian
120%{_libdir}/librarian.so
121%{_libdir}/pkgconfig/rarian.pc
122
123%changelog
124* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.1-4
125- rebuilt with rpm-4.8.1 for pkg-config
126
127* Sat Mar  6 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.8.1-3
128- rebuilt with new toolchain
129- add Requires(post): xml-common to rarian-compat
130
131* Sat Feb 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.8.1-2
132- changed Group to System Environment/Libraries
133- changed devel subpackage Group to Development/Libraries
134
135* Tue Sep 16 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.8.1-1vl5
136- new upstream release
137- spec in UTF-8
138
139* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.8.0-1vl5
140- new upstream release
141
142* Sat Mar  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.0-0vl1
143- initial build for Vine
144
145* Mon Feb 18 2008 Matthew Barnes <mbarnes@redhat.com> - 0.7.1-3
146- Require libxml2 in %%post and %%postun (RH bug #433268).
147
148* Sat Feb 09 2008 Matthew Barnes <mbarnes@redhat.com> - 0.7.1-2
149- Install XML DTD for scrollkeeper OMF files (RH bug #431088).
150
151* Tue Jan 08 2008 - Bastien Nocera <bnocera@redhat.com> - 0.7.1-1
152- Update to 0.7.1
153
154* Mon Nov 26 2007 Matthew Barnes <mbarnes@redhat.com> - 0.7.0-1
155- Update to 0.7.0
156
157* Tue Nov 06 2007 Matthew Barnes <mbarnes@redhat.com> - 0.6.0-2
158- Own /usr/share/help (RH bug #363311).
159
160* Wed Sep 12 2007 Matthew Barnes <mbarnes@redhat.com> - 0.6.0-1
161- Update to 0.6.0
162- Remove patch for RH bug #254301 (fixed upstream).
163
164* Thu Aug 30 2007 Matthew Barnes <mbarnes@redhat.com> - 0.5.8-3
165- Add patch for RH bug #254301 (rarian-sk-config --omfdir).
166
167* Wed Aug 22 2007 Matthew Barnes <mbarnes@redhat.com> - 0.5.8-2
168- Mass rebuild
169
170* Mon Aug 13 2007 Matthew Barnes <mbarnes@redhat.com> - 0.5.8-1
171- Update to 0.5.8
172
173* Thu Aug  9 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.6-5
174- Move Provides and Obsoletes in the same package, to
175  avoid unnessary complications
176
177* Sat Aug  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.6-4
178- Add a few missing Requires
179
180* Thu Aug 02 2007 Matthew Barnes <mbarnes@redhat.com> - 0.5.6-3
181- Fix the Obsoletes/Provides relationship.
182
183* Wed Aug 01 2007 Matthew Barnes <mbarnes@redhat.com> - 0.5.6-2
184- More package review feedback (#250150).
185
186* Wed Aug 01 2007 Matthew Barnes <mbarnes@redhat.com> - 0.5.6-1
187- Update to 0.5.6
188
189* Tue Jul 31 2007 Matthew Barnes <mbarnes@redhat.com> - 0.5.4-2
190- Incorporate package review suggestions.
191
192* Mon Jul 30 2007 Matthew Barnes <mbarnes@redhat.com> - 0.5.4-1
193- Initial packaging.
Note: See TracBrowser for help on using the repository browser.