source: projects/specs/branches/6/r/radvd/radvd-vl.spec @ 5648

Revision 5648, 6.5 KB checked in by Takemikaduchi, 12 years ago (diff)

arpscan, aslookup, audacity, black-box, bookview, bumprace, gimp-help, js: new upstream release
libsrtp, gstreamer-filters: new package
others: rebuild

Line 
1# $Id: radvd.spec,v 1.17 2006/11/01 14:54:28 psavola Exp $
2
3%define initdir /etc/rc.d/init.d
4#%(if test -d /etc/init.d/. ; then echo /etc/init.d ; else echo /etc/rc.d/init.d ; fi)
5
6%define RADVD_UID 75
7
8Summary: A Router Advertisement daemon
9Name: radvd
10Version: 1.1
11Release: 2%{?_dist_release}
12# The code includes the advertising clause, so it's GPL-incompatible
13License: BSD-style
14Group: System Environment/Daemons
15Source: http://www.litech.org/radvd/radvd-%{version}.tar.gz
16Requires(pre): chkconfig, /usr/sbin/useradd, /sbin/service, initscripts
17BuildRoot: %{_tmppath}/%{name}-root
18BuildRequires: flex, byacc
19
20%description
21radvd is the router advertisement daemon for IPv6.  It listens to router
22solicitations and sends router advertisements as described in "Neighbor
23Discovery for IP Version 6 (IPv6)" (RFC 2461).  With these advertisements
24hosts can automatically configure their addresses and some other
25parameters.  They also can choose a default router based on these
26advertisements.
27
28Install radvd if you are setting up IPv6 network and/or Mobile IPv6
29services.
30
31%prep
32%setup
33
34%build
35export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
36%configure --with-pidfile=/var/run/radvd/radvd.pid
37make
38# make %{?_smp_mflags}
39# Parallel builds still fail because seds that transform y.tab.x into
40# scanner/gram.x are not executed before compile of scanner/gram.x
41#
42
43%install
44[ $RPM_BUILD_ROOT != "/" ] && rm -rf $RPM_BUILD_ROOT
45
46%makeinstall
47mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
48mkdir -p $RPM_BUILD_ROOT%{initdir}
49mkdir -p $RPM_BUILD_ROOT/var/run/radvd
50
51install -m 644 redhat/radvd.conf.empty $RPM_BUILD_ROOT%{_sysconfdir}/radvd.conf
52install -m 755 redhat/radvd.init $RPM_BUILD_ROOT%{initdir}/radvd
53install -m 644 redhat/radvd.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/radvd
54
55%clean
56[ $RPM_BUILD_ROOT != "/" ] && rm -rf $RPM_BUILD_ROOT
57
58%postun
59if [ "$1" -ge "1" ]; then
60    /sbin/service radvd condrestart >/dev/null 2>&1
61fi
62
63%post
64/sbin/chkconfig --add radvd
65
66%preun
67if [ $1 = 0 ]; then
68   /sbin/service radvd stop >/dev/null 2>&1
69   /sbin/chkconfig --del radvd
70fi
71
72%pre
73
74/usr/sbin/useradd -c "radvd user" -r -M -s /sbin/nologin -u %{RADVD_UID} -d / radvd 2>/dev/null || :
75
76%files
77%defattr(-,root,root)
78%doc COPYRIGHT README CHANGES INTRO.html TODO
79%config(noreplace) %{_sysconfdir}/radvd.conf
80%config(noreplace) /etc/sysconfig/radvd
81%config %{initdir}/radvd
82%dir %attr(-,radvd,radvd) /var/run/radvd/
83%doc radvd.conf.example
84%{_mandir}/*/*
85%{_sbindir}/radvd
86%{_sbindir}/radvdump
87
88%changelog
89* Tue Feb 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1-2
90- rebuild with Vine6 environment
91
92* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
93- new upstream release (includes <BTS:686> fix)
94
95* Fri Oct 10 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-2vl5
96- applied new versioning policy
97
98* Wed Jan 02 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1vl2
99- rebuilt for VineSeed
100
101* Fri Nov 10 2006 yamamoto <yamamoto@yu.vinelinux.org> 1.0-1vl1
102- rebuild for vine 4.0
103
104* Wed Nov  1 2006 Pekka Savola <pekkas@netcore.fi> 1.0-1
105- 1.0; add BuildRequires
106
107* Fri Jan 13 2006 Pekka Savola <pekkas@netcore.fi> 0.9.1-1
108- 0.9.1
109
110* Tue Oct 18 2005 Pekka Savola <pekkas@netcore.fi> 0.9-1
111- 0.9 (also minor spec file cleanup in %%configure).
112
113* Fri Jul  8 2005 Pekka Savola <pekkas@netcore.fi> 0.8-1
114- 0.8.
115- Ship the example config file as %%doc (Red Hat's #159005)
116
117* Mon Feb 21 2005 Pekka Savola <pekkas@netcore.fi> 0.7.3-1
118- 0.7.3.
119
120* Mon Oct 28 2002 Pekka Savola <pekkas@netcore.fi>
121- 0.7.2.
122
123* Tue May  7 2002 Pekka Savola <pekkas@netcore.fi>
124- remove '-g %%{RADVD_GID}' when creating the user, which may be problematic
125  if the user didn't exist before.
126
127* Wed Jan 14 2002 Pekka Savola <pekkas@netcore.fi>
128- 0.7.1.
129
130* Tue Jan  8 2002 Pekka Savola <pekkas@netcore.fi>
131- Change 'reload' to signal HUP to radvd instead or restarting.
132
133* Fri Dec 28 2001 Pekka Savola <pekkas@netcore.fi>
134- License unfortunately is BSD *with* advertising clause, so to be pedantic,
135  change License: to 'BSD-style'.
136
137* Wed Nov 14 2001 Pekka Savola <pekkas@netcore.fi>
138- spec file cleanups
139- update to 0.7.0.
140
141* Wed Jun 20 2001 Pekka Savola <pekkas@netcore.fi>
142- use /sbin/service.
143- update to 0.6.2pl4.
144
145* Sat Apr 28 2001 Pekka Savola <pekkas@netcore.fi>
146- update to 0.6.2pl3.
147
148* Wed Apr 11 2001 Pekka Savola <pekkas@netcore.fi>
149- update to 0.6.2pl2.
150
151* Wed Apr  4 2001 Pekka Savola <pekkas@netcore.fi>
152- update to 0.62pl1.  Bye bye patches!
153- Require: initscripts (should really be with a version providing IPv6)
154- clean up the init script, make condrestart work properly
155- Use a static /etc/rc.d/init.d; init.d/radvd required it anyway.
156
157* Sun Apr  1 2001 Pekka Savola <pekkas@netcore.fi>
158- add patch to chroot (doesn't work well yet, as /proc is used directly)
159- clean up droproot patch, drop the rights earlier; require user-writable
160pidfile directory
161- set up the pidfile directory at compile time.
162
163* Sat Mar 31 2001 Pekka Savola <pekkas@netcore.fi>
164- add select/kill signals patch from Nathan Lutchansky <lutchann@litech.org>.
165- add address syntax checked fix from Marko Myllynen <myllynen@lut.fi>.
166- add patch to check the pid file before fork.
167- add support for OPTIONS sourced from /etc/sysconfig/radvd, provide a nice
168default one.
169- add/delete radvd user, change the pidfile to /var/run/radvd/radvd.pid.
170- fix initscript NETWORKING_IPV6 check.
171
172* Sun Mar 18 2001 Pekka Savola <pekkas@netcore.fi>
173- add droproot patch, change to nobody by default (should use radvd:radvd or
174the like, really).
175
176* Mon Mar  5 2001 Tim Powers <timp@redhat.com>
177- applied patch supplied by Pekka Savola in #30508
178- made changes to initscript as per Pekka's suggestions
179
180* Thu Feb 15 2001 Tim Powers <timp@redhat.com>
181- needed -D_GNU_SOURCE to build properly
182
183* Tue Feb  6 2001 Tim Powers <timp@redhat.com>
184- use %%configure and %%makeinstall, just glob the manpages, cleans
185  things up
186- fixed initscript so that it can be internationalized in the future
187
188* Fri Feb 2 2001 Pekka Savola <pekkas@netcore.fi>
189- Create a single package(source) for glibc21 and glibc22 (automatic
190Requires can handle this just fine).
191- use %%{_mandir} and friends
192- add more flesh to %doc
193- streamline %config file %attrs
194- streamline init.d file a bit:
195   * add a default chkconfig: (default to disable for security etc. reasons;
196     also, the default config isn't generic enough..)
197   * add reload/condrestart
198   * minor tweaks
199   * missing: localization support (initscripts-5.60)
200- use %%initdir macro
201
202* Thu Feb 1 2001 Lars Fenneberg <lf@elemental.net>
203- updated to new release 0.6.2
204
205* Thu Feb 1 2001 Marko Myllynen <myllynen@lut.fi>
206- initial version, radvd version 0.6.1
Note: See TracBrowser for help on using the repository browser.