source: projects/specs/branches/6/p/python/python-vl.spec @ 3515

Revision 3515, 31.0 KB checked in by iwaim, 13 years ago (diff)

python 2.6.6-4

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define unicode  ucs4
4%define bsddb_ver 4.8
5%define tcl_major 8.4
6%define tk_major 8.4
7%define tix_major 8.4
8%define pybasever 2.6
9%define python_lib %{_libdir}/python%{pybasever}
10
11Summary: An interpreted, interactive, object-oriented programming language.
12Summary(ja): オブジェクト指向言語 Python インタプリタ
13Name: python
14Version: %{pybasever}.6
15Release: 4%{?_dist_release}
16License: Modified CNRI Open Source License
17Group: Development/Languages
18URL: http://www.python.org/%{pybasever}/
19Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
20Source1: http://docs.python.org/archives/python-%{version}-docs-html.tar.bz2
21Source6: shmmodule.c
22
23# For TEST
24Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
25Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
26Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
27Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
28Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
29Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
30Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
31Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
32Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
33Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
34Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
35Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
36Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
37Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
38
39Patch0: python-2.6.5-Setup.dist.patch
40Patch1: python-2.6.6-lib64.patch
41Patch3: Python-2.2.1-pydocnogui.patch
42Patch5: Python-2.3.3-distutilrpm.patch
43
44Patch10: python-2.6-db48.patch
45Patch11: http://bugs.python.org/file16549/python-support_bdb-4.8-v2.patch
46
47Obsoletes: python2
48Obsoletes: Distutils
49Obsoletes: python-base
50Provides: Distutils
51# <BTS:VineLinux:1121>
52Obsoletes: pysqlite <= 2.6.1-1vl6
53Provides: pysqlite
54
55BuildRequires: db4-devel >= 4.8
56BuildRequires: gzip tar gcc-c++ pkgconfig sed findutils
57BuildRequires: bzip2-devel
58BuildRequires: gdbm-devel
59BuildRequires: glibc-devel
60BuildRequires: ncurses-devel
61BuildRequires: openssl-devel
62BuildRequires: readline-devel
63BuildRequires: sqlite3-devel
64BuildRequires: zlib-devel
65BuildRequires: expat-devel
66BuildRequires: libtermcap-devel, gmp-devel
67#BuildRequires: tetex-latex
68Requires: bzip2
69Requires: gdbm
70Requires: ncurses
71Requires: openssl
72Requires: readline
73Requires: sqlite3
74Requires: zlib
75BuildRoot: %{_tmppath}/%{name}-%{version}-root
76
77
78%description
79Python is an interpreted, interactive, object-oriented programming
80language.  It incorporates modules, exceptions, dynamic typing, very high
81level dynamic data types, and classes. Python combines remarkable power
82with very clear syntax. It has interfaces to many system calls and
83libraries, as well as to various window systems, and is extensible in C or
84C++. It is also usable as an extension language for applications that need
85a programmable interface.  Finally, Python is portable: it runs on many
86brands of UNIX, on PCs under Windows, MS-DOS, and OS/2, and on the
87Mac.
88
89%package devel
90Summary: The libraries and header files needed for Python development.
91Summary(ja): Python での開発に必要なライブラリやヘッダファイル
92Group: Development/Libraries
93Obsoletes: python2-devel
94
95%description devel
96The Python programming language's interpreter can be extended with
97dynamically loaded extensions and can be embedded in other programs.
98This package contains the header files and libraries needed to do
99these types of tasks.
100
101Install python-devel if you want to develop Python extensions.  The
102python package will also need to be installed.  You'll probably also
103want to install the python-docs package, which contains Python
104documentation.
105
106%package tools
107Summary: A collection of development tools included with Python.
108Summary(ja): Python に含まれる開発ツール一式
109Group: Development/Tools
110Requires: %{name} = %{version}
111Requires: tkinter = %{version}
112Obsoletes: python2-tools
113
114%description tools
115The Python package includes several development tools that are used
116to build python programs.  This package contains a selection of those
117tools, including the IDLE Python IDE.
118
119Install python-tools if you want to use these tools to develop
120Python programs.  You will also need to install the python and
121tkinter packages.
122
123%package docs
124Summary: Documentation for the Python programming language.
125Summary(ja): Python プログラミング言語のドキュメント
126Group: Applications/Documentation
127Obsoletes: python2-docs
128
129%description docs
130Documentation relating to the Python programming language in HTML and info
131formats.
132
133%package -n tkinter
134Summary: A graphical user interface for the Python scripting language.
135Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
136Group: Development/Languages
137Obsoletes: tkinter2
138Requires: %{name} = %{version}
139Requires: tcl, tk, tix
140BuildRequires: nkf
141BuildRequires: tcl, tk, tix
142BuildRequires: xorg-x11-devel mesa-libGL-devel
143
144
145%description -n tkinter
146The Tkinter (Tk interface) program is an graphical user interface for
147the Python scripting language.
148
149You should install the tkinter package if you'd like to use a graphical
150user interface for Python programming.
151
152%prep
153%setup -q -n Python-%{version}
154%patch0 -p1 -b .~Setup
155%if %{_lib} == lib64
156%patch1 -p2 -b .~lib64
157%endif
158%patch3 -p1 -b .~no_gui
159%patch5 -p1 -b .~distutilrpm
160
161## for bsddb-4.8
162# %patch10 -p1 -b .db48
163%patch11 -p0 -b .~db48-v2
164
165# shm module
166cp %{SOURCE6} Modules
167cat >> Modules/Setup.dist << EOF
168
169# Shared memory module
170shm shmmodule.c
171EOF
172
173# Fix library flags
174pushd Modules
175mv Setup.dist Setup.dist.tmp
176cat Setup.dist.tmp \
177        | sed "s^-ldb-^-ldb-%{bsddb_ver}^" \
178        | sed "s^-ltcl^-ltcl%{tcl_major}^" \
179        | sed "s^-ltk^-ltk%{tk_major}^" \
180        | sed "s^-ltix^-ltix%{tix_major}^" \
181        > Setup.dist
182rm -f Setup.dist.tmp
183popd
184
185
186%build
187topdir=`pwd`
188export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
189export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
190export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
191export LINKCC="gcc"
192if pkg-config openssl ; then
193        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
194        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
195fi
196%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
197make OPT="$CFLAGS" %{?_smp_mflags}
198
199export LD_LIBRARY_PATH=$topdir
200export PATH="$topdir:$PATH"
201cp $topdir/python $topdir/python%{pybasever}
202$topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
203make OPT="$CFLAGS" %{?_smp_mflags}
204
205
206%if %{run_test}
207## Test
208#cp %{SOURCE7} ./
209#cp %{SOURCE8} ./
210#cp %{SOURCE9} ./
211#cp %{SOURCE10} ./
212#cp %{SOURCE11} ./
213#cp %{SOURCE12} ./
214#cp %{SOURCE13} ./
215#cp %{SOURCE14} ./
216#cp %{SOURCE15} ./
217#cp %{SOURCE16} ./
218#cp %{SOURCE17} ./
219#cp %{SOURCE18} ./
220#cp %{SOURCE19} ./
221#cp %{SOURCE20} ./
222# not nesessary?
223
224## This runs the test set twice (once with no compiled files, once with
225## the compiled files left by the previous test run).
226find ./Lib -name '*.py[co]' -print | xargs rm -f
227LD_LIBRARY_PATH=$topdir:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
228PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages
229PYTHONPATH=$PYTHONPATH:$LD_LIBRARY_PATH
230PYTHONHOME=$topdir
231export PYTHONHOME PYTHONPATH LD_LIBRARY_PATH
232./python -tt -E ./Lib/test/regrtest.py -l -w
233./python -tt -E ./Lib/test/regrtest.py -l -w
234## Mon Mar 22 2010: last tested
235## 328 tests OK.
236## 1 test failed: test_pydoc
237## 37 tests skipped:
238%endif
239
240
241%install
242rm -fr $RPM_BUILD_ROOT
243mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
244
245# Clean up patched .py files that are saved as .lib64
246for f in distutils/command/install distutils/sysconfig; do
247    rm -f Lib/$f.py.lib64
248done
249
250# Temporary workaround to avoid confusing find-requires: don't ship the tests
251# as executable files
252chmod 0644 Lib/test/test_*.py
253
254make DESTDIR=$RPM_BUILD_ROOT install
255
256# Fix the interpreter path in binaries installed by distutils
257# (which changes them by itself)
258# Make sure we preserve the file permissions
259for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
260    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
261        && cat $fixed- > $fixed && rm -f $fixed-
262done
263
264
265## tools
266mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
267
268echo "#!/bin/bash
269exec %{python_lib}/site-packages/pynche/pynche" \
270        > $RPM_BUILD_ROOT/usr/bin/pynche
271chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche
272
273echo "#!/bin/bash
274exec %{python_lib}/site-packages/modulator/modulator.py" \
275        > $RPM_BUILD_ROOT/usr/bin/modulator
276chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator
277
278# idle
279mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
280install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
281chmod 755 $RPM_BUILD_ROOT/usr/bin/idle
282
283#modulator
284cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
285
286#pynche
287rm -f Tools/pynche/*.pyw
288cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
289
290(mv Tools/modulator/README Tools/modulator/README.modulator)
291(mv Tools/pynche/README Tools/pynche/README.pynche)
292
293#gettext
294install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/
295install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/
296
297# Get rid of crap
298find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
299find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
300find . -name "*~"|xargs rm -f
301find . -name ".cvsignore"|xargs rm -f
302#zero length
303rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
304
305# Clean up the testsuite - we don't need compiled files for it
306find $RPM_BUILD_ROOT%{python_lib}/test \
307    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
308rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
309
310find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
311
312## Fix the file permissions
313chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
314chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
315find $RPM_BUILD_ROOT%{python_lib} -type f -name '*.py' | xargs chmod -x
316
317## docs
318if [ -d Doc/html ] ; then
319        rm Doc/html
320fi
321tar xvzf %SOURCE1
322mv python-%{version}-docs-html Doc/html
323
324
325%clean
326rm -fr $RPM_BUILD_ROOT
327
328
329%files -f dynfiles
330%defattr(-, root, root)
331%doc LICENSE README
332%{_bindir}/%{name}*
333%{_mandir}/*/*
334%{_libdir}/libpython%{pybasever}.so*
335%dir %{python_lib}
336%dir %{python_lib}/lib-dynload
337%dir %{python_lib}/site-packages
338%{python_lib}/*.py*
339%{python_lib}/*.doc
340%{python_lib}/bsddb
341%{python_lib}/compiler
342%{python_lib}/ctypes
343%{python_lib}/curses
344%{python_lib}/distutils
345%{python_lib}/email
346%{python_lib}/encodings
347%{python_lib}/hotshot
348%{python_lib}/idlelib
349%{python_lib}/json
350%{python_lib}/lib2to3
351%{python_lib}/logging
352%{python_lib}/multiprocessing
353%{python_lib}/plat-linux2
354%{python_lib}/sqlite3
355%{python_lib}/wsgiref
356%{python_lib}/wsgiref.egg-info
357%{python_lib}/xml
358
359%files devel
360%defattr(-,root,root)
361%{_includedir}/*
362%{python_lib}/config
363%{python_lib}/test
364
365%files tools
366%defattr(-,root,root,755)
367%doc Tools/modulator/README.modulator
368%doc Tools/pynche/README.pynche
369%{python_lib}/site-packages
370%{_bindir}/2to3
371%{_bindir}/idle
372%{_bindir}/modulator
373%{_bindir}/msgfmt.py
374%{_bindir}/pydoc
375%{_bindir}/pygettext.py
376%{_bindir}/pynche
377%{_bindir}/smtpd.py
378
379%files docs
380%defattr(-,root,root,755)
381%doc Misc/HISTORY Misc/NEWS  Misc/README Misc/cheatsheet Misc/developers.txt
382%doc Doc/html
383
384%files -n tkinter
385%defattr(-,root,root,755)
386%{python_lib}/lib-tk
387%{python_lib}/lib-dynload/_tkinter.so
388
389
390%changelog
391* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 2.6.6-4
392- add Obsoletes: pysqlite <= 2.6.1-1vl6 (<BTS:VineLinux:1121>)
393- add Provides: pysqlite (<BTS:VineLinux:1121>)
394
395* Tue Feb 22 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.6-3
396- rebuild with tix-8.4.3, file-5.05-2
397
398* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-2
399- rebuild with openssl-1.0.0c
400
401* Wed Aug 25 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.6-1
402- updated python to 2.6.6
403- updated python-docs to 2.6.6
404- updated python-2.6.?-lib64.patch
405
406* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-4
407- rebuilt with tcl/tk-8.4.19-2
408
409* Mon Mar 22 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-3
410- fixed missing of python-docs files
411- dropt '--with doc' option
412- dropt BR: latex2html
413- replaced descriptions (from Misc/RPM/python-2.6.spec in tar-ball)
414
415* Sun Mar 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-2
416- replaced Patch0: python-2.6.?-Setup.dist.patch
417- replaced Patch1: python-2.6.?-lib64.patch
418- added python-2.6.5-docs-html.tar.bz2
419- dropt Python-2.6.4-Doc.78718.tgz
420
421* Sat Mar 20 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
422- updated python to 2.6.5
423- updated Patch0: Python-2.6.4-Setup.dist.patch
424- added macro bsddb_ver
425- added Patch11: python-support_bdb-4.8-v2.patch (instead of Patch10: python-2.6-db48.patch)
426
427* Sat Mar 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-5
428- added Python-2.6.4-Doc.78718.tgz (documents from http://svn.python.org/projects)
429- changed default to '--with doc' again
430
431* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.4-4
432- rebuilt with gcc-4.4.3-3 on ppc
433- s/BuildPreReq/BuildRequires/
434
435* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
436- replaced Python-%%{version}-Setup.dist.patch
437- added BR: sqlite3-devel
438
439* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-2
440- add Patch10 to build with db-4.8
441
442* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
443- updated python to 2.6.4
444- changed default to '--without doc'
445- added Setup.dist.patch instead of Setup.dist{32,64}.patch
446- updated python-*-lib64.patch to 2.6.3
447
448* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
449- updated python to 2.5.5
450
451* Wed May 06 2009 Shu KONNO <owa@bg.wakwak.com> 2.5.4-4vl5
452- added Python-2.5.4-{Setup,Setup64}.patch
453  - added _bsddb module
454  - dropt patch{0,9,10}
455
456* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4-3vl5
457- updated Patch0 for building with db-4.6.21
458
459* Thu Feb 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.4-2vl5
460- add patch10
461  - add -lcrypt for cryptmodule
462
463* Wed Dec 24 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.4-1vl5
464- new upstream release
465- changed typo of summary(ja)
466
467* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.3-1vl5
468- new upstream release
469- dropt python-2.4.4_CVE-2007-4965.patch
470- dropt python-2.4.4_CVE-2008-1721.patch
471- dropt python-2.4.4-CVE-2008-1679.patch
472
473* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.2-1vl5
474- updated python to 2.5.2
475- added python-2.5.2-config.patch instead of python-2.5c1-config.patch
476- added python-2.5.2-config64.patch instead of python-2.4.3-config.lib64.patch
477- added python-2.5.2-lib64.patch instead of python-2.4.2-lib64.patch
478- added modules ctypes, sqlite3, and wsgiref
479- dropt modules lib-old
480- dropt python-2.4.4_CVE-2008-1887.patch
481- dropt python-2.4.4_CVE-2007-2052.patch
482- fixed the file permissions
483
484* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
485- applied new versioning policy and spec in utf-8
486- added BuildPrereq: xorg-x11-devel
487- imported updates from Vine4.2
488        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
489        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
490        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
491        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
492        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
493        - add patch110 CVE-2008-1721 (zlib module)
494        - add remove unneeded files in Lib/test/
495        #- new versioning policy
496
497* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
498- updated python to 2.4.5
499
500* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
501- rebuild with expat-2.0.1
502
503* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
504- fix typo on Patch0 (s/db-4.2/db-4.3/)
505
506* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
507- rebuild with tcl/tk-8.4.18
508
509* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
510- imported updates from Vine4.2 Plus
511        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
512        - add BuildPrereq: nkf
513        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
514        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
515
516* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
517- rebuilt with openssl-0.9.8e and tix-8.4.2
518- fixed spec file encoding
519
520* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
521- rebuilt with new toolchain and db4-4.3.x
522- modified Patch0 (s/db-4.2/db-4.3/)
523
524* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
525- updated python to 2.4.4 (included security fix PSF-2006-001)
526- added japanese summary
527- updated patch8 (python-2.4.2-lib64.patch)
528- added patch9 (python-2.4.4c1-setup.lib64.patch)
529
530* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
531- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
532
533* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
534- rebuild with readline-5.1 (x86_64)
535
536* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
537- fixed python-2.4.3-config.patch cause undefined symbol: crypt
538
539* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
540- updated python to 2.4.3
541- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
542
543* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
544- set permition of lib-dynload/*.so to 755
545- added without_doc option
546- rebuilt with x86_64
547
548* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
549- add run_test option
550
551* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
552- add BuildPrereq: bzip2-devel
553- arrange testing script
554
555* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
556- back to %%configure macro
557- change testing script
558
559* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
560- update Patch8 (VineSeed:10306)
561- use ./configure instead of %%configure script
562- add forgotten popd
563
564* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
565- add --enable-shared to confiugre option
566- add %%{_libdir}/libpython2.4.so* to python package
567- add LD_LIBRARY_PATH=$topdir to use pathfix.py
568- change build method of Doc
569- add files for make test
570- change install method
571
572* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
573- update python to 2.4.2 (final)
574
575* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
576- update python to 2.4.1 (final)
577
578* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
579- update python to 2.4.1c2
580- moved all site-packages files to python-tools package
581
582* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
583- update python to 2.4.1c1
584- droped aspython2 macros
585- droped japanese-codecs module
586- droped Source2 idle, now it's provided from original source
587- droped Source3 modulator, now it's generated in a spec file
588- droped Source4 pynche, now it's generated in a spec file
589- droped Python-2.3.3-buildroot-bytecode.patch
590- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
591
592* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
593- update python to 2.3.5
594
595* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
596- add PSF-2005-001.patch
597
598* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
599- rebuilt
600
601* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
602- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
603
604* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
605- rebuilt with db4-4.2.25
606
607* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
608- updated python to 2.3.4
609- fixed patch10, patch11
610
611* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
612- rebuild
613
614* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
615- updated python-2.3.3-config2.patch
616
617* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
618- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
619
620* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
621- updated python to 2.3.3
622- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
623- updated config2.patch for 2.3.3
624- updated nowhatsnew.patch for 2.3.3
625- updated distutilrpm.patch in which tabstops have made indent error
626- updated buildroot-bytecode.patch for 2.3.3
627- deleted buildroot.patch which fixed in 2.3.3
628- changed Tools/idle with Lib/idlelib
629
630* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
631- rebuild with openssl-0.9.7d
632
633* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
634- updated JapaneseCodecs to 1.4.10
635
636* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
637- synced with RawHide 2.2.3-3 (substantially source ver up)
638
639* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
640- rebuild with tcltk-8.4.2
641- synced with RawHide 2.2.2-26
642  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
643  - rebuilt
644
645  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
646  - Fixed bug #84886: pydoc dies when run w/o arguments
647  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
648  - Fixed bug #84966: path in byte-compiled code still wrong
649
650  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
651  - ftp uri's should be able to specify being rooted at the root instead of
652    where you login via ftp (#84692)
653
654  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
655  - Using newer Japanese codecs (1.4.9). Thanks to
656    Peter Bowen <pzb@datastacks.com> for pointing this out.
657
658  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
659  - Rebuild
660
661  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
662  - Release number bumped really high: turning on UCS4 (ABI compatibility
663    breakage)
664
665  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
666  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
667    some work on python-2.2.2-lib64.patch
668
669  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
670  - Rebuild to incorporate the removal of .lib64 and - files.
671
672  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
673  - Fixed bug #82544: Errata removes most tools
674  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
675  - Removed .lib64 and - files that get installed after we fix the multilib
676    .py files.
677
678  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
679  - rebuilt
680
681  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
682  - rebuild to update tkinter's tcltk deps
683  - convert changelog to utf-8
684
685
686* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
687- rebuilt for Vine Linux against db4
688- obsolete python-base (which comes with python-2.2.1 of TestPkg)
689
690* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
691- rebuild
692
693* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
694- pick up OpenSSL cflags and ldflags from pkgconfig if available
695
696* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
697- urllib2 didn't support non-anonymous ftp.  add support based on how
698  urllib did it (#80676, #78168)
699
700* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
701- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
702- Added a bunch of missing BuildRequires found while fixing the
703  above-mentioned bug
704
705* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
706- rebuild to fix broken tcltk deps for tkinter
707
708* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
7092.2.2-3.7.3
710- Recompiled for 7.3 (to fix the -lcrypt bug)
711- Fix for the spurious error message at the end of the build (build-requires
712  gets confused by executable files starting with """"): make the tests
713  non-executable.
714
715* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
7162.2.2-5
717- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
718
7192.2.2-4
720- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
721  with the C++ compiler.
722
723* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
7242.2.2-3.*
725- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
726  use %%{_libdir}
727- Added XFree86-libs as BuildRequires (because of tkinter)
728- Fixed duplicate listing of plat-linux2
729- Fixed exclusion of lib-dynload/japanese
730- Added lib64 patch for the japanese codecs
731- Use setup magic instead of using tar directly on JapaneseCodecs
732
733* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
7342.2.2-2
735- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
736  requirement of tkinter from python-tools).
737- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
738
739* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
740- builds as python2 require a different libdb
741- changed the buildroot name of python to match python2 builds
742
743* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
744- updated python to 2.2.2 and adjusted the patches accordingly
745
746* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
747- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
748- Added BuildPrereq dependency on gcc-c++
749
750* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
751- security fix for _execvpe
752
753* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
754- Fix  #71011,#71134, #58157
755
756* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
757- Resurrect tkinter
758- Fix for distutils (#67671)
759- Fix #69962
760
761* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
762- Obsolete tkinter/tkinter2 (#69838)
763
764* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
765- Doc fixes (#53951) - not on alpha at the momemt
766
767* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
768- fix pydoc (#68082)
769
770* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
771- Add db4-devel as a BuildPrereq
772
773* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
774- automated rebuild
775
776* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
777- Add Japanese codecs (#66352)
778
779* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
780- No more tkinter...
781
782* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
783- Rebuild
784
785* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
786- Add the email subcomponent (#65301)
787
788* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
789- Rebuild
790
791* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
792- rebuild i new enviroment
793
794* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
795- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
796
797* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
798- Make it use db4
799
800* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
801- 2.2.1 - a bugfix-only release
802
803* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
804- the same, but in builddirs - this will remove them from the
805  docs package, which doesn't look in the buildroot for files.
806
807* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
808- Get rid of temporary files and .cvsignores included
809  in the tarball and make install
810
811* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
812- Don't own lib-tk in main package, only in tkinter (#62753)
813
814* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
815- rebuild
816
817* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
818- rebuild
819
820* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
821- Add a not to the Distutils obsoletes test (doh!)
822
823* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
824- Rebuild
825
826* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
827- Only obsolete Distutils when built as python
828
829* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
830- Make files in /usr/bin install side by side with python 1.5 when
831- Drop explicit requirement of db4
832  built as python2
833
834* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
835- Use version and pybasever macros to make updating easy
836- Use _smp_mflags macro
837
838* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
839- Add db4-devel to BuildPrereq
840
841* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
842- disable ndbm support, which is db2 in disguise (really interesting things
843  can happen when you mix db2 and db4 in a single application)
844
845* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
846- Obsolete subpackages if necesarry
847- provide versioned python2
848- build with db4
849
850* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
851- Alpha toolchain broken. Disable build on alpha.
852- New openssl
853
854* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
855- 2.2 final
856
857* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
858- 2.2 RC 1
859- Don't include the _tkinter module in the main package - it's
860  already in the tkiter packace
861- Turn off the mpzmodule, something broke in the buildroot
862
863* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
864- Use -fPIC for OPT as well, in lack of a proper libpython.so
865
866* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
867- changed DESTDIR to point to / so that distutils will install dynload
868  modules properly in the installroot
869
870* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
871- 2.2b2
872
873* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
874- python2ify
875
876* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
877- 2.2b1
878
879* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
880- 2.2a4
881- Enable UCS4 support
882- Enable IPv6
883- Provide distutils
884- Include msgfmt.py and pygettext.py
885
886* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
887- Obsolete Distutils, which is now part of the main package
888- Obsolete python2
889
890* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
891- Add docs, tools and tkinter subpackages, to match the 1.5 layout
892
893* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
894- 2.2a3
895- don't build tix and blt extensions
896
897* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
898- Add tk and tix to build dependencies
899
900* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
901- 2.1.1 bugfix release - with a GPL compatible license
902
903* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
904- Add new build dependencies (#49753)
905
906* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
907- build with -fPIC
908
909* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
910- 2.1
911- reorganization of file includes
912
913* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
914- fix the "requires" clause, it lacked a space causing problems
915- use %%{_tmppath}
916- don't define name, version etc
917- add the available patches from the Python home page
918
919* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
920- added devel subpackage
921
922* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
923- modify all files to use "python2.0" as the intrepter
924- don't build the Expat bindings
925- build against db1
926
927* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
928- updated for 2.0 final
929
930* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
931- updated for 2.0c1
932- build audioop, imageop, and rgbimg extension modules
933- include xml.parsers subpackage
934- add test.xml.out to files list
935
936* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
937- added bin/python2.0 to files list (suggested by Martin v. Loewis)
938
939* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
940- updated for release 1 of 2.0b2
941- use .bz2 version of Python source
942
943* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
944- Version 2 of 2.0b1
945- Make the package relocatable.  Thanks to Suchandra Thapa.
946- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
947  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.