source: projects/specs/branches/6/p/python-simplejson/python-simplejson-vl.spec @ 2258

Revision 2258, 5.6 KB checked in by owa, 13 years ago (diff)

python-* new upstream

Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%global _use_internal_dependency_generator 0
4%global __find_provides /bin/sh -c "%{_rpmconfigdir}/find-provides | grep -v -E '(_speedups.so)' || /bin/true"
5%global __find_requires /bin/sh -c "%{_rpmconfigdir}/find-requires | grep -v -E '(_speedups.so)' || /bin/true"
6
7Name:           python-simplejson
8
9Version:        2.1.2
10Release:        1%{?_dist_release}
11Summary:        Simple, fast, extensible JSON encoder/decoder for Python
12
13Group:          System Environment/Libraries
14# The main code is licensed MIT.
15# The docs include jquery which is licensed MIT or GPLv2
16License: MIT and (MIT or GPLv2)
17URL:            http://undefined.org/python/#simplejson
18Source0:        http://pypi.python.org/packages/source/s/simplejson/simplejson-%{version}.tar.gz
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
20
21BuildRequires:  python-devel
22BuildRequires:  python-setuptools
23BuildRequires:  python-nose
24
25
26%description
27simplejson is a simple, fast, complete, correct and extensible JSON
28<http://json.org> encoder and decoder for Python 2.5+. It is pure Python code
29with no dependencies, but includes an optional C extension for a serious speed
30boost.
31
32simplejson is the externally maintained development version of the json library
33included with Python 2.6 and Python 3.0, but maintains backwards compatibility
34with Python 2.5.
35
36The encoder may be subclassed to provide serialization in any kind of
37situation, without any special support by the objects to be serialized
38(somewhat like pickle).
39
40The decoder can handle incoming JSON strings of any specified encoding (UTF-8
41by default).
42
43
44%prep
45%setup -q -n simplejson-%{version}
46
47
48%build
49%{__python} setup.py build
50
51
52%install
53%__rm -rf $RPM_BUILD_ROOT
54%{__python} setup.py install --skip-build --root=$RPM_BUILD_ROOT
55
56%check
57nosetests -q
58
59%clean
60%__rm -rf $RPM_BUILD_ROOT
61
62
63%files
64%defattr(-,root,root,-)
65%doc docs LICENSE.txt
66%dir %{python_sitearch}/simplejson
67%{python_sitearch}/simplejson-*.egg-info
68%{python_sitearch}/simplejson/*.py*
69%{python_sitearch}/simplejson/tests/*.py*
70%{python_sitearch}/simplejson/_speedups.so
71
72
73%changelog
74* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> - 2.1.2-1
75- updated simplejson to 2.1.2
76
77* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 2.1.1-1
78- initial build based on Fedora development
79
80* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.1-3
81- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
82
83* Wed Jun 30 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 2.1.1-2
84- Filter unnecessary provides
85- License tag update
86- Minor spec file cleanups
87
88* Mon Jun 21 2010 Kyle VanderBeek <kylev@kylev.com> - 2.1.1-1
89- Update to 2.1.1
90
91* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.9-3
92- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
93
94* Fri Jun  5 2009 Kyle VanderBeek <kylev@kylev.com> - 2.0.9-2
95- Remove ill-advised gcc BuildRequires
96
97* Thu Jun  4 2009 Kyle VanderBeek <kylev@kylev.com> - 2.0.9-1
98- Update to 2.0.9
99- Make sure to require gcc to the speedups get compiled
100- Fix description since we're not "pure" python
101- Change to pypi instead of cheesehop
102
103* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.7-2
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
105
106* Tue Jan 06 2009 Luke Macken <lmacken@redhat.com> 2.0.7-1
107- Update to 2.0.7
108
109* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.3-3
110- Rebuild for Python 2.6
111
112* Thu Oct 23 2008 Luke Macken <lmacken@redhat.com> 2.0.3-2
113- Use nose to run the simplejson test suite
114
115* Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-1
116- update to 2.0.3
117
118* Wed Oct 01 2008 Luke Macken <lmacken@redhat.com> - 2.0.1-1
119- Update to 2.0.1, which contains many optimizations and bugfixes
120
121* Wed Sep 24 2008 Luke Macken <lmacken@redhat.com> - 1.9.3-1
122- Update to 1.9.3, which includes a significant decoding speed boost, and
123  various bug fixes.
124
125* Tue May 06 2008 Luke Macken <lmacken@redhat.com> - 1.9.1-1
126- Update to 1.9.1
127
128* Wed Apr 02 2008 Luke Macken <lmacken@redhat.com> - 1.8.1-1
129- Update to 1.8.1
130
131* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> - 1.7.4-1
132- Update to 1.7.4
133
134* Fri Feb  8 2008 Luke Macken <lmacken@redhat.com> - 1.7.3-3
135- Rebuild for gcc 4.3
136
137* Wed Oct 24 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-2
138- Include the LICENSE.txt
139
140* Wed Oct  3 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-1
141- 1.7.3
142
143* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-3
144- Update for python-setuptools changes in rawhide
145
146* Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-2
147- Rebuild
148
149* Sun Jul  8 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-1
150- 1.7.1
151
152* Wed Mar 21 2007 Luke Macken <lmacken@redhat.com> - 1.7-2
153- Use python_sitearch instead of sitelib
154
155* Tue Mar 20 2007 Luke Macken <lmacken@redhat.com> - 1.7-1
156- 1.7 (Bug #233212)
157
158* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> - 1.5
159- 1.5
160
161* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> - 1.4-4
162- Add python-devel to BuildRequires
163
164* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> - 1.4-2
165- Rebuild for new python
166
167* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> - 1.4-1
168- 1.4
169
170* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> - 1.3-4
171- Rebuild for FC6
172
173* Mon Aug 14 2006 Luke Macken <lmacken@redhat.com> - 1.3-3
174- Include .pyo's instead of just ghosting them
175
176* Wed Jul 12 2006 Luke Macken <lmacken@redhat.com> - 1.3-2
177- Add --single-version-externally-managed flag to install
178
179* Mon Jul 10 2006 Luke Macken <lmacken@redhat.com> - 1.3-1
180- Initial package
Note: See TracBrowser for help on using the repository browser.