source: projects/specs/branches/6/p/python-setuptools/python-setuptools-vl.spec @ 521

Revision 521, 3.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           python-setuptools
4Version:        0.6c11
5Release:        1%{?_dist_release}
6Summary:        Download, build, install, upgrade, and uninstall Python packages
7Summary(ja):     Python パッケージのダウンロード、ビルド、インストール、アップグレードおよびアンインストール用ツール
8Group:          Development/Tools
9License:        PSFL/ZPL
10URL:            http://peak.telecommunity.com/DevCenter/setuptools
11Source0:        http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}.tar.gz
12Source1:        psfl.txt
13Source2:        zpl.txt
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildArch:      noarch
17BuildRequires:  python-devel
18
19%description
20setuptools is a collection of enhancements to the Python distutils that allow
21you to more easily build and distribute Python packages, especially ones that
22have dependencies on other packages.
23
24%description -l ja
25setuptools は Python distutils の拡張機能を集めたツールです。
26このツールにより Python パッケージの構築や配布が簡単に行えるように
27なります。特に他のパッケージに依存しているパッケージを扱う際に便利
28です。
29
30
31%prep
32%setup -q -n setuptools-%{version}
33find -name '*.py' | xargs sed -i '1s|^#!python|#!%{__python}|'
34
35
36%build
37CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
38
39
40%install
41rm -rf $RPM_BUILD_ROOT
42%{__python} setup.py install -O1 --skip-build \
43    --root $RPM_BUILD_ROOT \
44    --single-version-externally-managed
45install -p -m 0644 %{SOURCE1} %{SOURCE2} .
46find $RPM_BUILD_ROOT%{python_sitelib} -name '*.exe' | xargs rm -f
47
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52
53%files
54%defattr(-,root,root,-)
55%doc *.txt
56%{_bindir}/*
57%{python_sitelib}/*
58
59
60%changelog
61* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.6c11-1
62- new upstream release
63
64* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.6c9-2
65- rebuild with python-2.6
66
67* Sun Dec 07 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6c9-1
68- new upstream release
69- add japanese summary and description
70
71* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> - 0.6c3-1vl5
72- rebuilt with python-2.5.2
73- applied new versioning policy
74
75* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6c3-1vl2
76- rebuilt for Vine Linux 4.0
77- changed Group to Development/Tools
78
79* Wed Nov 15 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
80- Refurbished for VineLinux3.2
81
82* Tue Sep 12 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c2-1
83- Upstream 0.6c2
84- Ghostbusting
85
86* Mon Jul 31 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c1-2
87- Set perms on license files (#200768)
88
89* Sat Jul 22 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c1-1
90- Version 0.6c1
91
92* Wed Jun 28 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6b3-1
93- Taking over from Ignacio
94- Version 0.6b3
95- Ghost .pyo files in sitelib
96- Add license files
97- Remove manual python-abi, since we're building FC4 and up
98- Kill .exe files
99
100* Wed Feb 15 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a10-1
101- Upstream update
102
103* Mon Jan 16 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a9-1
104- Upstream update
105
106* Sat Dec 24 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a8-1
107- Initial RPM release
Note: See TracBrowser for help on using the repository browser.