source: projects/specs/branches/6/p/python-pyxml/python-pyxml-vl.spec @ 5795

Revision 5795, 3.8 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild package

Line 
1%define module PyXML
2#%define pyver %(python -c 'import sys;print(sys.version[0:3])')
3#%define pysite %{_libdir}/python%{pyver}/site-packages
4%define pyinc %{_includedir}/python%{pyver}
5Summary:        XML libraries for python
6Summary(ja):    Python XML ライブラリ
7Name:           python-pyxml
8Version:        0.8.4
9Release:        6%{?_dist_release}
10URL:            http://pyxml.sourceforge.net/
11Source0:        http://prdownloads.sourceforge.net/pyxml/PyXML-%{version}.tar.gz
12Patch0:         PyXML-0.7.1-intern.patch
13Patch1:         PyXML-0.8.4-cvs20041111-python2.4-backport.patch
14Patch2:         PyXML-memmove.patch
15Patch3:         PyXML-0.8.4-python2.6.patch
16
17License:        Apacheish
18Group:          Development/Libraries
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  python-devel, expat-devel
22BuildRequires:  python-setuptools
23Requires:       python, libexpat
24Obsoletes:      %{module}
25Provides:       %{module}
26
27%description
28An XML package for Python. The distribution contains a validating XML
29parser, an implementation of the SAX and DOM programming interfaces
30and an interface to the Expat parser.
31
32%prep
33%setup -q -n %{module}-%{version}
34%patch0 -p1 -b .intern
35%patch1 -p1 -b .python2.4-backport
36%patch2 -p1
37%patch3 -p1
38
39# iconv to use utf8
40for file in CREDITS ANNOUNCE doc/xml-howto.txt doc/xml-ref.txt README; do
41  iconv -f iso8859-1 -t utf-8 -o tmp $file
42  mv tmp $file
43done
44
45%build
46CFLAGS="%{optflags}" \
47        %{_bindir}/python -c 'import setuptools; execfile("setup.py")' build --with-libexpat=%{_prefix}
48
49%install
50%__rm -rf %{buildroot}
51%{_bindir}/python -c 'import setuptools; execfile("setup.py")' install --skip-build install --root=%{buildroot}
52
53%{_bindir}/python -O %{_libdir}/python%{pyver}/compileall.py \
54        %{buildroot}%{python_sitearch}
55
56%clean
57%__rm -rf %{buildroot}
58
59%files
60%defattr(-,root,root)
61%doc LICENCE ANNOUNCE CREDITS README README.* TODO doc/*
62%{_bindir}/*
63%{python_sitearch}/*
64
65%changelog
66* Thu Mar 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.4-6
67- rebuild with Vine6 environment
68
69* Sat Jun 06 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.4-5
70- rebuilt with python-2.6
71- added Patch0-4 from Fedora
72  * Wed Dec 24 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 0.8.4-12
73  - Patch for 'as' reserved keyword (bug #477783)
74  * Thu Jul 27 2006 Florian La Roche <laroche@redhat.com> - 0.8.4-4
75  - don't check memmove
76  * Thu Nov 11 2004 Miloslav Trmac <mitr@redhat.com> - 0.8.4-0.cvs20041111.1
77  - Backport xml.sax.saxutils fix from Python 2.4b2
78  * Fri Jun 28 2002 Trond Eivind Glomsrød <teg@redhat.com>
79  - A fix for the expatreader
80
81* Sat Jun 06 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.4-4
82- spec in utf-8 properly
83- use rpm macros: pyver, python_sitearch
84
85* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.4-3vl5
86- rebuilt with python-2.5.2
87- applied new versioning policy and spec in utf-8
88
89* Wed Feb 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.8.4-2vl3
90- rebuild with expat-2.0.1
91
92* Mon May  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.4-2vl2
93- fixed Japanese summary
94- changed Group:
95
96* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.4-2vl1
97- initial build for Vine Linux
98
99* Wed May  4 2005 Gotz Waschk <waschk@mandriva.org> 0.8.4-2mdk
100- use external libexpat
101- enable xpath and xslt
102
103* Thu Dec 16 2004 Guillaume Rousse <guillomovitch@mandrake.org> 0.8.4-1mdk
104- new version
105- changed name
106
107* Sun Dec 05 2004 Michael Scherer <misc@mandrake.org> 0.8.3-4mdk
108- Rebuild for new python
109
110* Mon Nov 01 2004 Michael Scherer <misc@mandrake.org> 0.8.3-3mdk
111- [DIRM]
112
113* Sat Apr 10 2004 Michael Scherer <misc@mandrake.org> 0.8.3-2mdk
114- [DIRM]
115
116* Wed Aug 20 2003 Austin Acton <aacton@yorku.ca> 0.8.3-1mdk
117- 0.8.3
118
119* Tue Aug 12 2003 Per Oyvind Karlsen <peroyvind@linux-mandrake.com> 0.8.2-4mdk
120- rebuild for new python
121
122* Sat Mar 29 2003 David Walluck <walluck@linux-mandrake.com> 0.8.2-3mdk
123- release
124
125* Tue Mar 25 2003 David Walluck <david@anti-microsoft.org> 0.8.2-2plf
126- spec file cleanups
127
128* Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 0.8.2-1plf
129- release
Note: See TracBrowser for help on using the repository browser.