source: projects/specs/branches/6/p/python-pyrex/python-pyrex-vl.spec @ 2387

Revision 2387, 5.1 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define python_sitelib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(0)')
2%define packagename Pyrex
3Name:           python-pyrex
4Version:        0.9.9
5Release:        1%{?_dist_release}
6BuildArch:      noarch
7Summary:        A compiler/language for writing Python extension modules.
8Group:          Development/Languages
9License:        Public Domain
10URL:            http://www.cosc.canterbury.ac.nz/~greg/python/%{packagename}/
11Source0:        http://www.cosc.canterbury.ac.nz/~greg/python/%{packagename}/%{packagename}-%{version}.tar.gz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14BuildRequires:  python-devel
15BuildRequires:  nkf
16BuildRequires:  findutils
17Requires: python-devel
18
19
20%description
21Pyrex is Python with C types.  It is specially designed to allow you to
22write extension modules for Python that have the speed of C and the
23simplicity and readability of Python.  You write your code in a Python-like
24language with C-typed variables, then use the pyrexc compiler to transform
25it into a C representation.  This is useful for speeding up critical sections
26of your Python code or wrapping an external library.
27
28Please see the documentation for how to get the best performance from your
29code.
30
31%prep
32%setup -q -n %{packagename}-%{version}
33
34%build
35python setup.py build
36# Remove some Macintosh-isms
37find . -name '.DS_Store' -exec rm -f \{\} \;
38for i in CHANGES.txt ToDo.txt  Demos/Makefile.nodistutils Tools/*
39do
40  nkf -Lu --in-place $i
41done
42find Doc -type f | xargs nkf -Lu --in-place
43
44%install
45rm -rf $RPM_BUILD_ROOT
46python setup.py install --skip-build --root $RPM_BUILD_ROOT
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%files
52%defattr(-,root,root,-)
53%doc USAGE.txt README.txt CHANGES.txt ToDo.txt Demos Doc Tools
54%{python_sitelib}/Pyrex*
55%exclude %{python_sitelib}/Pyrex/Mac
56%{_bindir}/pyrexc
57
58%changelog
59* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-1
60- new upstream release
61
62* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8.4-2
63- rebuild with python-2.6
64
65* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8.4
66- new upstream release
67
68* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.9.3-1vl5
69- rebuilt with python-2.5.2
70- added pythonlib macro
71- applied new versioning policy
72
73* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
74- initial build for Vine Linux
75
76* Tue Mar 22 2005 Jeremy Katz <katzj@redhat.com> - 0.9.3-0
77- update to 0.9.3
78- add patch to fix generated code to build with gcc4
79- require python-abi and python-devel instead of conflicting with
80  newer python-devel
81
82* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0:0.9.2.1-3
83- rebuild against python 2.4
84
85* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9.2.1-2
86- Added Steve Grubb's spec file patch (RH Bug #130200)
87
88* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9.2.1-1
89- New upstream version
90- Pyrex-0.9-split-base-types.patch synced for new version
91
92* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
93- rebuilt
94
95* Fri Jun 03 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-5
96- Built to rawhide
97
98* Wed May 19 2004 Florian La Roche <Florian.LaRoche@redhat.de>
99- use rpm macros to determine lib64 usage
100
101* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-3
102- Added Pyrex-0.9-split-base-types.patch which fixes
103  long unsigned int bug showing up in dbus python binding
104  builds for the x86_64 arch
105- Added regex hack to spec to work around a bug in python's
106  distutils which would install files into /usr/lib instead of
107  /usr/lib64 on 64 bit archs
108 
109* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-2
110- Was informed that the epoch change was not needed so the epoch
111  was reverted back to 0 
112
113* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> - 1:0.9-1
114- Upped the epoch so as to avoid clashes with the Fedora extra package
115
116* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-1
117- Transfered to Red Hat Fedora's main tree
118- Removed need for LONG_LONG patch
119
120* Mon Feb 02 2004 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.4
121- Removed the site-packages directory from the directories owned by the
122  package
123
124* Mon Feb 02 2004 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.3
125- My mistake: rpm automatically removes %%ghost files, no need to script
126  it manually.
127- python distutils --record=FILE option doesn't record directories so include
128  the site-packages/[directories] manually
129
130* Thu Jan 15 2003 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.2
131- Merge changes from Michel Alexandre Salim <salimma[AT]users.sf.net>
132  + Require build system's python version because directories are named
133    pythonX.Y
134  + Create *.pyo files and %ghost them (Privleged user with python optimize
135    turned on may generate them, but they aren't needed for operation.
136  + Do not include the Mac Pyrex compiler stuff
137  + Change license to Public Domain
138- Script to remove any %%ghost files on package removal
139- Patch around an incompatible change between python 2.2 and python 2.3's
140  definition of LONG_LONG being renamed to PY_LONG_LONG
141 
142* Fri Jan 09 2003 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.1
143- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.