source: projects/specs/branches/6/p/python-nose/python-nose-vl.spec @ 5795

Revision 5795, 3.3 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild package

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
3
4%define pkg_release     3%{?_dist_release}
5
6Name:           python-nose
7Version:        0.10.4
8Release:        %{pkg_release}
9Summary:        A discovery-based unittest extension for Python
10Summary(ja):    Python 用の発見型ユニットテスト・エクステンション
11
12Group:          Development/Languages
13License:        LGPLv2
14URL:            http://somethingaboutorange.com/mrl/projects/nose/
15Source0:        http://somethingaboutorange.com/mrl/projects/nose/nose-%{version}.tar.gz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildArch:      noarch
19BuildRequires:  python-devel, python-setuptools
20Requires:       python-setuptools
21
22
23%description
24nose: a discovery-based unittest extension.
25
26nose provides an alternate test discovery and running process for unittest,
27one that is intended to mimic the behavior of py.test as much as is
28reasonably possible without resorting to too much magic.
29
30
31%prep
32%setup -q -n nose-%{version}
33
34%build
35CFLAGS="${RPM_OPT_FLAGS}" %{__python} setup.py build
36
37%install
38rm -rf ${RPM_BUILD_ROOT}
39%{__python} setup.py install -O1 --skip-build --root ${RPM_BUILD_ROOT} \
40        --single-version-externally-managed --install-data=%{_datadir}
41
42%clean
43rm -rf ${RPM_BUILD_ROOT}
44
45%files
46%defattr(-,root,root,-)
47%doc AUTHORS CHANGELOG lgpl.txt NEWS README.txt
48%{_bindir}/nosetests
49%{_mandir}/man1/nosetests.1.gz
50%{python_sitelib}/nose-%{version}-py%{pyver}.egg-info
51%{python_sitelib}/nose
52
53%changelog
54* Thu Mar 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.4-3
55- rebuild with Vine6 environment
56
57* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.10.4-2
58- rebuild with python-2.6
59
60* Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.4-1
61- initial build for Vine Linux based on fedora package
62
63* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.4-1
64- Update to 0.10.4 to fix 2.6 issues
65
66* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.3-2
67- Rebuild for Python 2.6
68
69* Sat Aug 02 2008 Luke Macken <lmacken@redhat.com> 0.10.3-1
70- Update to 0.10.3
71
72* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> 0.10.1-1
73- Update to 0.10.1
74
75* Mon Dec  3 2007 Luke Macken <lmacken@redhat.com> 0.10.0-2
76- Add python-setuptools to Requires (Bug #408491)
77
78* Tue Nov 27 2007 Luke Macken <lmacken@redhat.com> 0.10.0-1
79- 0.10.0
80
81* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.3.b1
82- Update for python-setuptools changes in rawhide
83
84* Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.2.b1
85- 0.10.0b1
86- Update license tag to LGPLv2
87
88* Fri Jun 20 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.1.a2
89- 0.10.0a2
90
91* Sat Jun  2 2007 Luke Macken <lmacken@redhat.com> 0.9.3-1
92- Latest upstream release
93- Remove python-nose-0.9.2-mandir.patch
94
95* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> 0.9.2-1
96- Add nosetests(1) manpage, and python-nose-0.9.2-mandir.patch to put it in
97  the correct location.
98- 0.9.2
99
100* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> 0.9.1-2
101- Rebuild for python 2.5
102
103* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> 0.9.1-1
104- 0.9.1
105
106* Fri Sep  8 2006 Luke Macken <lmacken@redhat.com> 0.9.0-1
107- 0.9.0
108
109* Wed Apr 19 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.8.7.2-1
110- Initial RPM release
Note: See TracBrowser for help on using the repository browser.