source: projects/specs/branches/6/p/python-mechanize/python-mechanize-vl.spec @ 5795

Revision 5795, 3.2 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild package

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           python-mechanize
4Version:        0.2.2
5Release:        2%{?_dist_release}
6Summary:        Stateful programmatic web browsing
7Summary(ja):    ウェブ・ブラウジング・プログラム用 Python モジュール
8
9Group:          System Environment/Libraries
10License:        BSD
11URL:            http://wwwsearch.sourceforge.net/mechanize
12Source0:        http://wwwsearch.sourceforge.net/mechanize/src/mechanize-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15
16BuildRequires:  python-devel
17BuildRequires:  python-setuptools
18Requires:       python-clientform
19
20
21%description
22Stateful programmatic web browsing, after Andy Lester's Perl module
23WWW::Mechanize.
24
25The library is layered: mechanize.Browser (stateful web browser),
26mechanize.UserAgent (configurable URL opener), plus urllib2 handlers.
27
28Features include: ftp:, http: and file: URL schemes, browser history,
29high-level hyperlink and HTML form support, HTTP cookies, HTTP-EQUIV and
30Refresh, Referer [sic] header, robots.txt, redirections, proxies, and
31Basic and Digest HTTP authentication.  mechanize's response objects are
32(lazily-) .seek()able and still work after .close().
33
34Much of the code originally derived from Perl code by Gisle Aas
35(libwww-perl), Johnny Lee (MSIE Cookie support) and last but not least
36Andy Lester (WWW::Mechanize).  urllib2 was written by Jeremy Hylton.
37
38
39%prep
40%setup -q -n mechanize-%{version}
41
42
43%build
44%{__python} setup.py build
45
46
47%install
48%__rm -rf $RPM_BUILD_ROOT
49%{__python} setup.py install --single-version-externally-managed \
50                             -O1 --root=$RPM_BUILD_ROOT
51
52
53%clean
54%__rm -rf $RPM_BUILD_ROOT
55
56
57%files
58%defattr(-,root,root,-)
59%doc COPYING.txt README.txt docs examples
60%{python_sitelib}/*
61
62
63%changelog
64* Thu Mar 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.2.2-2
65- rebuild with Vine6 environment
66
67* Tue Aug 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.2.2-1
68- new upstream release
69
70* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.10-2
71- rebuild with python-2.6
72
73* Sun Dec 28 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.1.10-1
74- initial build for Vine Linux based on fedora package
75
76* Wed Dec 10 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.1.10-1
77- Update to 0.1.10
78
79* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.1.6-0.3.b
80- Rebuild for Python 2.6
81
82* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> - 0.1.6-0.2.b
83- Update for python-setuptools changes in rawhide
84
85* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> - 0.1.6-0.1.b
86- 0.1.6b
87
88* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> - 0.1.5-0.1.b
89- Rebuild for python 2.5
90- 0.1.5b
91
92* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-5
93- Rebuild for FC6
94
95* Sun Jul  9 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-4
96- Remove unnecessary python-abi requirement
97
98* Wed May 17 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-3
99- Add BuildArch: noarch (bug #192155)
100
101* Sun May 14 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-2
102- Add python-abi Requires
103- Remove noarch
104
105* Thu May 11 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-1
106- Packaged for Fedora Extras
Note: See TracBrowser for help on using the repository browser.