source: projects/specs/branches/6/p/python-iwlib/python-iwlib-vl.spec @ 521

Revision 521, 1.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_ver: %define python_ver %(%{__python} -c "import sys ; print sys.version[:3]")}
3
4Summary: Wireless settings python bindings
5Summary(ja): wireless-tools の python バインディング
6Name: python-iwlib
7Version: 0.1
8Release: 2%{?_dist_release}
9URL: http://git.fedorahosted.org/git/python-iwlib.git
10Source: http://fedorahosted.org/released/python-iwlib/%{name}-%{version}.tar.bz2
11License: GPLv2
12Group: System Environment/Libraries
13ExcludeArch: s390 s390x
14BuildRequires: python-devel
15BuildRequires: wireless-tools-devel
16Requires: wireless-tools
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19%description
20Python bindings for the iwlib kernel interface,
21that provides functions to examine the wireless network devices
22installed on the system.
23
24%prep
25%setup -q
26
27%build
28%{__python} setup.py build
29
30%install
31rm -rf %{buildroot}
32%{__python} setup.py install --skip-build --root %{buildroot}
33mkdir -p %{buildroot}%{_sbindir}
34chmod 755 %{buildroot}%{python_sitearch}/iwlib.so
35
36%clean
37rm -rf %{buildroot}
38
39%files
40%defattr(-,root,root)
41%doc COPYING
42%{python_sitearch}/iwlib.so
43%if "%{python_ver}" >= "2.5"
44%{python_sitearch}/*.egg-info
45%endif
46
47%changelog
48* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1-2
49- rebuild with python-2.6
50
51* Wed Sep 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1-1
52- initial build for Vine Linux
53
54* Mon Jul 27 2009 Jiri Popelka <jpopelka@redhat.com> - 0.1-1
55- Get iwlib code from rhpl 0.222-1
Note: See TracBrowser for help on using the repository browser.