source: projects/specs/branches/6/p/python-imaging/python-imaging-vl.spec @ 3807

Revision 3807, 4.3 KB checked in by owa, 13 years ago (diff)

update:mono,xsp,python-imaging

Line 
1Summary: The Python Imaging Library
2Summary(ja): Python イメージ処理ライブラリ
3Name: python-imaging
4Version: 1.1.7
5Release: 2%{?_dist_release}
6License: Distributable
7Group: Development/Languages
8URL: http://www.pythonware.com/products/pil
9Source0: http://effbot.org/downloads/Imaging-%{version}.tar.gz
10Patch0: Imaging-1.1.7-setup.lib64.patch
11BuildRequires: python-devel >= 2.6
12BuildRequires: libjpeg-devel libpng-devel zlib-devel freetype2-devel
13BuildRequires: xorg-x11-devel
14BuildRequires: sane-devel
15Requires: python >= 2.6
16Requires: libjpeg >= 6a
17Requires: libpng >= 1.0.12
18Requires: zlib >= 1.1.4
19Requires: freetype2 >= 2.1.3
20Provides: Imaging, python-PIL
21Obsoletes: Imaging < %{version}
22Obsoletes: python-PIL < %{version}
23Obsoletes: python-Imaging <= %{version}
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25Distribution: Vine Linux
26Vendor: Project Vine
27Packager: owa
28
29%description
30The Python Imaging Library (PIL) adds image processing capabilities
31to your Python environment.  This library provides extensive file
32format support, an efficient internal representation, and fairly
33powerful image processing capabilities.
34%description -l ja
35Python Imaging Library (PIL) は Python 環境にイメージ処理能力を加えます.
36このライブラリには広範なファイル型式への対応, 効果的な内部表現, そして
37真にパワフルなイメージ処理能力が備わっています.
38
39
40%prep
41%setup -q -n Imaging-%{version}
42%ifarch x86_64
43%patch0 -p1 -b .lib64~
44%endif
45
46
47%build
48python setup.py build_ext -i
49python selftest.py
50
51
52%install
53rm -rf $RPM_BUILD_ROOT
54python setup.py install --root=$RPM_BUILD_ROOT
55
56mkdir -p $RPM_BUILD_ROOT%{_includedir}/python%{pyver}/PIL
57cp -p libImaging/*.h $RPM_BUILD_ROOT%{_includedir}/python%{pyver}/PIL/
58
59mkdir -p $RPM_BUILD_ROOT%{python_sitearch}/Sane
60pushd Sane
61python setup.py install --root=$RPM_BUILD_ROOT --install-lib=%{python_sitearch}/Sane
62install -m644 demo_numarray.py $RPM_BUILD_ROOT%{python_sitearch}/Sane
63install -m644 CHANGES README sanedoc.txt $RPM_BUILD_ROOT%{python_sitearch}/Sane
64popd
65
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(-, root, root)
72%doc BUILDME CHANGES CONTENTS README
73%doc Docs
74%dir %{python_sitearch}/PIL
75%dir %{python_sitearch}/Sane
76%{_bindir}/pil*.py
77%{_includedir}/python%{pyver}/PIL/*.h
78%{python_sitearch}/PIL.pth
79%{python_sitearch}/PIL/*
80%{python_sitearch}/Sane/*
81
82
83%changelog
84* Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 1.1.7-2
85- install PIL with setup.py
86- install Sane with setup.py
87- install %{_bindir}/pil*.py
88- added BR: sane-devel
89
90* Thu Feb 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.7-1
91- new upstream release
92- recreated Patch0
93
94* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-3
95- rebuild for python-2.6
96
97* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-2vl5
98- rebuilt with python-2.5.2
99
100* Sat Jun 14 2008 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-1vl5
101- applied new versioning policy and spec in utf-8
102- added BuildRequires: xorg-x11-devel
103- fixed typo at Distribution
104
105* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-0vl4
106- fixed prereq, buildrequires pkgs
107
108* Wed Mar 21 2007 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-0vl2
109- updated Imaging to 1.1.6
110- added BuildRequires: XOrg-devel zlib-devel libjpeg-devel libpng-devel freetype2-devel
111
112* Sat Oct 14 2006 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl5
113- added Imaging-1.1.5-setup.lib64.patch
114- rebuilt for x86_64 architecture support
115
116* Wed May 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> python-imaging-1.1.5-0vl4
117- changed Group:
118
119* Fri Oct 07 2005 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl3
120- rebuilt
121
122* Sun May 22 2005 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl2
123- changed package name 'python-Imaging' to 'python-imaging'
124
125* Fri May 20 2005 Shu KONNO <owa@bg.wakwak.com> python-Imaging-1.1.5-0vl1
126- changed package name 'Imaging' to 'python-Imaging'
127- updated Python Imaging Library (PIL) to 1.1.5
128- rebuilt with python-2.4
129
130* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 1.1.3-0vl1
131- updated 1.1.3
132
133* Thu Jul 26 2001 Satoshi MACHINO <machino@vinelinux.org> 1.1.2-0vl1
134- updated 1.1.2
135
136* Thu Aug 03 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
137- Imaging-1.1-0vl1
138- build on VineSeed
139
140* Sun Mar  7 1999 MATSUMOTO Shoji <vine@flatout.org>
141- make spec
Note: See TracBrowser for help on using the repository browser.