source: projects/specs/branches/6/p/python-funcparserlib/python-funcparserlib-vl.spec @ 3891

Revision 3891, 1.6 KB checked in by iwaim, 13 years ago (diff)

new: python-funcparserlib

Line 
1%define ver 0.3.5
2%define rel 1
3
4Summary: Recursive descent parsing library for Python based on functional combinators
5Name: python-funcparserlib
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: MIT License
9Group: Development/Libraries
10URL: http://code.google.com/p/funcparserlib/
11Source0:http://pypi.python.org/packages/source/f/funcparserlib/funcparserlib-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
13BuildArch: noarch
14BuildRequires: python-devel
15Requires: python
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21Parser combinators are just higher-order functions that take parsers as
22their arguments and return them as result values. Parser combinators are:
23
24- First-class values
25- Extremely composable
26- Tend to make the code quite compact
27- Resemble the readable notation of xBNF grammars
28
29Parsers made with funcparserlib are pure-Python LL(*) parsers. It means
30that it's very easy to write them without thinking about look-aheads and
31all that hardcore parsing stuff. But the recursive descent parsing is a
32rather slow method compared to LL(k) or LR(k) algorithms.
33
34So the primary domain for funcparserlib is parsing little languages or
35external DSLs (domain specific languages).
36
37%prep
38%setup -q -n funcparserlib-%{ver}
39
40%build
41%__python setup.py build
42
43%install
44%__rm -rf %{buildroot}
45%__python setup.py install --skip-build --root %{buildroot}
46
47%clean
48%__rm -rf %{buildroot}
49
50%files
51%defattr(-,root,root,-)
52%doc CHANGES LICENSE README doc examples
53%{python_sitelib}/funcparserlib-%{ver}-py*.egg-info
54%{python_sitelib}/funcparserlib
55
56%changelog
57* Mon May 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.3.5-1
58- Initial build.
59
60
Note: See TracBrowser for help on using the repository browser.