source: projects/specs/branches/6/p/python-ethtool/python-ethtool-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_ver: %define python_ver %(%{__python} -c "import sys ; print sys.version[:3]")}
3
4Summary: Ethernet settings python bindings
5Summary(ja): ethtool の python バインディング
6Name: python-ethtool
7Version: 0.3
8Release: 2%{?_dist_release}
9URL: http://git.kernel.org/?p=linux/kernel/git/acme/python-ethtool.git
10Source: http://userweb.kernel.org/~acme/python-ethtool/%{name}-%{version}.tar.bz2
11License: GPLv2
12Group: System Environment/Libraries
13BuildRequires: python-devel
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16%description
17Python bindings for the ethtool kernel interface, that allows querying and
18changing of ethernet card settings, such as speed, port, autonegotiation, and
19PCI locations.
20
21%prep
22%setup -q
23
24%build
25%{__python} setup.py build
26
27%install
28rm -rf %{buildroot}
29%{__python} setup.py install --skip-build --root %{buildroot}
30mkdir -p %{buildroot}%{_sbindir}
31cp -p pethtool.py %{buildroot}%{_sbindir}/pethtool
32cp -p pifconfig.py %{buildroot}%{_sbindir}/pifconfig
33
34%clean
35rm -rf %{buildroot}
36
37%files
38%defattr(-,root,root)
39%doc COPYING
40%{_sbindir}/pethtool
41%{_sbindir}/pifconfig
42%{python_sitearch}/ethtool.so
43%if "%{python_ver}" >= "2.5"
44%{python_sitearch}/*.egg-info
45%endif
46
47%changelog
48* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.3-2
49- rebuild with python-2.6
50
51* Wed Sep 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1
52- initial build for Vine Linux
53
54* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-5
55- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
56
57* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-4
58- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
59
60* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.3-3
61- Rebuild for Python 2.6
62
63* Fri Sep  5 2008 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.3-2
64- Rewrote build and install sections as part of the fedora review process
65  BZ #459549
66
67* Tue Aug 26 2008 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.3-1
68- Add get_flags method from the first python-ethtool contributor, yay
69- Add pifconfig command, that mimics the ifconfig tool using the
70  bindings available
71
72* Wed Aug 20 2008 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.2-1
73- Expand description and summary fields, as part of the fedora
74  review process.
75
76* Tue Jun 10 2008 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.1-3
77- add dist to the release tag
78
79* Tue Dec 18 2007 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.1-2
80- First build into MRG repo
81
82* Tue Dec 18 2007 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.1-1
83- Get ethtool code from rhpl 0.212
Note: See TracBrowser for help on using the repository browser.