source: projects/specs/branches/6/p/python-egenix-mx-base/python-egenix-mx-base-vl.spec @ 5795

Revision 5795, 3.1 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild package

Line 
1%define python_platlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
2%define mxlibname egenix-mx-base
3
4Summary: eGenix mx-Extensions for Python - BASE package
5Summary(ja): eGenix 配布 Python DateTime ライブラリ
6Name: python-%{mxlibname}
7Version: 3.1.0
8Release: 4%{?_dist_release}
9License: eGenix.com Public License (similar to the Python 2.0)
10Group: Development/Libraries
11URL: http://www.egenix.com/files/python/eGenix-mx-Extensions.html
12Source: http://www.egenix.com/files/python/%{mxlibname}-%{version}.tar.gz
13BuildRoot: %{_tmppath}/%{mxlibname}-%{version}-root
14Buildrequires: python-devel
15Requires: python >= 2.4
16Provides: mxDateTime
17
18%description
19The eGenix mx Extension Series are a collection of
20Python extensions written in ANSI C and Python
21which provide a large spectrum of useful additions
22to everyday Python programming.
23
24The BASE package includes the Open Source subpackages
25of the series and is needed by all other add-on
26packages of the series.
27
28This software is brought to you by eGenix.com and
29distributed under the eGenix.com Public License.
30
31
32%prep
33%setup -q -n %{mxlibname}-%{version}
34
35#%ifarch x86_64
36#%patch0
37#cd mx/stdlib/distutils
38#%patch0
39#%endif
40
41
42%build
43CFLAGS="$RPM_OPT_FLAGS" python setup.py build
44
45
46%install
47rm -rf $RPM_BUILD_ROOT
48python setup.py install \
49        --root=$RPM_BUILD_ROOT \
50        --install-purelib=%{python_platlib} \
51        --install-platlib=%{python_platlib} \
52        # disabled below, because '*.h' files have been copied to data's directory
53        #--install-data=%{_sharedstatedir}/doc/%{name}-%{version}
54
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59
60%files
61%defattr(-,root,root)
62%doc mx/Doc mx/LICENSE mx/COPYRIGHT mx/DateTime/README
63%{python_platlib}
64
65%changelog
66* Thu Mar 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.0-4
67- rebuild with Vine6 environment
68
69* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.0-3
70- rebuild with python-2.6
71
72* Thu Jul 17 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.0-2vl5
73- rebuilt with python-2.5.2
74
75* Thu Jul 17 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.0-1vl5
76- updated egenix-mx-base to 3.1.0
77- applied new versioning policy and spec in utf-8
78- added python_platlib macro
79
80* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 3.0.0-0vl2
81- updated egenix-mx-base to 3.0.0
82- dropt Patch0: egenix-mx-base-2.0.6-mxSetup_x86_64.patch
83- fixed prereq, buildrequires pkgs
84
85* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 2.0.6-0vl4
86- fixed %%install directory
87
88* Sat Oct 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.6-0vl3
89- changed url
90- added egenix-mx-base-2.0.6-mxSetup_x86_64.patch
91- changed options in %%install
92
93* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 2.0.6-0vl2
94- rebuilded with python-2.4.1
95
96* Sun Mar 20 2005 Shu KONNO <owa@bg.wakwak.com> 2.0.6-0vl1
97- updated egenix-mx-base to 2.0.6
98- rebuild with python-2.3.5 for Vine
99
100* Sun Feb 22 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.5-uvl1
101- rebuilded with python-2.3
102
103* Sun Aug 31 2003 Shu KONNO <owa@bg.wakwak.com> 2.0.5-py2.1_uvl1
104- updated egenix-mx-base to 2.0.5
105
106* Wed Mar 5 2003 Shu KONNO <owa@bg.wakwak.com> 2.0.4-py2.1_0vp1
107- updated egenix-mx-base to 2.0.4
108- rebuilded with python-2.1
109
110* Mon Jul 1 2002 Shu KONNO <owa@bg.wakwak.com> 2.0.3-0vp1
111- created
112
Note: See TracBrowser for help on using the repository browser.