source: projects/specs/branches/6/p/python-crypto/python-crypto-vl.spec @ 6441

Revision 6441, 5.5 KB checked in by kudoh, 12 years ago (diff)
Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Summary:        Cryptography library for Python
5Summary(ja):    Python 用 Cryptography ライブラリ
6Name:           python-crypto
7Version:        2.6
8Release:        1%{?_dist_release}
9License:        Python License (CNRI Python License)
10Group:          Development/Libraries
11URL:            http://www.dlitz.net/software/pycrypto/
12Source:         http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/pycrypto-%{version}.tar.gz
13
14Patch0:         dont-drop-g.patch
15Patch1:         fix-epydoc-ignore.patch
16Patch2:         fix-unresolved-reference-size.patch
17Patch3:         doc.patch
18
19BuildRequires:  python >= 2.2
20BuildRequires:  python-devel >= 2.2
21BuildRequires:  gmp-devel >= 4.1
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23
24%description
25Python-crypto is a collection of both secure hash functions
26(such as MD5 and SHA), and various encryption algorithms
27(AES, DES, IDEA, RSA, ElGamal, etc.).
28
29%prep
30%setup -n pycrypto-%{version} -q
31%patch0 -p1
32%patch1 -p1
33%patch2 -p1
34%patch3 -p1
35
36# Remove spurious shellbangs
37%{__sed} -i -e '\|^#!/usr/local/bin/python| d' lib/Crypto/Util/RFC1751.py
38
39%build
40CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
41
42%install
43%{__rm} -rf %{buildroot}
44%{__python} setup.py install -O1 --skip-build --root %{buildroot}
45
46# Remove group write permissions on shared objects
47/usr/bin/find %{buildroot}%{python_sitearch} -name '*.so' \
48        -exec %{__chmod} g-w {} \;
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53
54%files
55%defattr(-,root,root,-)
56%doc README TODO ACKS ChangeLog LEGAL/ COPYRIGHT Doc/
57#%{python_sitearch}/pycrypto-2.2-py2.6.egg-info
58%{python_sitearch}/
59
60%changelog
61* Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6-1
62- new upstream release
63
64* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5-2
65- rebuild with python-2.7.2
66
67* Mon Jan 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5-1
68- new upstream release
69- added patches(1,2,3) from Debian
70
71* Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.1-1
72- new upstream release
73- dropt patch1
74
75* Sun Oct 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3-2
76- rebuilt with rpm-4.8.1 for pkg-config
77
78* Sat Aug 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3-1
79- new upstream release
80- changed %%files
81
82* Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2-2
83- fix %files (change directory from %{python_sitelib} to %{python_sitearch})
84
85* Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2-1
86- new upstream release
87
88* Wed Jul 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.0-1
89- new upstream release
90- changed URL and SOURCE to new upstream
91- dropt patch0,2
92- replaced patch1 from Debian newer
93- added pacth3 from Debian
94- changed document files dir in %%files
95
96* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.1-3
97- rebuild with python-2.6
98
99* Fri Oct 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-2
100- added Patch0,1,2 from Debian to fix some problem
101
102* Wed Jul 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-1
103- initial build for VineSeed
104
105* Mon Jun 04 2007 David Woodhouse <dwmw2@infradead.org> - 2.0.1-7.1
106- Fix libdir handling so it works on more arches than x86_64
107
108* Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-7
109- Fix typo
110
111* Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-6
112- Remove dist
113- rebuild, because the older version was much bigger, as it was build when
114  distutils was doing static links of libpython
115
116* Sat Dec 09 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-5
117- Rebuild for python 2.5
118
119* Thu Sep 07 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-4
120- Don't ghost pyo files (#205408)
121
122* Tue Aug 29 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-3
123- Rebuild for Fedora Extras 6
124
125* Mon Feb 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-2
126- Rebuild for Fedora Extras 5
127
128* Wed Aug 17 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0.1-1
129- Update to 2.0.1
130- Use Dist
131- Drop python-crypto-64bit-unclean.patch, similar patch was applied
132  upstream
133
134* Thu May 05 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-4
135- add python-crypto-64bit-unclean.patch (#156173)
136
137* Mon Mar 21 2005 Seth Vidal <skvidal at phy.duke.edu> - 0:2.0-3
138- iterate release for build on python 2.4 based systems
139
140* Sat Dec 18 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-2
141- Fix build on x86_64: use python_sitearch for files and patch source
142  to find gmp
143
144* Thu Aug 26 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-0.fdr.1
145- Update to 2.00
146
147* Fri Aug 13 2004 Ville Skytta <ville.skytta at iki.fi> - 0:1.9-0.fdr.6.a6
148- Don't use get_python_version(), it's available in Python >= 2.3 only.
149
150* Thu Aug 12 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.5.a6
151- Own dir python_sitearch/Crypto/
152
153* Wed Aug 11 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.4.a6
154- Match python spec template more
155
156* Sat Jul 17 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.3.a6
157- Own _libdir/python/site-packages/Crypto/
158
159* Wed Mar 24 2004 Panu Matilainen <pmatilai@welho.com> 0.3.2-0.fdr.2.a6
160- generate .pyo files during install
161- require exact version of python used to build the package
162- include more docs + demos
163- fix dependency on /usr/local/bin/python
164- use fedora.us style buildroot
165- buildrequires gmp-devel
166- use description from README
167
168* Sun Jan 11 2004 Ryan Boder <icanoop@bitwiser.org>  0.3.2-0.fdr.1.a6
169- Initial build.
170
Note: See TracBrowser for help on using the repository browser.