source: projects/specs/branches/6/p/python-configobj/python-configobj-vl.spec @ 521

Revision 521, 3.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           python-configobj
4Version:        4.5.3
5Release:        2%{?_dist_release}
6Summary:        Config file reading, writing, and validation
7Summary(ja):    設定ファイルの読み込み、書き込み、及び評価用のPython ツール
8Group:          System Environment/Libraries
9License:        BSD
10URL:            http://www.voidspace.org.uk/python/configobj.html
11Source0:        http://dl.sf.net/configobj/configobj-%{version}.zip
12
13BuildRequires:  python-devel, python-setuptools
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildArch:      noarch
16
17
18%description
19ConfigObj is a simple but powerful config file reader and writer: an ini file
20round tripper. Its main feature is that it is very easy to use, with a
21straightforward programmer's interface and a simple syntax for config files.
22It has lots of other features though:
23    * Nested sections (subsections), to any level
24    * List values
25    * Multiple line values
26    * String interpolation (substitution)
27    * Integrated with a powerful validation system
28          o including automatic type checking/conversion
29          o repeated sections
30          o and allowing default values
31    * All comments in the file are preserved
32    * The order of keys/sections is preserved
33    * No external dependencies
34    * Full Unicode support
35    * A powerful unrepr mode for storing basic datatypes
36
37
38%prep
39%setup -q -n configobj-%{version}
40
41
42%build
43%{__python} setup.py build
44
45
46%install
47rm -rf $RPM_BUILD_ROOT
48%{__python} setup.py install -O1 --skip-build --root=$RPM_BUILD_ROOT
49
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54
55%files
56%defattr(-,root,root,-)
57%doc docs
58%{python_sitelib}/*.py
59%{python_sitelib}/*.pyc
60%{python_sitelib}/*.pyo
61%{python_sitelib}/configobj-*.egg-info
62
63%changelog
64* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.5.3-2
65- rebuilt with python-2.6.4
66
67* Wed Dec 24 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.5.3-1
68- initial build for Vine Linux based on fedora package
69
70* Mon Dec 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 4.5.3-3
71- Upload Source file so this actually builds.
72
73* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.5.3-2
74- Rebuild for Python 2.6
75
76* Sat Jun 28 2008 Luke Macken <lmacken@redhat.com> - 4.5.3-1
77- Update to 4.5.3
78
79* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> - 4.5.2-1
80- Update to 4.5.2
81
82* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> - 4.4.0-2
83- Update for python-setuptools changes in rawhide
84
85* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> - 4.4.0-1
86- 4.4.0
87
88* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> - 4.3.2-6
89- Rebuild for python 2.5
90
91* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> - 4.3.2-5
92- Fix dist tag
93
94* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> - 4.3.2-4
95- Rebuild for FC6
96
97* Mon Aug 14 2006 Luke Macken <lmacken@redhat.com> - 4.3.2-3
98- Include pyo files
99
100* Tue Jul 18 2006 Luke Macken <lmacken@redhat.com> - 4.3.2-2
101- Fix typo in the url
102
103* Mon Jul 10 2006 Luke Macken <lmacken@redhat.com> - 4.3.2-1
104- Initial package
Note: See TracBrowser for help on using the repository browser.