source: projects/specs/branches/6/p/python-Coherence/python-Coherence-vl.spec @ 977

Revision 977, 3.9 KB checked in by daisuke, 14 years ago (diff)

python-Coherence: add dbus service file

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary:        Python framework to participate in DLNA/UPnP network.
4Summary(ja):    DLNA や UPnP に参加するための python フレームワーク
5Name:           python-Coherence
6Version:        0.6.6.2
7Release:        1%{?_dist_release}
8License:        MIT
9Group:          Development/Languages
10URL:            https://coherence.beebits.net/
11Source:         https://coherence.beebits.net/download/Coherence-%{version}.tar.gz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14Buildarch:      noarch
15BuildRequires:  python-devel
16BuildRequires:  python-setuptools
17
18Requires:       python-setuptools
19Requires:       python-configobj
20Requires:       python-twisted
21Requires:       dbus
22
23%description
24Coherence is a framework written in Python enabling applications to participate
25in digital living networks, such as the UPnP universe.
26
27%description -l ja
28Coherence はアプリケーションをDLNA(Digital Living Network Alliance)やUPnPに
29参加できるようにする Python で書かれたフレームワークです。
30
31
32%prep
33%setup -q -n Coherence-%{version}
34
35
36%build
37%{__python} setup.py build
38
39
40%install
41%{__rm} -rf ${RPM_BUILD_ROOT}
42%{__python} setup.py install \
43    --single-version-externally-managed \
44    -O1 --skip-build --root %{buildroot}
45# Install the D-Bus service file
46%{__install} -D -m 0644 -p misc/org.Coherence.service \
47    %{buildroot}/%{_datadir}/dbus-1/services/org.Coherence.service
48# Install the man page
49%{__install} -D -m 0644 -p docs/man/coherence.1 \
50    %{buildroot}/%{_mandir}/man1/coherence.1
51
52
53%clean
54%{__rm} -rf ${RPM_BUILD_ROOT}
55
56
57%files
58%defattr(-,root,root,-)
59%doc LICENCE README docs/*
60%exclude %{_bindir}/applet-coherence
61%{_bindir}/coherence
62%{_datadir}/dbus-1/services/org.Coherence.service
63%{python_sitelib}/Coherence-*.egg-info/
64%{python_sitelib}/coherence/
65# We don't want this in the package
66%exclude %{python_sitelib}/misc/
67%{_mandir}/man1/coherence.1*
68
69
70%changelog
71* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.6.2-1
72- new upstream release
73- add Summary(ja):
74- install D-Bus service file
75- install man pages
76
77* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.5.8-2
78- rebuild with python-2.6
79
80* Wed Dec 24 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.8-1
81- initial build for Vine Linux based on fedora package
82
83* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5.8-2
84- Rebuild for Python 2.6
85
86* Tue Jul 15 2008 Matthias Saou <http://freshrpms.net/> 0.5.8-1
87- Update to 0.5.8.
88- Don't include new "misc" directory, as its location is ugly!
89- Don't include applet-coherence as it probably requires the "misc" directory.
90- Remove all reqs but python-configobj, as it seems to be the only one left.
91
92* Sun Feb  3 2008 Matthias Saou <http://freshrpms.net/> 0.5.0-1
93- Update to 0.5.0.
94
95* Wed Aug 29 2007 Matthias Saou <http://freshrpms.net/> 0.4.0-2
96- Update python-setuptools build requirement to new python-setuptools-devel.
97
98* Fri Aug  3 2007 Matthias Saou <http://freshrpms.net/> 0.4.0-1
99- Update to 0.4.0.
100- No need to update License field, MIT is already correct.
101
102* Tue Jul 24 2007 Matthias Saou <http://freshrpms.net/> 0.3.0-1
103- Update to 0.3.0.
104
105* Tue May  8 2007 Matthias Saou <http://freshrpms.net/> 0.2.1-3
106- Rename Coherence -> python-Coherence to match our python naming guidelines.
107
108* Mon May  7 2007 Matthias Saou <http://freshrpms.net/> 0.2.1-2
109- Rename coherence -> Coherence to match upstream and our naming guidelines.
110- Obsolete coherence < 0.2.1-2 but don't provide it since elisa's requirement
111  has been updated to match the name change and nothing else requires it.
112
113* Fri Apr 20 2007 Matthias Saou <http://freshrpms.net/> 0.2.1-1
114- Update to 0.2.1.
115
116* Fri Mar 23 2007 Matthias Saou <http://freshrpms.net/> 0.1.0-1
117- Update to 0.1.0 release.
118
119* Wed Feb 14 2007 Matthias Saou <http://freshrpms.net/> 0.0-1.r303
120- Switch to using the go-4-python-2.5 svn branch.
121
122* Fri Feb  9 2007 Matthias Saou <http://freshrpms.net/> 0-0.1.r294
123- Initial RPM release.
124
Note: See TracBrowser for help on using the repository browser.