source: projects/specs/branches/6/p/pygtk2/pygtk2-vl.spec @ 4080

Revision 4080, 8.8 KB checked in by daisuke, 13 years ago (diff)

pygtk2: udpate to 2.24.0

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define buildglade %(pkg-config libglade-2.0 && echo 1 || echo 0)
4%define pyver %(python -c 'import sys;print(sys.version[0:3])')
5
6Summary: Python bindings for the GTK+ widget set.
7Summary(ja): GTK+ ウィジットセットの Python 実装
8Name: pygtk2
9Version: 2.24.0
10Release: 1%{?_dist_release}
11
12Group: Development/Languages
13License: LGPLv2
14Source: ftp://ftp.gnome.org/pub/GNOME/sources/pygtk/2.24/pygtk-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Buildrequires: python-devel >= 2.5
19Buildrequires: libglade2-devel >= 2.5.0
20BuildRequires: gtk2-devel >= 2.16.0
21BuildRequires: pygobject-devel >= 2.16.0
22BuildRequires: pycairo-devel >= 1.8.2
23BuildRequires: python-numeric
24BuildRequires: docbook-style-xsl
25BuildRequires: libxslt
26Buildrequires: automake >= 1.6.3-5
27
28Requires: pygobject
29Requires: pycairo
30Requires: python-numeric
31
32Obsoletes: pygtk
33
34%description
35PyGTK is an extension module for python that gives you access to the GTK+
36widget set.  Just about anything you can write in C with GTK+ you can write
37in python with PyGTK (within reason), but with all the benefits of python.
38
39%description -l ja
40PyGTK は GTK+ ウィジットセットへアクセス可能にする python の拡張モジュール
41です。 C で GTK+ を使用して書けることは、大概 python で PyGTK を利用して書
42けます。 python のおかげでもあります。
43
44%package libglade
45Summary: A wrapper for the libglade library for use with PyGTK
46Summary(ja): PyGTK を利用するための libglade ライブラリのラッパ
47Group: Development/Libraries
48Requires: pygtk2 = %{version}
49
50%description libglade
51This module contains a wrapper for the libglade library.  Libglade allows
52a program to construct its user interface from an XML description, which
53allows the programmer to keep the UI and program logic separate.
54
55%description -l ja libglade
56このモジュールは libglade ライブラリのためのラッパを含んでいます。libglade は
57プログラムのユーザインタフェースを XML 記述で構成することを可能にします。この
58ためプログラマは、プログラムの UI とロジックを分離させておくことができます。
59
60%package devel
61Summary: files needed to build wrappers for GTK+ addon libraries
62Summary(ja): GTK+ の追加ライブラリのラッパ作成に必要なファイル
63Group: Development/Libraries
64Requires: pygtk2 = %{version}
65Requires: pygobject-devel >= 2.12.0
66Requires: gtk2-devel
67
68%description devel
69This package contains files required to build wrappers for GTK+ addon
70libraries so that they interoperate with pygtk.
71
72%description -l ja devel
73このパッケージには GTK+ の追加ライブラリのラッパを作るために必要なファイルを含
74みます。これらは PyGTK との仲介をします。
75
76%prep
77%setup -q -n pygtk-%{version}
78
79%build
80[ -x /usr/bin/python%{pyver} ] && export PYTHON=/usr/bin/python%{pyver}
81#aclocal && automake && autoconf
82%configure --enable-thread --enable-numpy
83export tagname=CC
84make LIBTOOL=/usr/bin/libtool
85
86%install
87rm -rf $RPM_BUILD_ROOT
88export tagname=CC
89make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
90find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%files
96%defattr(-,root,root)
97%doc AUTHORS NEWS README MAPPING ChangeLog
98%doc examples
99
100%defattr(644, root, root, 755)
101%dir %{python_sitearch}/gtk-2.0
102%dir %{python_sitearch}/gtk-2.0/gtk
103%{python_sitearch}/gtk-2.0/gtk/*.py*
104%dir %{_libdir}/pygtk
105%dir %{_libdir}/pygtk/2.0
106%{_libdir}/pygtk/2.0/*
107
108%defattr(755, root, root, 755)
109%{_bindir}/pygtk-demo
110%{python_sitearch}/gtk-2.0/atk.so
111%{python_sitearch}/gtk-2.0/pango.so
112%{python_sitearch}/gtk-2.0/gtk/_gtk.so
113%{python_sitearch}/gtk-2.0/gtkunixprint.so
114%{python_sitearch}/gtk-2.0/pangocairo.so
115
116%if %{buildglade}
117%files libglade
118%defattr(755, root, root, 755)
119%{_libdir}/python?.?/site-packages/gtk-2.0/gtk/glade.so
120%endif
121
122%files devel
123%defattr(644, root, root, 755)
124%dir %{_includedir}/pygtk-2.0
125%dir %{_includedir}/pygtk-2.0/pygtk
126%{_includedir}/pygtk-2.0/pygtk/*.h
127%{_libdir}/pkgconfig/pygtk-2.0.pc
128%dir %{_datadir}/pygtk
129%dir %{_datadir}/pygtk/2.0
130%dir %{_datadir}/pygtk/2.0/defs
131%{_datadir}/pygtk/2.0/defs/*.defs
132%{_datadir}/pygtk/2.0/defs/pangocairo.override
133%{_datadir}/gtk-doc/html/pygtk
134%defattr(755, root, root, 755)
135%{_bindir}/pygtk-codegen-2.0
136
137%changelog
138* Tue Jun 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
139- new upstream release
140
141* Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-2
142- add Requires: gtk2-devel (-devel package)
143
144* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
145- new upstream release
146
147* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
148- new upstream release
149
150* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
151- new upstream release
152- rebuild with python-2.6
153
154* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
155- new upstream release
156
157* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.1-2vl5
158- rebuilt with python-2.5.2
159
160* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-1vl5
161- rebuilt with python-2.4.5
162- used %%{?_dist_release} macro
163
164* Fri Jan 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
165- new upstream release
166
167* Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.0-0vl1
168- new upstream release
169
170* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.5-0vl1
171- new upstream release
172
173* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.4-0vl2
174- added Requires pygobject-devel to devel package
175
176* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.4-0vl1
177- new upstream release
178- add Requires/BuildRequires pygobject,pycairo
179
180* Thu Jun 22 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl1
181- new upstream release 2.8.6
182
183* Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.4-0vl1
184- new upstream release 2.8.4
185- added japanese summary and description
186
187* Tue Oct 18 2005 Shu KONNO <owa@bg.wakwak.com> 2.8.2-0vl1
188- new upstream release 2.8.2
189
190* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
191- new upstream release 2.8.1
192- added %clean sectioin
193
194* Sat Sep 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.0-0vl1
195- new upstream release 2.8.0
196
197* Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.1-0vl1
198- new upstream release 2.6.1
199
200* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl2
201- rebuild with python-2.4.1-0vl1
202
203* Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
204- new upstream release
205
206* Sat Jun 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.0-1vl1
207- updated to 2.2.0
208
209* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl4
210- rebuild with python-2.3.3-0vl1
211
212* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl3.1
213- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
214
215* Thu Sep 18 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0-1vl3
216- added missing %%defattr
217
218* Wed Sep 17 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl2
219- added Provides and Obsoletes pygtk
220
221* Sun Sep 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1vl1
222- new upstream release (based on Redhat Rawhide 2.0.0-1)
223  * Thu Aug  7 2003 Elliot Lee <sopwith@redhat.com> 1.99.16-10
224  - Fix libtool
225  * Fri Jul 18 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-8
226  - part of the fixnew patch wasn't applied upstream, apply it (#99400)
227
228* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.14-0vl1
229- new upstream release
230- build for Vine Linux
231
232* Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
233- rebuild for multilib
234- use %%configure
235
236* Fri Aug 30 2002 Matt Wilson <msw@redhat.com>
237- fix pixbuf leaks (#72137)
238- five more pixbuf leaks plugged
239
240* Wed Aug 28 2002 Jonathan Blandford <jrb@redhat.com>
241- remover Packager tag
242
243* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
244- add binding for gdk_atom_intern
245
246* Mon Jul 29 2002 Matt Wilson <msw@redhat.com>
247- 0.99.12
248
249* Wed Jul 17 2002 Matt Wilson <msw@redhat.com>
250- new version from CVS
251
252* Thu Jun 27 2002 Tim Waugh <twaugh@redhat.com>
253- Fix bug #65770.
254
255* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
256- automated rebuild
257
258* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
259- new version from CVS
260
261* Sun May 26 2002 Tim Powers <timp@redhat.com>
262- automated rebuild
263
264* Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
265- 1.99.10
266
267* Wed Feb 27 2002 Matt Wilson <msw@redhat.com>
268- 1.99.8
269
270* Mon Jan 28 2002 Matt Wilson <msw@redhat.com>
271- added atkmodule.so to file list
272
273* Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
274- fix devel filelist to match new header location
275
276* Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
277- get the headers from their new version-specific location
278
279* Thu Oct 11 2001 Matt Wilson <msw@redhat.com>
280- fixed typo in devel filelist
281- added macro that tests to see if we have libglade2, make the
282  filelist a condition of that
283- changed name to 'pygtk2' to avoid name conflict with pygtk
284
Note: See TracBrowser for help on using the repository browser.